import libsolv-0.7.11-1.el8
This commit is contained in:
parent
f82323f15f
commit
01782d4008
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/libsolv-0.7.7.tar.gz
|
||||
SOURCES/libsolv-0.7.11.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
be93515a4fca86e76c1dfd2f2cb99950de0f42a4 SOURCES/libsolv-0.7.7.tar.gz
|
||||
8b76afedf65264789edf51b34042e6d923dbeb9f SOURCES/libsolv-0.7.11.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From fc1fe251a565423327faad91b9341b1344334456 Mon Sep 17 00:00:00 2001
|
||||
From 9839a88e4fda23b46015170b201c98da7bcdd55e Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Rohel <jrohel@redhat.com>
|
||||
Date: Fri, 25 Oct 2019 14:33:22 +0200
|
||||
Subject: [PATCH 1/2] Add support for computing hashes using OpenSSL
|
||||
@ -14,10 +14,10 @@ of computing hashes (MD5, SHA1, SHA224, SHA256, SHA384, SHA512).
|
||||
4 files changed, 54 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index b39fd991..33ce8047 100644
|
||||
index c1ada004..83727358 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -39,6 +39,7 @@ OPTION (ENABLE_ZCHUNK_COMPRESSION "Build with zchunk compression support?" OFF)
|
||||
@@ -40,6 +40,7 @@ OPTION (ENABLE_ZCHUNK_COMPRESSION "Build with zchunk compression support?" OFF)
|
||||
OPTION (WITH_SYSTEM_ZCHUNK "Use system zchunk library?" OFF)
|
||||
OPTION (WITH_LIBXML2 "Build with libxml2 instead of libexpat?" OFF)
|
||||
OPTION (WITHOUT_COOKIEOPEN "Disable the use of stdio cookie opens?" OFF)
|
||||
@ -25,7 +25,7 @@ index b39fd991..33ce8047 100644
|
||||
|
||||
include (GNUInstallDirs)
|
||||
message (STATUS "Libraries will be installed in ${CMAKE_INSTALL_FULL_LIBDIR}")
|
||||
@@ -160,6 +161,11 @@ INCLUDE_DIRECTORIES (${EXPAT_INCLUDE_DIRS})
|
||||
@@ -161,6 +162,11 @@ INCLUDE_DIRECTORIES (${EXPAT_INCLUDE_DIRS})
|
||||
ENDIF (WITH_LIBXML2 )
|
||||
ENDIF (ENABLE_RPMMD OR ENABLE_SUSEREPO OR ENABLE_APPDATA OR ENABLE_COMPS OR ENABLE_HELIXREPO OR ENABLE_MDKREPO)
|
||||
|
||||
@ -37,16 +37,16 @@ index b39fd991..33ce8047 100644
|
||||
IF (ENABLE_ZLIB_COMPRESSION)
|
||||
FIND_PACKAGE (ZLIB REQUIRED)
|
||||
INCLUDE_DIRECTORIES (${ZLIB_INCLUDE_DIRS})
|
||||
@@ -270,7 +276,7 @@ ENDIF (${CMAKE_MAJOR_VERSION} GREATER 2)
|
||||
|
||||
@@ -281,7 +287,7 @@ ENDIF (${CMAKE_MAJOR_VERSION} GREATER 2)
|
||||
# should create config.h with #cmakedefine instead...
|
||||
FOREACH (VAR HAVE_STRCHRNUL HAVE_FOPENCOOKIE HAVE_FUNOPEN WORDS_BIGENDIAN
|
||||
- HAVE_RPM_DB_H HAVE_PGPDIGGETPARAMS WITH_LIBXML2 WITHOUT_COOKIEOPEN)
|
||||
+ HAVE_RPM_DB_H HAVE_PGPDIGGETPARAMS WITH_LIBXML2 WITHOUT_COOKIEOPEN WITH_OPENSSL)
|
||||
HAVE_RPM_DB_H HAVE_PGPDIGGETPARAMS HAVE_RPMDBNEXTITERATORHEADERBLOB HAVE_RPMDBFSTAT
|
||||
- WITH_LIBXML2 WITHOUT_COOKIEOPEN)
|
||||
+ WITH_LIBXML2 WITHOUT_COOKIEOPEN WITH_OPENSSL)
|
||||
IF(${VAR})
|
||||
ADD_DEFINITIONS (-D${VAR}=1)
|
||||
SET (SWIG_FLAGS ${SWIG_FLAGS} -D${VAR})
|
||||
@@ -407,6 +413,9 @@ ENDIF (ENABLE_ZSTD_COMPRESSION)
|
||||
@@ -418,6 +424,9 @@ ENDIF (ENABLE_ZSTD_COMPRESSION)
|
||||
IF (WITH_SYSTEM_ZCHUNK)
|
||||
SET (SYSTEM_LIBRARIES ${SYSTEM_LIBRARIES} ${ZCHUNK_LIBRARIES})
|
||||
ENDIF (WITH_SYSTEM_ZCHUNK)
|
||||
@ -156,8 +156,11 @@ index f19030eb..d477e195 100644
|
||||
|
||||
ADD_EXECUTABLE (mergesolv mergesolv.c )
|
||||
TARGET_LINK_LIBRARIES (mergesolv toolstuff libsolvext libsolv ${SYSTEM_LIBRARIES})
|
||||
--
|
||||
2.26.0
|
||||
|
||||
From ef403d41780fb2bac1df40cbb7a55967e8206127 Mon Sep 17 00:00:00 2001
|
||||
|
||||
From 2c2f43ccefae0892698b313afa870cce5e2a38c8 Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Rohel <jrohel@redhat.com>
|
||||
Date: Tue, 9 Apr 2019 10:20:16 +0200
|
||||
Subject: [PATCH 2/2] Use OpenSSL for computing hashes by default
|
||||
@ -169,10 +172,10 @@ it does not need to change the .spec file for using OpenSSL.
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 33ce8047..5d1d6daf 100644
|
||||
index 83727358..a2c313f7 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -39,7 +39,7 @@ OPTION (ENABLE_ZCHUNK_COMPRESSION "Build with zchunk compression support?" OFF)
|
||||
@@ -40,7 +40,7 @@ OPTION (ENABLE_ZCHUNK_COMPRESSION "Build with zchunk compression support?" OFF)
|
||||
OPTION (WITH_SYSTEM_ZCHUNK "Use system zchunk library?" OFF)
|
||||
OPTION (WITH_LIBXML2 "Build with libxml2 instead of libexpat?" OFF)
|
||||
OPTION (WITHOUT_COOKIEOPEN "Disable the use of stdio cookie opens?" OFF)
|
||||
@ -181,3 +184,6 @@ index 33ce8047..5d1d6daf 100644
|
||||
|
||||
include (GNUInstallDirs)
|
||||
message (STATUS "Libraries will be installed in ${CMAKE_INSTALL_FULL_LIBDIR}")
|
||||
--
|
||||
2.26.0
|
||||
|
||||
|
@ -41,7 +41,7 @@
|
||||
#global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||
|
||||
Name: lib%{libname}
|
||||
Version: 0.7.7
|
||||
Version: 0.7.11
|
||||
Release: 1%{?commit:.git.%{commitnum}.%{?shortcommit}}%{?dist}
|
||||
Summary: Package dependency solver
|
||||
|
||||
@ -295,6 +295,25 @@ Python 3 version.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Apr 06 2020 Ales Matej <amatej@redhat.org> - 0.7.11-1
|
||||
- Update to 0.7.11
|
||||
- selected bug fixes:
|
||||
* support arch<->noarch package changes when creating patch
|
||||
conflicts from the updateinfo data
|
||||
* also support other rpm database types
|
||||
* fixed solv_zchunk decoding error if large chunks are used
|
||||
* treat retracted pathes as irrelevant
|
||||
* made add_update_target work with multiversion installs
|
||||
- new features
|
||||
* support for SOLVER_BLACKLIST jobs that block the installation of matched
|
||||
packages unless they are directly selected by an SOLVER_INSTALL job
|
||||
* libsolv now also parses the patch status in the updateinfo parser
|
||||
* new solvable_matchessolvable() function
|
||||
* support conda constrains dependencies
|
||||
* new rpm_stat_database() function
|
||||
* new rpm_hash_database_state() function
|
||||
|
||||
|
||||
* Tue Jun 11 2019 Ales Matej <amatej@redhat.org> - 0.7.7-1
|
||||
- Update to 0.7.7
|
||||
- selected bug fixes:
|
||||
|
Loading…
Reference in New Issue
Block a user