import libsndfile-1.0.31-7.el9
This commit is contained in:
commit
8a72fbf0a3
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/libsndfile-1.0.31.tar.bz2
|
1
.libsndfile.metadata
Normal file
1
.libsndfile.metadata
Normal file
@ -0,0 +1 @@
|
||||
f16a88e7223baef7c4497536dc1b55b56811debc SOURCES/libsndfile-1.0.31.tar.bz2
|
103
SOURCES/libsndfile-1.0.25-system-gsm.patch
Normal file
103
SOURCES/libsndfile-1.0.25-system-gsm.patch
Normal file
@ -0,0 +1,103 @@
|
||||
diff -up libsndfile-1.0.31/CMakeLists.txt.nobundlegsm libsndfile-1.0.31/CMakeLists.txt
|
||||
--- libsndfile-1.0.31/CMakeLists.txt.nobundlegsm 2021-01-24 13:22:23.000000000 +0100
|
||||
+++ libsndfile-1.0.31/CMakeLists.txt 2021-01-27 12:54:51.112184824 +0100
|
||||
@@ -230,7 +230,6 @@ add_library (sndfile
|
||||
src/double64.c
|
||||
src/ima_adpcm.c
|
||||
src/ms_adpcm.c
|
||||
- src/gsm610.c
|
||||
src/dwvw.c
|
||||
src/vox_adpcm.c
|
||||
src/interleave.c
|
||||
@@ -286,23 +285,6 @@ add_library (sndfile
|
||||
src/ogg_opus.c
|
||||
src/ogg_vcomment.c
|
||||
src/nms_adpcm.c
|
||||
- src/GSM610/config.h
|
||||
- src/GSM610/gsm.h
|
||||
- src/GSM610/gsm610_priv.h
|
||||
- src/GSM610/add.c
|
||||
- src/GSM610/code.c
|
||||
- src/GSM610/decode.c
|
||||
- src/GSM610/gsm_create.c
|
||||
- src/GSM610/gsm_decode.c
|
||||
- src/GSM610/gsm_destroy.c
|
||||
- src/GSM610/gsm_encode.c
|
||||
- src/GSM610/gsm_option.c
|
||||
- src/GSM610/long_term.c
|
||||
- src/GSM610/lpc.c
|
||||
- src/GSM610/preprocess.c
|
||||
- src/GSM610/rpe.c
|
||||
- src/GSM610/short_term.c
|
||||
- src/GSM610/table.c
|
||||
src/G72x/g72x.h
|
||||
src/G72x/g72x_priv.h
|
||||
src/G72x/g721.c
|
||||
@@ -349,6 +331,7 @@ target_link_libraries (sndfile
|
||||
$<$<BOOL:${HAVE_EXTERNAL_XIPH_LIBS}>:FLAC::FLAC>
|
||||
$<$<AND:$<BOOL:${ENABLE_EXPERIMENTAL}>,$<BOOL:${HAVE_EXTERNAL_XIPH_LIBS}>,$<BOOL:${HAVE_SPEEX}>>:Speex::Speex>
|
||||
$<$<BOOL:${HAVE_EXTERNAL_XIPH_LIBS}>:Opus::opus>
|
||||
+ -lgsm
|
||||
)
|
||||
set_target_properties (sndfile PROPERTIES
|
||||
PUBLIC_HEADER "${sndfile_HDRS}"
|
||||
diff -up libsndfile-1.0.31/Makefile.am.nobundlegsm libsndfile-1.0.31/Makefile.am
|
||||
--- libsndfile-1.0.31/Makefile.am.nobundlegsm 2021-01-27 12:57:08.819482207 +0100
|
||||
+++ libsndfile-1.0.31/Makefile.am 2021-01-27 12:57:08.847481859 +0100
|
||||
@@ -46,7 +46,6 @@ SYMBOL_FILES = src/Symbols.gnu-binutils
|
||||
|
||||
EXTRA_DIST += include/sndfile.h.in src/config.h.in src/test_endswap.tpl src/test_endswap.def \
|
||||
$(SYMBOL_FILES) src/create_symbols_file.py src/binheader_writef_check.py \
|
||||
- src/GSM610/README src/GSM610/COPYRIGHT src/GSM610/ChangeLog \
|
||||
src/G72x/README src/G72x/README.original src/G72x/ChangeLog \
|
||||
src/make-static-lib-hidden-privates.sh \
|
||||
src/config.h.cmake
|
||||
@@ -71,7 +70,7 @@ src_libsndfile_la_SOURCES = src/sndfile.
|
||||
src/ogg_vorbis.c src/ogg_speex.c src/ogg_pcm.c src/ogg_opus.c src/ogg_vcomment.c \
|
||||
src/common.h src/sfconfig.h src/sfendian.h src/wavlike.h src/sf_unistd.h src/ogg.h src/chanmap.h src/ogg_vcomment.h
|
||||
nodist_src_libsndfile_la_SOURCES = $(nodist_include_HEADERS)
|
||||
-src_libsndfile_la_LIBADD = src/GSM610/libgsm.la src/G72x/libg72x.la src/ALAC/libalac.la \
|
||||
+src_libsndfile_la_LIBADD = -lgsm src/G72x/libg72x.la src/ALAC/libalac.la \
|
||||
src/libcommon.la $(EXTERNAL_XIPH_LIBS) -lm
|
||||
EXTRA_src_libsndfile_la_DEPENDENCIES = $(SYMBOL_FILES)
|
||||
|
||||
@@ -90,17 +89,6 @@ src_test_main_SOURCES = src/test_main.c
|
||||
src/test_binheader_writef.c src/test_nms_adpcm.c
|
||||
src_test_main_LDADD = src/libcommon.la
|
||||
|
||||
-##############
|
||||
-# src/GSM610 #
|
||||
-##############
|
||||
-
|
||||
-noinst_LTLIBRARIES += src/GSM610/libgsm.la
|
||||
-src_GSM610_libgsm_la_SOURCES = src/GSM610/config.h src/GSM610/gsm.h src/GSM610/gsm610_priv.h \
|
||||
- src/GSM610/add.c src/GSM610/code.c src/GSM610/decode.c src/GSM610/gsm_create.c \
|
||||
- src/GSM610/gsm_decode.c src/GSM610/gsm_destroy.c src/GSM610/gsm_encode.c \
|
||||
- src/GSM610/gsm_option.c src/GSM610/long_term.c src/GSM610/lpc.c src/GSM610/preprocess.c \
|
||||
- src/GSM610/rpe.c src/GSM610/short_term.c src/GSM610/table.c
|
||||
-
|
||||
############
|
||||
# src/G72x #
|
||||
############
|
||||
diff -up libsndfile-1.0.31/src/gsm610.c.nobundlegsm libsndfile-1.0.31/src/gsm610.c
|
||||
--- libsndfile-1.0.31/src/gsm610.c.nobundlegsm 2021-01-23 17:12:45.000000000 +0100
|
||||
+++ libsndfile-1.0.31/src/gsm610.c 2021-01-27 12:54:51.112184824 +0100
|
||||
@@ -27,7 +27,7 @@
|
||||
#include "sfendian.h"
|
||||
#include "common.h"
|
||||
#include "wavlike.h"
|
||||
-#include "GSM610/gsm.h"
|
||||
+#include <gsm.h>
|
||||
|
||||
#define GSM610_BLOCKSIZE 33
|
||||
#define GSM610_SAMPLES 160
|
||||
@@ -391,7 +391,8 @@ gsm610_seek (SF_PRIVATE *psf, int UNUSED
|
||||
psf_fseek (psf, psf->dataoffset, SEEK_SET) ;
|
||||
pgsm610->blockcount = 0 ;
|
||||
|
||||
- gsm_init (pgsm610->gsm_data) ;
|
||||
+ gsm_destroy (pgsm610->gsm_data) ;
|
||||
+ pgsm610->gsm_data = gsm_create () ;
|
||||
if ((SF_CONTAINER (psf->sf.format)) == SF_FORMAT_WAV ||
|
||||
(SF_CONTAINER (psf->sf.format)) == SF_FORMAT_W64)
|
||||
gsm_option (pgsm610->gsm_data, GSM_OPT_WAV49, &true_flag) ;
|
25
SOURCES/libsndfile-1.0.25-zerodivfix.patch
Normal file
25
SOURCES/libsndfile-1.0.25-zerodivfix.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 725c7dbb95bfaf8b4bb7b04820e3a00cceea9ce6 Mon Sep 17 00:00:00 2001
|
||||
From: Erik de Castro Lopo <erikd@mega-nerd.com>
|
||||
Date: Wed, 24 Dec 2014 21:02:35 +1100
|
||||
Subject: [PATCH] src/file_io.c : Prevent potential divide-by-zero.
|
||||
|
||||
Closes: https://github.com/erikd/libsndfile/issues/92
|
||||
---
|
||||
src/file_io.c | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/file_io.c b/src/file_io.c
|
||||
index 26d3d6d..6ccab78 100644
|
||||
--- a/src/file_io.c
|
||||
+++ b/src/file_io.c
|
||||
@@ -1322,6 +1322,9 @@ psf_fwrite (const void *ptr, sf_count_t bytes, sf_count_t items, SF_PRIVATE *psf
|
||||
{ sf_count_t total = 0 ;
|
||||
ssize_t count ;
|
||||
|
||||
+ if (bytes == 0 || items == 0)
|
||||
+ return 0 ;
|
||||
+
|
||||
if (psf->virtual_io)
|
||||
return psf->vio.write (ptr, bytes*items, psf->vio_user_data) / bytes ;
|
||||
|
||||
|
25
SOURCES/libsndfile-1.0.31-ced91d7b.patch
Normal file
25
SOURCES/libsndfile-1.0.31-ced91d7b.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From ced91d7b971be6173b604154c39279ce90ad87cc Mon Sep 17 00:00:00 2001
|
||||
From: yuan <ssspeed00@gmail.com>
|
||||
Date: Tue, 20 Apr 2021 16:16:32 +0800
|
||||
Subject: [PATCH] flac: Fix improper buffer reusing (#732)
|
||||
|
||||
---
|
||||
src/flac.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/flac.c b/src/flac.c
|
||||
index 64d0172e6..e33204505 100644
|
||||
--- a/src/flac.c
|
||||
+++ b/src/flac.c
|
||||
@@ -948,7 +948,11 @@ flac_read_loop (SF_PRIVATE *psf, unsigned len)
|
||||
/* Decode some more. */
|
||||
while (pflac->pos < pflac->len)
|
||||
{ if (FLAC__stream_decoder_process_single (pflac->fsd) == 0)
|
||||
+ { psf_log_printf (psf, "FLAC__stream_decoder_process_single returned false\n") ;
|
||||
+ /* Current frame is busted, so NULL the pointer. */
|
||||
+ pflac->frame = NULL ;
|
||||
break ;
|
||||
+ } ;
|
||||
state = FLAC__stream_decoder_get_state (pflac->fsd) ;
|
||||
if (state >= FLAC__STREAM_DECODER_END_OF_STREAM)
|
||||
{ psf_log_printf (psf, "FLAC__stream_decoder_get_state returned %s\n", FLAC__StreamDecoderStateString [state]) ;
|
21
SOURCES/libsndfile-1.0.31-deb669ee.patch
Normal file
21
SOURCES/libsndfile-1.0.31-deb669ee.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff --git a/src/ms_adpcm.c b/src/ms_adpcm.c
|
||||
index 5e8f1a31..a21cb994 100644
|
||||
--- a/src/ms_adpcm.c
|
||||
+++ b/src/ms_adpcm.c
|
||||
@@ -128,8 +128,14 @@ wavlike_msadpcm_init (SF_PRIVATE *psf, int blockalign, int samplesperblock)
|
||||
if (psf->file.mode == SFM_WRITE)
|
||||
samplesperblock = 2 + 2 * (blockalign - 7 * psf->sf.channels) / psf->sf.channels ;
|
||||
|
||||
- if (blockalign < 7 * psf->sf.channels)
|
||||
- { psf_log_printf (psf, "*** Error blockalign (%d) should be > %d.\n", blockalign, 7 * psf->sf.channels) ;
|
||||
+ /* There's 7 samples per channel in the preamble of each block */
|
||||
+ if (samplesperblock < 7 * psf->sf.channels)
|
||||
+ { psf_log_printf (psf, "*** Error samplesperblock (%d) should be >= %d.\n", samplesperblock, 7 * psf->sf.channels) ;
|
||||
+ return SFE_INTERNAL ;
|
||||
+ } ;
|
||||
+
|
||||
+ if (2 * blockalign < samplesperblock * psf->sf.channels)
|
||||
+ { psf_log_printf (psf, "*** Error blockalign (%d) should be >= %d.\n", blockalign, samplesperblock * psf->sf.channels / 2) ;
|
||||
return SFE_INTERNAL ;
|
||||
} ;
|
||||
|
396
SPECS/libsndfile.spec
Normal file
396
SPECS/libsndfile.spec
Normal file
@ -0,0 +1,396 @@
|
||||
Summary: Library for reading and writing sound files
|
||||
Name: libsndfile
|
||||
Version: 1.0.31
|
||||
Release: 7%{?dist}
|
||||
License: LGPLv2+ and GPLv2+ and BSD
|
||||
URL: http://libsndfile.github.io/libsndfile/
|
||||
Source0: https://github.com/libsndfile/libsndfile/releases/download/%{version}/libsndfile-%{version}.tar.bz2
|
||||
Patch0: libsndfile-1.0.25-system-gsm.patch
|
||||
Patch1: libsndfile-1.0.25-zerodivfix.patch
|
||||
# from upstream, for <= 1.0.31, rhbz#1985029
|
||||
Patch2: libsndfile-1.0.31-deb669ee.patch
|
||||
# from upstream, fix #2030508, for <= 1.0.31
|
||||
Patch3: libsndfile-1.0.31-ced91d7b.patch
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: alsa-lib-devel
|
||||
BuildRequires: flac-devel
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: sqlite-devel
|
||||
BuildRequires: gsm-devel
|
||||
BuildRequires: libtool
|
||||
BuildRequires: make
|
||||
BuildRequires: python3
|
||||
BuildRequires: opus-devel
|
||||
|
||||
|
||||
%description
|
||||
libsndfile is a C library for reading and writing sound files such as
|
||||
AIFF, AU, WAV, and others through one standard interface. It can
|
||||
currently read/write 8, 16, 24 and 32-bit PCM files as well as 32 and
|
||||
64-bit floating point WAV files and a number of compressed formats. It
|
||||
compiles and runs on *nix, MacOS, and Win32.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development files for libsndfile
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release} pkgconfig
|
||||
|
||||
|
||||
%description devel
|
||||
libsndfile is a C library for reading and writing sound files such as
|
||||
AIFF, AU, WAV, and others through one standard interface.
|
||||
This package contains files needed to develop with libsndfile.
|
||||
|
||||
|
||||
%package utils
|
||||
Summary: Command Line Utilities for libsndfile
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
|
||||
%description utils
|
||||
libsndfile is a C library for reading and writing sound files such as
|
||||
AIFF, AU, WAV, and others through one standard interface.
|
||||
This package contains command line utilities for libsndfile.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .system-gsm
|
||||
rm -r src/GSM610
|
||||
# TODO: check if this patch is still needed
|
||||
%patch1 -p1 -b .zerodivfix
|
||||
%patch2 -p1 -b .deb669ee
|
||||
%patch3 -p1 -b .ced91d7b
|
||||
|
||||
%build
|
||||
autoreconf -I M4 -fiv # for system-gsm patch
|
||||
%configure \
|
||||
--disable-dependency-tracking \
|
||||
--enable-sqlite \
|
||||
--enable-alsa \
|
||||
--enable-largefile \
|
||||
--disable-static
|
||||
|
||||
# Get rid of rpath
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
|
||||
%make_build
|
||||
|
||||
|
||||
%install
|
||||
%make_install
|
||||
rm -rf __docs
|
||||
mkdir __docs
|
||||
cp -pR $RPM_BUILD_ROOT%{_docdir}/%{name}/* __docs
|
||||
rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
|
||||
find %{buildroot} -type f -name "*.la" -delete
|
||||
|
||||
# fix multilib issues
|
||||
mv %{buildroot}%{_includedir}/sndfile.h \
|
||||
%{buildroot}%{_includedir}/sndfile-%{__isa_bits}.h
|
||||
|
||||
cat > %{buildroot}%{_includedir}/sndfile.h <<EOF
|
||||
#include <bits/wordsize.h>
|
||||
|
||||
#if __WORDSIZE == 32
|
||||
# include "sndfile-32.h"
|
||||
#elif __WORDSIZE == 64
|
||||
# include "sndfile-64.h"
|
||||
#else
|
||||
# error "unexpected value for __WORDSIZE macro"
|
||||
#endif
|
||||
EOF
|
||||
|
||||
%if 0%{?rhel} != 0
|
||||
rm -f %{buildroot}%{_bindir}/sndfile-jackplay
|
||||
%endif
|
||||
|
||||
|
||||
%check
|
||||
LD_LIBRARY_PATH=$PWD/src/.libs make check
|
||||
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
|
||||
%files
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%doc AUTHORS README NEWS
|
||||
%{_libdir}/%{name}.so.*
|
||||
|
||||
%files utils
|
||||
%{_bindir}/sndfile-cmp
|
||||
%{_bindir}/sndfile-concat
|
||||
%{_bindir}/sndfile-convert
|
||||
%{_bindir}/sndfile-deinterleave
|
||||
%{_bindir}/sndfile-info
|
||||
%{_bindir}/sndfile-interleave
|
||||
%{_bindir}/sndfile-metadata-get
|
||||
%{_bindir}/sndfile-metadata-set
|
||||
%{_bindir}/sndfile-play
|
||||
%{_bindir}/sndfile-salvage
|
||||
%{_mandir}/man1/sndfile-cmp.1*
|
||||
%{_mandir}/man1/sndfile-concat.1*
|
||||
%{_mandir}/man1/sndfile-convert.1*
|
||||
%{_mandir}/man1/sndfile-deinterleave.1*
|
||||
%{_mandir}/man1/sndfile-info.1*
|
||||
%{_mandir}/man1/sndfile-interleave.1*
|
||||
%{_mandir}/man1/sndfile-metadata-get.1*
|
||||
%{_mandir}/man1/sndfile-metadata-set.1*
|
||||
%{_mandir}/man1/sndfile-play.1*
|
||||
%{_mandir}/man1/sndfile-salvage.1*
|
||||
|
||||
%files devel
|
||||
%doc __docs ChangeLog
|
||||
%{_includedir}/sndfile.h
|
||||
%{_includedir}/sndfile.hh
|
||||
%{_includedir}/sndfile-%{__isa_bits}.h
|
||||
%{_libdir}/%{name}.so
|
||||
%{_libdir}/pkgconfig/sndfile.pc
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jan 12 2022 Michal Hlavinka <mhlavink@redhat.com> - 1.0.31-7
|
||||
- fix heap buffer overflow in flac (#2030508)
|
||||
|
||||
* Wed Aug 11 2021 Michal Hlavinka <mhlavink@redhat.com> - 1.0.31-6
|
||||
- a crafted wav file could cause heap buffer overflow that allowed an arbitrary code execution(#1985029)
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com>
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com>
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Mon Feb 22 2021 Michal Hlavinka <mhlavink@redhat.com> - 1.0.31-3
|
||||
- add opus-devel BR to satisfy configure requirements check (#1931251)
|
||||
|
||||
* Mon Jul 13 2020 Tom Stellard <tstellar@redhat.com> - 1.0.31-2
|
||||
- Use make macros
|
||||
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||
|
||||
* Wed Jan 27 2021 Michal Hlavinka <mhlavink@redhat.com> - 1.0.31-1
|
||||
- updated to 1.0.31
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.28-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.28-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.28-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.28-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.28-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.28-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Mar 07 2018 Michal Hlavinka <mhlavink@redhat.com> - 1.0.28-8
|
||||
- add gcc buildrequire
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.28-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 24 2017 Michal Hlavinka <mhlavink@redhat.com> - 1.0.28-6
|
||||
- heap-based Buffer Overflow in psf_binheader_writef function (#1483140, CVE-2017-12562)
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.28-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.28-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Wed Jun 21 2017 Michal Hlavinka <mhlavink@redhat.com> - 1.0.28-3
|
||||
- fix buffer overflow in aiff (CVE-2017-6892,rhbz#1463328)
|
||||
|
||||
* Mon Jun 05 2017 Michal Hlavinka <mhlavink@redhat.com> - 1.0.28-2
|
||||
- fix flac and pcm buffer overflows (CVE-2017-8361,CVE-2017-8362,CVE-2017-8363,CVE-2017-8365)
|
||||
|
||||
* Tue Apr 11 2017 Michal Hlavinka <mhlavink@redhat.com> - 1.0.28-1
|
||||
- updated to 1.0.28
|
||||
- fix possible buffer overflow when parsing crafted ID3 tags (#1440758, CVE-2017-7586)
|
||||
- fix possible buffer overflow when parsing crafted flac file (#1440756, CVE-2017-7585)
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.27-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Nov 11 2016 Michal Hlavinka <mhlavink@redhat.com> - 1.0.27-1
|
||||
- updated to 1.0.27
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.25-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Nov 06 2015 Michal Hlavinka <mhlavink@redhat.com> - 1.0.25-19
|
||||
- fix incomplete patch for CVE-2015-7805
|
||||
|
||||
* Fri Nov 06 2015 Michal Hlavinka <mhlavink@redhat.com> - 1.0.25-18
|
||||
- fix CVE-2015-7805: Heap overflow vulnerability when parsing specially
|
||||
crafted AIFF header
|
||||
|
||||
* Thu Aug 27 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 1.0.25-17
|
||||
- Use __isa_bits macro instead of list of 64-bit architectures
|
||||
|
||||
* Sun Jul 19 2015 Peter Robinson <pbrobinson@fedoraproject.org> 1.0.25-16
|
||||
- Fix FTBFS
|
||||
- Use %%license
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.25-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Tue Jan 13 2015 Michal Hlavinka <mhlavink@redhat.com> - 1.0.25-14
|
||||
- fix CVE-2014-9496: 2 buffer overruns in sd2_parse_rsrc_fork (#1178840)
|
||||
- division by zero leading to denial of service in psf_fwrite (#1177254)
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.25-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Aug 02 2014 Kalev Lember <kalevlember@gmail.com> - 1.0.25-12
|
||||
- Fix up previous commit
|
||||
|
||||
* Sat Aug 2 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.0.25-11
|
||||
- Modernise spec
|
||||
- Generic 32/64bit platform detection
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.25-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Jan 13 2014 Michal Hlavinka <mhlavink@redhat.com> - 1.0.25-9
|
||||
- fix ppc64le build (#1051639)
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.25-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Mon Jun 03 2013 Michal Hlavinka <mhlavink@redhat.com> - 1.0.25-7
|
||||
- fix support for aarch64, another part (#969831)
|
||||
|
||||
* Wed Mar 27 2013 Michal Hlavinka <mhlavink@redhat.com> - 1.0.25-6
|
||||
- fix support for aarch64 (#925887)
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.25-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.25-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.25-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Sat Nov 12 2011 Ville Skyttä <ville.skytta@iki.fi> - 1.0.25-2
|
||||
- Patch to use system libgsm instead of a bundled copy.
|
||||
- Make main package dep in -devel ISA qualified.
|
||||
- Drop -octave Provides (not actually built with octave > 3.0).
|
||||
- Don't build throwaway static lib.
|
||||
- Run test suite during build.
|
||||
|
||||
* Thu Jul 14 2011 Michal Hlavinka <mhlavink@redhat.com> - 1.0.25-1
|
||||
- Update to 1.0.25
|
||||
- fixes integer overflow by processing certain PAF audio files (#721240)
|
||||
|
||||
* Sun Mar 27 2011 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> - 1.0.24-1
|
||||
- Update to 1.0.24
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.23-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Sat Oct 16 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> - 1.0.23-1
|
||||
- Update to 10.0.23
|
||||
|
||||
* Tue Oct 05 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> - 1.0.22-1
|
||||
- Update to 10.0.22
|
||||
|
||||
* Tue May 11 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> - 1.0.21-1
|
||||
- Update to 10.0.21
|
||||
- Do not include the static library in the package (RHBZ#556074)
|
||||
- Remove BR on jack since sndfile-jackplay is not provided anymore
|
||||
|
||||
* Mon Feb 1 2010 Stepan Kasal <skasal@redhat.com> - 1.0.20-5
|
||||
- Do not build against Jack on RHEL
|
||||
- Fix the Source0: URL
|
||||
- Fix the licence tag
|
||||
|
||||
* Sat Nov 14 2009 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> - 1.0.20-4
|
||||
- Split utils into a subpackage
|
||||
|
||||
* Sat Nov 14 2009 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> - 1.0.20-3
|
||||
- Add FLAC/Ogg/Vorbis support (BR: libvorbis-devel)
|
||||
- Make build verbose
|
||||
- Remove rpath
|
||||
- Fix ChangeLog encoding
|
||||
- Move the big Changelog to the devel package
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.20-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Sat Jun 06 2009 Lennart Poettering <lpoetter@redhat.com> - 1.0.20-1
|
||||
- Updated to 1.0.20
|
||||
|
||||
* Tue Mar 03 2009 Robert Scheck <robert@fedoraproject.org> - 1.0.17-8
|
||||
- Rebuilt against libtool 2.2
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.17-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Sat Oct 25 2008 Andreas Thienemann <andreas@bawue.net> - 1.0.17-6
|
||||
- Removed spurious #endif in the libsndfile.h wrapper. Thx to Edward
|
||||
Sheldrake for finding it. Fixes #468508.
|
||||
- Fix build for autoconf-2.63
|
||||
|
||||
* Thu Oct 23 2008 Andreas Thienemann <andreas@bawue.net> - 1.0.17-5
|
||||
- Fixed multilib conflict. #342401
|
||||
- Made flac support actually work correctly.
|
||||
|
||||
* Thu Aug 7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0.17-4
|
||||
- fix license tag
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.17-3
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Thu Sep 20 2007 Andreas Thienemann <andreas@bawue.net> - 1.0.17-2
|
||||
- Adding FLAC support to libsndfile courtesy of gentoo, #237575
|
||||
- Fixing CVE-2007-4974. Thanks to the gentoo people for the patch, #296221
|
||||
|
||||
* Fri Sep 08 2006 Andreas Thienemann <andreas@bawue.net> - 1.0.17-1
|
||||
- Updated to 1.0.17
|
||||
|
||||
* Sun Apr 30 2006 Andreas Thienemann <andreas@bawue.net> - 1.0.16-1
|
||||
- Updated to 1.0.16
|
||||
|
||||
* Thu Mar 30 2006 Andreas Thienemann <andreas@bawue.net> - 1.0.15-1
|
||||
- Updated to 1.0.15
|
||||
|
||||
* Thu Mar 16 2006 Dams <anvil[AT]livna.org> - 1.0.14-1.fc5
|
||||
- Updated to 1.0.14
|
||||
- Dropped patch0
|
||||
|
||||
* Thu May 12 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.0.11-3
|
||||
- rebuilt
|
||||
|
||||
* Sat Mar 5 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.0.11-2
|
||||
- Fix format string bug (#149863).
|
||||
- Drop explicit Epoch 0.
|
||||
|
||||
* Sat Dec 4 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:1.0.11-0.fdr.1
|
||||
- Update to 1.0.11.
|
||||
|
||||
* Wed Oct 13 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:1.0.10-0.fdr.1
|
||||
- Update to 1.0.10, update URLs, include ALSA support.
|
||||
- Disable dependency tracking to speed up the build.
|
||||
- Add missing ldconfig invocations.
|
||||
- Make -devel require pkgconfig.
|
||||
- Include developer docs in -devel.
|
||||
- Provide -octave in main package, own more related dirs.
|
||||
- Bring specfile up to date with current spec templates.
|
||||
|
||||
* Sat Apr 12 2003 Dams <anvil[AT]livna.org>
|
||||
- Initial build.
|
Loading…
Reference in New Issue
Block a user