updated to 1.0.31
This commit is contained in:
parent
af3b7d2a10
commit
17efde6a79
@ -1,6 +1,87 @@
|
|||||||
diff -up libsndfile-1.0.28/src/gsm610.c.systemgsm libsndfile-1.0.28/src/gsm610.c
|
diff -up libsndfile-1.0.31/CMakeLists.txt.nobundlegsm libsndfile-1.0.31/CMakeLists.txt
|
||||||
--- libsndfile-1.0.28/src/gsm610.c.systemgsm 2016-09-10 10:08:27.000000000 +0200
|
--- libsndfile-1.0.31/CMakeLists.txt.nobundlegsm 2021-01-24 13:22:23.000000000 +0100
|
||||||
+++ libsndfile-1.0.28/src/gsm610.c 2017-04-11 10:47:40.437162489 +0200
|
+++ libsndfile-1.0.31/CMakeLists.txt 2021-01-27 12:54:51.112184824 +0100
|
||||||
|
@@ -230,7 +230,6 @@ add_library (sndfile
|
||||||
|
src/double64.c
|
||||||
|
src/ima_adpcm.c
|
||||||
|
src/ms_adpcm.c
|
||||||
|
- src/gsm610.c
|
||||||
|
src/dwvw.c
|
||||||
|
src/vox_adpcm.c
|
||||||
|
src/interleave.c
|
||||||
|
@@ -286,23 +285,6 @@ add_library (sndfile
|
||||||
|
src/ogg_opus.c
|
||||||
|
src/ogg_vcomment.c
|
||||||
|
src/nms_adpcm.c
|
||||||
|
- src/GSM610/config.h
|
||||||
|
- src/GSM610/gsm.h
|
||||||
|
- src/GSM610/gsm610_priv.h
|
||||||
|
- src/GSM610/add.c
|
||||||
|
- src/GSM610/code.c
|
||||||
|
- src/GSM610/decode.c
|
||||||
|
- src/GSM610/gsm_create.c
|
||||||
|
- src/GSM610/gsm_decode.c
|
||||||
|
- src/GSM610/gsm_destroy.c
|
||||||
|
- src/GSM610/gsm_encode.c
|
||||||
|
- src/GSM610/gsm_option.c
|
||||||
|
- src/GSM610/long_term.c
|
||||||
|
- src/GSM610/lpc.c
|
||||||
|
- src/GSM610/preprocess.c
|
||||||
|
- src/GSM610/rpe.c
|
||||||
|
- src/GSM610/short_term.c
|
||||||
|
- src/GSM610/table.c
|
||||||
|
src/G72x/g72x.h
|
||||||
|
src/G72x/g72x_priv.h
|
||||||
|
src/G72x/g721.c
|
||||||
|
@@ -349,6 +331,7 @@ target_link_libraries (sndfile
|
||||||
|
$<$<BOOL:${HAVE_EXTERNAL_XIPH_LIBS}>:FLAC::FLAC>
|
||||||
|
$<$<AND:$<BOOL:${ENABLE_EXPERIMENTAL}>,$<BOOL:${HAVE_EXTERNAL_XIPH_LIBS}>,$<BOOL:${HAVE_SPEEX}>>:Speex::Speex>
|
||||||
|
$<$<BOOL:${HAVE_EXTERNAL_XIPH_LIBS}>:Opus::opus>
|
||||||
|
+ -lgsm
|
||||||
|
)
|
||||||
|
set_target_properties (sndfile PROPERTIES
|
||||||
|
PUBLIC_HEADER "${sndfile_HDRS}"
|
||||||
|
diff -up libsndfile-1.0.31/Makefile.am.nobundlegsm libsndfile-1.0.31/Makefile.am
|
||||||
|
--- libsndfile-1.0.31/Makefile.am.nobundlegsm 2021-01-27 12:57:08.819482207 +0100
|
||||||
|
+++ libsndfile-1.0.31/Makefile.am 2021-01-27 12:57:08.847481859 +0100
|
||||||
|
@@ -46,7 +46,6 @@ SYMBOL_FILES = src/Symbols.gnu-binutils
|
||||||
|
|
||||||
|
EXTRA_DIST += include/sndfile.h.in src/config.h.in src/test_endswap.tpl src/test_endswap.def \
|
||||||
|
$(SYMBOL_FILES) src/create_symbols_file.py src/binheader_writef_check.py \
|
||||||
|
- src/GSM610/README src/GSM610/COPYRIGHT src/GSM610/ChangeLog \
|
||||||
|
src/G72x/README src/G72x/README.original src/G72x/ChangeLog \
|
||||||
|
src/make-static-lib-hidden-privates.sh \
|
||||||
|
src/config.h.cmake
|
||||||
|
@@ -71,7 +70,7 @@ src_libsndfile_la_SOURCES = src/sndfile.
|
||||||
|
src/ogg_vorbis.c src/ogg_speex.c src/ogg_pcm.c src/ogg_opus.c src/ogg_vcomment.c \
|
||||||
|
src/common.h src/sfconfig.h src/sfendian.h src/wavlike.h src/sf_unistd.h src/ogg.h src/chanmap.h src/ogg_vcomment.h
|
||||||
|
nodist_src_libsndfile_la_SOURCES = $(nodist_include_HEADERS)
|
||||||
|
-src_libsndfile_la_LIBADD = src/GSM610/libgsm.la src/G72x/libg72x.la src/ALAC/libalac.la \
|
||||||
|
+src_libsndfile_la_LIBADD = -lgsm src/G72x/libg72x.la src/ALAC/libalac.la \
|
||||||
|
src/libcommon.la $(EXTERNAL_XIPH_LIBS) -lm
|
||||||
|
EXTRA_src_libsndfile_la_DEPENDENCIES = $(SYMBOL_FILES)
|
||||||
|
|
||||||
|
@@ -90,17 +89,6 @@ src_test_main_SOURCES = src/test_main.c
|
||||||
|
src/test_binheader_writef.c src/test_nms_adpcm.c
|
||||||
|
src_test_main_LDADD = src/libcommon.la
|
||||||
|
|
||||||
|
-##############
|
||||||
|
-# src/GSM610 #
|
||||||
|
-##############
|
||||||
|
-
|
||||||
|
-noinst_LTLIBRARIES += src/GSM610/libgsm.la
|
||||||
|
-src_GSM610_libgsm_la_SOURCES = src/GSM610/config.h src/GSM610/gsm.h src/GSM610/gsm610_priv.h \
|
||||||
|
- src/GSM610/add.c src/GSM610/code.c src/GSM610/decode.c src/GSM610/gsm_create.c \
|
||||||
|
- src/GSM610/gsm_decode.c src/GSM610/gsm_destroy.c src/GSM610/gsm_encode.c \
|
||||||
|
- src/GSM610/gsm_option.c src/GSM610/long_term.c src/GSM610/lpc.c src/GSM610/preprocess.c \
|
||||||
|
- src/GSM610/rpe.c src/GSM610/short_term.c src/GSM610/table.c
|
||||||
|
-
|
||||||
|
############
|
||||||
|
# src/G72x #
|
||||||
|
############
|
||||||
|
diff -up libsndfile-1.0.31/src/gsm610.c.nobundlegsm libsndfile-1.0.31/src/gsm610.c
|
||||||
|
--- libsndfile-1.0.31/src/gsm610.c.nobundlegsm 2021-01-23 17:12:45.000000000 +0100
|
||||||
|
+++ libsndfile-1.0.31/src/gsm610.c 2021-01-27 12:54:51.112184824 +0100
|
||||||
@@ -27,7 +27,7 @@
|
@@ -27,7 +27,7 @@
|
||||||
#include "sfendian.h"
|
#include "sfendian.h"
|
||||||
#include "common.h"
|
#include "common.h"
|
||||||
@ -15,42 +96,8 @@ diff -up libsndfile-1.0.28/src/gsm610.c.systemgsm libsndfile-1.0.28/src/gsm610.c
|
|||||||
pgsm610->blockcount = 0 ;
|
pgsm610->blockcount = 0 ;
|
||||||
|
|
||||||
- gsm_init (pgsm610->gsm_data) ;
|
- gsm_init (pgsm610->gsm_data) ;
|
||||||
+ gsm_destroy (pgsm610->gsm_data) ;
|
+ gsm_destroy (pgsm610->gsm_data) ;
|
||||||
+ pgsm610->gsm_data = gsm_create () ;
|
+ pgsm610->gsm_data = gsm_create () ;
|
||||||
if ((SF_CONTAINER (psf->sf.format)) == SF_FORMAT_WAV ||
|
if ((SF_CONTAINER (psf->sf.format)) == SF_FORMAT_WAV ||
|
||||||
(SF_CONTAINER (psf->sf.format)) == SF_FORMAT_W64)
|
(SF_CONTAINER (psf->sf.format)) == SF_FORMAT_W64)
|
||||||
gsm_option (pgsm610->gsm_data, GSM_OPT_WAV49, &true_flag) ;
|
gsm_option (pgsm610->gsm_data, GSM_OPT_WAV49, &true_flag) ;
|
||||||
diff -up libsndfile-1.0.28/src/Makefile.am.systemgsm libsndfile-1.0.28/src/Makefile.am
|
|
||||||
--- libsndfile-1.0.28/src/Makefile.am.systemgsm 2017-04-01 09:18:02.000000000 +0200
|
|
||||||
+++ libsndfile-1.0.28/src/Makefile.am 2017-04-11 10:48:43.855620172 +0200
|
|
||||||
@@ -8,7 +8,7 @@ lib_LTLIBRARIES = libsndfile.la
|
|
||||||
include_HEADERS = sndfile.hh
|
|
||||||
nodist_include_HEADERS = sndfile.h
|
|
||||||
|
|
||||||
-noinst_LTLIBRARIES = GSM610/libgsm.la G72x/libg72x.la ALAC/libalac.la libcommon.la
|
|
||||||
+noinst_LTLIBRARIES = G72x/libg72x.la ALAC/libalac.la libcommon.la
|
|
||||||
|
|
||||||
SYMBOL_FILES = Symbols.gnu-binutils Symbols.darwin libsndfile-1.def Symbols.os2 Symbols.static
|
|
||||||
|
|
||||||
@@ -43,7 +43,7 @@ libsndfile_la_CPPFLAGS = -DSNDFILE_EXPOR
|
|
||||||
libsndfile_la_LDFLAGS = -no-undefined -version-info $(SHARED_VERSION_INFO) $(SHLIB_VERSION_ARG)
|
|
||||||
libsndfile_la_SOURCES = $(FILESPECIFIC) $(noinst_HEADERS)
|
|
||||||
nodist_libsndfile_la_SOURCES = $(nodist_include_HEADERS)
|
|
||||||
-libsndfile_la_LIBADD = GSM610/libgsm.la G72x/libg72x.la ALAC/libalac.la \
|
|
||||||
+libsndfile_la_LIBADD = -lgsm G72x/libg72x.la ALAC/libalac.la \
|
|
||||||
libcommon.la $(EXTERNAL_XIPH_LIBS) -lm
|
|
||||||
|
|
||||||
EXTRA_libsndfile_la_DEPENDENCIES = $(SYMBOL_FILES)
|
|
||||||
@@ -58,12 +58,6 @@ libcommon_la_SOURCES = common.c file_io.
|
|
||||||
#======================================================================
|
|
||||||
# Subdir libraries.
|
|
||||||
|
|
||||||
-GSM610_libgsm_la_SOURCES = GSM610/config.h GSM610/gsm.h GSM610/gsm610_priv.h \
|
|
||||||
- GSM610/add.c GSM610/code.c GSM610/decode.c GSM610/gsm_create.c \
|
|
||||||
- GSM610/gsm_decode.c GSM610/gsm_destroy.c GSM610/gsm_encode.c \
|
|
||||||
- GSM610/gsm_option.c GSM610/long_term.c GSM610/lpc.c GSM610/preprocess.c \
|
|
||||||
- GSM610/rpe.c GSM610/short_term.c GSM610/table.c
|
|
||||||
-
|
|
||||||
G72x_libg72x_la_SOURCES = G72x/g72x.h G72x/g72x_priv.h \
|
|
||||||
G72x/g721.c G72x/g723_16.c G72x/g723_24.c G72x/g723_40.c G72x/g72x.c
|
|
||||||
|
|
||||||
|
@ -1,88 +0,0 @@
|
|||||||
From cf7a8182c2642c50f1cf90dddea9ce96a8bad2e8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?J=C3=B6rn=20Heusipp?= <osmanx@problemloesungsmaschine.de>
|
|
||||||
Date: Wed, 14 Jun 2017 12:25:40 +0200
|
|
||||||
Subject: [PATCH] src/common.c: Fix heap buffer overflows when writing strings
|
|
||||||
in binheader
|
|
||||||
|
|
||||||
Fixes the following problems:
|
|
||||||
1. Case 's' only enlarges the buffer by 16 bytes instead of size bytes.
|
|
||||||
2. psf_binheader_writef() enlarges the header buffer (if needed) prior to the
|
|
||||||
big switch statement by an amount (16 bytes) which is enough for all cases
|
|
||||||
where only a single value gets added. Cases 's', 'S', 'p' however
|
|
||||||
additionally write an arbitrary length block of data and again enlarge the
|
|
||||||
buffer to the required amount. However, the required space calculation does
|
|
||||||
not take into account the size of the length field which gets output before
|
|
||||||
the data.
|
|
||||||
3. Buffer size requirement calculation in case 'S' does not account for the
|
|
||||||
padding byte ("size += (size & 1) ;" happens after the calculation which
|
|
||||||
uses "size").
|
|
||||||
4. Case 'S' can overrun the header buffer by 1 byte when no padding is
|
|
||||||
involved
|
|
||||||
("memcpy (&(psf->header.ptr [psf->header.indx]), strptr, size + 1) ;" while
|
|
||||||
the buffer is only guaranteed to have "size" space available).
|
|
||||||
5. "psf->header.ptr [psf->header.indx] = 0 ;" in case 'S' always writes 1 byte
|
|
||||||
beyond the space which is guaranteed to be allocated in the header buffer.
|
|
||||||
6. Case 's' can overrun the provided source string by 1 byte if padding is
|
|
||||||
involved ("memcpy (&(psf->header.ptr [psf->header.indx]), strptr, size) ;"
|
|
||||||
where "size" is "strlen (strptr) + 1" (which includes the 0 terminator,
|
|
||||||
plus optionally another 1 which is padding and not guaranteed to be
|
|
||||||
readable via the source string pointer).
|
|
||||||
|
|
||||||
Closes: https://github.com/erikd/libsndfile/issues/292
|
|
||||||
---
|
|
||||||
src/common.c | 15 +++++++--------
|
|
||||||
1 file changed, 7 insertions(+), 8 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/common.c b/src/common.c
|
|
||||||
index 1a6204ca..6b2a2ee9 100644
|
|
||||||
--- a/src/common.c
|
|
||||||
+++ b/src/common.c
|
|
||||||
@@ -681,16 +681,16 @@ psf_binheader_writef (SF_PRIVATE *psf, const char *format, ...)
|
|
||||||
/* Write a C string (guaranteed to have a zero terminator). */
|
|
||||||
strptr = va_arg (argptr, char *) ;
|
|
||||||
size = strlen (strptr) + 1 ;
|
|
||||||
- size += (size & 1) ;
|
|
||||||
|
|
||||||
- if (psf->header.indx + (sf_count_t) size >= psf->header.len && psf_bump_header_allocation (psf, 16))
|
|
||||||
+ if (psf->header.indx + 4 + (sf_count_t) size + (sf_count_t) (size & 1) > psf->header.len && psf_bump_header_allocation (psf, 4 + size + (size & 1)))
|
|
||||||
return count ;
|
|
||||||
|
|
||||||
if (psf->rwf_endian == SF_ENDIAN_BIG)
|
|
||||||
- header_put_be_int (psf, size) ;
|
|
||||||
+ header_put_be_int (psf, size + (size & 1)) ;
|
|
||||||
else
|
|
||||||
- header_put_le_int (psf, size) ;
|
|
||||||
+ header_put_le_int (psf, size + (size & 1)) ;
|
|
||||||
memcpy (&(psf->header.ptr [psf->header.indx]), strptr, size) ;
|
|
||||||
+ size += (size & 1) ;
|
|
||||||
psf->header.indx += size ;
|
|
||||||
psf->header.ptr [psf->header.indx - 1] = 0 ;
|
|
||||||
count += 4 + size ;
|
|
||||||
@@ -703,16 +703,15 @@ psf_binheader_writef (SF_PRIVATE *psf, const char *format, ...)
|
|
||||||
*/
|
|
||||||
strptr = va_arg (argptr, char *) ;
|
|
||||||
size = strlen (strptr) ;
|
|
||||||
- if (psf->header.indx + (sf_count_t) size > psf->header.len && psf_bump_header_allocation (psf, size))
|
|
||||||
+ if (psf->header.indx + 4 + (sf_count_t) size + (sf_count_t) (size & 1) > psf->header.len && psf_bump_header_allocation (psf, 4 + size + (size & 1)))
|
|
||||||
return count ;
|
|
||||||
if (psf->rwf_endian == SF_ENDIAN_BIG)
|
|
||||||
header_put_be_int (psf, size) ;
|
|
||||||
else
|
|
||||||
header_put_le_int (psf, size) ;
|
|
||||||
- memcpy (&(psf->header.ptr [psf->header.indx]), strptr, size + 1) ;
|
|
||||||
+ memcpy (&(psf->header.ptr [psf->header.indx]), strptr, size + (size & 1)) ;
|
|
||||||
size += (size & 1) ;
|
|
||||||
psf->header.indx += size ;
|
|
||||||
- psf->header.ptr [psf->header.indx] = 0 ;
|
|
||||||
count += 4 + size ;
|
|
||||||
break ;
|
|
||||||
|
|
||||||
@@ -724,7 +723,7 @@ psf_binheader_writef (SF_PRIVATE *psf, const char *format, ...)
|
|
||||||
size = (size & 1) ? size : size + 1 ;
|
|
||||||
size = (size > 254) ? 254 : size ;
|
|
||||||
|
|
||||||
- if (psf->header.indx + (sf_count_t) size > psf->header.len && psf_bump_header_allocation (psf, size))
|
|
||||||
+ if (psf->header.indx + 1 + (sf_count_t) size > psf->header.len && psf_bump_header_allocation (psf, 1 + size))
|
|
||||||
return count ;
|
|
||||||
|
|
||||||
header_put_byte (psf, size) ;
|
|
@ -1,64 +0,0 @@
|
|||||||
From fd0484aba8e51d16af1e3a880f9b8b857b385eb3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Erik de Castro Lopo <erikd@mega-nerd.com>
|
|
||||||
Date: Wed, 12 Apr 2017 19:45:30 +1000
|
|
||||||
Subject: [PATCH] FLAC: Fix a buffer read overrun
|
|
||||||
|
|
||||||
Buffer read overrun occurs when reading a FLAC file that switches
|
|
||||||
from 2 channels to one channel mid-stream. Only option is to
|
|
||||||
abort the read.
|
|
||||||
|
|
||||||
Closes: https://github.com/erikd/libsndfile/issues/230
|
|
||||||
---
|
|
||||||
src/common.h | 1 +
|
|
||||||
src/flac.c | 13 +++++++++++++
|
|
||||||
src/sndfile.c | 1 +
|
|
||||||
3 files changed, 15 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/common.h b/src/common.h
|
|
||||||
index 0bd810c3..e2669b6a 100644
|
|
||||||
--- a/src/common.h
|
|
||||||
+++ b/src/common.h
|
|
||||||
@@ -725,6 +725,7 @@ enum
|
|
||||||
SFE_FLAC_INIT_DECODER,
|
|
||||||
SFE_FLAC_LOST_SYNC,
|
|
||||||
SFE_FLAC_BAD_SAMPLE_RATE,
|
|
||||||
+ SFE_FLAC_CHANNEL_COUNT_CHANGED,
|
|
||||||
SFE_FLAC_UNKOWN_ERROR,
|
|
||||||
|
|
||||||
SFE_WVE_NOT_WVE,
|
|
||||||
diff --git a/src/flac.c b/src/flac.c
|
|
||||||
index 84de0e26..986a7b8f 100644
|
|
||||||
--- a/src/flac.c
|
|
||||||
+++ b/src/flac.c
|
|
||||||
@@ -434,6 +434,19 @@ sf_flac_meta_callback (const FLAC__StreamDecoder * UNUSED (decoder), const FLAC_
|
|
||||||
|
|
||||||
switch (metadata->type)
|
|
||||||
{ case FLAC__METADATA_TYPE_STREAMINFO :
|
|
||||||
+ if (psf->sf.channels > 0 && psf->sf.channels != (int) metadata->data.stream_info.channels)
|
|
||||||
+ { psf_log_printf (psf, "Error: FLAC stream changed from %d to %d channels\n"
|
|
||||||
+ "Nothing to be but to error out.\n" ,
|
|
||||||
+ psf->sf.channels, metadata->data.stream_info.channels) ;
|
|
||||||
+ psf->error = SFE_FLAC_CHANNEL_COUNT_CHANGED ;
|
|
||||||
+ return ;
|
|
||||||
+ } ;
|
|
||||||
+
|
|
||||||
+ if (psf->sf.channels > 0 && psf->sf.samplerate != (int) metadata->data.stream_info.sample_rate)
|
|
||||||
+ { psf_log_printf (psf, "Warning: FLAC stream changed sample rates from %d to %d.\n"
|
|
||||||
+ "Carrying on as if nothing happened.",
|
|
||||||
+ psf->sf.samplerate, metadata->data.stream_info.sample_rate) ;
|
|
||||||
+ } ;
|
|
||||||
psf->sf.channels = metadata->data.stream_info.channels ;
|
|
||||||
psf->sf.samplerate = metadata->data.stream_info.sample_rate ;
|
|
||||||
psf->sf.frames = metadata->data.stream_info.total_samples ;
|
|
||||||
diff --git a/src/sndfile.c b/src/sndfile.c
|
|
||||||
index 41875610..e2a87be8 100644
|
|
||||||
--- a/src/sndfile.c
|
|
||||||
+++ b/src/sndfile.c
|
|
||||||
@@ -245,6 +245,7 @@ ErrorStruct SndfileErrors [] =
|
|
||||||
{ SFE_FLAC_INIT_DECODER , "Error : problem with initialization of the flac decoder." },
|
|
||||||
{ SFE_FLAC_LOST_SYNC , "Error : flac decoder lost sync." },
|
|
||||||
{ SFE_FLAC_BAD_SAMPLE_RATE, "Error : flac does not support this sample rate." },
|
|
||||||
+ { SFE_FLAC_CHANNEL_COUNT_CHANGED, "Error : flac channel changed mid stream." },
|
|
||||||
{ SFE_FLAC_UNKOWN_ERROR , "Error : unknown error in flac decoder." },
|
|
||||||
|
|
||||||
{ SFE_WVE_NOT_WVE , "Error : not a WVE file." },
|
|
@ -1,25 +0,0 @@
|
|||||||
From f833c53cb596e9e1792949f762e0b33661822748 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Erik de Castro Lopo <erikd@mega-nerd.com>
|
|
||||||
Date: Tue, 23 May 2017 20:15:24 +1000
|
|
||||||
Subject: [PATCH] src/aiff.c: Fix a buffer read overflow
|
|
||||||
|
|
||||||
Secunia Advisory SA76717.
|
|
||||||
|
|
||||||
Found by: Laurent Delosieres, Secunia Research at Flexera Software
|
|
||||||
---
|
|
||||||
src/aiff.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/aiff.c b/src/aiff.c
|
|
||||||
index 5b5f9f53..45864b76 100644
|
|
||||||
--- a/src/aiff.c
|
|
||||||
+++ b/src/aiff.c
|
|
||||||
@@ -1759,7 +1759,7 @@ aiff_read_chanmap (SF_PRIVATE * psf, unsigned dword)
|
|
||||||
psf_binheader_readf (psf, "j", dword - bytesread) ;
|
|
||||||
|
|
||||||
if (map_info->channel_map != NULL)
|
|
||||||
- { size_t chanmap_size = psf->sf.channels * sizeof (psf->channel_map [0]) ;
|
|
||||||
+ { size_t chanmap_size = SF_MIN (psf->sf.channels, layout_tag & 0xffff) * sizeof (psf->channel_map [0]) ;
|
|
||||||
|
|
||||||
free (psf->channel_map) ;
|
|
||||||
|
|
@ -1,18 +1,12 @@
|
|||||||
Summary: Library for reading and writing sound files
|
Summary: Library for reading and writing sound files
|
||||||
Name: libsndfile
|
Name: libsndfile
|
||||||
Version: 1.0.28
|
Version: 1.0.31
|
||||||
Release: 14%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+ and GPLv2+ and BSD
|
License: LGPLv2+ and GPLv2+ and BSD
|
||||||
URL: http://www.mega-nerd.com/libsndfile/
|
URL: http://libsndfile.github.io/libsndfile/
|
||||||
Source0: http://www.mega-nerd.com/libsndfile/files/libsndfile-%{version}.tar.gz
|
Source0: https://github.com/libsndfile/libsndfile/releases/download/%{version}/libsndfile-%{version}.tar.bz2
|
||||||
Patch0: libsndfile-1.0.25-system-gsm.patch
|
Patch0: libsndfile-1.0.25-system-gsm.patch
|
||||||
Patch1: libsndfile-1.0.25-zerodivfix.patch
|
Patch1: libsndfile-1.0.25-zerodivfix.patch
|
||||||
Patch2: revert.patch
|
|
||||||
Patch3: libsndfile-1.0.28-flacbufovfl.patch
|
|
||||||
Patch4: libsndfile-1.0.29-cve2017_6892.patch
|
|
||||||
#libsndfile-1.0.29-cve2017_6892.patch
|
|
||||||
# from upstream, for <= 1.0.28, rhbz#1483140
|
|
||||||
Patch5: libsndfile-1.0.28-cve2017_12562.patch
|
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: alsa-lib-devel
|
BuildRequires: alsa-lib-devel
|
||||||
BuildRequires: flac-devel
|
BuildRequires: flac-devel
|
||||||
@ -58,13 +52,10 @@ This package contains command line utilities for libsndfile.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .systemgsm
|
%patch0 -p1 -b .system-gsm
|
||||||
%patch1 -p1 -b .zerodivfix
|
|
||||||
%patch2 -p1 -b .revert
|
|
||||||
%patch3 -p1 -b .flacbufovfl
|
|
||||||
%patch4 -p1 -b .cve2017_6892
|
|
||||||
%patch5 -p1 -b .cve2017_12562
|
|
||||||
rm -r src/GSM610
|
rm -r src/GSM610
|
||||||
|
# TODO: check if this patch is still needed
|
||||||
|
%patch1 -p1 -b .zerodivfix
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -I M4 -fiv # for system-gsm patch
|
autoreconf -I M4 -fiv # for system-gsm patch
|
||||||
@ -134,7 +125,6 @@ LD_LIBRARY_PATH=$PWD/src/.libs make check
|
|||||||
%{_bindir}/sndfile-metadata-get
|
%{_bindir}/sndfile-metadata-get
|
||||||
%{_bindir}/sndfile-metadata-set
|
%{_bindir}/sndfile-metadata-set
|
||||||
%{_bindir}/sndfile-play
|
%{_bindir}/sndfile-play
|
||||||
%{_bindir}/sndfile-regtest
|
|
||||||
%{_bindir}/sndfile-salvage
|
%{_bindir}/sndfile-salvage
|
||||||
%{_mandir}/man1/sndfile-cmp.1*
|
%{_mandir}/man1/sndfile-cmp.1*
|
||||||
%{_mandir}/man1/sndfile-concat.1*
|
%{_mandir}/man1/sndfile-concat.1*
|
||||||
@ -157,6 +147,9 @@ LD_LIBRARY_PATH=$PWD/src/.libs make check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 27 2021 Michal Hlavinka <mhlavink@redhat.com> - 1.0.31-1
|
||||||
|
- updated to 1.0.31
|
||||||
|
|
||||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.28-14
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.28-14
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
37
revert.patch
37
revert.patch
@ -1,37 +0,0 @@
|
|||||||
--- libsndfile-1.0.28/src/rf64.c 2017-04-02 09:43:22.000000000 +0200
|
|
||||||
+++ libsndfile-1.0.27/src/rf64.c 2016-04-01 23:08:53.000000000 +0200
|
|
||||||
@@ -735,25 +734,27 @@ rf64_write_header (SF_PRIVATE *psf, int
|
|
||||||
|
|
||||||
#endif
|
|
||||||
|
|
||||||
- pad_size = psf->dataoffset - 16 - psf->header.indx ;
|
|
||||||
- if (pad_size >= 0)
|
|
||||||
- psf_binheader_writef (psf, "m4z", PAD_MARKER, pad_size, make_size_t (pad_size)) ;
|
|
||||||
+ if (psf->header.indx + 8 < psf->dataoffset)
|
|
||||||
+ { /* Add PAD data if necessary. */
|
|
||||||
+ int k = psf->dataoffset - 16 - psf->header.indx ;
|
|
||||||
+ psf_binheader_writef (psf, "m4z", PAD_MARKER, k, make_size_t (k)) ;
|
|
||||||
+ } ;
|
|
||||||
|
|
||||||
if (wpriv->rf64_downgrade && (psf->filelength < RIFF_DOWNGRADE_BYTES))
|
|
||||||
psf_binheader_writef (psf, "tm8", data_MARKER, psf->datalength) ;
|
|
||||||
else
|
|
||||||
psf_binheader_writef (psf, "m4", data_MARKER, 0xffffffff) ;
|
|
||||||
|
|
||||||
- psf_fwrite (psf->header.ptr, psf->header.indx, 1, psf) ;
|
|
||||||
+ psf_fwrite (psf->header.ptr, psf->header.indx, 1, psf) ;
|
|
||||||
if (psf->error)
|
|
||||||
return psf->error ;
|
|
||||||
|
|
||||||
- if (has_data && psf->dataoffset != psf->header.indx)
|
|
||||||
- { psf_log_printf (psf, "Oooops : has_data && psf->dataoffset != psf->header.indx\n") ;
|
|
||||||
+ if (has_data && psf->dataoffset != psf->header.indx)
|
|
||||||
+ { psf_log_printf (psf, "Oooops : has_data && psf->dataoffset != psf->header.indx\n") ;
|
|
||||||
return psf->error = SFE_INTERNAL ;
|
|
||||||
} ;
|
|
||||||
|
|
||||||
- psf->dataoffset = psf->header.indx ;
|
|
||||||
+ psf->dataoffset = psf->header.indx ;
|
|
||||||
|
|
||||||
if (NOT (has_data))
|
|
||||||
psf_fseek (psf, psf->dataoffset, SEEK_SET) ;
|
|
Loading…
Reference in New Issue
Block a user