Update to 2.3.3
This commit is contained in:
parent
05d2c52dbb
commit
5371574cc9
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
libsmbios-2.2.26.tar.bz2
|
libsmbios-2.2.26.tar.bz2
|
||||||
/libsmbios-2.2.28.tar.bz2
|
/libsmbios-2.2.28.tar.bz2
|
||||||
/libsmbios-2.3.0.tar.bz2
|
/libsmbios-2.3.0.tar.bz2
|
||||||
|
/libsmbios-2.3.3.tar.gz
|
||||||
|
@ -1,149 +0,0 @@
|
|||||||
From 74913b28e3a436a6c519f66332a0b140bf72aa67 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter Jones <pjones@redhat.com>
|
|
||||||
Date: Thu, 25 Feb 2016 15:22:57 -0500
|
|
||||||
Subject: [PATCH] Don't force the compiler version check on consumers of the
|
|
||||||
library.
|
|
||||||
|
|
||||||
This check just stops things from building when the compiler gets
|
|
||||||
upgraded, and it clearly hasn't been maintained in some time. The .so
|
|
||||||
almost certainly still works fine, and if the headers don't, the
|
|
||||||
consuming build will fail anyway.
|
|
||||||
|
|
||||||
Signed-off-by: Peter Jones <pjones@redhat.com>
|
|
||||||
---
|
|
||||||
Makefile.am | 6 +++---
|
|
||||||
Makefile.in | 6 +++---
|
|
||||||
src/include/smbios/config/compiler/gcc.hpp | 4 ++--
|
|
||||||
src/include/smbios/config/compiler/sunpro_cc.hpp | 2 ++
|
|
||||||
src/include/smbios/config/compiler/visualc.hpp | 2 ++
|
|
||||||
src/include/smbios_c/config/compiler/gcc.h | 4 ++--
|
|
||||||
src/include/smbios_c/config/compiler/visualc.h | 2 ++
|
|
||||||
7 files changed, 16 insertions(+), 10 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
|
||||||
index 0f39e27..8ded6cd 100644
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -17,9 +17,9 @@ lib_LTLIBRARIES=
|
|
||||||
|
|
||||||
TESTS=
|
|
||||||
|
|
||||||
-AM_CPPFLAGS = -I$(top_builddir)/out/include -I$(top_srcdir)/src/include -DLIBSMBIOS_LOCALEDIR=\"$(localedir)\"
|
|
||||||
-AM_CFLAGS = -Wall
|
|
||||||
-AM_CXXFLAGS = -Wall
|
|
||||||
+AM_CPPFLAGS = -I$(top_builddir)/out/include -I$(top_srcdir)/src/include -DLIBSMBIOS_LOCALEDIR=\"$(localedir)\" -DLIBSMBIOS_BUILD
|
|
||||||
+AM_CFLAGS = -Wall -DLIBSMBIOS_BUILD
|
|
||||||
+AM_CXXFLAGS = -Wall -DLIBSMBIOS_BUILD
|
|
||||||
AM_LDADD = $(LIBINTL)
|
|
||||||
|
|
||||||
AM_LDFLAGS = -L$(top_builddir)/out/
|
|
||||||
diff --git a/Makefile.in b/Makefile.in
|
|
||||||
index 00a7c2b..f7a2126 100644
|
|
||||||
--- a/Makefile.in
|
|
||||||
+++ b/Makefile.in
|
|
||||||
@@ -1213,9 +1213,9 @@ check_SCRIPTS =
|
|
||||||
noinst_LTLIBRARIES = out/libgetopt.la
|
|
||||||
lib_LTLIBRARIES = $(am__append_3) out/libsmbios_c.la
|
|
||||||
TESTS = src/pyunit/runtests.sh $(am__append_27)
|
|
||||||
-AM_CPPFLAGS = -I$(top_builddir)/out/include -I$(top_srcdir)/src/include -DLIBSMBIOS_LOCALEDIR=\"$(localedir)\"
|
|
||||||
-AM_CFLAGS = -Wall
|
|
||||||
-AM_CXXFLAGS = -Wall
|
|
||||||
+AM_CPPFLAGS = -I$(top_builddir)/out/include -I$(top_srcdir)/src/include -DLIBSMBIOS_LOCALEDIR=\"$(localedir)\" -DLIBSMBIOS_BUILD
|
|
||||||
+AM_CFLAGS = -Wall -DLIBSMBIOS_BUILD
|
|
||||||
+AM_CXXFLAGS = -Wall -DLIBSMBIOS_BUILD
|
|
||||||
AM_LDADD = $(LIBINTL)
|
|
||||||
AM_LDFLAGS = -L$(top_builddir)/out/ $(am__append_1) $(am__append_2)
|
|
||||||
|
|
||||||
diff --git a/src/include/smbios/config/compiler/gcc.hpp b/src/include/smbios/config/compiler/gcc.hpp
|
|
||||||
index 13d97d9..c8b1b0d 100644
|
|
||||||
--- a/src/include/smbios/config/compiler/gcc.hpp
|
|
||||||
+++ b/src/include/smbios/config/compiler/gcc.hpp
|
|
||||||
@@ -113,6 +113,7 @@
|
|
||||||
# error "Compiler too old. GCC > 3.0 required"
|
|
||||||
#endif
|
|
||||||
//
|
|
||||||
+#ifdef LIBSMBIOS_BUILD
|
|
||||||
#if (__GNUC__ > 5)
|
|
||||||
# if defined(LIBSMBIOS_ASSERT_CONFIG)
|
|
||||||
# error "Unknown compiler version - please run the configure tests and report the results"
|
|
||||||
@@ -120,5 +121,4 @@
|
|
||||||
# warning "Unknown compiler version - please run the configure tests and report the results"
|
|
||||||
# endif
|
|
||||||
#endif
|
|
||||||
-
|
|
||||||
-
|
|
||||||
+#endif
|
|
||||||
diff --git a/src/include/smbios/config/compiler/sunpro_cc.hpp b/src/include/smbios/config/compiler/sunpro_cc.hpp
|
|
||||||
index 64e5c7e..8fc8095 100644
|
|
||||||
--- a/src/include/smbios/config/compiler/sunpro_cc.hpp
|
|
||||||
+++ b/src/include/smbios/config/compiler/sunpro_cc.hpp
|
|
||||||
@@ -123,11 +123,13 @@
|
|
||||||
#endif
|
|
||||||
//
|
|
||||||
// last known and checked version is 0x590:
|
|
||||||
+#ifdef LIBSMBIOS_BUILD
|
|
||||||
#if (__SUNPRO_CC > 0x590)
|
|
||||||
# if defined(LIBSMBIOS_ASSERT_CONFIG)
|
|
||||||
# error "Unknown compiler version - please run the configure tests and report the results"
|
|
||||||
# endif
|
|
||||||
#endif
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#ifndef UNREFERENCED_PARAMETER
|
|
||||||
#define UNREFERENCED_PARAMETER(P) ((void)(P))
|
|
||||||
diff --git a/src/include/smbios/config/compiler/visualc.hpp b/src/include/smbios/config/compiler/visualc.hpp
|
|
||||||
index 564b09b..d244898 100644
|
|
||||||
--- a/src/include/smbios/config/compiler/visualc.hpp
|
|
||||||
+++ b/src/include/smbios/config/compiler/visualc.hpp
|
|
||||||
@@ -171,6 +171,7 @@
|
|
||||||
#endif
|
|
||||||
//
|
|
||||||
// last known and checked version is 1310:
|
|
||||||
+#ifdef LIBSMBIOS_BUILD
|
|
||||||
#if (_MSC_VER > 1400)
|
|
||||||
# if defined(LIBSMBIOS_ASSERT_CONFIG)
|
|
||||||
# error "Unknown compiler version - please run the configure tests and report the results"
|
|
||||||
@@ -178,3 +179,4 @@
|
|
||||||
# pragma message("Unknown compiler version - please run the configure tests and report the results")
|
|
||||||
# endif
|
|
||||||
#endif
|
|
||||||
+#endif
|
|
||||||
diff --git a/src/include/smbios_c/config/compiler/gcc.h b/src/include/smbios_c/config/compiler/gcc.h
|
|
||||||
index 007cc73..a299e72 100644
|
|
||||||
--- a/src/include/smbios_c/config/compiler/gcc.h
|
|
||||||
+++ b/src/include/smbios_c/config/compiler/gcc.h
|
|
||||||
@@ -24,6 +24,7 @@
|
|
||||||
# error "GCC versions < 2.90 not supported"
|
|
||||||
#endif
|
|
||||||
//
|
|
||||||
+#ifdef LIBSMBIOS_BUILD
|
|
||||||
#if (__GNUC__ > 5)
|
|
||||||
# if defined(LIBSMBIOS_C_ASSERT_CONFIG)
|
|
||||||
# error "Unknown compiler version - please run the configure tests and report the results"
|
|
||||||
@@ -31,5 +32,4 @@
|
|
||||||
# warning "Unknown compiler version - please run the configure tests and report the results"
|
|
||||||
# endif
|
|
||||||
#endif
|
|
||||||
-
|
|
||||||
-
|
|
||||||
+#endif
|
|
||||||
diff --git a/src/include/smbios_c/config/compiler/visualc.h b/src/include/smbios_c/config/compiler/visualc.h
|
|
||||||
index 545d4ef..f44ab62 100644
|
|
||||||
--- a/src/include/smbios_c/config/compiler/visualc.h
|
|
||||||
+++ b/src/include/smbios_c/config/compiler/visualc.h
|
|
||||||
@@ -53,6 +53,7 @@
|
|
||||||
#endif
|
|
||||||
//
|
|
||||||
// last known and checked version is 1310:
|
|
||||||
+#ifdef LIBSMBIOS_BUILD
|
|
||||||
#if (_MSC_VER > 1500)
|
|
||||||
# if defined(LIBSMBIOS_C_ASSERT_CONFIG)
|
|
||||||
# error "Unknown compiler version - please run the configure tests and report the results"
|
|
||||||
@@ -60,3 +61,4 @@
|
|
||||||
# pragma message("Unknown compiler version - please run the configure tests and report the results")
|
|
||||||
# endif
|
|
||||||
#endif
|
|
||||||
+#endif
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
@ -5,11 +5,11 @@
|
|||||||
# these are all substituted by autoconf
|
# these are all substituted by autoconf
|
||||||
%define major 2
|
%define major 2
|
||||||
%define minor 3
|
%define minor 3
|
||||||
%define micro 0
|
%define micro 3
|
||||||
%define extra %{nil}
|
%define extra %{nil}
|
||||||
%define pot_file libsmbios
|
%define pot_file libsmbios
|
||||||
%define lang_dom libsmbios-2.3-x86_64
|
%define lang_dom libsmbios-2.3-x86_64
|
||||||
%define release_version 2.3.0
|
%define release_version 2.3.3
|
||||||
|
|
||||||
%define release_name libsmbios
|
%define release_name libsmbios
|
||||||
%define other_name libsmbios2
|
%define other_name libsmbios2
|
||||||
@ -99,15 +99,18 @@
|
|||||||
|
|
||||||
Name: %{release_name}
|
Name: %{release_name}
|
||||||
Version: %{release_version}
|
Version: %{release_version}
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ or OSL 2.1
|
License: GPLv2+ or OSL 2.1
|
||||||
Summary: Libsmbios C/C++ shared libraries
|
Summary: Libsmbios C/C++ shared libraries
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://linux.dell.com/libsmbios/download/libsmbios/libsmbios-%{version}/libsmbios-%{version}.tar.bz2
|
Source: https://github.com/dell/libsmbios/archive/v%{version}/libsmbios-%{version}.tar.gz
|
||||||
Patch0001: 0001-Don-t-force-the-compiler-version-check-on-consumers-.patch
|
|
||||||
URL: http://linux.dell.com/libsmbios/main
|
URL: http://linux.dell.com/libsmbios/main
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: strace libxml2-devel gcc-c++ gettext git doxygen %{valgrind_BR} %{cppunit_BR} %{fdupes_BR} %{pkgconfig_BR} %{python_devel_BR}
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: automake
|
||||||
|
BuildRequires: gettext-devel
|
||||||
|
BuildRequires: libtool
|
||||||
|
BuildRequires: strace libxml2-devel gcc-c++ gettext doxygen %{valgrind_BR} %{cppunit_BR} %{fdupes_BR} %{pkgconfig_BR} %{python_devel_BR}
|
||||||
# uncomment for official fedora
|
# uncomment for official fedora
|
||||||
Obsoletes: libsmbios-libs < 2.0.0
|
Obsoletes: libsmbios-libs < 2.0.0
|
||||||
Provides: libsmbios-libs = 0:%{version}-%{release}
|
Provides: libsmbios-libs = 0:%{version}-%{release}
|
||||||
@ -217,16 +220,7 @@ substitutions in yum repository configuration files on Dell systems.
|
|||||||
%setup -q -n libsmbios-%{version}
|
%setup -q -n libsmbios-%{version}
|
||||||
find . -type d -exec chmod -f 755 {} \;
|
find . -type d -exec chmod -f 755 {} \;
|
||||||
find doc src -type f -exec chmod -f 644 {} \;
|
find doc src -type f -exec chmod -f 644 {} \;
|
||||||
chmod 755 src/cppunit/*.sh
|
find ./src/cppunit/ -name "*.sh" -type f -exec chmod 755 '{}' \;
|
||||||
git init
|
|
||||||
git config user.email "%{name}-owner@fedoraproject.org"
|
|
||||||
git config user.name "Fedora Ninjas"
|
|
||||||
git config gc.auto 0
|
|
||||||
git add .
|
|
||||||
git commit -a -q -m "%{version} baseline."
|
|
||||||
git am %{patches} </dev/null
|
|
||||||
git config --unset user.email
|
|
||||||
git config --unset user.name
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# this line lets us build an RPM directly from a git tarball
|
# this line lets us build an RPM directly from a git tarball
|
||||||
@ -239,7 +233,8 @@ echo '../configure "$@"' > configure
|
|||||||
chmod +x ./configure
|
chmod +x ./configure
|
||||||
|
|
||||||
%configure \
|
%configure \
|
||||||
%{?!as_needed:--disable-as-needed} %{?!build_python:--disable-python}
|
%{?!as_needed:--disable-as-needed} %{?!build_python:--disable-python} \
|
||||||
|
--enable-libsmbios_cxx
|
||||||
|
|
||||||
mkdir -p out/libsmbios_c
|
mkdir -p out/libsmbios_c
|
||||||
mkdir -p out/libsmbios_c++
|
mkdir -p out/libsmbios_c++
|
||||||
@ -309,17 +304,15 @@ ln -s %{_sbindir}/dellWirelessCtl %{buildroot}/%{_bindir}/dellWirelessCtl
|
|||||||
ln -s smbios-sys-info %{buildroot}/%{_sbindir}/getSystemId
|
ln -s smbios-sys-info %{buildroot}/%{_sbindir}/getSystemId
|
||||||
ln -s smbios-wireless-ctl %{buildroot}/%{_sbindir}/dellWirelessCtl
|
ln -s smbios-wireless-ctl %{buildroot}/%{_sbindir}/dellWirelessCtl
|
||||||
ln -s smbios-lcd-brightness %{buildroot}/%{_sbindir}/dellLcdBrightness
|
ln -s smbios-lcd-brightness %{buildroot}/%{_sbindir}/dellLcdBrightness
|
||||||
ln -s smbios-rbu-bios-update %{buildroot}/%{_sbindir}/dellBiosUpdate
|
|
||||||
|
|
||||||
cat > files-python-smbios <<-EOF
|
cat > files-python-smbios <<-EOF
|
||||||
%doc COPYING-GPL COPYING-OSL README
|
%doc COPYING-GPL COPYING-OSL
|
||||||
%{python_sitelib}/*
|
%{python_sitelib}/*
|
||||||
EOF
|
EOF
|
||||||
|
|
||||||
cat > files-smbios-utils-python <<-EOF
|
cat > files-smbios-utils-python <<-EOF
|
||||||
%doc COPYING-GPL COPYING-OSL README
|
%doc COPYING-GPL COPYING-OSL
|
||||||
%doc src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
|
%doc src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
|
||||||
%doc doc/pkgheader.sh
|
|
||||||
%dir %{_sysconfdir}/libsmbios
|
%dir %{_sysconfdir}/libsmbios
|
||||||
%config(noreplace) %{_sysconfdir}/libsmbios/*
|
%config(noreplace) %{_sysconfdir}/libsmbios/*
|
||||||
|
|
||||||
@ -329,17 +322,17 @@ cat > files-smbios-utils-python <<-EOF
|
|||||||
%{_sbindir}/smbios-passwd
|
%{_sbindir}/smbios-passwd
|
||||||
%{_sbindir}/smbios-wakeup-ctl
|
%{_sbindir}/smbios-wakeup-ctl
|
||||||
%{_sbindir}/smbios-wireless-ctl
|
%{_sbindir}/smbios-wireless-ctl
|
||||||
%{_sbindir}/smbios-rbu-bios-update
|
|
||||||
%{_sbindir}/smbios-lcd-brightness
|
%{_sbindir}/smbios-lcd-brightness
|
||||||
%{_sbindir}/smbios-keyboard-ctl
|
%{_sbindir}/smbios-keyboard-ctl
|
||||||
%{_sbindir}/smbios-thermal-ctl
|
%{_sbindir}/smbios-thermal-ctl
|
||||||
|
%{_sbindir}/smbios-battery-ctl
|
||||||
|
|
||||||
# symlinks: backwards compat
|
# used by HAL in old location, so keep it around until HAL is updated.
|
||||||
|
%{_sbindir}/dellLEDCtl
|
||||||
%{_sbindir}/dellLcdBrightness
|
%{_sbindir}/dellLcdBrightness
|
||||||
|
%{_sbindir}/dellMediaDirectCtl
|
||||||
%{_sbindir}/getSystemId
|
%{_sbindir}/getSystemId
|
||||||
%{_sbindir}/dellWirelessCtl
|
%{_sbindir}/dellWirelessCtl
|
||||||
%{_sbindir}/dellBiosUpdate
|
|
||||||
# used by HAL in old location, so keep it around until HAL is updated.
|
|
||||||
%{_bindir}/dellWirelessCtl
|
%{_bindir}/dellWirelessCtl
|
||||||
|
|
||||||
# data files
|
# data files
|
||||||
@ -347,7 +340,7 @@ cat > files-smbios-utils-python <<-EOF
|
|||||||
EOF
|
EOF
|
||||||
|
|
||||||
cat > files-yum-dellsysid <<-EOF
|
cat > files-yum-dellsysid <<-EOF
|
||||||
%doc COPYING-GPL COPYING-OSL README
|
%doc COPYING-GPL COPYING-OSL
|
||||||
# YUM Plugin
|
# YUM Plugin
|
||||||
%config(noreplace) %{_sysconfdir}/yum/pluginconf.d/*
|
%config(noreplace) %{_sysconfdir}/yum/pluginconf.d/*
|
||||||
%{_exec_prefix}/lib/yum-plugins/*
|
%{_exec_prefix}/lib/yum-plugins/*
|
||||||
@ -377,7 +370,7 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
%files -n libsmbios-devel -f _build/buildlogs.txt
|
%files -n libsmbios-devel -f _build/buildlogs.txt
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc COPYING-GPL COPYING-OSL README src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
|
%doc COPYING-GPL COPYING-OSL src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
|
||||||
%{_includedir}/smbios
|
%{_includedir}/smbios
|
||||||
%{_includedir}/smbios_c
|
%{_includedir}/smbios_c
|
||||||
%{_libdir}/libsmbios.so
|
%{_libdir}/libsmbios.so
|
||||||
@ -389,22 +382,14 @@ rm -rf %{buildroot}
|
|||||||
%files -n smbios-utils
|
%files -n smbios-utils
|
||||||
# opensuse 11.1 enforces non-empty file list :(
|
# opensuse 11.1 enforces non-empty file list :(
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc COPYING-GPL COPYING-OSL README
|
%doc COPYING-GPL COPYING-OSL
|
||||||
# no other files.
|
# no other files.
|
||||||
|
|
||||||
%files -n smbios-utils-bin
|
%files -n smbios-utils-bin
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc COPYING-GPL COPYING-OSL README
|
%doc COPYING-GPL COPYING-OSL
|
||||||
%doc src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
|
%doc src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
|
||||||
%doc doc/pkgheader.sh
|
|
||||||
#
|
|
||||||
# legacy C++
|
|
||||||
%{_sbindir}/dellBiosUpdate-compat
|
|
||||||
%{_sbindir}/dellLEDCtl
|
|
||||||
%ifnarch ia64
|
|
||||||
%{_sbindir}/dellMediaDirectCtl
|
|
||||||
%endif
|
|
||||||
#
|
|
||||||
# new C utilities
|
# new C utilities
|
||||||
%{_sbindir}/smbios-state-byte-ctl
|
%{_sbindir}/smbios-state-byte-ctl
|
||||||
%{_sbindir}/smbios-get-ut-data
|
%{_sbindir}/smbios-get-ut-data
|
||||||
@ -423,6 +408,9 @@ rm -rf %{buildroot}
|
|||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 14 2017 Pete Walter <pwalter@fedoraproject.org> - 2.3.3-1
|
||||||
|
- Update to 2.3.3
|
||||||
|
|
||||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-6
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user