Update libshout to 2.4.6
This commit is contained in:
parent
1b9ac51f7e
commit
26a9888595
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
libshout-2.2.2.tar.gz
|
libshout-2.2.2.tar.gz
|
||||||
/libshout-2.4.3.tar.gz
|
/libshout-2.4.3.tar.gz
|
||||||
|
/libshout-2.4.6.tar.gz
|
||||||
|
@ -1,72 +0,0 @@
|
|||||||
diff -Naur libshout-2.2/include/shout/Makefile.am libshout-2.2.patched/include/shout/Makefile.am
|
|
||||||
--- libshout-2.2/include/shout/Makefile.am 2004-03-21 05:03:33.000000000 +0100
|
|
||||||
+++ libshout-2.2.patched/include/shout/Makefile.am 2006-03-10 14:09:58.000000000 +0100
|
|
||||||
@@ -2,5 +2,5 @@
|
|
||||||
|
|
||||||
AUTOMAKE_OPTIONS = foreign
|
|
||||||
|
|
||||||
-includedir = $(prefix)/include/shout
|
|
||||||
-nodist_include_HEADERS = shout.h
|
|
||||||
+pkgincludedir = $(includedir)/shout
|
|
||||||
+nodist_pkginclude_HEADERS = shout.h
|
|
||||||
diff -Naur libshout-2.2/include/shout/Makefile.in libshout-2.2.patched/include/shout/Makefile.in
|
|
||||||
--- libshout-2.2/include/shout/Makefile.in 2006-01-03 20:19:05.000000000 +0100
|
|
||||||
+++ libshout-2.2.patched/include/shout/Makefile.in 2006-03-10 14:14:56.000000000 +0100
|
|
||||||
@@ -61,7 +61,7 @@
|
|
||||||
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
|
|
||||||
am__installdirs = "$(DESTDIR)$(includedir)"
|
|
||||||
nodist_includeHEADERS_INSTALL = $(INSTALL_HEADER)
|
|
||||||
-HEADERS = $(nodist_include_HEADERS)
|
|
||||||
+HEADERS = $(nodist_pkginclude_HEADERS)
|
|
||||||
ETAGS = etags
|
|
||||||
CTAGS = ctags
|
|
||||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
|
||||||
@@ -197,7 +197,7 @@
|
|
||||||
host_cpu = @host_cpu@
|
|
||||||
host_os = @host_os@
|
|
||||||
host_vendor = @host_vendor@
|
|
||||||
-includedir = $(prefix)/include/shout
|
|
||||||
+pkgincludedir = $(includedir)//shout
|
|
||||||
infodir = @infodir@
|
|
||||||
install_sh = @install_sh@
|
|
||||||
libdir = @libdir@
|
|
||||||
@@ -217,7 +217,7 @@
|
|
||||||
target = @target@
|
|
||||||
target_alias = @target_alias@
|
|
||||||
AUTOMAKE_OPTIONS = foreign
|
|
||||||
-nodist_include_HEADERS = shout.h
|
|
||||||
+nodist_pkginclude_HEADERS = shout.h
|
|
||||||
all: all-am
|
|
||||||
|
|
||||||
.SUFFIXES:
|
|
||||||
@@ -262,22 +262,22 @@
|
|
||||||
distclean-libtool:
|
|
||||||
-rm -f libtool
|
|
||||||
uninstall-info-am:
|
|
||||||
-install-nodist_includeHEADERS: $(nodist_include_HEADERS)
|
|
||||||
+install-nodist_includeHEADERS: $(nodist_pkginclude_HEADERS)
|
|
||||||
@$(NORMAL_INSTALL)
|
|
||||||
- test -z "$(includedir)" || $(mkdir_p) "$(DESTDIR)$(includedir)"
|
|
||||||
- @list='$(nodist_include_HEADERS)'; for p in $$list; do \
|
|
||||||
+ test -z "$(pkgincludedir)" || $(mkdir_p) "$(DESTDIR)$(pkgincludedir)"
|
|
||||||
+ @list='$(nodist_pkginclude_HEADERS)'; for p in $$list; do \
|
|
||||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
||||||
f=$(am__strip_dir) \
|
|
||||||
- echo " $(nodist_includeHEADERS_INSTALL) '$$d$$p' '$(DESTDIR)$(includedir)/$$f'"; \
|
|
||||||
- $(nodist_includeHEADERS_INSTALL) "$$d$$p" "$(DESTDIR)$(includedir)/$$f"; \
|
|
||||||
+ echo " $(nodist_includeHEADERS_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgincludedir)/$$f'"; \
|
|
||||||
+ $(nodist_includeHEADERS_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgincludedir)/$$f"; \
|
|
||||||
done
|
|
||||||
|
|
||||||
uninstall-nodist_includeHEADERS:
|
|
||||||
@$(NORMAL_UNINSTALL)
|
|
||||||
- @list='$(nodist_include_HEADERS)'; for p in $$list; do \
|
|
||||||
+ @list='$(nodist_pkginclude_HEADERS)'; for p in $$list; do \
|
|
||||||
f=$(am__strip_dir) \
|
|
||||||
- echo " rm -f '$(DESTDIR)$(includedir)/$$f'"; \
|
|
||||||
- rm -f "$(DESTDIR)$(includedir)/$$f"; \
|
|
||||||
+ echo " rm -f '$(DESTDIR)$(pkgincludedir)/$$f'"; \
|
|
||||||
+ rm -f "$(DESTDIR)$(pkgincludedir)/$$f"; \
|
|
||||||
done
|
|
||||||
|
|
||||||
ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
|
|
@ -1,6 +1,6 @@
|
|||||||
Name: libshout
|
Name: libshout
|
||||||
Version: 2.4.3
|
Version: 2.4.6
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Icecast source streaming library
|
Summary: Icecast source streaming library
|
||||||
|
|
||||||
# COPYING: GPLv2 text
|
# COPYING: GPLv2 text
|
||||||
@ -143,8 +143,10 @@ rm -rf $RPM_BUILD_ROOT%{_docdir}
|
|||||||
%files
|
%files
|
||||||
%doc NEWS README
|
%doc NEWS README
|
||||||
%license COPYING
|
%license COPYING
|
||||||
|
%{_bindir}/shout
|
||||||
%{_libdir}/libshout.so.3
|
%{_libdir}/libshout.so.3
|
||||||
%{_libdir}/libshout.so.3.*
|
%{_libdir}/libshout.so.3.*
|
||||||
|
%{_mandir}/*/shout.*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%doc examples/*.c doc/*.xml
|
%doc examples/*.c doc/*.xml
|
||||||
@ -154,6 +156,9 @@ rm -rf $RPM_BUILD_ROOT%{_docdir}
|
|||||||
%{_datadir}/aclocal/shout.m4
|
%{_datadir}/aclocal/shout.m4
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 15 2022 Sérgio Basto <sergio@serjux.com> - 2.4.6-1
|
||||||
|
- Update libshout to 2.4.6
|
||||||
|
|
||||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.3-7
|
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.3-7
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libshout-2.4.3.tar.gz) = fe36778c6640e620f27504cb21234940e18a65a33f9178bf7e77d4baf854a9affc82d85db8ed8c1c8e2d80399685d8be10106fff5be1ddf76e03e2ffeeed1d34
|
SHA512 (libshout-2.4.6.tar.gz) = e8478cdbf9a27674c16a7b620d1576f2e31a47262b8e29b314d0f46d4e5be24b9a29790b7b226f48939bc34cacf5734fae0aa5686c7ed5879cdbd827ff8e0339
|
||||||
|
Loading…
Reference in New Issue
Block a user