b609a6d466
Merged errno fix from Joshua Brindle (Tresys). Merged fix for semod_build_modules_list leak on error path from Serge Hallyn (IBM). Bug found by Coverity. Merged several fixes from Serge Hallyn (IBM). Bugs found by Coverity. Fixed several other bugs and warnings. Merged patch to move module read/write code from libsemanage to libsepol from Jason Tang (Tresys). Merged relay records patch from Ivan Gyurdiev. Merged key extract patch from Ivan Gyurdiev.
44 lines
1.8 KiB
Diff
44 lines
1.8 KiB
Diff
--- libsemanage-1.1.4/src/semod.conf.rhat 2005-08-30 09:24:00.000000000 -0400
|
|
+++ libsemanage-1.1.4/src/semod.conf 2005-08-30 10:22:33.000000000 -0400
|
|
@@ -16,10 +16,10 @@
|
|
# License along with this library; if not, write to the Free Software
|
|
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
|
|
|
|
-# Specify how libsemod will interact with the module store. The three
|
|
+# Specify how libsemanage will interact with the module store. The three
|
|
# options are:
|
|
#
|
|
-# "direct" - libsemod will write directly to the store.
|
|
+# "direct" - libsemanage will write directly to the store.
|
|
# /foo/bar - Write by way of a policy server, whose named socket
|
|
# is at /foo/bar. The path must begin with a '/'.
|
|
# foo.com:4242 - Establish a TCP connection to a remote policy server
|
|
@@ -44,7 +44,7 @@
|
|
#args = -b $@
|
|
#[end]
|
|
|
|
-# In addition to loading a policy libsemod will validate file contexts
|
|
+# In addition to loading a policy libsemanage will validate file contexts
|
|
# by calling the setfiles utility. As above, "$@" will be replaced
|
|
# with the policy filename. In addition "$<" will be replaced with
|
|
# the file contexts filename.
|
|
--- libsemanage-1.1.4/src/Makefile.rhat 2005-08-30 09:24:00.000000000 -0400
|
|
+++ libsemanage-1.1.4/src/Makefile 2005-08-30 10:23:09.000000000 -0400
|
|
@@ -4,7 +4,7 @@
|
|
SHLIBDIR ?= $(DESTDIR)/lib
|
|
INCLUDEDIR ?= $(PREFIX)/include
|
|
|
|
-DEFAULT_SEMOD_CONF_LOCATION=$(PREFIX)/share/semod/semod.conf
|
|
+DEFAULT_SEMOD_CONF_LOCATION=/etc/selinux/semod.conf
|
|
|
|
LEX = flex
|
|
LFLAGS = -s
|
|
@@ -40,7 +40,6 @@
|
|
install: all
|
|
test -d $(LIBDIR) || install -m 755 -d $(LIBDIR)
|
|
install -m 644 $(LIBA) $(LIBDIR)
|
|
- install -m 644 -D semod.conf $(DEFAULT_SEMOD_CONF_LOCATION)
|
|
|
|
clean:
|
|
rm -f $(OBJS) $(LIBA) conf-scan.c conf-parse.c conf-parse.h
|