bc30cb8b07
Rebase on upstream f56a72ac9e86
32 lines
1.5 KiB
Diff
32 lines
1.5 KiB
Diff
From 33e56c9b2e302ef96f848f741423231df0a9998d Mon Sep 17 00:00:00 2001
|
|
From: James Carter <jwcart2@gmail.com>
|
|
Date: Fri, 28 Oct 2022 16:13:51 -0400
|
|
Subject: [PATCH] libsemanage: Remove dependency on the Python module distutils
|
|
Content-type: text/plain
|
|
|
|
The distutils package is deprecated and scheduled to be removed in
|
|
Python 3.12. Use the sysconfig module instead.
|
|
|
|
Signed-off-by: James Carter <jwcart2@gmail.com>
|
|
Acked-by: Petr Lautrbach <plautrba@redhat.com>
|
|
---
|
|
libsemanage/src/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/libsemanage/src/Makefile b/libsemanage/src/Makefile
|
|
index 01df0181df1e..589e4a706bfd 100644
|
|
--- a/libsemanage/src/Makefile
|
|
+++ b/libsemanage/src/Makefile
|
|
@@ -14,7 +14,7 @@ INCLUDEDIR ?= $(PREFIX)/include
|
|
SYSCONFDIR ?= /etc
|
|
PYINC ?= $(shell $(PKG_CONFIG) --cflags $(PYPREFIX))
|
|
PYLIBS ?= $(shell $(PKG_CONFIG) --libs $(PYPREFIX))
|
|
-PYTHONLIBDIR ?= $(shell $(PYTHON) -c "from distutils.sysconfig import *; print(get_python_lib(plat_specific=1, prefix='$(PREFIX)'))")
|
|
+PYTHONLIBDIR ?= $(shell $(PYTHON) -c "import sysconfig; print(sysconfig.get_path('platlib', vars={'platbase': '$(PREFIX)', 'base': '$(PREFIX)'}))")
|
|
PYCEXT ?= $(shell $(PYTHON) -c 'import importlib.machinery;print(importlib.machinery.EXTENSION_SUFFIXES[0])')
|
|
RUBYINC ?= $(shell $(RUBY) -e 'puts "-I" + RbConfig::CONFIG["rubyarchhdrdir"] + " -I" + RbConfig::CONFIG["rubyhdrdir"]')
|
|
RUBYLIBS ?= $(shell $(RUBY) -e 'puts "-L" + RbConfig::CONFIG["libdir"] + " -L" + RbConfig::CONFIG["archlibdir"] + " " + RbConfig::CONFIG["LIBRUBYARG_SHARED"]')
|
|
--
|
|
2.38.1
|
|
|