bc30cb8b07
Rebase on upstream f56a72ac9e86
41 lines
1.7 KiB
Diff
41 lines
1.7 KiB
Diff
From 01b5ef48dcc37ff06c5515b90d9da5b02dce820d Mon Sep 17 00:00:00 2001
|
|
From: Matt Sheets <masheets@linux.microsoft.com>
|
|
Date: Thu, 22 Sep 2022 11:02:55 -0700
|
|
Subject: [PATCH] libsemanage: Allow user to set SYSCONFDIR
|
|
Content-type: text/plain
|
|
|
|
This change will allow a user to set the location of their
|
|
sysconfdir, defaulted to /etc, if they are installing into
|
|
nonstandard locations.
|
|
|
|
Signed-off-by: Matt Sheets <masheets@linux.microsoft.com>
|
|
Reviewed-by: Daniel Burgener <dburgener@linux.microsoft.com>
|
|
---
|
|
libsemanage/src/Makefile | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/libsemanage/src/Makefile b/libsemanage/src/Makefile
|
|
index 71c2a1d2513f..01df0181df1e 100644
|
|
--- a/libsemanage/src/Makefile
|
|
+++ b/libsemanage/src/Makefile
|
|
@@ -11,6 +11,7 @@ PKG_CONFIG ?= pkg-config
|
|
PREFIX ?= /usr
|
|
LIBDIR ?= $(PREFIX)/lib
|
|
INCLUDEDIR ?= $(PREFIX)/include
|
|
+SYSCONFDIR ?= /etc
|
|
PYINC ?= $(shell $(PKG_CONFIG) --cflags $(PYPREFIX))
|
|
PYLIBS ?= $(shell $(PKG_CONFIG) --libs $(PYPREFIX))
|
|
PYTHONLIBDIR ?= $(shell $(PYTHON) -c "from distutils.sysconfig import *; print(get_python_lib(plat_specific=1, prefix='$(PREFIX)'))")
|
|
@@ -19,7 +20,7 @@ RUBYINC ?= $(shell $(RUBY) -e 'puts "-I" + RbConfig::CONFIG["rubyarchhdrdir"] +
|
|
RUBYLIBS ?= $(shell $(RUBY) -e 'puts "-L" + RbConfig::CONFIG["libdir"] + " -L" + RbConfig::CONFIG["archlibdir"] + " " + RbConfig::CONFIG["LIBRUBYARG_SHARED"]')
|
|
RUBYINSTALL ?= $(shell $(RUBY) -e 'puts RbConfig::CONFIG["vendorarchdir"]')
|
|
|
|
-DEFAULT_SEMANAGE_CONF_LOCATION=/etc/selinux/semanage.conf
|
|
+DEFAULT_SEMANAGE_CONF_LOCATION=$(SYSCONFDIR)/selinux/semanage.conf
|
|
|
|
ifeq ($(DEBUG),1)
|
|
export CFLAGS ?= -g3 -O0 -gdwarf-2 -fno-strict-aliasing -Wall -Wshadow -Werror
|
|
--
|
|
2.38.1
|
|
|