*** empty log message ***
This commit is contained in:
parent
cde1f77237
commit
cef3ae1b81
@ -1,45 +1,42 @@
|
||||
diff --exclude-from=exclude -N -u -r nsalibsemanage/src/fcontext_record.c libsemanage-1.5.9/src/fcontext_record.c
|
||||
--- nsalibsemanage/src/fcontext_record.c 2006-01-06 10:33:10.000000000 -0500
|
||||
+++ libsemanage-1.5.9/src/fcontext_record.c 2006-01-06 13:40:38.000000000 -0500
|
||||
@@ -81,8 +81,18 @@
|
||||
const semanage_fcontext_t* fcontext,
|
||||
const semanage_fcontext_key_t* key) {
|
||||
diff --exclude-from=exclude -N -u -r nsalibsemanage/Makefile libsemanage-1.5.14/Makefile
|
||||
--- nsalibsemanage/Makefile 2006-01-05 10:33:10.000000000 -0500
|
||||
+++ libsemanage-1.5.14/Makefile 2006-01-13 23:46:32.000000000 -0500
|
||||
@@ -1,11 +1,17 @@
|
||||
all:
|
||||
$(MAKE) -C src all
|
||||
|
||||
- return strcmp(fcontext->expr, key->expr) &&
|
||||
- (fcontext->type == key->type);
|
||||
+ int rv = strcmp(fcontext->expr, key->expr);
|
||||
+ if (rv != 0)
|
||||
+ return rv;
|
||||
+ else {
|
||||
+ if (fcontext->type < key->type)
|
||||
+ return -1;
|
||||
+
|
||||
+ else if (key->type < fcontext->type)
|
||||
+ return 1;
|
||||
+
|
||||
+ else return 0;
|
||||
+ }
|
||||
}
|
||||
hidden_def(semanage_fcontext_compare)
|
||||
|
||||
@@ -90,8 +100,18 @@
|
||||
const semanage_fcontext_t* fcontext,
|
||||
const semanage_fcontext_t* fcontext2) {
|
||||
|
||||
- return strcmp(fcontext->expr, fcontext2->expr) &&
|
||||
- (fcontext->type == fcontext2->type);
|
||||
+ int rv = strcmp(fcontext->expr, fcontext2->expr);
|
||||
+ if (rv != 0)
|
||||
+ return rv;
|
||||
+ else {
|
||||
+ if (fcontext->type < fcontext2->type)
|
||||
+ return -1;
|
||||
+pywrap:
|
||||
+ $(MAKE) -C src pywrap
|
||||
+
|
||||
+ else if (fcontext2->type < fcontext->type)
|
||||
+ return 1;
|
||||
+
|
||||
+ else return 0;
|
||||
+ }
|
||||
}
|
||||
hidden_def(semanage_fcontext_compare2)
|
||||
install:
|
||||
$(MAKE) -C include install
|
||||
$(MAKE) -C src install
|
||||
$(MAKE) -C man install
|
||||
|
||||
+install-pywrap:
|
||||
+ $(MAKE) -C src install-pywrap
|
||||
+
|
||||
relabel:
|
||||
|
||||
clean:
|
||||
diff --exclude-from=exclude -N -u -r nsalibsemanage/src/Makefile libsemanage-1.5.14/src/Makefile
|
||||
--- nsalibsemanage/src/Makefile 2005-11-29 10:54:15.000000000 -0500
|
||||
+++ libsemanage-1.5.14/src/Makefile 2006-01-13 23:46:17.000000000 -0500
|
||||
@@ -37,7 +37,7 @@
|
||||
|
||||
SWIG = swig -Wall -python -o $(SWIGCOUT) -outdir ./
|
||||
|
||||
-all: $(LIBA) $(LIBSO) $(SWIGSO)
|
||||
+all: $(LIBA) $(LIBSO)
|
||||
|
||||
pywrap: all $(SWIGLOBJ) $(SWIGSO)
|
||||
|
||||
@@ -75,7 +75,7 @@
|
||||
swigify: $(SWIGIF)
|
||||
$(SWIG) $^
|
||||
|
||||
-install: all install-pywrap
|
||||
+install: all
|
||||
test -d $(LIBDIR) || install -m 755 -d $(LIBDIR)
|
||||
install -m 644 $(LIBA) $(LIBDIR)
|
||||
test -d $(SHLIBDIR) || install -m 755 -d $(SHLIBDIR)
|
||||
|
@ -3,10 +3,11 @@
|
||||
Summary: SELinux binary policy manipulation library
|
||||
Name: libsemanage
|
||||
Version: 1.5.14
|
||||
Release: 1
|
||||
Release: 2
|
||||
License: GPL
|
||||
Group: System Environment/Libraries
|
||||
Source: http://www.nsa.gov/selinux/archives/libsemanage-%{version}.tgz
|
||||
Patch: libsemanage-rhat.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-buildroot
|
||||
BuildRequires: libselinux-devel >= %{libselinuxver}
|
||||
@ -39,17 +40,18 @@ needed for developing applications that manipulate binary policies.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch -p1 -b .rhat
|
||||
|
||||
%build
|
||||
make clean
|
||||
make CFLAGS="%{optflags}"
|
||||
make CFLAGS="%{optflags}" all pywrap
|
||||
|
||||
%install
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
mkdir -p ${RPM_BUILD_ROOT}/%{_lib}
|
||||
mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
|
||||
make DESTDIR="${RPM_BUILD_ROOT}" LIBDIR="${RPM_BUILD_ROOT}%{_libdir}" SHLIBDIR="${RPM_BUILD_ROOT}/%{_lib}" install
|
||||
make DESTDIR="${RPM_BUILD_ROOT}" LIBDIR="${RPM_BUILD_ROOT}%{_libdir}" SHLIBDIR="${RPM_BUILD_ROOT}/%{_lib}" install install-pywrap
|
||||
|
||||
%clean
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
@ -76,6 +78,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%changelog
|
||||
|
||||
* Fri Jan 13 2006 Dan Walsh <dwalsh@redhat.com> 1.5.14-2
|
||||
- Break out python out of regular Makefile
|
||||
|
||||
* Fri Jan 13 2006 Dan Walsh <dwalsh@redhat.com> 1.5.14-1
|
||||
- Upgrade to latest from NSA
|
||||
* Merged disallow port overlap patch from Ivan Gyurdiev.
|
||||
|
Loading…
Reference in New Issue
Block a user