libsemanage-2.5-1
- Update to upstream release 2016-02-23
This commit is contained in:
parent
5d71d668b9
commit
83d1ec7678
1
.gitignore
vendored
1
.gitignore
vendored
@ -133,3 +133,4 @@ libsemanage-2.0.45.tgz
|
|||||||
/libsemanage-2.3.tgz
|
/libsemanage-2.3.tgz
|
||||||
/libsemanage-2.4.tar.gz
|
/libsemanage-2.4.tar.gz
|
||||||
/libsemanage-2.5-rc1.tar.gz
|
/libsemanage-2.5-rc1.tar.gz
|
||||||
|
/libsemanage-2.5.tar.gz
|
||||||
|
@ -1,171 +1,7 @@
|
|||||||
diff --git libsemanage-2.5-rc1/ChangeLog libsemanage-2.5-rc1/ChangeLog
|
diff --git libsemanage-2.5/utils/semanage_migrate_store libsemanage-2.5/utils/semanage_migrate_store
|
||||||
index c1b09f1..29720de 100644
|
|
||||||
--- libsemanage-2.5-rc1/ChangeLog
|
|
||||||
+++ libsemanage-2.5-rc1/ChangeLog
|
|
||||||
@@ -1,4 +1,6 @@
|
|
||||||
2.5-rc1 2016-01-07
|
|
||||||
+ * Do not overwrite CFLAGS in test Makefile, from Nicolas Iooss.
|
|
||||||
+ * Fix uninitialized variable in direct_commit and direct_api, from Nicolas Iooss.
|
|
||||||
* semanage_migrate_store: Load libsepol.so.1 instead of libsepol.so, from Laurent Bigonville.
|
|
||||||
* Store homedir_template and users_extra in policy store, from Steve Lawrence
|
|
||||||
* Fix null pointer dereference in semanage_module_key_destroy, from Yuli Khodorkovskiy.
|
|
||||||
diff --git libsemanage-2.5-rc1/src/database_llist.c libsemanage-2.5-rc1/src/database_llist.c
|
|
||||||
index 53583d4..8ce2e2c 100644
|
|
||||||
--- libsemanage-2.5-rc1/src/database_llist.c
|
|
||||||
+++ libsemanage-2.5-rc1/src/database_llist.c
|
|
||||||
@@ -154,7 +154,6 @@ int dbase_llist_add(semanage_handle_t * handle,
|
|
||||||
if (dbase_llist_cache_prepend(handle, dbase, data) < 0)
|
|
||||||
goto err;
|
|
||||||
|
|
||||||
- key = NULL;
|
|
||||||
dbase->modified = 1;
|
|
||||||
return STATUS_SUCCESS;
|
|
||||||
|
|
||||||
@@ -224,7 +223,6 @@ hidden int dbase_llist_count(semanage_handle_t * handle __attribute__ ((unused))
|
|
||||||
{
|
|
||||||
|
|
||||||
*response = dbase->cache_sz;
|
|
||||||
- handle = NULL;
|
|
||||||
return STATUS_SUCCESS;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -303,7 +301,6 @@ int dbase_llist_del(semanage_handle_t * handle __attribute__ ((unused)),
|
|
||||||
prev = ptr;
|
|
||||||
}
|
|
||||||
|
|
||||||
- handle = NULL;
|
|
||||||
return STATUS_SUCCESS;
|
|
||||||
}
|
|
||||||
|
|
||||||
diff --git libsemanage-2.5-rc1/src/database_policydb.c libsemanage-2.5-rc1/src/database_policydb.c
|
|
||||||
index e786afe..748a6ed 100644
|
|
||||||
--- libsemanage-2.5-rc1/src/database_policydb.c
|
|
||||||
+++ libsemanage-2.5-rc1/src/database_policydb.c
|
|
||||||
@@ -165,7 +165,6 @@ static int dbase_policydb_flush(semanage_handle_t * handle
|
|
||||||
dbase->modified = 0;
|
|
||||||
|
|
||||||
/* Stub */
|
|
||||||
- handle = NULL;
|
|
||||||
return STATUS_ERR;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -298,9 +297,6 @@ static int dbase_policydb_del(semanage_handle_t * handle
|
|
||||||
{
|
|
||||||
|
|
||||||
/* Stub */
|
|
||||||
- key = NULL;
|
|
||||||
- handle = NULL;
|
|
||||||
- dbase = NULL;
|
|
||||||
return STATUS_ERR;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -311,8 +307,6 @@ static int dbase_policydb_clear(semanage_handle_t * handle
|
|
||||||
{
|
|
||||||
|
|
||||||
/* Stub */
|
|
||||||
- handle = NULL;
|
|
||||||
- dbase = NULL;
|
|
||||||
return STATUS_ERR;
|
|
||||||
}
|
|
||||||
|
|
||||||
diff --git libsemanage-2.5-rc1/src/debug.c libsemanage-2.5-rc1/src/debug.c
|
|
||||||
index ea51ffb..08a9e02 100644
|
|
||||||
--- libsemanage-2.5-rc1/src/debug.c
|
|
||||||
+++ libsemanage-2.5-rc1/src/debug.c
|
|
||||||
@@ -86,8 +86,6 @@ void hidden semanage_msg_default_handler(void *varg __attribute__ ((unused)),
|
|
||||||
fprintf(stream, " (%s).", strerror(errsv));
|
|
||||||
|
|
||||||
fprintf(stream, "\n");
|
|
||||||
-
|
|
||||||
- varg = NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
#ifdef __GNUC__
|
|
||||||
diff --git libsemanage-2.5-rc1/src/direct_api.c libsemanage-2.5-rc1/src/direct_api.c
|
|
||||||
index 68dd0d1..2187b65 100644
|
|
||||||
--- libsemanage-2.5-rc1/src/direct_api.c
|
|
||||||
+++ libsemanage-2.5-rc1/src/direct_api.c
|
|
||||||
@@ -291,7 +291,6 @@ static void semanage_direct_destroy(semanage_handle_t * sh
|
|
||||||
__attribute__ ((unused)))
|
|
||||||
{
|
|
||||||
/* do nothing */
|
|
||||||
- sh = NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
static int semanage_direct_disconnect(semanage_handle_t * sh)
|
|
||||||
@@ -1076,7 +1075,7 @@ static int semanage_direct_commit(semanage_handle_t * sh)
|
|
||||||
/* Declare some variables */
|
|
||||||
int modified = 0, fcontexts_modified, ports_modified,
|
|
||||||
seusers_modified, users_extra_modified, dontaudit_modified,
|
|
||||||
- preserve_tunables_modified, bools_modified,
|
|
||||||
+ preserve_tunables_modified, bools_modified = 0,
|
|
||||||
disable_dontaudit, preserve_tunables;
|
|
||||||
dbase_config_t *users = semanage_user_dbase_local(sh);
|
|
||||||
dbase_config_t *users_base = semanage_user_base_dbase_local(sh);
|
|
||||||
@@ -2136,6 +2135,7 @@ static int semanage_direct_set_module_info(semanage_handle_t *sh,
|
|
||||||
char fn[PATH_MAX];
|
|
||||||
const char *path = NULL;
|
|
||||||
int enabled = 0;
|
|
||||||
+ semanage_module_info_t *modinfo_tmp = NULL;
|
|
||||||
|
|
||||||
semanage_module_key_t modkey;
|
|
||||||
ret = semanage_module_key_init(sh, &modkey);
|
|
||||||
@@ -2144,8 +2144,6 @@ static int semanage_direct_set_module_info(semanage_handle_t *sh,
|
|
||||||
goto cleanup;
|
|
||||||
}
|
|
||||||
|
|
||||||
- semanage_module_info_t *modinfo_tmp = NULL;
|
|
||||||
-
|
|
||||||
/* check transaction */
|
|
||||||
if (!sh->is_in_transaction) {
|
|
||||||
if (semanage_begin_transaction(sh) < 0) {
|
|
||||||
@@ -2316,6 +2314,8 @@ static int semanage_direct_list_all(semanage_handle_t *sh,
|
|
||||||
|
|
||||||
uint16_t priority = 0;
|
|
||||||
|
|
||||||
+ semanage_module_info_t *modinfo_tmp = NULL;
|
|
||||||
+
|
|
||||||
semanage_module_info_t modinfo;
|
|
||||||
ret = semanage_module_info_init(sh, &modinfo);
|
|
||||||
if (ret != 0) {
|
|
||||||
@@ -2323,8 +2323,6 @@ static int semanage_direct_list_all(semanage_handle_t *sh,
|
|
||||||
goto cleanup;
|
|
||||||
}
|
|
||||||
|
|
||||||
- semanage_module_info_t *modinfo_tmp = NULL;
|
|
||||||
-
|
|
||||||
if (sh->is_in_transaction) {
|
|
||||||
toplevel = semanage_path(SEMANAGE_TMP, SEMANAGE_MODULES);
|
|
||||||
} else {
|
|
||||||
diff --git libsemanage-2.5-rc1/tests/Makefile libsemanage-2.5-rc1/tests/Makefile
|
|
||||||
index 59067ac..fec96ff 100644
|
|
||||||
--- libsemanage-2.5-rc1/tests/Makefile
|
|
||||||
+++ libsemanage-2.5-rc1/tests/Makefile
|
|
||||||
@@ -11,9 +11,9 @@ LIBS = ../src/libsemanage.a ../../libselinux/src/libselinux.a ../../libsepol/src
|
|
||||||
|
|
||||||
EXECUTABLE = libsemanage-tests
|
|
||||||
CC = gcc
|
|
||||||
-CFLAGS = -c -g -O0 -Wall -W -Wundef -Wmissing-noreturn -Wmissing-format-attribute -Wno-unused-parameter
|
|
||||||
+CFLAGS += -g -O0 -Wall -W -Wundef -Wmissing-noreturn -Wmissing-format-attribute -Wno-unused-parameter
|
|
||||||
INCLUDE = -I$(TESTSRC) -I$(TESTSRC)/../include
|
|
||||||
-LDFLAGS = -lcunit -lustr -lbz2 -laudit
|
|
||||||
+LDFLAGS += -lcunit -lustr -lbz2 -laudit
|
|
||||||
OBJECTS = $(SOURCES:.c=.o)
|
|
||||||
|
|
||||||
all: $(EXECUTABLE)
|
|
||||||
@@ -22,7 +22,7 @@ $(EXECUTABLE): $(OBJECTS)
|
|
||||||
$(CC) $(OBJECTS) $(LIBS) $(LDFLAGS) -o $@
|
|
||||||
|
|
||||||
%.o: %.c
|
|
||||||
- $(CC) $(CFLAGS) $(INCLUDE) $*.c -o $*.o
|
|
||||||
+ $(CC) $(CFLAGS) $(INCLUDE) -c $*.c -o $*.o
|
|
||||||
|
|
||||||
clean distclean:
|
|
||||||
rm -rf $(OBJECTS) $(EXECUTABLE)
|
|
||||||
diff --git libsemanage-2.5-rc1/utils/semanage_migrate_store libsemanage-2.5-rc1/utils/semanage_migrate_store
|
|
||||||
index 0ebd285..2bdcc05 100755
|
index 0ebd285..2bdcc05 100755
|
||||||
--- libsemanage-2.5-rc1/utils/semanage_migrate_store
|
--- libsemanage-2.5/utils/semanage_migrate_store
|
||||||
+++ libsemanage-2.5-rc1/utils/semanage_migrate_store
|
+++ libsemanage-2.5/utils/semanage_migrate_store
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#!/usr/bin/python -E
|
-#!/usr/bin/python -E
|
||||||
+#!/usr/bin/python3 -E
|
+#!/usr/bin/python3 -E
|
||||||
|
@ -7,13 +7,13 @@
|
|||||||
Summary: SELinux binary policy manipulation library
|
Summary: SELinux binary policy manipulation library
|
||||||
Name: libsemanage
|
Name: libsemanage
|
||||||
Version: 2.5
|
Version: 2.5
|
||||||
Release: 0.1.rc1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160107/libsemanage-2.5-rc1.tar.gz
|
Source: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160223/libsemanage-2.5.tar.gz
|
||||||
# download https://raw.githubusercontent.com/fedora-selinux/scripts/master/selinux/make-fedora-selinux-patch.sh
|
# download https://raw.githubusercontent.com/fedora-selinux/scripts/master/selinux/make-fedora-selinux-patch.sh
|
||||||
# run:
|
# run:
|
||||||
# $ VERSION=2.5-rc1 ./make-fedora-selinux-patch.sh libsemanage
|
# $ VERSION=2.5 ./make-fedora-selinux-patch.sh libsemanage
|
||||||
# HEAD https://github.com/fedora-selinux/selinux/commit/fcbe30acc1ab728944f06ee9df9dc007053b5781
|
# HEAD https://github.com/fedora-selinux/selinux/commit/fcbe30acc1ab728944f06ee9df9dc007053b5781
|
||||||
Patch1: libsemanage-fedora.patch
|
Patch1: libsemanage-fedora.patch
|
||||||
URL: https://github.com/SELinuxProject/selinux/wiki
|
URL: https://github.com/SELinuxProject/selinux/wiki
|
||||||
@ -86,7 +86,7 @@ SELinux management applications.
|
|||||||
%endif # if with_python3
|
%endif # if with_python3
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n libsemanage-2.5-rc1
|
%setup -q -n libsemanage-2.5
|
||||||
%patch1 -p1 -b .fedora
|
%patch1 -p1 -b .fedora
|
||||||
|
|
||||||
|
|
||||||
@ -194,6 +194,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%endif # if with_python3
|
%endif # if with_python3
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 23 2016 Petr Lautrbach <plautrba@redhat.com> 2.5-1
|
||||||
|
- Update to upstream release 2016-02-23
|
||||||
|
|
||||||
* Sun Feb 21 2016 Petr Lautrbach <plautrba@redhat.com> 2.5-0.1.rc1
|
* Sun Feb 21 2016 Petr Lautrbach <plautrba@redhat.com> 2.5-0.1.rc1
|
||||||
- Update to upstream rc1 release 2016-01-07
|
- Update to upstream rc1 release 2016-01-07
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user