parent
88e75bd275
commit
513da381ab
@ -1,3 +1,16 @@
|
|||||||
|
diff --git libsemanage-2.6/src/Makefile libsemanage-2.6/src/Makefile
|
||||||
|
index 68aab72..ccaa29d 100644
|
||||||
|
--- libsemanage-2.6/src/Makefile
|
||||||
|
+++ libsemanage-2.6/src/Makefile
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
# runtimes (e.g. Python 2 vs Python 3) by optionally prefixing the build
|
||||||
|
# targets with "PYPREFIX":
|
||||||
|
PYTHON ?= python
|
||||||
|
-PYPREFIX ?= $(notdir $(PYTHON))
|
||||||
|
+PYPREFIX ?= $(shell $(PYTHON) -c 'import sys;print("python%d" % sys.version_info[0])')
|
||||||
|
RUBY ?= ruby
|
||||||
|
RUBYPREFIX ?= $(notdir $(RUBY))
|
||||||
|
PKG_CONFIG ?= pkg-config
|
||||||
diff --git libsemanage-2.6/src/semanage_store.c libsemanage-2.6/src/semanage_store.c
|
diff --git libsemanage-2.6/src/semanage_store.c libsemanage-2.6/src/semanage_store.c
|
||||||
index ca29257..c36425e 100644
|
index ca29257..c36425e 100644
|
||||||
--- libsemanage-2.6/src/semanage_store.c
|
--- libsemanage-2.6/src/semanage_store.c
|
||||||
|
@ -7,7 +7,7 @@
|
|||||||
Summary: SELinux binary policy manipulation library
|
Summary: SELinux binary policy manipulation library
|
||||||
Name: libsemanage
|
Name: libsemanage
|
||||||
Version: 2.6
|
Version: 2.6
|
||||||
Release: 1.1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014/libsemanage-2.6.tar.gz
|
Source: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014/libsemanage-2.6.tar.gz
|
||||||
@ -195,6 +195,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%endif # if with_python3
|
%endif # if with_python3
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 02 2017 Petr Lautrbach <plautrba@redhat.com> - 2.6-2
|
||||||
|
- Fix FTBFS - fatal error (#1427903)
|
||||||
|
|
||||||
* Mon Feb 20 2017 Petr Lautrbach <plautrba@redhat.com> - 2.6-1.1
|
* Mon Feb 20 2017 Petr Lautrbach <plautrba@redhat.com> - 2.6-1.1
|
||||||
- Update to upstream release 2016-10-14
|
- Update to upstream release 2016-10-14
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user