bc2c12a08f
- Build libselinux without rpm_execcon() (#1284019)
32 lines
1.3 KiB
Diff
32 lines
1.3 KiB
Diff
diff -up libselinux/include/selinux/selinux.h.rpm_execcon libselinux/include/selinux/selinux.h
|
|
--- libselinux/include/selinux/selinux.h.rpm_execcon 2015-12-02 21:18:25.000000000 +0100
|
|
+++ libselinux/include/selinux/selinux.h 2015-12-10 17:50:09.861577967 +0100
|
|
@@ -601,10 +601,12 @@ void fini_selinuxmnt(void);
|
|
* program, falling back to a new context with the specified type. */
|
|
extern int setexecfilecon(const char *filename, const char *fallback_type);
|
|
|
|
+#ifndef DISABLE_RPM
|
|
/* Execute a helper for rpm in an appropriate security context. */
|
|
extern int rpm_execcon(unsigned int verified,
|
|
const char *filename,
|
|
char *const argv[], char *const envp[]);
|
|
+#endif
|
|
|
|
/* Returns whether a file context is customizable, and should not
|
|
be relabeled . */
|
|
diff -up libselinux/src/Makefile.rpm_execcon libselinux/src/Makefile
|
|
--- libselinux/src/Makefile.rpm_execcon 2015-12-02 21:18:25.000000000 +0100
|
|
+++ libselinux/src/Makefile 2015-12-10 17:51:26.158784386 +0100
|
|
@@ -85,9 +85,9 @@ ifneq (,$(filter i386,$(ARCH)))
|
|
TLSFLAGS += -mno-tls-direct-seg-refs
|
|
endif
|
|
|
|
-SWIG = swig -Wall -python -o $(SWIGCOUT) -outdir ./
|
|
+SWIG = swig -Wall -python -o $(SWIGCOUT) -outdir ./ $(EMFLAGS)
|
|
|
|
-SWIGRUBY = swig -Wall -ruby -o $(SWIGRUBYCOUT) -outdir ./
|
|
+SWIGRUBY = swig -Wall -ruby -o $(SWIGRUBYCOUT) -outdir ./ $(EMFLAGS)
|
|
|
|
all: $(LIBA) $(LIBSO) $(LIBPC)
|
|
|