f2f46ec91f
- Drop golang bindings - Add support for pcre2 to pkgconfig definition
293 lines
9.0 KiB
Diff
293 lines
9.0 KiB
Diff
diff --git libselinux-2.7/Makefile libselinux-2.7/Makefile
|
|
index 1ecab17..16531fe 100644
|
|
--- libselinux-2.7/Makefile
|
|
+++ libselinux-2.7/Makefile
|
|
@@ -21,13 +21,14 @@ export DISABLE_SETRANS DISABLE_RPM DISABLE_FLAGS ANDROID_HOST
|
|
|
|
USE_PCRE2 ?= n
|
|
ifeq ($(USE_PCRE2),y)
|
|
- PCRE_CFLAGS := -DUSE_PCRE2 -DPCRE2_CODE_UNIT_WIDTH=8 $(shell $(PKG_CONFIG) --cflags libpcre2-8)
|
|
- PCRE_LDLIBS := $(shell $(PKG_CONFIG) --libs libpcre2-8)
|
|
+ PCRE_MODULE := libpcre2-8
|
|
+ PCRE_CFLAGS := -DUSE_PCRE2 -DPCRE2_CODE_UNIT_WIDTH=8
|
|
else
|
|
- PCRE_CFLAGS := $(shell $(PKG_CONFIG) --cflags libpcre)
|
|
- PCRE_LDLIBS := $(shell $(PKG_CONFIG) --libs libpcre)
|
|
+ PCRE_MODULE := libpcre
|
|
endif
|
|
-export PCRE_CFLAGS PCRE_LDLIBS
|
|
+PCRE_CFLAGS += $(shell $(PKG_CONFIG) --cflags $(PCRE_MODULE))
|
|
+PCRE_LDLIBS := $(shell $(PKG_CONFIG) --libs $(PCRE_MODULE))
|
|
+export PCRE_MODULE PCRE_CFLAGS PCRE_LDLIBS
|
|
|
|
OS := $(shell uname)
|
|
export OS
|
|
diff --git libselinux-2.7/man/man8/selinux.8 libselinux-2.7/man/man8/selinux.8
|
|
index e37aee6..bf23b65 100644
|
|
--- libselinux-2.7/man/man8/selinux.8
|
|
+++ libselinux-2.7/man/man8/selinux.8
|
|
@@ -91,11 +91,13 @@ This manual page was written by Dan Walsh <dwalsh@redhat.com>.
|
|
.BR sepolicy (8),
|
|
.BR system-config-selinux (8),
|
|
.BR togglesebool (8),
|
|
-.BR restorecon (8),
|
|
.BR fixfiles (8),
|
|
+.BR restorecon (8),
|
|
.BR setfiles (8),
|
|
.BR semanage (8),
|
|
.BR sepolicy (8)
|
|
+.BR seinfo (8),
|
|
+.BR sesearch (8)
|
|
|
|
Every confined service on the system has a man page in the following format:
|
|
.br
|
|
diff --git libselinux-2.7/src/Makefile libselinux-2.7/src/Makefile
|
|
index 2408fae..18df75c 100644
|
|
--- libselinux-2.7/src/Makefile
|
|
+++ libselinux-2.7/src/Makefile
|
|
@@ -148,7 +148,7 @@ $(LIBSO): $(LOBJS)
|
|
ln -sf $@ $(TARGET)
|
|
|
|
$(LIBPC): $(LIBPC).in ../VERSION
|
|
- sed -e 's/@VERSION@/$(VERSION)/; s:@prefix@:$(PREFIX):; s:@libdir@:$(LIBBASE):; s:@includedir@:$(INCLUDEDIR):' < $< > $@
|
|
+ sed -e 's/@VERSION@/$(VERSION)/; s:@prefix@:$(PREFIX):; s:@libdir@:$(LIBBASE):; s:@includedir@:$(INCLUDEDIR):; s:@PCRE_MODULE@:$(PCRE_MODULE):' < $< > $@
|
|
|
|
selinuxswig_python_exception.i: ../include/selinux/selinux.h
|
|
bash -e exception.sh > $@ || (rm -f $@ ; false)
|
|
diff --git libselinux-2.7/src/avc.c libselinux-2.7/src/avc.c
|
|
index 96b2678..5230efd 100644
|
|
--- libselinux-2.7/src/avc.c
|
|
+++ libselinux-2.7/src/avc.c
|
|
@@ -4,7 +4,7 @@
|
|
* Author : Eamon Walsh <ewalsh@epoch.ncsc.mil>
|
|
*
|
|
* Derived from the kernel AVC implementation by
|
|
- * Stephen Smalley <sds@epoch.ncsc.mil> and
|
|
+ * Stephen Smalley <sds@tycho.nsa.gov> and
|
|
* James Morris <jmorris@redhat.com>.
|
|
*/
|
|
#include <selinux/avc.h>
|
|
diff --git libselinux-2.7/src/avc_sidtab.c libselinux-2.7/src/avc_sidtab.c
|
|
index 9669264..c775430 100644
|
|
--- libselinux-2.7/src/avc_sidtab.c
|
|
+++ libselinux-2.7/src/avc_sidtab.c
|
|
@@ -81,6 +81,11 @@ sidtab_context_to_sid(struct sidtab *s,
|
|
int hvalue, rc = 0;
|
|
struct sidtab_node *cur;
|
|
|
|
+ if (! ctx) {
|
|
+ errno=EINVAL;
|
|
+ return -1;
|
|
+ }
|
|
+
|
|
*sid = NULL;
|
|
hvalue = sidtab_hash(ctx);
|
|
|
|
diff --git libselinux-2.7/src/booleans.c libselinux-2.7/src/booleans.c
|
|
index 1da55bf..604c588 100644
|
|
--- libselinux-2.7/src/booleans.c
|
|
+++ libselinux-2.7/src/booleans.c
|
|
@@ -55,6 +55,7 @@ int security_get_boolean_names(char ***names, int *len)
|
|
snprintf(path, sizeof path, "%s%s", selinux_mnt, SELINUX_BOOL_DIR);
|
|
*len = scandir(path, &namelist, &filename_select, alphasort);
|
|
if (*len <= 0) {
|
|
+ errno = ENOENT;
|
|
return -1;
|
|
}
|
|
|
|
diff --git libselinux-2.7/src/canonicalize_context.c libselinux-2.7/src/canonicalize_context.c
|
|
index ba4c9a2..c815872 100644
|
|
--- libselinux-2.7/src/canonicalize_context.c
|
|
+++ libselinux-2.7/src/canonicalize_context.c
|
|
@@ -17,6 +17,11 @@ int security_canonicalize_context_raw(const char * con,
|
|
size_t size;
|
|
int fd, ret;
|
|
|
|
+ if (! con) {
|
|
+ errno=EINVAL;
|
|
+ return -1;
|
|
+ }
|
|
+
|
|
if (!selinux_mnt) {
|
|
errno = ENOENT;
|
|
return -1;
|
|
diff --git libselinux-2.7/src/check_context.c libselinux-2.7/src/check_context.c
|
|
index 8a7997f..5be8434 100644
|
|
--- libselinux-2.7/src/check_context.c
|
|
+++ libselinux-2.7/src/check_context.c
|
|
@@ -14,6 +14,11 @@ int security_check_context_raw(const char * con)
|
|
char path[PATH_MAX];
|
|
int fd, ret;
|
|
|
|
+ if (! con) {
|
|
+ errno=EINVAL;
|
|
+ return -1;
|
|
+ }
|
|
+
|
|
if (!selinux_mnt) {
|
|
errno = ENOENT;
|
|
return -1;
|
|
diff --git libselinux-2.7/src/compute_av.c libselinux-2.7/src/compute_av.c
|
|
index 1d05e7b..d9095cc 100644
|
|
--- libselinux-2.7/src/compute_av.c
|
|
+++ libselinux-2.7/src/compute_av.c
|
|
@@ -26,6 +26,11 @@ int security_compute_av_flags_raw(const char * scon,
|
|
return -1;
|
|
}
|
|
|
|
+ if ((! scon) || (! tcon)) {
|
|
+ errno=EINVAL;
|
|
+ return -1;
|
|
+ }
|
|
+
|
|
snprintf(path, sizeof path, "%s/access", selinux_mnt);
|
|
fd = open(path, O_RDWR | O_CLOEXEC);
|
|
if (fd < 0)
|
|
diff --git libselinux-2.7/src/compute_create.c libselinux-2.7/src/compute_create.c
|
|
index 0975aea..3e6a48c 100644
|
|
--- libselinux-2.7/src/compute_create.c
|
|
+++ libselinux-2.7/src/compute_create.c
|
|
@@ -64,6 +64,11 @@ int security_compute_create_name_raw(const char * scon,
|
|
return -1;
|
|
}
|
|
|
|
+ if ((! scon) || (! tcon)) {
|
|
+ errno=EINVAL;
|
|
+ return -1;
|
|
+ }
|
|
+
|
|
snprintf(path, sizeof path, "%s/create", selinux_mnt);
|
|
fd = open(path, O_RDWR | O_CLOEXEC);
|
|
if (fd < 0)
|
|
diff --git libselinux-2.7/src/compute_member.c libselinux-2.7/src/compute_member.c
|
|
index 4e2d221..d1dd977 100644
|
|
--- libselinux-2.7/src/compute_member.c
|
|
+++ libselinux-2.7/src/compute_member.c
|
|
@@ -25,6 +25,11 @@ int security_compute_member_raw(const char * scon,
|
|
return -1;
|
|
}
|
|
|
|
+ if ((! scon) || (! tcon)) {
|
|
+ errno=EINVAL;
|
|
+ return -1;
|
|
+ }
|
|
+
|
|
snprintf(path, sizeof path, "%s/member", selinux_mnt);
|
|
fd = open(path, O_RDWR | O_CLOEXEC);
|
|
if (fd < 0)
|
|
diff --git libselinux-2.7/src/compute_relabel.c libselinux-2.7/src/compute_relabel.c
|
|
index 49f77ef..c3db7c0 100644
|
|
--- libselinux-2.7/src/compute_relabel.c
|
|
+++ libselinux-2.7/src/compute_relabel.c
|
|
@@ -25,6 +25,11 @@ int security_compute_relabel_raw(const char * scon,
|
|
return -1;
|
|
}
|
|
|
|
+ if ((! scon) || (! tcon)) {
|
|
+ errno=EINVAL;
|
|
+ return -1;
|
|
+ }
|
|
+
|
|
snprintf(path, sizeof path, "%s/relabel", selinux_mnt);
|
|
fd = open(path, O_RDWR | O_CLOEXEC);
|
|
if (fd < 0)
|
|
diff --git libselinux-2.7/src/compute_user.c libselinux-2.7/src/compute_user.c
|
|
index 7b88121..401fd10 100644
|
|
--- libselinux-2.7/src/compute_user.c
|
|
+++ libselinux-2.7/src/compute_user.c
|
|
@@ -24,6 +24,11 @@ int security_compute_user_raw(const char * scon,
|
|
return -1;
|
|
}
|
|
|
|
+ if (! scon) {
|
|
+ errno=EINVAL;
|
|
+ return -1;
|
|
+ }
|
|
+
|
|
snprintf(path, sizeof path, "%s/user", selinux_mnt);
|
|
fd = open(path, O_RDWR | O_CLOEXEC);
|
|
if (fd < 0)
|
|
diff --git libselinux-2.7/src/fsetfilecon.c libselinux-2.7/src/fsetfilecon.c
|
|
index 52707d0..0cbe12d 100644
|
|
--- libselinux-2.7/src/fsetfilecon.c
|
|
+++ libselinux-2.7/src/fsetfilecon.c
|
|
@@ -9,8 +9,12 @@
|
|
|
|
int fsetfilecon_raw(int fd, const char * context)
|
|
{
|
|
- int rc = fsetxattr(fd, XATTR_NAME_SELINUX, context, strlen(context) + 1,
|
|
- 0);
|
|
+ int rc;
|
|
+ if (! context) {
|
|
+ errno=EINVAL;
|
|
+ return -1;
|
|
+ }
|
|
+ rc = fsetxattr(fd, XATTR_NAME_SELINUX, context, strlen(context) + 1, 0);
|
|
if (rc < 0 && errno == ENOTSUP) {
|
|
char * ccontext = NULL;
|
|
int err = errno;
|
|
diff --git libselinux-2.7/src/libselinux.pc.in libselinux-2.7/src/libselinux.pc.in
|
|
index 2cd04d3..2e90a84 100644
|
|
--- libselinux-2.7/src/libselinux.pc.in
|
|
+++ libselinux-2.7/src/libselinux.pc.in
|
|
@@ -7,6 +7,6 @@ Name: libselinux
|
|
Description: SELinux utility library
|
|
Version: @VERSION@
|
|
URL: http://userspace.selinuxproject.org/
|
|
-Requires.private: libsepol libpcre
|
|
+Requires.private: libsepol @PCRE_MODULE@
|
|
Libs: -L${libdir} -lselinux
|
|
Cflags: -I${includedir}
|
|
diff --git libselinux-2.7/src/lsetfilecon.c libselinux-2.7/src/lsetfilecon.c
|
|
index 1d3b28a..ea6d70b 100644
|
|
--- libselinux-2.7/src/lsetfilecon.c
|
|
+++ libselinux-2.7/src/lsetfilecon.c
|
|
@@ -9,8 +9,13 @@
|
|
|
|
int lsetfilecon_raw(const char *path, const char * context)
|
|
{
|
|
- int rc = lsetxattr(path, XATTR_NAME_SELINUX, context, strlen(context) + 1,
|
|
- 0);
|
|
+ int rc;
|
|
+ if (! context) {
|
|
+ errno=EINVAL;
|
|
+ return -1;
|
|
+ }
|
|
+
|
|
+ rc = lsetxattr(path, XATTR_NAME_SELINUX, context, strlen(context) + 1, 0);
|
|
if (rc < 0 && errno == ENOTSUP) {
|
|
char * ccontext = NULL;
|
|
int err = errno;
|
|
diff --git libselinux-2.7/src/setfilecon.c libselinux-2.7/src/setfilecon.c
|
|
index d05969c..3f0200e 100644
|
|
--- libselinux-2.7/src/setfilecon.c
|
|
+++ libselinux-2.7/src/setfilecon.c
|
|
@@ -9,8 +9,12 @@
|
|
|
|
int setfilecon_raw(const char *path, const char * context)
|
|
{
|
|
- int rc = setxattr(path, XATTR_NAME_SELINUX, context, strlen(context) + 1,
|
|
- 0);
|
|
+ int rc;
|
|
+ if (! context) {
|
|
+ errno=EINVAL;
|
|
+ return -1;
|
|
+ }
|
|
+ rc = setxattr(path, XATTR_NAME_SELINUX, context, strlen(context) + 1, 0);
|
|
if (rc < 0 && errno == ENOTSUP) {
|
|
char * ccontext = NULL;
|
|
int err = errno;
|
|
diff --git libselinux-2.7/utils/matchpathcon.c libselinux-2.7/utils/matchpathcon.c
|
|
index 67e4a43..9756d7d 100644
|
|
--- libselinux-2.7/utils/matchpathcon.c
|
|
+++ libselinux-2.7/utils/matchpathcon.c
|
|
@@ -14,7 +14,7 @@
|
|
static __attribute__ ((__noreturn__)) void usage(const char *progname)
|
|
{
|
|
fprintf(stderr,
|
|
- "usage: %s [-N] [-n] [-f file_contexts] [ -P policy_root_path ] [-p prefix] [-Vq] path...\n",
|
|
+ "usage: %s [-V] [-N] [-n] [-m type] [-f file_contexts_file] [-p prefix] [-P policy_root_path] filepath...\n",
|
|
progname);
|
|
exit(1);
|
|
}
|