45 lines
1.9 KiB
Diff
45 lines
1.9 KiB
Diff
From 94364696c5aed35a9c1f529d96d1930cef37ecda Mon Sep 17 00:00:00 2001
|
|
From: James Carter <jwcart2@gmail.com>
|
|
Date: Fri, 28 Oct 2022 16:10:39 -0400
|
|
Subject: [PATCH] libselinux: Remove dependency on the Python module distutils
|
|
Content-type: text/plain
|
|
|
|
The distutils package is deprecated and scheduled to be removed in
|
|
Python 3.12. Use the setuptools and sysconfig modules instead.
|
|
|
|
Signed-off-by: James Carter <jwcart2@gmail.com>
|
|
Acked-by: Petr Lautrbach <plautrba@redhat.com>
|
|
---
|
|
libselinux/src/Makefile | 2 +-
|
|
libselinux/src/setup.py | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/libselinux/src/Makefile b/libselinux/src/Makefile
|
|
index 49b7d60a1f74..dc2848322e4d 100644
|
|
--- a/libselinux/src/Makefile
|
|
+++ b/libselinux/src/Makefile
|
|
@@ -14,7 +14,7 @@ SHLIBDIR ?= /lib
|
|
INCLUDEDIR ?= $(PREFIX)/include
|
|
PYINC ?= $(shell $(PKG_CONFIG) --cflags $(PYPREFIX))
|
|
PYLIBS ?= $(shell $(PKG_CONFIG) --libs $(PYPREFIX))
|
|
-PYTHONLIBDIR ?= $(shell $(PYTHON) -c "from distutils.sysconfig import *; print(get_python_lib(plat_specific=1, prefix='$(PREFIX)'))")
|
|
+PYTHONLIBDIR ?= $(shell $(PYTHON) -c "import sysconfig; print(sysconfig.get_path('platlib', vars={'platbase': '$(PREFIX)', 'base': '$(PREFIX)'}))")
|
|
PYCEXT ?= $(shell $(PYTHON) -c 'import importlib.machinery;print(importlib.machinery.EXTENSION_SUFFIXES[0])')
|
|
RUBYINC ?= $(shell $(RUBY) -e 'puts "-I" + RbConfig::CONFIG["rubyarchhdrdir"] + " -I" + RbConfig::CONFIG["rubyhdrdir"]')
|
|
RUBYLIBS ?= $(shell $(RUBY) -e 'puts "-L" + RbConfig::CONFIG["libdir"] + " -L" + RbConfig::CONFIG["archlibdir"] + " " + RbConfig::CONFIG["LIBRUBYARG_SHARED"]')
|
|
diff --git a/libselinux/src/setup.py b/libselinux/src/setup.py
|
|
index 71e69a107f01..6cbe3a0e924b 100644
|
|
--- a/libselinux/src/setup.py
|
|
+++ b/libselinux/src/setup.py
|
|
@@ -1,6 +1,6 @@
|
|
#!/usr/bin/python3
|
|
|
|
-from distutils.core import Extension, setup
|
|
+from setuptools import Extension, setup
|
|
|
|
setup(
|
|
name="selinux",
|
|
--
|
|
2.38.1
|
|
|