57 lines
2.3 KiB
Diff
57 lines
2.3 KiB
Diff
From c2d58b378b3cf350d042a7b657e2b7f5861c5f26 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Christian=20G=C3=B6ttsche?= <cgzones@googlemail.com>
|
|
Date: Mon, 8 Aug 2022 19:36:55 +0200
|
|
Subject: [PATCH] Ignore egg-info directories and clean them
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
Content-type: text/plain
|
|
|
|
Test .gitignore and make clean distclean
|
|
error: missing .gitignore entry for libselinux/src/selinux.egg-info/
|
|
error: missing .gitignore entry for python/sepolicy/sepolicy.egg-info/
|
|
Error: Process completed with exit code 1.
|
|
|
|
error: "make clean distclean" did not remove libselinux/src/selinux.egg-info/PKG-INFO
|
|
error: "make clean distclean" did not remove libselinux/src/selinux.egg-info/SOURCES.txt
|
|
error: "make clean distclean" did not remove libselinux/src/selinux.egg-info/dependency_links.txt
|
|
error: "make clean distclean" did not remove libselinux/src/selinux.egg-info/top_level.txt
|
|
error: "make clean distclean" did not remove python/sepolicy/sepolicy.egg-info/PKG-INFO
|
|
error: "make clean distclean" did not remove python/sepolicy/sepolicy.egg-info/SOURCES.txt
|
|
error: "make clean distclean" did not remove python/sepolicy/sepolicy.egg-info/dependency_links.txt
|
|
error: "make clean distclean" did not remove python/sepolicy/sepolicy.egg-info/top_level.txt
|
|
Error: Process completed with exit code 1.
|
|
|
|
Signed-off-by: Christian Göttsche <cgzones@googlemail.com>
|
|
Acked-by: James Carter <jwcart2@gmail.com>
|
|
---
|
|
libselinux/src/.gitignore | 1 +
|
|
libselinux/src/Makefile | 2 +-
|
|
2 files changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/libselinux/src/.gitignore b/libselinux/src/.gitignore
|
|
index 001f20b01e39..94400e81fb33 100644
|
|
--- a/libselinux/src/.gitignore
|
|
+++ b/libselinux/src/.gitignore
|
|
@@ -1,3 +1,4 @@
|
|
selinux.py
|
|
selinuxswig_python_wrap.c
|
|
selinuxswig_ruby_wrap.c
|
|
+selinux.egg-info/
|
|
diff --git a/libselinux/src/Makefile b/libselinux/src/Makefile
|
|
index 88aa32f80944..49b7d60a1f74 100644
|
|
--- a/libselinux/src/Makefile
|
|
+++ b/libselinux/src/Makefile
|
|
@@ -201,7 +201,7 @@ relabel:
|
|
clean-pywrap:
|
|
-rm -f $(SWIGLOBJ) $(SWIGSO) $(AUDIT2WHYLOBJ) $(AUDIT2WHYSO)
|
|
$(PYTHON) setup.py clean
|
|
- -rm -rf build *~ \#* *pyc .#*
|
|
+ -rm -rf build *~ \#* *pyc .#* selinux.egg-info/
|
|
|
|
clean-rubywrap:
|
|
-rm -f $(SWIGRUBYLOBJ) $(SWIGRUBYSO)
|
|
--
|
|
2.38.1
|
|
|