c18e55e40f
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/libselinux.git#93aa02b877ab3de1c71fbf52e63689760aaaf3ae
60 lines
1.9 KiB
Diff
60 lines
1.9 KiB
Diff
From f870bd1ea6847840f1878490e090ef96ed708ac4 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Bj=C3=B6rn=20Bidar?= <bjorn.bidar@jolla.com>
|
|
Date: Mon, 12 Oct 2020 19:07:22 +0300
|
|
Subject: [PATCH] libselinux: LABEL_BACKEND_ANDROID add option to enable
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Add option to just enable the android label backend without disabling
|
|
anything else eg. using ANDROID_HOST. Enable by default when using ANDROID_HOST.
|
|
|
|
Signed-off-by: Björn Bidar <bjorn.bidar@jolla.com>
|
|
---
|
|
libselinux/Makefile | 3 ++-
|
|
libselinux/src/Makefile | 6 +++++-
|
|
2 files changed, 7 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/libselinux/Makefile b/libselinux/Makefile
|
|
index cb5872b7b090..ac16c15e8d0a 100644
|
|
--- a/libselinux/Makefile
|
|
+++ b/libselinux/Makefile
|
|
@@ -4,6 +4,7 @@ PKG_CONFIG ?= pkg-config
|
|
DISABLE_SETRANS ?= n
|
|
DISABLE_RPM ?= n
|
|
ANDROID_HOST ?= n
|
|
+LABEL_BACKEND_ANDROID ?= n
|
|
ifeq ($(ANDROID_HOST),y)
|
|
override DISABLE_SETRANS=y
|
|
override DISABLE_BOOL=y
|
|
@@ -20,7 +21,7 @@ endif
|
|
ifeq ($(DISABLE_X11),y)
|
|
DISABLE_FLAGS+= -DNO_X_BACKEND
|
|
endif
|
|
-export DISABLE_SETRANS DISABLE_RPM DISABLE_FLAGS ANDROID_HOST DISABLE_X11
|
|
+export DISABLE_SETRANS DISABLE_RPM DISABLE_FLAGS ANDROID_HOST DISABLE_X11 LABEL_BACKEND_ANDROID
|
|
|
|
USE_PCRE2 ?= n
|
|
ifeq ($(USE_PCRE2),y)
|
|
diff --git a/libselinux/src/Makefile b/libselinux/src/Makefile
|
|
index be0b6eec6f6d..52c40f018f51 100644
|
|
--- a/libselinux/src/Makefile
|
|
+++ b/libselinux/src/Makefile
|
|
@@ -122,8 +122,12 @@ SRCS= callbacks.c freecon.c label.c label_file.c \
|
|
label_backends_android.c regex.c label_support.c \
|
|
matchpathcon.c setrans_client.c sha1.c booleans.c
|
|
else
|
|
-DISABLE_FLAGS+= -DNO_ANDROID_BACKEND
|
|
+LABEL_BACKEND_ANDROID=y
|
|
+endif
|
|
+
|
|
+ifneq ($(LABEL_BACKEND_ANDROIDT),y)
|
|
SRCS:= $(filter-out label_backends_android.c, $(SRCS))
|
|
+DISABLE_FLAGS+= -DNO_ANDROID_BACKEND
|
|
endif
|
|
|
|
ifeq ($(DISABLE_X11),y)
|
|
--
|
|
2.29.2
|
|
|