74de835e2c
- Use libsepol.so.2 - Convert matchpathcon to selabel_lookup() - Change userspace AVC setenforce and policy load messages to audit format - Remove trailing slash on selabel_file lookups - Use kernel status page by default
28 lines
811 B
Diff
28 lines
811 B
Diff
From e7abd802d4d8541627c590424a6578348ee6032b Mon Sep 17 00:00:00 2001
|
|
From: Stephen Smalley <stephen.smalley.work@gmail.com>
|
|
Date: Thu, 6 Aug 2020 10:46:38 -0400
|
|
Subject: [PATCH] libselinux: fix build order
|
|
|
|
We need to install the include files before we try to build the source.
|
|
Otherwise, make DESTDIR=~/obj install can fail if there are older
|
|
headers under /usr/include.
|
|
|
|
Signed-off-by: Stephen Smalley <stephen.smalley.work@gmail.com>
|
|
---
|
|
libselinux/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/libselinux/Makefile b/libselinux/Makefile
|
|
index 16531fe95bf5..6a43b243f4da 100644
|
|
--- a/libselinux/Makefile
|
|
+++ b/libselinux/Makefile
|
|
@@ -1,4 +1,4 @@
|
|
-SUBDIRS = src include utils man
|
|
+SUBDIRS = include src utils man
|
|
|
|
PKG_CONFIG ?= pkg-config
|
|
DISABLE_SETRANS ?= n
|
|
--
|
|
2.29.0
|
|
|