b95f8bdd48
There was a change in swig-3.10 to use importlib instead of imp. While the implementation with imp looked for _selinux.so also in the directory where __init__.py was, importlib search only standard paths. It means that we need to move _selinux.so from $(PYLIBDIR)/site-packages/selinux/ to $(PYLIBDIR)/site-packages/ Fixes: >>> import selinux Traceback (most recent call last): File "/usr/lib64/python3.5/site-packages/selinux/__init__.py", line 18, in swig_import_helper return importlib.import_module(mname) File "/usr/lib64/python3.5/importlib/__init__.py", line 126, in import_module return _bootstrap._gcd_import(name[level:], package, level) File "<frozen importlib._bootstrap>", line 986, in _gcd_import File "<frozen importlib._bootstrap>", line 969, in _find_and_load File "<frozen importlib._bootstrap>", line 956, in _find_and_load_unlocked ImportError: No module named '_selinux' During handling of the above exception, another exception occurred: Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/lib64/python3.5/site-packages/selinux/__init__.py", line 21, in <module> _selinux = swig_import_helper() File "/usr/lib64/python3.5/site-packages/selinux/__init__.py", line 20, in swig_import_helper return importlib.import_module('_selinux') File "/usr/lib64/python3.5/importlib/__init__.py", line 126, in import_module return _bootstrap._gcd_import(name[level:], package, level) ImportError: No module named '_selinux'
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
From d04204820e04f19c6603ad2b0a45a382bc4546c7 Mon Sep 17 00:00:00 2001
|
|
From: Petr Lautrbach <plautrba@redhat.com>
|
|
Date: Fri, 24 Jun 2016 14:29:08 +0200
|
|
Subject: [PATCH] libselinux: Change the location of _selinux.so
|
|
|
|
There was a change in swig-3.10 to use importlib instead of imp. While
|
|
the implementation with imp looked for _selinux.so in the directory
|
|
where is __init__.py, importlib search standard paths. It means that we
|
|
need to move _selinux.so from $(PYLIBDIR)/site-packages/selinux/ to
|
|
$(PYLIBDIR)/site-packages/.
|
|
---
|
|
src/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/Makefile b/src/Makefile
|
|
index d94163e..37d01af 100644
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -156,7 +156,7 @@ install: all
|
|
|
|
install-pywrap: pywrap
|
|
test -d $(PYLIBDIR)/site-packages/selinux || install -m 755 -d $(PYLIBDIR)/site-packages/selinux
|
|
- install -m 755 $(SWIGSO) $(PYLIBDIR)/site-packages/selinux/_selinux.so
|
|
+ install -m 755 $(SWIGSO) $(PYLIBDIR)/site-packages/_selinux.so
|
|
install -m 755 $(AUDIT2WHYSO) $(PYLIBDIR)/site-packages/selinux/audit2why.so
|
|
install -m 644 $(SWIGPYOUT) $(PYLIBDIR)/site-packages/selinux/__init__.py
|
|
|
|
--
|
|
2.7.4
|
|
|