- Fix spec file caused by spec review

This commit is contained in:
Daniel J Walsh 2008-01-03 20:29:21 +00:00
parent 41bd3b2ae1
commit e1e36a0421
2 changed files with 41 additions and 18 deletions

View File

@ -1,6 +1,6 @@
diff --exclude-from=exclude -N -u -r nsalibselinux/include/selinux/av_permissions.h libselinux-2.0.45/include/selinux/av_permissions.h diff --exclude-from=exclude -N -u -r nsalibselinux/include/selinux/av_permissions.h libselinux-2.0.46/include/selinux/av_permissions.h
--- nsalibselinux/include/selinux/av_permissions.h 2007-11-15 15:52:46.000000000 -0500 --- nsalibselinux/include/selinux/av_permissions.h 2007-11-15 15:52:46.000000000 -0500
+++ libselinux-2.0.45/include/selinux/av_permissions.h 2007-11-30 17:27:14.000000000 -0500 +++ libselinux-2.0.46/include/selinux/av_permissions.h 2008-01-03 15:23:31.000000000 -0500
@@ -900,6 +900,8 @@ @@ -900,6 +900,8 @@
#define PACKET__SEND 0x00000001UL #define PACKET__SEND 0x00000001UL
#define PACKET__RECV 0x00000002UL #define PACKET__RECV 0x00000002UL
@ -10,9 +10,29 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/include/selinux/av_permission
#define KEY__VIEW 0x00000001UL #define KEY__VIEW 0x00000001UL
#define KEY__READ 0x00000002UL #define KEY__READ 0x00000002UL
#define KEY__WRITE 0x00000004UL #define KEY__WRITE 0x00000004UL
diff --exclude-from=exclude -N -u -r nsalibselinux/src/matchpathcon.c libselinux-2.0.45/src/matchpathcon.c diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-2.0.46/src/Makefile
--- nsalibselinux/src/Makefile 2007-09-26 19:37:45.000000000 -0400
+++ libselinux-2.0.46/src/Makefile 2008-01-03 15:24:29.000000000 -0500
@@ -77,14 +77,14 @@
install: all
test -d $(LIBDIR) || install -m 755 -d $(LIBDIR)
- install -m 644 $(LIBA) $(LIBDIR)
test -d $(SHLIBDIR) || install -m 755 -d $(SHLIBDIR)
install -m 755 $(LIBSO) $(SHLIBDIR)
cd $(LIBDIR) && ln -sf ../../`basename $(SHLIBDIR)`/$(LIBSO) $(TARGET)
install-pywrap: pywrap
test -d $(PYTHONLIBDIR)/site-packages || install -m 755 -d $(PYTHONLIBDIR)/site-packages
- install -m 755 $(SWIGFILES) $(PYTHONLIBDIR)/site-packages
+ install -m 755 $(SWIGSO) $(PYTHONLIBDIR)/site-packages
+ install -m 644 selinux.py $(PYTHONLIBDIR)/site-packages
relabel:
/sbin/restorecon $(SHLIBDIR)/$(LIBSO)
diff --exclude-from=exclude -N -u -r nsalibselinux/src/matchpathcon.c libselinux-2.0.46/src/matchpathcon.c
--- nsalibselinux/src/matchpathcon.c 2007-09-28 09:48:58.000000000 -0400 --- nsalibselinux/src/matchpathcon.c 2007-09-28 09:48:58.000000000 -0400
+++ libselinux-2.0.45/src/matchpathcon.c 2007-11-30 17:27:14.000000000 -0500 +++ libselinux-2.0.46/src/matchpathcon.c 2008-01-03 15:23:32.000000000 -0500
@@ -2,6 +2,7 @@ @@ -2,6 +2,7 @@
#include <string.h> #include <string.h>
#include <errno.h> #include <errno.h>
@ -30,9 +50,9 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/src/matchpathcon.c libselinux
va_end(ap); va_end(ap);
} }
diff --exclude-from=exclude -N -u -r nsalibselinux/utils/matchpathcon.c libselinux-2.0.45/utils/matchpathcon.c diff --exclude-from=exclude -N -u -r nsalibselinux/utils/matchpathcon.c libselinux-2.0.46/utils/matchpathcon.c
--- nsalibselinux/utils/matchpathcon.c 2007-07-16 14:20:45.000000000 -0400 --- nsalibselinux/utils/matchpathcon.c 2007-07-16 14:20:45.000000000 -0400
+++ libselinux-2.0.45/utils/matchpathcon.c 2007-11-30 17:27:14.000000000 -0500 +++ libselinux-2.0.46/utils/matchpathcon.c 2008-01-03 15:23:32.000000000 -0500
@@ -17,10 +17,24 @@ @@ -17,10 +17,24 @@
exit(1); exit(1);
} }

View File

@ -2,11 +2,12 @@
Summary: SELinux library and simple utilities Summary: SELinux library and simple utilities
Name: libselinux Name: libselinux
Version: 2.0.46 Version: 2.0.46
Release: 1%{?dist} Release: 2%{?dist}
License: Public domain (uncopyrighted) License: Public Domain
Group: System Environment/Libraries Group: System Environment/Libraries
Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz
Patch: libselinux-rhat.patch Patch: libselinux-rhat.patch
URL: http://www.nsa.gov/selinux
BuildRequires: libsepol-devel >= %{libsepolver} swig BuildRequires: libsepol-devel >= %{libsepolver} swig
Requires: libsepol >= %{libsepolver} Requires: libsepol >= %{libsepolver}
@ -28,14 +29,14 @@ process and file security contexts and to obtain security policy
decisions. Required for any applications that use the SELinux API. decisions. Required for any applications that use the SELinux API.
%package python %package python
Summary: python bindings for libselinux Summary: SELinux python bindings for libselinux
Group: Development/Libraries Group: Development/Libraries
Requires: libselinux = %{version}-%{release} Requires: libselinux = %{version}-%{release}
BuildRequires: python-devel BuildRequires: python-devel
%description python %description python
The libselinux-python package contains the python bindings for developing SELinux The libselinux-python package contains the python bindings for developing
applications. SELinux applications.
%package devel %package devel
Summary: Header files and libraries used to build SELinux Summary: Header files and libraries used to build SELinux
@ -111,7 +112,6 @@ exit 0
%files devel %files devel
%defattr(-,root,root) %defattr(-,root,root)
%{_libdir}/libselinux.a
%{_libdir}/libselinux.so %{_libdir}/libselinux.so
%dir %{_includedir}/selinux %dir %{_includedir}/selinux
%{_includedir}/selinux/* %{_includedir}/selinux/*
@ -123,6 +123,9 @@ exit 0
%{_libdir}/python*/site-packages/selinux.py* %{_libdir}/python*/site-packages/selinux.py*
%changelog %changelog
* Thu Jan 3 2008 Dan Walsh <dwalsh@redhat.com> - 2.0.46-2
- Fix spec file caused by spec review
* Fri Nov 30 2007 Dan Walsh <dwalsh@redhat.com> - 2.0.46-1 * Fri Nov 30 2007 Dan Walsh <dwalsh@redhat.com> - 2.0.46-1
- Upgrade to upstream - Upgrade to upstream
* matchpathcon(8) man page update from Dan Walsh. * matchpathcon(8) man page update from Dan Walsh.
@ -325,7 +328,7 @@ exit 0
* Wed Feb 7 2007 Dan Walsh <dwalsh@redhat.com> - 2.0.0-1 * Wed Feb 7 2007 Dan Walsh <dwalsh@redhat.com> - 2.0.0-1
* Merged patch from Todd Miller to remove sscanf in matchpathcon.c because * Merged patch from Todd Miller to remove sscanf in matchpathcon.c because
of the use of the non-standard format %as. (original patch changed of the use of the non-standard format (original patch changed
for style). for style).
* Merged patch from Todd Miller to fix memory leak in matchpathcon.c. * Merged patch from Todd Miller to fix memory leak in matchpathcon.c.
@ -489,8 +492,8 @@ Resolves: #200110
* Fri Jun 16 2006 Dan Walsh <dwalsh@redhat.com> 1.30.15-1 * Fri Jun 16 2006 Dan Walsh <dwalsh@redhat.com> 1.30.15-1
- Upgrade to latest from NSA - Upgrade to latest from NSA
* Merged patch from Dan Walsh with: * Merged patch from Dan Walsh with:
* Added selinux_getpolicytype() function. * Added selinux_getpolicytype() function.
* Modified setrans code to skip processing if !mls_enabled. * Modified setrans code to skip processing if !mls_enabled.
* Set errno in the !selinux_mnt case. * Set errno in the !selinux_mnt case.
* Allocate large buffers from the heap, not on stack. * Allocate large buffers from the heap, not on stack.
Affects is_context_customizable, selinux_init_load_policy, Affects is_context_customizable, selinux_init_load_policy,
@ -865,7 +868,7 @@ Resolves: #200110
- Update from NSA - Update from NSA
* Merged several fixes for error handling paths in the * Merged several fixes for error handling paths in the
AVC sidtab, matchpathcon, booleans, context, and get_context_list AVC sidtab, matchpathcon, booleans, context, and get_context_list
code from Serge Hallyn (IBM). Bugs found by Coverity. code from Serge Hallyn (IBM). Bugs found by Coverity.
* Removed setupns; migrated to pam. * Removed setupns; migrated to pam.
* Merged patches to rename checkPasswdAccess() from Joshua Brindle. * Merged patches to rename checkPasswdAccess() from Joshua Brindle.
Original symbol is temporarily retained for compatibility until Original symbol is temporarily retained for compatibility until
@ -973,7 +976,7 @@ Resolves: #200110
* Thu Feb 10 2005 Dan Walsh <dwalsh@redhat.com> 1.21.9-1 * Thu Feb 10 2005 Dan Walsh <dwalsh@redhat.com> 1.21.9-1
- Update from NSA - Update from NSA
* Changed relabel Makefile target to use restorecon. * Changed relabel Makefile target to use restorecon.
* Tue Feb 8 2005 Dan Walsh <dwalsh@redhat.com> 1.21.8-1 * Tue Feb 8 2005 Dan Walsh <dwalsh@redhat.com> 1.21.8-1
- Update from NSA - Update from NSA
@ -1074,7 +1077,7 @@ Resolves: #200110
* Thu Oct 28 2004 Steve Grubb <sgrubb@redhat.com> 1.17.15-2 * Thu Oct 28 2004 Steve Grubb <sgrubb@redhat.com> 1.17.15-2
- Changed the location of the utilities to /usr/sbin since - Changed the location of the utilities to /usr/sbin since
normal users can't use them anyways. normal users can't use them anyways.
* Wed Oct 27 2004 Steve Grubb <sgrubb@redhat.com> 1.17.15-2 * Wed Oct 27 2004 Steve Grubb <sgrubb@redhat.com> 1.17.15-2
- Updated various utilities, removed utilities that are for testing, - Updated various utilities, removed utilities that are for testing,