Merged Makefile PYLIBVER definition patch from Dan Walsh.
This commit is contained in:
parent
55f0304445
commit
c8030dcf96
@ -77,3 +77,4 @@ libselinux-1.29.6.tgz
|
||||
libselinux-1.29.7.tgz
|
||||
libselinux-1.29.8.tgz
|
||||
libselinux-1.30.tgz
|
||||
libselinux-1.30.1.tgz
|
||||
|
@ -1,11 +1,22 @@
|
||||
--- libselinux-1.29.7/src/Makefile~ 2006-01-20 10:37:52.000000000 -0500
|
||||
+++ libselinux-1.29.7/src/Makefile 2006-03-16 17:22:52.000000000 -0500
|
||||
@@ -3,7 +3,7 @@
|
||||
LIBDIR ?= $(PREFIX)/lib
|
||||
SHLIBDIR ?= $(DESTDIR)/lib
|
||||
INCLUDEDIR ?= $(PREFIX)/include
|
||||
-PYLIBVER ?= python2.4
|
||||
+PYLIBVER ?= $(shell python -c 'import sys;print "python%d.%d" % sys.version_info[0:2]')
|
||||
PYINC ?= /usr/include/$(PYLIBVER)
|
||||
PYLIB ?= /usr/lib/$(PYLIBVER)
|
||||
PYTHONLIBDIR ?= $(LIBDIR)/$(PYLIBVER)
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/selinuxswig.i libselinux-1.30.1/src/selinuxswig.i
|
||||
--- nsalibselinux/src/selinuxswig.i 2006-01-04 10:37:35.000000000 -0500
|
||||
+++ libselinux-1.30.1/src/selinuxswig.i 2006-04-11 14:23:41.000000000 -0400
|
||||
@@ -29,8 +29,9 @@
|
||||
$1 = &temp;
|
||||
}
|
||||
%typemap(argout) security_context_t * {
|
||||
- $result = t_output_helper($result, PyString_FromString(*$1));
|
||||
+ $result = SWIG_Python_AppendOutput($result, PyString_FromString(*$1));
|
||||
}
|
||||
+%typedef unsigned mode_t;
|
||||
|
||||
extern int is_selinux_enabled(void);
|
||||
extern int is_selinux_mls_enabled(void);
|
||||
@@ -114,6 +115,6 @@
|
||||
}
|
||||
|
||||
%typemap(argout) char ** {
|
||||
- $result = t_output_helper($result, PyString_FromString(*$1));
|
||||
+ $result = SWIG_Python_AppendOutput($result, PyString_FromString(*$1));
|
||||
}
|
||||
extern int getseuserbyname(const char *linuxuser, char **seuser, char **level);
|
||||
|
@ -2,7 +2,7 @@
|
||||
%define libsetransver 0.1.20-1
|
||||
Summary: SELinux library and simple utilities
|
||||
Name: libselinux
|
||||
Version: 1.30
|
||||
Version: 1.30.1
|
||||
Release: 1
|
||||
License: Public domain (uncopyrighted)
|
||||
Group: System Environment/Libraries
|
||||
@ -111,6 +111,9 @@ exit 0
|
||||
%{_libdir}/python*/site-packages/selinux.py*
|
||||
|
||||
%changelog
|
||||
* Mon Mar 27 2006 Dan Walsh <dwalsh@redhat.com> 1.30.1-1
|
||||
* Merged Makefile PYLIBVER definition patch from Dan Walsh.
|
||||
|
||||
* Fri Mar 10 2006 Dan Walsh <dwalsh@redhat.com> 1.30-1
|
||||
- Make some fixes so it will build on RHEL4
|
||||
- Upgrade to latest from NSA
|
||||
|
Loading…
Reference in New Issue
Block a user