Remove unused files
- libselinux-rpm_execcon.patch is already applied in upstream sources - make-rhat-patches.sh was renamed and pushed to https://raw.githubusercontent.com/fedora-selinux/scripts/master/selinux/make-fedora-selinux-patch.sh
This commit is contained in:
parent
a1ef8d83ed
commit
ba888ffe29
@ -1,31 +0,0 @@
|
|||||||
diff -up libselinux/include/selinux/selinux.h.rpm_execcon libselinux/include/selinux/selinux.h
|
|
||||||
--- libselinux/include/selinux/selinux.h.rpm_execcon 2015-12-02 21:18:25.000000000 +0100
|
|
||||||
+++ libselinux/include/selinux/selinux.h 2015-12-10 17:50:09.861577967 +0100
|
|
||||||
@@ -601,10 +601,12 @@ void fini_selinuxmnt(void);
|
|
||||||
* program, falling back to a new context with the specified type. */
|
|
||||||
extern int setexecfilecon(const char *filename, const char *fallback_type);
|
|
||||||
|
|
||||||
+#ifndef DISABLE_RPM
|
|
||||||
/* Execute a helper for rpm in an appropriate security context. */
|
|
||||||
extern int rpm_execcon(unsigned int verified,
|
|
||||||
const char *filename,
|
|
||||||
char *const argv[], char *const envp[]);
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
/* Returns whether a file context is customizable, and should not
|
|
||||||
be relabeled . */
|
|
||||||
diff -up libselinux/src/Makefile.rpm_execcon libselinux/src/Makefile
|
|
||||||
--- libselinux/src/Makefile.rpm_execcon 2015-12-02 21:18:25.000000000 +0100
|
|
||||||
+++ libselinux/src/Makefile 2015-12-10 17:51:26.158784386 +0100
|
|
||||||
@@ -85,9 +85,9 @@ ifneq (,$(filter i386,$(ARCH)))
|
|
||||||
TLSFLAGS += -mno-tls-direct-seg-refs
|
|
||||||
endif
|
|
||||||
|
|
||||||
-SWIG = swig -Wall -python -o $(SWIGCOUT) -outdir ./
|
|
||||||
+SWIG = swig -Wall -python -o $(SWIGCOUT) -outdir ./ $(EMFLAGS)
|
|
||||||
|
|
||||||
-SWIGRUBY = swig -Wall -ruby -o $(SWIGRUBYCOUT) -outdir ./
|
|
||||||
+SWIGRUBY = swig -Wall -ruby -o $(SWIGRUBYCOUT) -outdir ./ $(EMFLAGS)
|
|
||||||
|
|
||||||
all: $(LIBA) $(LIBSO) $(LIBPC)
|
|
||||||
|
|
@ -1,28 +0,0 @@
|
|||||||
#!/bin/bash
|
|
||||||
|
|
||||||
LIBSELINUX_VERSION=2.5-rc1
|
|
||||||
REPO=https://github.com/fedora-selinux/selinux
|
|
||||||
BRANCH=master-rc
|
|
||||||
|
|
||||||
REBASEDIR=`mktemp -d rebase.XXXXXX`
|
|
||||||
pushd $REBASEDIR
|
|
||||||
|
|
||||||
git clone $REPO
|
|
||||||
pushd selinux; git checkout $BRANCH; COMMIT=`git rev-parse --verify HEAD`; popd
|
|
||||||
|
|
||||||
# prepare libselinux-rhat.patch
|
|
||||||
tar xfz ../libselinux-$LIBSELINUX_VERSION.tar.gz
|
|
||||||
pushd libselinux-$LIBSELINUX_VERSION
|
|
||||||
|
|
||||||
git init; git add .; git commit -m "init"
|
|
||||||
cp -r ../selinux/libselinux/* .
|
|
||||||
git add -A .
|
|
||||||
|
|
||||||
git diff --cached --src-prefix=libselinux-$LIBSELINUX_VERSION/ --dst-prefix=libselinux-$LIBSELINUX_VERSION/ > ../../libselinux-rhat.patch
|
|
||||||
|
|
||||||
popd
|
|
||||||
|
|
||||||
popd
|
|
||||||
# echo rm -rf $REBASEDIR
|
|
||||||
|
|
||||||
echo libselinux-rhat.patch created from $REPO/commit/$COMMIT
|
|
Loading…
Reference in New Issue
Block a user