libselinux-2.5-8
There was a change in swig-3.10 to use importlib instead of imp. While the implementation with imp looked for _selinux.so also in the directory where __init__.py was, importlib search only standard paths. It means that we need to move _selinux.so from $(PYLIBDIR)/site-packages/selinux/ to $(PYLIBDIR)/site-packages/ Fixes: >>> import selinux Traceback (most recent call last): File "/usr/lib64/python3.5/site-packages/selinux/__init__.py", line 18, in swig_import_helper return importlib.import_module(mname) File "/usr/lib64/python3.5/importlib/__init__.py", line 126, in import_module return _bootstrap._gcd_import(name[level:], package, level) File "<frozen importlib._bootstrap>", line 986, in _gcd_import File "<frozen importlib._bootstrap>", line 969, in _find_and_load File "<frozen importlib._bootstrap>", line 956, in _find_and_load_unlocked ImportError: No module named '_selinux' During handling of the above exception, another exception occurred: Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/lib64/python3.5/site-packages/selinux/__init__.py", line 21, in <module> _selinux = swig_import_helper() File "/usr/lib64/python3.5/site-packages/selinux/__init__.py", line 20, in swig_import_helper return importlib.import_module('_selinux') File "/usr/lib64/python3.5/importlib/__init__.py", line 126, in import_module return _bootstrap._gcd_import(name[level:], package, level) ImportError: No module named '_selinux'
This commit is contained in:
parent
fd9d18361d
commit
b95f8bdd48
30
0001-libselinux-Change-the-location-of-_selinux.so.patch
Normal file
30
0001-libselinux-Change-the-location-of-_selinux.so.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From d04204820e04f19c6603ad2b0a45a382bc4546c7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Petr Lautrbach <plautrba@redhat.com>
|
||||||
|
Date: Fri, 24 Jun 2016 14:29:08 +0200
|
||||||
|
Subject: [PATCH] libselinux: Change the location of _selinux.so
|
||||||
|
|
||||||
|
There was a change in swig-3.10 to use importlib instead of imp. While
|
||||||
|
the implementation with imp looked for _selinux.so in the directory
|
||||||
|
where is __init__.py, importlib search standard paths. It means that we
|
||||||
|
need to move _selinux.so from $(PYLIBDIR)/site-packages/selinux/ to
|
||||||
|
$(PYLIBDIR)/site-packages/.
|
||||||
|
---
|
||||||
|
src/Makefile | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/Makefile b/src/Makefile
|
||||||
|
index d94163e..37d01af 100644
|
||||||
|
--- a/src/Makefile
|
||||||
|
+++ b/src/Makefile
|
||||||
|
@@ -156,7 +156,7 @@ install: all
|
||||||
|
|
||||||
|
install-pywrap: pywrap
|
||||||
|
test -d $(PYLIBDIR)/site-packages/selinux || install -m 755 -d $(PYLIBDIR)/site-packages/selinux
|
||||||
|
- install -m 755 $(SWIGSO) $(PYLIBDIR)/site-packages/selinux/_selinux.so
|
||||||
|
+ install -m 755 $(SWIGSO) $(PYLIBDIR)/site-packages/_selinux.so
|
||||||
|
install -m 755 $(AUDIT2WHYSO) $(PYLIBDIR)/site-packages/selinux/audit2why.so
|
||||||
|
install -m 644 $(SWIGPYOUT) $(PYLIBDIR)/site-packages/selinux/__init__.py
|
||||||
|
|
||||||
|
--
|
||||||
|
2.7.4
|
||||||
|
|
@ -9,7 +9,7 @@
|
|||||||
Summary: SELinux library and simple utilities
|
Summary: SELinux library and simple utilities
|
||||||
Name: libselinux
|
Name: libselinux
|
||||||
Version: 2.5
|
Version: 2.5
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
License: Public Domain
|
License: Public Domain
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
# https://github.com/SELinuxProject/selinux/wiki/Releases
|
# https://github.com/SELinuxProject/selinux/wiki/Releases
|
||||||
@ -22,6 +22,7 @@ Url: https://github.com/SELinuxProject/selinux/wiki
|
|||||||
# $ VERSION=2.5 ./make-fedora-selinux-patch.sh libselinux
|
# $ VERSION=2.5 ./make-fedora-selinux-patch.sh libselinux
|
||||||
# HEAD https://github.com/fedora-selinux/selinux/commit/9abe77e2a670f2f2dfb91f9cec46ee37f9c23995
|
# HEAD https://github.com/fedora-selinux/selinux/commit/9abe77e2a670f2f2dfb91f9cec46ee37f9c23995
|
||||||
Patch1: libselinux-fedora.patch
|
Patch1: libselinux-fedora.patch
|
||||||
|
Patch2: 0001-libselinux-Change-the-location-of-_selinux.so.patch
|
||||||
BuildRequires: pkgconfig python python-devel ruby-devel ruby libsepol-static >= %{libsepolver} swig pcre-devel xz-devel
|
BuildRequires: pkgconfig python python-devel ruby-devel ruby libsepol-static >= %{libsepolver} swig pcre-devel xz-devel
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
BuildRequires: python3 python3-devel
|
BuildRequires: python3 python3-devel
|
||||||
@ -237,6 +238,7 @@ rm -rf %{buildroot}
|
|||||||
%files python
|
%files python
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%dir %{python_sitearch}/selinux
|
%dir %{python_sitearch}/selinux
|
||||||
|
%{python_sitearch}/_selinux.so
|
||||||
%{python_sitearch}/selinux/*
|
%{python_sitearch}/selinux/*
|
||||||
|
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
@ -245,6 +247,7 @@ rm -rf %{buildroot}
|
|||||||
%dir %{python3_sitearch}/selinux
|
%dir %{python3_sitearch}/selinux
|
||||||
%dir %{python3_sitearch}/selinux/__pycache__
|
%dir %{python3_sitearch}/selinux/__pycache__
|
||||||
%{python3_sitearch}/selinux/*.py*
|
%{python3_sitearch}/selinux/*.py*
|
||||||
|
%{python3_sitearch}/_selinux.so
|
||||||
%{python3_sitearch}/selinux/*.so
|
%{python3_sitearch}/selinux/*.so
|
||||||
%{python3_sitearch}/selinux/__pycache__/*
|
%{python3_sitearch}/selinux/__pycache__/*
|
||||||
%endif with_python3
|
%endif with_python3
|
||||||
@ -254,6 +257,9 @@ rm -rf %{buildroot}
|
|||||||
%{ruby_vendorarchdir}/selinux.so
|
%{ruby_vendorarchdir}/selinux.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 24 2016 Petr Lautrbach <plautrba@redhat.com> - 2.5-8
|
||||||
|
- Move _selinux.so to /usr/lib64/python*/site-packages
|
||||||
|
|
||||||
* Thu Jun 23 2016 Petr Lautrbach <plautrba@redhat.com> - 2.5-7
|
* Thu Jun 23 2016 Petr Lautrbach <plautrba@redhat.com> - 2.5-7
|
||||||
- Modify audit2why analyze function to use loaded policy
|
- Modify audit2why analyze function to use loaded policy
|
||||||
- Sort object files for deterministic linking order
|
- Sort object files for deterministic linking order
|
||||||
|
Loading…
Reference in New Issue
Block a user