*** empty log message ***
This commit is contained in:
parent
0102138c4a
commit
ae054c560b
@ -11,6 +11,22 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/src/avc_internal.c libselinux
|
|||||||
if (!blocking && fcntl(fd, F_SETFL, O_NONBLOCK)) {
|
if (!blocking && fcntl(fd, F_SETFL, O_NONBLOCK)) {
|
||||||
close(fd);
|
close(fd);
|
||||||
rc = -1;
|
rc = -1;
|
||||||
|
diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-2.0.34/src/Makefile
|
||||||
|
--- nsalibselinux/src/Makefile 2007-08-03 16:02:56.000000000 -0400
|
||||||
|
+++ libselinux-2.0.34/src/Makefile 2007-09-24 11:51:42.000000000 -0400
|
||||||
|
@@ -57,10 +57,10 @@
|
||||||
|
$(CC) $(CFLAGS) -I$(PYINC) -fPIC -DSHARED -c -o $@ $<
|
||||||
|
|
||||||
|
$(SWIGSO): $(SWIGLOBJ)
|
||||||
|
- $(CC) $(LDFLAGS) -shared -o $@ $< -L. -lselinux -L$(LIBDIR) -Wl,-soname,$@
|
||||||
|
+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $< -L. -lselinux -L$(LIBDIR) -Wl,-soname,$@
|
||||||
|
|
||||||
|
$(LIBSO): $(LOBJS)
|
||||||
|
- $(CC) $(LDFLAGS) -shared -o $@ $^ -ldl -L$(LIBDIR) -Wl,-soname,$(LIBSO),-z,defs,-z,relro
|
||||||
|
+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -ldl -L$(LIBDIR) -Wl,-soname,$(LIBSO),-z,defs,-z,relro
|
||||||
|
ln -sf $@ $(TARGET)
|
||||||
|
|
||||||
|
%.o: %.c policy.h
|
||||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/matchpathcon.c libselinux-2.0.34/src/matchpathcon.c
|
diff --exclude-from=exclude -N -u -r nsalibselinux/src/matchpathcon.c libselinux-2.0.34/src/matchpathcon.c
|
||||||
--- nsalibselinux/src/matchpathcon.c 2007-09-18 16:27:25.000000000 -0400
|
--- nsalibselinux/src/matchpathcon.c 2007-09-18 16:27:25.000000000 -0400
|
||||||
+++ libselinux-2.0.34/src/matchpathcon.c 2007-09-18 16:32:31.000000000 -0400
|
+++ libselinux-2.0.34/src/matchpathcon.c 2007-09-18 16:32:31.000000000 -0400
|
||||||
|
@ -2,7 +2,7 @@
|
|||||||
Summary: SELinux library and simple utilities
|
Summary: SELinux library and simple utilities
|
||||||
Name: libselinux
|
Name: libselinux
|
||||||
Version: 2.0.34
|
Version: 2.0.34
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: Public domain (uncopyrighted)
|
License: Public domain (uncopyrighted)
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz
|
Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz
|
||||||
@ -124,6 +124,9 @@ exit 0
|
|||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
|
||||||
|
* Mon Sep 24 2007 Dan Walsh <dwalsh@redhat.com> - 2.0.34-3
|
||||||
|
- Add sparc patch to from Dennis Gilmore to build on Sparc platform
|
||||||
|
|
||||||
* Mon Sep 24 2007 Dan Walsh <dwalsh@redhat.com> - 2.0.34-2
|
* Mon Sep 24 2007 Dan Walsh <dwalsh@redhat.com> - 2.0.34-2
|
||||||
- Remove leaked file descriptor
|
- Remove leaked file descriptor
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user