- Update to upstream
Fix from Eric Paris to fix leak on non-selinux systems. regenerate swig wrappers pkgconfig fix to respect LIBDIR from Dan Walsh.
This commit is contained in:
parent
68c8d967fd
commit
982ffdc3f5
@ -175,3 +175,4 @@ libselinux-2.0.88.tgz
|
||||
libselinux-2.0.89.tgz
|
||||
libselinux-2.0.90.tgz
|
||||
libselinux-2.0.91.tgz
|
||||
libselinux-2.0.92.tgz
|
||||
|
@ -1,6 +1,23 @@
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/man/man8/selinuxconlist.8 libselinux-2.0.90/man/man8/selinuxconlist.8
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/man/man3/is_selinux_enabled.3 libselinux-2.0.92/man/man3/is_selinux_enabled.3
|
||||
--- nsalibselinux/man/man3/is_selinux_enabled.3 2009-03-06 14:41:45.000000000 -0500
|
||||
+++ libselinux-2.0.92/man/man3/is_selinux_enabled.3 2010-03-07 07:40:57.000000000 -0500
|
||||
@@ -1,4 +1,4 @@
|
||||
-.TH "is_selinux_enabled" "3" "1 January 2004" "russell@coker.com.au" "SELinux API documentation"
|
||||
+.TH "is_selinux_enabled" "3" "7 Mar 2010" "russell@coker.com.au" "SELinux API documentation"
|
||||
.SH "NAME"
|
||||
is_selinux_enabled \- check whether SELinux is enabled
|
||||
|
||||
@@ -14,6 +14,7 @@
|
||||
.SH "DESCRIPTION"
|
||||
.B is_selinux_enabled
|
||||
returns 1 if SELinux is running or 0 if it is not.
|
||||
+On error, \-1 is returned.
|
||||
|
||||
.B is_selinux_mls_enabled
|
||||
returns 1 if SELinux is running in MLS mode or 0 if it is not.
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/man/man8/selinuxconlist.8 libselinux-2.0.92/man/man8/selinuxconlist.8
|
||||
--- nsalibselinux/man/man8/selinuxconlist.8 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ libselinux-2.0.90/man/man8/selinuxconlist.8 2010-01-18 16:52:28.000000000 -0500
|
||||
+++ libselinux-2.0.92/man/man8/selinuxconlist.8 2010-03-07 07:38:19.000000000 -0500
|
||||
@@ -0,0 +1,18 @@
|
||||
+.TH "selinuxconlist" "1" "7 May 2008" "dwalsh@redhat.com" "SELinux Command Line documentation"
|
||||
+.SH "NAME"
|
||||
@ -20,9 +37,9 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/man/man8/selinuxconlist.8 lib
|
||||
+
|
||||
+.SH "SEE ALSO"
|
||||
+secon(8), selinuxdefcon(8)
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/man/man8/selinuxdefcon.8 libselinux-2.0.90/man/man8/selinuxdefcon.8
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/man/man8/selinuxdefcon.8 libselinux-2.0.92/man/man8/selinuxdefcon.8
|
||||
--- nsalibselinux/man/man8/selinuxdefcon.8 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ libselinux-2.0.90/man/man8/selinuxdefcon.8 2010-01-18 16:52:28.000000000 -0500
|
||||
+++ libselinux-2.0.92/man/man8/selinuxdefcon.8 2010-03-07 07:38:19.000000000 -0500
|
||||
@@ -0,0 +1,24 @@
|
||||
+.TH "selinuxdefcon" "1" "7 May 2008" "dwalsh@redhat.com" "SELinux Command Line documentation"
|
||||
+.SH "NAME"
|
||||
@ -48,9 +65,9 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/man/man8/selinuxdefcon.8 libs
|
||||
+
|
||||
+.SH "SEE ALSO"
|
||||
+secon(8), selinuxconlist(8)
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/callbacks.c libselinux-2.0.90/src/callbacks.c
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/callbacks.c libselinux-2.0.92/src/callbacks.c
|
||||
--- nsalibselinux/src/callbacks.c 2009-04-08 09:06:23.000000000 -0400
|
||||
+++ libselinux-2.0.90/src/callbacks.c 2010-01-18 16:52:28.000000000 -0500
|
||||
+++ libselinux-2.0.92/src/callbacks.c 2010-03-07 07:38:19.000000000 -0500
|
||||
@@ -16,6 +16,7 @@
|
||||
{
|
||||
int rc;
|
||||
@ -59,84 +76,9 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/src/callbacks.c libselinux-2.
|
||||
va_start(ap, fmt);
|
||||
rc = vfprintf(stderr, fmt, ap);
|
||||
va_end(ap);
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/init.c libselinux-2.0.90/src/init.c
|
||||
--- nsalibselinux/src/init.c 2009-07-14 11:16:03.000000000 -0400
|
||||
+++ libselinux-2.0.90/src/init.c 2010-02-22 11:04:16.000000000 -0500
|
||||
@@ -23,7 +23,7 @@
|
||||
static void init_selinuxmnt(void)
|
||||
{
|
||||
char *buf=NULL, *p;
|
||||
- FILE *fp;
|
||||
+ FILE *fp=NULL;
|
||||
struct statfs sfbuf;
|
||||
int rc;
|
||||
size_t len;
|
||||
@@ -57,16 +57,17 @@
|
||||
break;
|
||||
}
|
||||
}
|
||||
- fclose(fp);
|
||||
|
||||
- if (!exists)
|
||||
- return;
|
||||
+ if (!exists)
|
||||
+ goto out;
|
||||
+
|
||||
+ fclose(fp);
|
||||
|
||||
/* At this point, the usual spot doesn't have an selinuxfs so
|
||||
* we look around for it */
|
||||
fp = fopen("/proc/mounts", "r");
|
||||
if (!fp)
|
||||
- return;
|
||||
+ goto out;
|
||||
|
||||
__fsetlocking(fp, FSETLOCKING_BYCALLER);
|
||||
while ((num = getline(&buf, &len, fp)) != -1) {
|
||||
@@ -90,7 +91,8 @@
|
||||
|
||||
out:
|
||||
free(buf);
|
||||
- fclose(fp);
|
||||
+ if (fp)
|
||||
+ fclose(fp);
|
||||
return;
|
||||
}
|
||||
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/libselinux.pc.in libselinux-2.0.90/src/libselinux.pc.in
|
||||
--- nsalibselinux/src/libselinux.pc.in 2009-11-02 12:58:30.000000000 -0500
|
||||
+++ libselinux-2.0.90/src/libselinux.pc.in 2010-02-18 10:02:46.000000000 -0500
|
||||
@@ -1,6 +1,6 @@
|
||||
prefix=@prefix@
|
||||
exec_prefix=${prefix}
|
||||
-libdir=${exec_prefix}/lib
|
||||
+libdir=${exec_prefix}/@libdir@
|
||||
includedir=@includedir@
|
||||
|
||||
Name: libselinux
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-2.0.90/src/Makefile
|
||||
--- nsalibselinux/src/Makefile 2009-12-01 15:46:50.000000000 -0500
|
||||
+++ libselinux-2.0.90/src/Makefile 2010-02-18 10:20:27.000000000 -0500
|
||||
@@ -11,6 +11,7 @@
|
||||
RUBYPLATFORM ?= $(shell ruby -e 'print RUBY_PLATFORM')
|
||||
RUBYINC ?= $(LIBDIR)/ruby/$(RUBYLIBVER)/$(RUBYPLATFORM)
|
||||
RUBYINSTALL ?= $(LIBDIR)/ruby/site_ruby/$(RUBYLIBVER)/$(RUBYPLATFORM)
|
||||
+LIBBASE=$(shell basename $(LIBDIR))
|
||||
|
||||
VERSION = $(shell cat ../VERSION)
|
||||
LIBVERSION = 1
|
||||
@@ -85,7 +86,7 @@
|
||||
ln -sf $@ $(TARGET)
|
||||
|
||||
$(LIBPC): $(LIBPC).in
|
||||
- sed -e 's/@VERSION@/$(VERSION)/; s:@prefix@:$(PREFIX):; s:@libdir@:$(LIBDIR):; s:@includedir@:$(INCLUDEDIR):' < $< > $@
|
||||
+ sed -e 's/@VERSION@/$(VERSION)/; s:@prefix@:$(PREFIX):; s:@libdir@:$(LIBBASE):; s:@includedir@:$(INCLUDEDIR):' < $< > $@
|
||||
|
||||
selinuxswig_python_exception.i: ../include/selinux/selinux.h
|
||||
bash exception.sh > $@
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/matchpathcon.c libselinux-2.0.90/src/matchpathcon.c
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/matchpathcon.c libselinux-2.0.92/src/matchpathcon.c
|
||||
--- nsalibselinux/src/matchpathcon.c 2009-03-06 14:41:45.000000000 -0500
|
||||
+++ libselinux-2.0.90/src/matchpathcon.c 2010-01-18 16:52:28.000000000 -0500
|
||||
+++ libselinux-2.0.92/src/matchpathcon.c 2010-03-07 07:38:19.000000000 -0500
|
||||
@@ -2,6 +2,7 @@
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
|
@ -4,7 +4,7 @@
|
||||
|
||||
Summary: SELinux library and simple utilities
|
||||
Name: libselinux
|
||||
Version: 2.0.91
|
||||
Version: 2.0.92
|
||||
Release: 1%{?dist}
|
||||
License: Public Domain
|
||||
Group: System Environment/Libraries
|
||||
@ -166,6 +166,12 @@ exit 0
|
||||
%{ruby_sitearch}/selinux.so
|
||||
|
||||
%changelog
|
||||
* Sun Mar 7 2010 Dan Walsh <dwalsh@redhat.com> - 2.0.92-1
|
||||
- Update to upstream
|
||||
* Fix from Eric Paris to fix leak on non-selinux systems.
|
||||
* regenerate swig wrappers
|
||||
* pkgconfig fix to respect LIBDIR from Dan Walsh.
|
||||
|
||||
* Wed Feb 24 2010 Dan Walsh <dwalsh@redhat.com> - 2.0.91-1
|
||||
- Update to upstream
|
||||
* Change the AVC to only audit the permissions specified by the
|
||||
|
Loading…
Reference in New Issue
Block a user