- Fix __init__.py specification
This commit is contained in:
parent
831e63b413
commit
88cc8f8805
@ -12,8 +12,8 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/include/selinux/av_permission
|
||||
#define KEY__WRITE 0x00000004UL
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/audit2why.c libselinux-2.0.46/src/audit2why.c
|
||||
--- nsalibselinux/src/audit2why.c 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ libselinux-2.0.46/src/audit2why.c 2008-01-10 13:31:17.000000000 -0500
|
||||
@@ -0,0 +1,462 @@
|
||||
+++ libselinux-2.0.46/src/audit2why.c 2008-01-10 15:45:51.000000000 -0500
|
||||
@@ -0,0 +1,463 @@
|
||||
+#include <unistd.h>
|
||||
+#include <stdlib.h>
|
||||
+#include <ctype.h>
|
||||
@ -346,6 +346,7 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/src/audit2why.c libselinux-2.
|
||||
+ int i=0;
|
||||
+ PyObject *result = PyList_New(2);
|
||||
+ if (!result) return NULL;
|
||||
+ Py_INCREF(result);
|
||||
+ Py_INCREF(Py_None);
|
||||
+ PyList_SetItem(result, 1, Py_None);
|
||||
+
|
||||
@ -478,7 +479,7 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/src/audit2why.c libselinux-2.
|
||||
+}
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-2.0.46/src/Makefile
|
||||
--- nsalibselinux/src/Makefile 2007-09-26 19:37:45.000000000 -0400
|
||||
+++ libselinux-2.0.46/src/Makefile 2008-01-10 13:25:57.000000000 -0500
|
||||
+++ libselinux-2.0.46/src/Makefile 2008-01-11 08:43:39.000000000 -0500
|
||||
@@ -18,6 +18,7 @@
|
||||
SWIGSO=_selinux.so
|
||||
SWIGFILES=$(SWIGSO) selinux.py
|
||||
@ -533,7 +534,7 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-2.0.4
|
||||
+ test -d $(PYTHONLIBDIR)/site-packages || install -m 755 -d $(PYTHONLIBDIR)/site-packages/selinux
|
||||
+ install -m 755 $(SWIGSO) $(PYTHONLIBDIR)/site-packages/selinux
|
||||
+ install -m 755 $(AUDIT2WHYSO) $(PYTHONLIBDIR)/site-packages/selinux
|
||||
+ install -m 644 selinux.py $(PYTHONLIBDIR)/site-packages/selinux/__init_.py
|
||||
+ install -m 644 selinux.py $(PYTHONLIBDIR)/site-packages/selinux/__init__.py
|
||||
|
||||
relabel:
|
||||
/sbin/restorecon $(SHLIBDIR)/$(LIBSO)
|
||||
|
@ -2,7 +2,7 @@
|
||||
Summary: SELinux library and simple utilities
|
||||
Name: libselinux
|
||||
Version: 2.0.46
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
License: Public Domain
|
||||
Group: System Environment/Libraries
|
||||
Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz
|
||||
@ -122,6 +122,9 @@ exit 0
|
||||
%{_libdir}/python*/site-packages/selinux/*
|
||||
|
||||
%changelog
|
||||
* Fri Jan 11 2008 Dan Walsh <dwalsh@redhat.com> - 2.0.46-6
|
||||
- Fix __init__.py specification
|
||||
|
||||
* Tue Jan 8 2008 Dan Walsh <dwalsh@redhat.com> - 2.0.46-5
|
||||
- Add audit2why python bindings
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user