- Change getsebool to return on/off instead of active/inactive

This commit is contained in:
Daniel J Walsh 2005-11-29 19:21:03 +00:00
parent 116a5b0c09
commit 56d326bb01
2 changed files with 33 additions and 26 deletions

View File

@ -1,26 +1,30 @@
diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-1.27.22/src/Makefile
--- nsalibselinux/src/Makefile 2005-11-28 21:47:32.000000000 -0500
+++ libselinux-1.27.22/src/Makefile 2005-11-28 16:57:58.000000000 -0500
@@ -3,10 +3,10 @@
LIBDIR ?= $(PREFIX)/lib
SHLIBDIR ?= $(DESTDIR)/lib
INCLUDEDIR ?= $(PREFIX)/include
-PYINC ?= /usr/include/python2.4
-PYLIB ?= /usr/lib/python2.4
PYLIBVER ?= python2.4
-PYTHONLIBDIR ?= $(LIBDIR)/python2.4
+PYINC ?= /usr/include/$(PYLIBVER)
+PYLIB ?= /usr/lib/$(PYLIBVER)
+PYTHONLIBDIR ?= $(LIBDIR)/$(PYLIBVER)
diff --exclude-from=exclude -N -u -r nsalibselinux/man/man8/getsebool.8 libselinux-1.27.25/man/man8/getsebool.8
--- nsalibselinux/man/man8/getsebool.8 2005-11-16 21:39:52.000000000 -0500
+++ libselinux-1.27.25/man/man8/getsebool.8 2005-11-29 14:19:22.000000000 -0500
@@ -9,7 +9,7 @@
.SH "DESCRIPTION"
.B getsebool
reports where a particular SELinux boolean or
-all SELinux booleans are active or inactive.
+all SELinux booleans are on or off
In certain situations a boolean can be in one state with a pending
change to the other state. getsebool will report this as a pending change.
The pending value indicates
diff --exclude-from=exclude -N -u -r nsalibselinux/utils/getsebool.c libselinux-1.27.25/utils/getsebool.c
--- nsalibselinux/utils/getsebool.c 2004-11-30 15:56:56.000000000 -0500
+++ libselinux-1.27.25/utils/getsebool.c 2005-11-29 14:09:58.000000000 -0500
@@ -85,11 +85,11 @@
}
if (pending != active) {
printf("%s --> %s pending: %s\n", names[i],
- ( active ? "active" : "inactive"),
- ( pending ? "active" : "inactive"));
+ ( active ? "on" : "off"),
+ ( pending ? "on" : "off"));
} else {
printf("%s --> %s\n", names[i],
- ( active ? "active" : "inactive"));
+ ( active ? "on" : "off"));
}
}
LIBVERSION = 1
@@ -36,7 +36,7 @@
$(CC) $(CFLAGS) -I$(PYINC) -fpic -DSHARED -c -o $@ $<
$(SWIGSO): $(SWIGLOBJ)
- $(CC) $(LDFLAGS) -shared -o $@ $< -L. -lselinux -l$(PYLIBVER) -L$(LIBDIR) -Wl,-soname,$@,-z,defs
+ $(CC) $(LDFLAGS) -shared -o $@ $< -L. -lselinux -L$(LIBDIR) -Wl,-soname,$@
$(LIBSO): $(LOBJS)
$(CC) $(LDFLAGS) -shared -o $@ $^ -ldl -lsepol -L$(LIBDIR) -Wl,-soname,$(LIBSO),-z,defs

View File

@ -2,7 +2,7 @@
Summary: SELinux library and simple utilities
Name: libselinux
Version: 1.27.25
Release: 1
Release: 2
License: Public domain (uncopyrighted)
Group: System Environment/Libraries
Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz
@ -104,6 +104,9 @@ exit 0
%{_libdir}/python2.4/site-packages/selinux.py*
%changelog
* Tue Nov 29 2005 Dan Walsh <dwalsh@redhat.com> 1.27.25-2
- Change getsebool to return on/off instead of active/inactive
* Tue Nov 29 2005 Dan Walsh <dwalsh@redhat.com> 1.27.25-1
- Update to latest from NSA
* Added -f file_contexts option to matchpathcon util.