- Update to upstream
This commit is contained in:
parent
e672e99f9d
commit
49eae3b63b
@ -160,3 +160,4 @@ libselinux-2.0.73.tgz
|
|||||||
libselinux-2.0.74.tgz
|
libselinux-2.0.74.tgz
|
||||||
libselinux-2.0.75.tgz
|
libselinux-2.0.75.tgz
|
||||||
libselinux-2.0.76.tgz
|
libselinux-2.0.76.tgz
|
||||||
|
libselinux-2.0.77.tgz
|
||||||
|
@ -3078,6 +3078,47 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/utils/getdefaultcon.c libseli
|
|||||||
- return 0;
|
- return 0;
|
||||||
+ return ret >= 0;
|
+ return ret >= 0;
|
||||||
}
|
}
|
||||||
|
diff --exclude-from=exclude -N -u -r nsalibselinux/utils/Makefile libselinux-2.0.76/utils/Makefile
|
||||||
|
--- nsalibselinux/utils/Makefile 2008-08-28 09:34:24.000000000 -0400
|
||||||
|
+++ libselinux-2.0.76/utils/Makefile 2008-12-19 15:55:54.000000000 -0500
|
||||||
|
@@ -2,28 +2,33 @@
|
||||||
|
PREFIX ?= $(DESTDIR)/usr
|
||||||
|
LIBDIR ?= $(PREFIX)/lib
|
||||||
|
BINDIR ?= $(PREFIX)/sbin
|
||||||
|
+_BINDIR ?= $(DESTDIR)/sbin
|
||||||
|
|
||||||
|
CFLAGS ?= -Wall
|
||||||
|
override CFLAGS += -I../include -D_GNU_SOURCE $(EMFLAGS)
|
||||||
|
LDLIBS += -L../src -lselinux -L$(LIBDIR)
|
||||||
|
|
||||||
|
TARGETS=$(patsubst %.c,%,$(wildcard *.c))
|
||||||
|
+
|
||||||
|
+
|
||||||
|
ifeq ($(DISABLE_AVC),y)
|
||||||
|
UNUSED_TARGETS+=compute_av compute_create compute_member compute_relabel
|
||||||
|
endif
|
||||||
|
ifeq ($(DISABLE_BOOL),y)
|
||||||
|
UNUSED_TARGETS+=getsebool togglesebool
|
||||||
|
endif
|
||||||
|
-TARGETS:= $(filter-out $(UNUSED_TARGETS), $(TARGETS))
|
||||||
|
+TARGETS:= $(filter-out $(UNUSED_TARGETS) matchpathcon, $(TARGETS))
|
||||||
|
|
||||||
|
-all: $(TARGETS)
|
||||||
|
+all: $(TARGETS) matchpathcon
|
||||||
|
|
||||||
|
install: all
|
||||||
|
-mkdir -p $(BINDIR)
|
||||||
|
install -m 755 $(TARGETS) $(BINDIR)
|
||||||
|
-
|
||||||
|
+ -mkdir -p $(_BINDIR)
|
||||||
|
+ install -m 755 matchpathcon $(_BINDIR)
|
||||||
|
+ (cd $(BINDIR); ln -fs ../../sbin/matchpathcon)
|
||||||
|
clean:
|
||||||
|
- rm -f $(TARGETS) *.o
|
||||||
|
+ rm -f $(TARGETS) *.o *~
|
||||||
|
|
||||||
|
indent:
|
||||||
|
../../scripts/Lindent $(wildcard *.[ch])
|
||||||
diff --exclude-from=exclude -N -u -r nsalibselinux/utils/matchpathcon.c libselinux-2.0.76/utils/matchpathcon.c
|
diff --exclude-from=exclude -N -u -r nsalibselinux/utils/matchpathcon.c libselinux-2.0.76/utils/matchpathcon.c
|
||||||
--- nsalibselinux/utils/matchpathcon.c 2008-10-28 10:06:51.000000000 -0400
|
--- nsalibselinux/utils/matchpathcon.c 2008-10-28 10:06:51.000000000 -0400
|
||||||
+++ libselinux-2.0.76/utils/matchpathcon.c 2008-12-19 15:14:20.000000000 -0500
|
+++ libselinux-2.0.76/utils/matchpathcon.c 2008-12-19 15:14:20.000000000 -0500
|
||||||
|
@ -4,8 +4,8 @@
|
|||||||
|
|
||||||
Summary: SELinux library and simple utilities
|
Summary: SELinux library and simple utilities
|
||||||
Name: libselinux
|
Name: libselinux
|
||||||
Version: 2.0.76
|
Version: 2.0.77
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Public Domain
|
License: Public Domain
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz
|
Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz
|
||||||
@ -127,6 +127,7 @@ exit 0
|
|||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
/%{_lib}/libselinux.so.*
|
/%{_lib}/libselinux.so.*
|
||||||
/var/run/setrans
|
/var/run/setrans
|
||||||
|
/sbin/matchpathcon
|
||||||
|
|
||||||
%files utils
|
%files utils
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -163,10 +164,13 @@ exit 0
|
|||||||
%{ruby_sitearch}/selinux.so
|
%{ruby_sitearch}/selinux.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 6 2009 Dan Walsh <dwalsh@redhat.com> - 2.0.77-1
|
||||||
|
- Update to upstream
|
||||||
|
|
||||||
* Tue Dec 16 2008 Dan Walsh <dwalsh@redhat.com> - 2.0.76-6
|
* Tue Dec 16 2008 Dan Walsh <dwalsh@redhat.com> - 2.0.76-6
|
||||||
- Strip trailing / for matchpathcon
|
- Strip trailing / for matchpathcon
|
||||||
|
|
||||||
* Tue Dec 16 2008 Dan Walsh <dwalsh@redhat.com> - 2.0.76-5
|
* Tue Dec 16 2008 Dan Walsh <dwalsh@redhat.com>l - 2.0.76-5
|
||||||
- Fix segfault if seusers file does not work
|
- Fix segfault if seusers file does not work
|
||||||
|
|
||||||
* Fri Dec 12 2008 Dan Walsh <dwalsh@redhat.com> - 2.0.76-4
|
* Fri Dec 12 2008 Dan Walsh <dwalsh@redhat.com> - 2.0.76-4
|
||||||
|
Loading…
Reference in New Issue
Block a user