- Put back libselinux.a
This commit is contained in:
parent
5c1daf361c
commit
45460445ad
@ -1,6 +1,6 @@
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/include/selinux/av_permissions.h libselinux-2.0.46/include/selinux/av_permissions.h
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/include/selinux/av_permissions.h libselinux-2.0.47/include/selinux/av_permissions.h
|
||||
--- nsalibselinux/include/selinux/av_permissions.h 2007-11-15 15:52:46.000000000 -0500
|
||||
+++ libselinux-2.0.46/include/selinux/av_permissions.h 2008-01-11 10:51:06.000000000 -0500
|
||||
+++ libselinux-2.0.47/include/selinux/av_permissions.h 2008-01-11 10:55:14.000000000 -0500
|
||||
@@ -900,6 +900,8 @@
|
||||
#define PACKET__SEND 0x00000001UL
|
||||
#define PACKET__RECV 0x00000002UL
|
||||
@ -10,9 +10,9 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/include/selinux/av_permission
|
||||
#define KEY__VIEW 0x00000001UL
|
||||
#define KEY__READ 0x00000002UL
|
||||
#define KEY__WRITE 0x00000004UL
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/audit2why.c libselinux-2.0.46/src/audit2why.c
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/audit2why.c libselinux-2.0.47/src/audit2why.c
|
||||
--- nsalibselinux/src/audit2why.c 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ libselinux-2.0.46/src/audit2why.c 2008-01-11 10:51:10.000000000 -0500
|
||||
+++ libselinux-2.0.47/src/audit2why.c 2008-01-11 10:55:14.000000000 -0500
|
||||
@@ -0,0 +1,460 @@
|
||||
+#include <unistd.h>
|
||||
+#include <stdlib.h>
|
||||
@ -474,9 +474,9 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/src/audit2why.c libselinux-2.
|
||||
+ PyModule_AddIntConstant(m,"CONSTRAINT", CONSTRAINT);
|
||||
+ PyModule_AddIntConstant(m,"RBAC", RBAC);
|
||||
+}
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-2.0.46/src/Makefile
|
||||
--- nsalibselinux/src/Makefile 2007-09-26 19:37:45.000000000 -0400
|
||||
+++ libselinux-2.0.46/src/Makefile 2008-01-11 10:51:06.000000000 -0500
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-2.0.47/src/Makefile
|
||||
--- nsalibselinux/src/Makefile 2008-01-11 10:52:37.000000000 -0500
|
||||
+++ libselinux-2.0.47/src/Makefile 2008-01-15 08:46:34.000000000 -0500
|
||||
@@ -18,6 +18,7 @@
|
||||
SWIGSO=_selinux.so
|
||||
SWIGFILES=$(SWIGSO) selinux.py
|
||||
@ -516,13 +516,7 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-2.0.4
|
||||
%.o: %.c policy.h
|
||||
$(CC) $(CFLAGS) $(TLSFLAGS) -c -o $@ $<
|
||||
|
||||
@@ -77,20 +84,21 @@
|
||||
|
||||
install: all
|
||||
test -d $(LIBDIR) || install -m 755 -d $(LIBDIR)
|
||||
- install -m 644 $(LIBA) $(LIBDIR)
|
||||
test -d $(SHLIBDIR) || install -m 755 -d $(SHLIBDIR)
|
||||
install -m 755 $(LIBSO) $(SHLIBDIR)
|
||||
@@ -83,14 +90,16 @@
|
||||
cd $(LIBDIR) && ln -sf ../../`basename $(SHLIBDIR)`/$(LIBSO) $(TARGET)
|
||||
|
||||
install-pywrap: pywrap
|
||||
@ -542,9 +536,9 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-2.0.4
|
||||
|
||||
distclean: clean
|
||||
rm -f $(SWIGCOUT) $(SWIGFILES)
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/matchpathcon.c libselinux-2.0.46/src/matchpathcon.c
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/matchpathcon.c libselinux-2.0.47/src/matchpathcon.c
|
||||
--- nsalibselinux/src/matchpathcon.c 2007-09-28 09:48:58.000000000 -0400
|
||||
+++ libselinux-2.0.46/src/matchpathcon.c 2008-01-11 10:51:06.000000000 -0500
|
||||
+++ libselinux-2.0.47/src/matchpathcon.c 2008-01-11 10:55:14.000000000 -0500
|
||||
@@ -2,6 +2,7 @@
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
@ -562,9 +556,9 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/src/matchpathcon.c libselinux
|
||||
va_end(ap);
|
||||
}
|
||||
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/selinux.py libselinux-2.0.46/src/selinux.py
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/selinux.py libselinux-2.0.47/src/selinux.py
|
||||
--- nsalibselinux/src/selinux.py 2007-10-05 13:09:54.000000000 -0400
|
||||
+++ libselinux-2.0.46/src/selinux.py 2008-01-11 10:51:06.000000000 -0500
|
||||
+++ libselinux-2.0.47/src/selinux.py 2008-01-11 10:55:14.000000000 -0500
|
||||
@@ -1,5 +1,5 @@
|
||||
# This file was automatically generated by SWIG (http://www.swig.org).
|
||||
-# Version 1.3.31
|
||||
@ -572,9 +566,9 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/src/selinux.py libselinux-2.0
|
||||
#
|
||||
# Don't modify this file, modify the SWIG interface instead.
|
||||
# This file is compatible with both classic and new-style classes.
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/selinuxswig.i libselinux-2.0.46/src/selinuxswig.i
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/selinuxswig.i libselinux-2.0.47/src/selinuxswig.i
|
||||
--- nsalibselinux/src/selinuxswig.i 2007-10-01 09:54:35.000000000 -0400
|
||||
+++ libselinux-2.0.46/src/selinuxswig.i 2008-01-11 10:51:06.000000000 -0500
|
||||
+++ libselinux-2.0.47/src/selinuxswig.i 2008-01-11 10:55:14.000000000 -0500
|
||||
@@ -5,11 +5,16 @@
|
||||
%module selinux
|
||||
%{
|
||||
@ -592,9 +586,9 @@ diff --exclude-from=exclude -N -u -r nsalibselinux/src/selinuxswig.i libselinux-
|
||||
|
||||
%typemap(in, numinputs=0) (char ***names, int *len) (char **temp1, int temp2) {
|
||||
$1 = &temp1;
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/selinuxswig_wrap.c libselinux-2.0.46/src/selinuxswig_wrap.c
|
||||
diff --exclude-from=exclude -N -u -r nsalibselinux/src/selinuxswig_wrap.c libselinux-2.0.47/src/selinuxswig_wrap.c
|
||||
--- nsalibselinux/src/selinuxswig_wrap.c 2007-10-05 13:09:54.000000000 -0400
|
||||
+++ libselinux-2.0.46/src/selinuxswig_wrap.c 2008-01-11 10:51:06.000000000 -0500
|
||||
+++ libselinux-2.0.47/src/selinuxswig_wrap.c 2008-01-11 10:55:14.000000000 -0500
|
||||
@@ -1,6 +1,6 @@
|
||||
/* ----------------------------------------------------------------------------
|
||||
* This file was automatically generated by SWIG (http://www.swig.org).
|
||||
|
@ -2,7 +2,7 @@
|
||||
Summary: SELinux library and simple utilities
|
||||
Name: libselinux
|
||||
Version: 2.0.47
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: Public Domain
|
||||
Group: System Environment/Libraries
|
||||
Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz
|
||||
|
Loading…
Reference in New Issue
Block a user