SELinux userspace 3.0 release
This commit is contained in:
parent
2bb8ef885f
commit
10608d13f5
1
.gitignore
vendored
1
.gitignore
vendored
@ -213,3 +213,4 @@ libselinux-2.0.96.tgz
|
||||
/libselinux-2.9-rc2.tar.gz
|
||||
/libselinux-2.9.tar.gz
|
||||
/libselinux-3.0-rc1.tar.gz
|
||||
/libselinux-3.0.tar.gz
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 0271bf4136e3a2bb476919eb9e984418ab95cb75 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
Date: Fri, 25 Oct 2019 15:41:49 +0200
|
||||
Subject: [PATCH] libselinux/src/Makefile: don't pass bogus -I and -L to python
|
||||
setup.py build_ext
|
||||
|
||||
Using $(DESTDIR) during the build does not follow the normal/standard
|
||||
semantic of DESTDIR: it is normally only needed during the
|
||||
installation. Therefore, a lot of build systems/environments don't
|
||||
pass any DESTDIR at build time, which causes setup.py to be called
|
||||
with -I /usr/include -L /usr/lib, which breaks cross-compilation.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
---
|
||||
libselinux/src/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libselinux/src/Makefile b/libselinux/src/Makefile
|
||||
index 2b1696a0c17b..3b8bad810de0 100644
|
||||
--- a/libselinux/src/Makefile
|
||||
+++ b/libselinux/src/Makefile
|
||||
@@ -130,7 +130,7 @@ SWIGRUBY = swig -Wall -ruby -o $(SWIGRUBYCOUT) -outdir ./ $(DISABLE_FLAGS)
|
||||
all: $(LIBA) $(LIBSO) $(LIBPC)
|
||||
|
||||
pywrap: all selinuxswig_python_exception.i
|
||||
- CFLAGS="$(CFLAGS) $(SWIG_CFLAGS)" $(PYTHON) setup.py build_ext -I $(DESTDIR)$(INCLUDEDIR) -L $(DESTDIR)$(LIBDIR)
|
||||
+ CFLAGS="$(CFLAGS) $(SWIG_CFLAGS)" $(PYTHON) setup.py build_ext
|
||||
|
||||
rubywrap: all $(SWIGRUBYSO)
|
||||
|
||||
--
|
||||
2.23.0
|
||||
|
@ -1,24 +1,23 @@
|
||||
%define ruby_inc %(pkg-config --cflags ruby)
|
||||
%define libsepolver 3.0
|
||||
%define libsepolver 3.0-1
|
||||
|
||||
Summary: SELinux library and simple utilities
|
||||
Name: libselinux
|
||||
Version: 3.0
|
||||
Release: 0.r1.1%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: Public Domain
|
||||
# https://github.com/SELinuxProject/selinux/wiki/Releases
|
||||
Source0: https://github.com/SELinuxProject/selinux/releases/download/20191031/libselinux-3.0-rc1.tar.gz
|
||||
Source0: https://github.com/SELinuxProject/selinux/releases/download/20191204/libselinux-3.0.tar.gz
|
||||
Source1: selinuxconlist.8
|
||||
Source2: selinuxdefcon.8
|
||||
Url: https://github.com/SELinuxProject/selinux/wiki
|
||||
# $ git clone https://github.com/fedora-selinux/selinux.git
|
||||
# $ cd selinux
|
||||
# $ git format-patch -N libselinux-3.0-rc1 -- libselinux
|
||||
# $ git format-patch -N libselinux-3.0 -- libselinux
|
||||
# $ i=1; for j in 00*patch; do printf "Patch%04d: %s\n" $i $j; i=$((i+1));done
|
||||
# Patch list start
|
||||
Patch0001: 0001-Fix-selinux-man-page-to-refer-seinfo-and-sesearch-to.patch
|
||||
Patch0002: 0002-Verify-context-input-to-funtions-to-make-sure-the-co.patch
|
||||
Patch0003: 0003-libselinux-src-Makefile-don-t-pass-bogus-I-and-L-to-.patch
|
||||
# Patch list end
|
||||
BuildRequires: gcc
|
||||
BuildRequires: ruby-devel ruby libsepol-static >= %{libsepolver} swig pcre2-devel xz-devel
|
||||
@ -89,7 +88,7 @@ The libselinux-static package contains the static libraries
|
||||
needed for developing SELinux applications.
|
||||
|
||||
%prep
|
||||
%autosetup -p 2 -n libselinux-%{version}-rc1
|
||||
%autosetup -p 2 -n libselinux-%{version}
|
||||
|
||||
%build
|
||||
export DISABLE_RPM="y"
|
||||
@ -220,6 +219,9 @@ rm -f %{buildroot}%{_mandir}/man8/togglesebool*
|
||||
%{ruby_vendorarchdir}/selinux.so
|
||||
|
||||
%changelog
|
||||
* Fri Dec 6 2019 Petr Lautrbach <plautrba@redhat.com> - 3.0-1
|
||||
- SELinux userspace 3.0 release
|
||||
|
||||
* Mon Nov 11 2019 Petr Lautrbach <plautrba@redhat.com> - 3.0-0.r1.1
|
||||
- SELinux userspace 3.0-rc1 release candidate
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libselinux-3.0-rc1.tar.gz) = c2060523462423846325790eb0d23dc0cdf24d3672cd9ba3df8de3fef4b56f2778303d33cc735d4264fdcac90c11585e588aaa8ead6db458082c3746a93f602e
|
||||
SHA512 (libselinux-3.0.tar.gz) = 6fd8c3711e25cb1363232e484268609b71d823975537b3863e403836222eba026abce8ca198f64dba6f4c1ea4deb7ecef68a0397b9656a67b363e4d74409cd95
|
||||
|
Loading…
Reference in New Issue
Block a user