librx/rx-1.5-libtoolmode.patch
Petr Šabata 0cc442632a RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN
with the following as its source:
https://src.fedoraproject.org/rpms/librx#c94077bac5a14c94ea2df018325428d443b6a82a
2020-10-15 17:28:34 +02:00

29 lines
985 B
Diff

diff -up rx-1.5/rx/Makefile.in.BAD rx-1.5/rx/Makefile.in
--- rx-1.5/rx/Makefile.in.BAD 2009-02-16 11:36:15.000000000 -0500
+++ rx-1.5/rx/Makefile.in 2009-02-16 11:36:39.000000000 -0500
@@ -67,13 +67,13 @@ gen_c_files=rgx.x
$(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $<
.c.lo:
- $(LIBTOOL) $(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $< -o $@
+ $(LIBTOOL) --mode=compile $(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $< -o $@
all: librx.la
install: all
$(INSTALL) $(srcdir)/inst-rxposix.h $(DESTDIR)$(includedir)/rxposix.h
- $(LIBTOOL) $(INSTALL) -c librx.la $(DESTDIR)$(libdir)
+ $(LIBTOOL) --mode=install $(INSTALL) -c librx.la $(DESTDIR)$(libdir)
uninstall:
@@ -127,7 +127,7 @@ librx.a: $(libobjs) $(opt_objs)
$(RANLIB) librx.a
librx.la: $(liblobjs) $(opt_objs)
- $(LIBTOOL) $(CC) $(ALL_CFLAGS) $(DEFS) -I$(srcdir) -o $@ $(liblobjs) -rpath $(libdir)
+ $(LIBTOOL) --mode=link $(CC) $(ALL_CFLAGS) $(DEFS) -I$(srcdir) -o $@ $(liblobjs) -rpath $(libdir)
depends: