import librx-1.5-41.el9
This commit is contained in:
commit
6c34dd0643
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/rx-1.5.tar.bz2
|
1
.librx.metadata
Normal file
1
.librx.metadata
Normal file
@ -0,0 +1 @@
|
||||
cb2deac5b046e2b347cc2c259e14c9b28659d95d SOURCES/rx-1.5.tar.bz2
|
11
SOURCES/librx-1.5-libdir64.patch
Normal file
11
SOURCES/librx-1.5-libdir64.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- rx-1.5/rx/Makefile.in.BAD 2005-05-08 22:46:56.000000000 -0500
|
||||
+++ rx-1.5/rx/Makefile.in 2005-05-08 22:47:16.000000000 -0500
|
||||
@@ -25,7 +25,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir = $(exec_prefix)/bin
|
||||
-libdir = $(exec_prefix)/lib
|
||||
+libdir = $(exec_prefix)/lib64
|
||||
includedir = $(prefix)/include
|
||||
infodir = $(prefix)/info
|
||||
|
28
SOURCES/rx-1.5-libtoolmode.patch
Normal file
28
SOURCES/rx-1.5-libtoolmode.patch
Normal file
@ -0,0 +1,28 @@
|
||||
diff -up rx-1.5/rx/Makefile.in.BAD rx-1.5/rx/Makefile.in
|
||||
--- rx-1.5/rx/Makefile.in.BAD 2009-02-16 11:36:15.000000000 -0500
|
||||
+++ rx-1.5/rx/Makefile.in 2009-02-16 11:36:39.000000000 -0500
|
||||
@@ -67,13 +67,13 @@ gen_c_files=rgx.x
|
||||
$(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $<
|
||||
|
||||
.c.lo:
|
||||
- $(LIBTOOL) $(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $< -o $@
|
||||
+ $(LIBTOOL) --mode=compile $(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $< -o $@
|
||||
|
||||
all: librx.la
|
||||
|
||||
install: all
|
||||
$(INSTALL) $(srcdir)/inst-rxposix.h $(DESTDIR)$(includedir)/rxposix.h
|
||||
- $(LIBTOOL) $(INSTALL) -c librx.la $(DESTDIR)$(libdir)
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL) -c librx.la $(DESTDIR)$(libdir)
|
||||
|
||||
|
||||
uninstall:
|
||||
@@ -127,7 +127,7 @@ librx.a: $(libobjs) $(opt_objs)
|
||||
$(RANLIB) librx.a
|
||||
|
||||
librx.la: $(liblobjs) $(opt_objs)
|
||||
- $(LIBTOOL) $(CC) $(ALL_CFLAGS) $(DEFS) -I$(srcdir) -o $@ $(liblobjs) -rpath $(libdir)
|
||||
+ $(LIBTOOL) --mode=link $(CC) $(ALL_CFLAGS) $(DEFS) -I$(srcdir) -o $@ $(liblobjs) -rpath $(libdir)
|
||||
|
||||
|
||||
depends:
|
94
SOURCES/rx-1.5-shared.patch
Normal file
94
SOURCES/rx-1.5-shared.patch
Normal file
@ -0,0 +1,94 @@
|
||||
diff -Naurk.orig rx-1.5/configure.in.orig rx-1.5/configure.in
|
||||
--- rx-1.5/configure.in.orig Fri Nov 22 08:39:12 1996
|
||||
+++ rx-1.5/configure.in Wed Apr 24 10:41:41 2002
|
||||
@@ -1,4 +1,5 @@
|
||||
AC_INIT(Makefile.in)
|
||||
+AC_PROG_LIBTOOL
|
||||
|
||||
all_subdirs=`cat $srcdir/*/PLUGIN/REQ $srcdir/*/PLUGIN/OPT /dev/null | tsort | xargs echo`
|
||||
req_subdirs=`cat $srcdir/*/PLUGIN/REQ /dev/null | tsort | xargs echo`
|
||||
@@ -47,4 +48,5 @@
|
||||
|
||||
|
||||
AC_SUBST(existingdirs)
|
||||
+AC_SUBST(LIBTOOL_DEPS)
|
||||
AC_OUTPUT(Makefile)
|
||||
diff -Naurk.orig rx-1.5/rx/Makefile.in.orig rx-1.5/rx/Makefile.in
|
||||
--- rx-1.5/rx/Makefile.in.orig Fri Nov 22 15:47:49 1996
|
||||
+++ rx-1.5/rx/Makefile.in Wed Apr 24 10:48:19 2002
|
||||
@@ -40,6 +40,10 @@
|
||||
AR_FLAGS = rc
|
||||
RANLIB = @RANLIB@
|
||||
opt_objs=@opt_objs@
|
||||
+LIBTOOL = libtool
|
||||
+DESTDIR =
|
||||
+LIBTOOL_DEPS = @LIBTOOL_DEPS@
|
||||
+
|
||||
|
||||
source= hashrexp.c rx.c rxanal.c rxbasic.c rxbitset.c rxcset.c rxdbug.c rxgnucomp.c rxhash.c rxnfa.c rxnode.c rxposix.c rxsimp.c rxspencer.c rxstr.c rxsuper.c rxunfa.c rgx.c
|
||||
|
||||
@@ -50,10 +54,11 @@
|
||||
../doc/rx.texi ../doc/rx.info ../doc/texinfo.tex
|
||||
distfiles=$(source) $(headers) $(ancillery)
|
||||
libobjs= hashrexp.o rx.o rxanal.o rxbasic.o rxbitset.o rxcset.o rxdbug.o rxgnucomp.o rxhash.o rxnfa.o rxnode.o rxposix.o rxsimp.o rxspencer.o rxstr.o rxsuper.o rxunfa.o
|
||||
+liblobjs= hashrexp.lo rx.lo rxanal.lo rxbasic.lo rxbitset.lo rxcset.lo rxdbug.lo rxgnucomp.lo rxhash.lo rxnfa.lo rxnode.lo rxposix.lo rxsimp.lo rxspencer.lo rxstr.lo rxsuper.lo rxunfa.lo
|
||||
gen_c_files=rgx.x
|
||||
|
||||
.SUFFIXES:
|
||||
-.SUFFIXES: .o .c .h .ps .dvi .info .texinfo .scm .cd .x
|
||||
+.SUFFIXES: .lo .o .c .h .ps .dvi .info .texinfo .scm .cd .x
|
||||
|
||||
.c.x:
|
||||
$(CC) $(ALL_CFLAGS) -DSCM_MAGIC_SNARFER -E $< | grep "^%%%" | sed -e "s/^%%%//" > $@ ; \
|
||||
@@ -61,22 +66,27 @@
|
||||
.c.o:
|
||||
$(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $<
|
||||
|
||||
-all: librx.a
|
||||
+.c.lo:
|
||||
+ $(LIBTOOL) $(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $< -o $@
|
||||
+
|
||||
+all: librx.la
|
||||
|
||||
install: all
|
||||
- test -d $(libdir) || mkdir $(libdir)
|
||||
- test -d $(includedir) || mkdir $(includedir)
|
||||
- $(INSTALL) librx.a $(libdir)/librx.a
|
||||
- $(RANLIB) $(libdir)/librx.a
|
||||
- $(INSTALL) $(srcdir)/inst-rxposix.h $(includedir)/rxposix.h
|
||||
+ $(INSTALL) $(srcdir)/inst-rxposix.h $(DESTDIR)$(includedir)/rxposix.h
|
||||
+ $(LIBTOOL) $(INSTALL) -c librx.la $(DESTDIR)$(libdir)
|
||||
|
||||
|
||||
uninstall:
|
||||
-rm -f $(libdir)/librx.a
|
||||
+ -rm -f $(libdir)/librx.la
|
||||
+ -rm -f $(libdir)/librx.so
|
||||
+ -rm -f $(libdir)/librx.so.0
|
||||
+ -rm -f $(libdir)/librx.so.0.0.0
|
||||
-rm -f $(includedir)/rxposix.h
|
||||
|
||||
clean:
|
||||
- -rm -f $(libobjs) librx.a $(opt_objs)
|
||||
+ -rm -f $(libobjs) $(liblobjs) librx.a $(opt_objs)
|
||||
+ -rm -rf .libs
|
||||
|
||||
distclean: clean
|
||||
-rm Makefile config.status config.log rgx.x
|
||||
@@ -116,6 +126,9 @@
|
||||
$(AR) $(AR_FLAGS) librx.a $(libobjs) $(opt_objs)
|
||||
$(RANLIB) librx.a
|
||||
|
||||
+librx.la: $(liblobjs) $(opt_objs)
|
||||
+ $(LIBTOOL) $(CC) $(ALL_CFLAGS) $(DEFS) -I$(srcdir) -o $@ $(liblobjs) -rpath $(libdir)
|
||||
+
|
||||
|
||||
depends:
|
||||
touch $(gen_c_files) scmconfig.h
|
||||
@@ -150,3 +163,6 @@
|
||||
rxunfa.o : rxunfa.c rxall.h rx.h rxhash.h rxbitset.h rxunfa.h _rx.h rxcset.h \
|
||||
rxnfa.h rxnode.h
|
||||
rgx.o : rgx.c rgx.x
|
||||
+
|
||||
+libtool: $(LIBTOOL_DEPS)
|
||||
+ $(SHELL) ./config.status --recheck
|
25
SOURCES/rx-1.5-texinfo.patch
Normal file
25
SOURCES/rx-1.5-texinfo.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -Naurk.texipatch rx-1.5/doc/rx.texi.texipatch rx-1.5/doc/rx.texi
|
||||
--- rx-1.5/doc/rx.texi.texipatch Wed Jan 15 23:31:37 1997
|
||||
+++ rx-1.5/doc/rx.texi Tue Apr 30 20:51:08 2002
|
||||
@@ -3,6 +3,12 @@
|
||||
@setfilename rx.info
|
||||
@settitle Rx
|
||||
@setchapternewpage odd
|
||||
+
|
||||
+@dircategory Development/C
|
||||
+@direntry
|
||||
+* Rx: (rx) POSIX regexp functions.
|
||||
+@end direntry
|
||||
+
|
||||
@c %**end of header
|
||||
|
||||
@c This title page illustrates only one of the
|
||||
@@ -367,7 +373,7 @@
|
||||
@end example
|
||||
|
||||
Subexpressions also have a special meaning with regard to backreferences
|
||||
-and substitutions (see @xref{Backreferences}).
|
||||
+and substitutions. @xref{Backreferences}.
|
||||
|
||||
|
||||
@node Repeated Subexpressions, Optional Subexpressions, Subexpressions, Posix Basic Regular Expressions
|
202
SPECS/librx.spec
Normal file
202
SPECS/librx.spec
Normal file
@ -0,0 +1,202 @@
|
||||
Summary: POSIX regexp functions
|
||||
Name: librx
|
||||
Version: 1.5
|
||||
Release: 41%{?dist}
|
||||
License: GPLv2+
|
||||
URL: http://www.gnu.org/software/rx/rx.html
|
||||
# Originally downloaded from ftp://ftp.gnu.org/gnu/rx/rx-1.5.tar.bz2
|
||||
# The FSF no longer offers this code.
|
||||
Source0: rx-%{version}.tar.bz2
|
||||
Patch0: rx-1.5-shared.patch
|
||||
Patch1: rx-1.5-texinfo.patch
|
||||
Patch2: librx-1.5-libdir64.patch
|
||||
Patch3: rx-1.5-libtoolmode.patch
|
||||
BuildRequires: texinfo, libtool
|
||||
BuildRequires: make
|
||||
|
||||
%description
|
||||
Rx is, among other things, an implementation of the interface
|
||||
specified by POSIX for programming with regular expressions. Some
|
||||
other implementations are GNU regex.c and Henry Spencer's regex
|
||||
library.
|
||||
|
||||
%package devel
|
||||
Summary: POSIX regexp functions, developers library
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Rx is, among other things, an implementation of the interface
|
||||
specified by POSIX for programming with regular expressions. Some
|
||||
other implementations are GNU regex.c and Henry Spencer's regex
|
||||
library.
|
||||
|
||||
This package contains files needed for development with librx.
|
||||
|
||||
%prep
|
||||
%setup -q -n rx-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1 -b .texipatch
|
||||
%ifarch x86_64 s390x ia64 %{power64} alpha sparc64 aarch64 %{mips64}
|
||||
%patch2 -p1 -b .64bit
|
||||
%endif
|
||||
%patch3 -p1 -b .libtoolmode
|
||||
|
||||
%build
|
||||
%configure
|
||||
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -Wl,-z,now"
|
||||
make doc/rx.info
|
||||
|
||||
%install
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
|
||||
make install DESTDIR=${RPM_BUILD_ROOT}
|
||||
install -m 644 doc/rx.info ${RPM_BUILD_ROOT}%{_infodir}
|
||||
rm -rf ${RPM_BUILD_ROOT}%{_libdir}/librx.la
|
||||
rm -rf ${RPM_BUILD_ROOT}%{_libdir}/librx.a
|
||||
chmod -x ${RPM_BUILD_ROOT}%{_includedir}/rxposix.h
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%files devel
|
||||
%doc ANNOUNCE BUILDING COOKOFF rx/ChangeLog
|
||||
%{_includedir}/*
|
||||
%{_infodir}/*
|
||||
%{_libdir}/*.so
|
||||
|
||||
%changelog
|
||||
* Thu Feb 17 2022 Josef Ridky <jridky@redhat.com> - 1.5-41
|
||||
- add gating.yaml file
|
||||
|
||||
* Wed Feb 16 2022 Josef Ridky <jridky@redhat.com> - 1.5-40
|
||||
- Fix annocheck failure (#2044876)
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.5-39
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.5-38
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-37
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-36
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-35
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-34
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-33
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-32
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-31
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-30
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-29
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-28
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Aug 12 2016 Michal Toman <mtoman@fedoraproject.org> - 1.5-27
|
||||
- Use lib64 on 64-bit MIPS
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-26
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-25
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-24
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-23
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Tue May 20 2014 Brent Baude <baude@us.ibm.com> - 1.5-22
|
||||
- Update 64bit arch list
|
||||
|
||||
* Wed Jan 15 2014 Jason L Tibbitts III <tibbs@math.uh.edu> - 1.5-21
|
||||
- Remove single trailing space in -devel post scriptlet which caused a file
|
||||
named " " in / to appear on install.
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed May 29 2013 Peter Robinson <pbrobinson@fedoraproject.org> 1.5-19
|
||||
- Update 64bit arch list
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Jan 20 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.5-15
|
||||
- don't package static lib (resolves bz 556072)
|
||||
|
||||
* Wed Aug 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.5-14
|
||||
- take URL out of Source0
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-13.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Fri Apr 24 2009 Karsten Hopp <karsten@redhat.com> 1.5-12.1
|
||||
- add s390x to 64bit archs
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Mon Feb 16 2009 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-11
|
||||
- pass modes to libtool
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.5-10
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Thu Aug 23 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-9
|
||||
- fix license, rebuild for BuildID
|
||||
|
||||
* Mon Sep 11 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-8
|
||||
- fix bz 200090
|
||||
|
||||
* Mon Sep 11 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-7
|
||||
- fix bz 197717
|
||||
- bump for FC-6
|
||||
|
||||
* Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-6
|
||||
- bump for FC-5
|
||||
|
||||
* Mon May 9 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-5
|
||||
- remove hardcoded dist tags
|
||||
|
||||
* Sun May 8 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-4
|
||||
- Fix 64 bit arches to install to the right libdir
|
||||
|
||||
* Thu May 5 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-3
|
||||
- add BuildRequires: texinfo
|
||||
|
||||
* Sun Apr 24 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-2
|
||||
- use dist tag
|
||||
|
||||
* Sat Apr 23 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-1
|
||||
- new package, based on Alexey Voinov's package from AltLinux
|
Loading…
Reference in New Issue
Block a user