Update to latest upstream 1.4.0 and LGPL license

Signed-off-by: Sinny Kumari <sinny@redhat.com>
This commit is contained in:
Sinny Kumari 2016-03-08 16:51:22 +05:30
parent f9ac85d5d9
commit d63f28b77f
4 changed files with 30 additions and 37 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@ librtas-1.3.4.tar.gz
/librtas-1.3.12.tar.gz
/librtas-1.3.13.tar.gz
/librtas-1.3.14.tar.gz
/librtas-1.4.0.tar.gz

View File

@ -1,55 +1,45 @@
diff -up librtas-1.3.6/libofdt_src/Makefile.ln librtas-1.3.6/libofdt_src/Makefile
--- librtas-1.3.6/libofdt_src/Makefile.ln 2011-02-07 11:53:34.000000000 -0500
+++ librtas-1.3.6/libofdt_src/Makefile 2011-08-11 06:45:39.948735397 -0400
@@ -26,12 +26,12 @@ all: $(LIBOFDT_OBJS) $(LIBOFDT_HDRS)
install:
@$(call install_lib,$(LIBOFDT),$(DESTDIR))
@$(call install_inc,$(LIBOFDT_SHIP_HDR),$(DESTDIR))
- @ln -sf $(LIBOFDT) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBOFDT))/$(LIBOFDT_SONAME)
+ @ln -sf $(LIBOFDT) $(DESTDIR)/$(LIB_DIR)/$(LIBOFDT_SONAME)
uninstall:
@$(call uninstall_lib,$(LIBOFDT),$(DESTDIR))
@$(call uninstall_inc,$(LIBOFDT_SHIP_HDR),$(DESTDIR))
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBOFDT))/$(LIBOFDT_SONAME)
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBOFDT_SONAME)
clean:
@echo "Cleaning up $(WORK_DIR) files..."
diff -up librtas-1.3.6/librtasevent_src/Makefile.ln librtas-1.3.6/librtasevent_src/Makefile
--- librtas-1.3.6/librtasevent_src/Makefile.ln 2011-02-07 11:53:34.000000000 -0500
+++ librtas-1.3.6/librtasevent_src/Makefile 2011-08-11 06:47:03.377757115 -0400
@@ -27,13 +27,12 @@ all: $(LIBRE_OBJS) $(HEADERS)
diff -upr librtas-1.4.0/librtasevent_src/Makefile librtas-1.4.0p/librtasevent_src/Makefile
--- librtas-1.4.0/librtasevent_src/Makefile 2016-01-07 23:50:43.000000000 +0530
+++ librtas-1.4.0p/librtasevent_src/Makefile 2016-03-11 15:53:00.536781740 +0530
@@ -27,14 +27,14 @@ all: $(LIBRE_OBJS) $(HEADERS)
install:
@$(call install_lib,$(LIBRE),$(DESTDIR))
@$(call install_inc,$(LIBRE_HDRS),$(DESTDIR))
- @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME)
- @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME).1
+ @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME)
+ @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME).1
uninstall:
@$(call uninstall_lib,$(LIBRE),$(DESTDIR))
@$(call uninstall_inc,$(LIBRE_HDRS),$(DESTDIR))
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME)
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME).1
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME)
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME).1
clean:
@echo "Cleaning up $(WORK_DIR) files..."
diff -up librtas-1.3.6/librtas_src/Makefile.ln librtas-1.3.6/librtas_src/Makefile
--- librtas-1.3.6/librtas_src/Makefile.ln 2011-02-07 11:53:34.000000000 -0500
+++ librtas-1.3.6/librtas_src/Makefile 2011-08-11 06:45:39.950735397 -0400
@@ -32,12 +32,12 @@ librtas_static: $(LIBRTAS_OBJS) $(HEADER
diff -upr librtas-1.4.0/librtas_src/Makefile librtas-1.4.0p/librtas_src/Makefile
--- librtas-1.4.0/librtas_src/Makefile 2016-01-07 23:50:43.000000000 +0530
+++ librtas-1.4.0p/librtas_src/Makefile 2016-03-11 15:51:42.482021031 +0530
@@ -32,14 +32,14 @@ librtas_static: $(LIBRTAS_OBJS) $(HEADER
install:
@$(call install_lib,$(LIBRTAS),$(DESTDIR))
@$(call install_inc,$(HEADERS),$(DESTDIR))
- @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
- @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME).1
+ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME)
+ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME).1
uninstall:
@$(call uninstall_lib,$(LIBRTAS),$(DESTDIR))
@$(call uninstall_inc,$(LIBRTAS_HDR),$(DESTDIR))
- @$(call uninstall_inc,$(HEADERS),$(DESTDIR))
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME).1
+ @$(call uninstall_inc,$(LIBRTAS_HDR),$(DESTDIR))
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME)
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME).1
clean:
@echo "Cleaning up $(WORK_DIR) files..."

View File

@ -1,9 +1,9 @@
Summary: Libraries to provide access to RTAS calls and RTAS events
Name: librtas
Version: 1.3.14
Release: 2%{?dist}
Version: 1.4.0
Release: 1%{?dist}
URL: http://librtas.ozlabs.org
License: CPL
License: LGPL
Group: System Environment/Libraries
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
@ -33,7 +33,7 @@ The librtas-devel packages contains the header files necessary for
developing programs using librtas.
%prep
%setup
%setup -q
%patch0 -p1 -b .libdir
%patch1 -p1 -b .ln
@ -54,10 +54,11 @@ mkdir -p %{buildroot}/%{_libdir}
%postun -p /sbin/ldconfig
%files
%doc COPYRIGHT README Changelog
%doc COPYING.LESSER README Changelog
%{_libdir}/librtas.so.%{version}
%{_libdir}/librtasevent.so.%{version}
%{_libdir}/libofdt.so.%{version}
%{_libdir}/librtas.so.1
%{_libdir}/librtasevent.so.1
%files devel
%{_libdir}/librtas.so
@ -66,11 +67,12 @@ mkdir -p %{buildroot}/%{_libdir}
%{_includedir}/librtasevent.h
%{_includedir}/librtasevent_v4.h
%{_includedir}/librtasevent_v6.h
%{_includedir}/common.h
%{_includedir}/libofdt.h
%{_libdir}/libofdt.so
%changelog
* Fri Mar 11 2016 Sinny Kumari <sinnykumari@fedoraproject.org> - 1.4.0-1
- Update to latest upstream 1.4.0
- License change from CPL to LGPL
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.14-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

View File

@ -1 +1 @@
984d882e691ff7d127fce25266d2a4c4 librtas-1.3.14.tar.gz
5d692a2387f0b7cfa29e410655fc696d librtas-1.4.0.tar.gz