Rebase to 2.0.1
This commit is contained in:
parent
f6749a94bb
commit
587c426391
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@ librtas-1.3.4.tar.gz
|
|||||||
/librtas-1.4.0.tar.gz
|
/librtas-1.4.0.tar.gz
|
||||||
/librtas-2.0.0.tar.gz
|
/librtas-2.0.0.tar.gz
|
||||||
/v2.0.0.tar.gz
|
/v2.0.0.tar.gz
|
||||||
|
/v2.0.1.tar.gz
|
||||||
|
@ -1,21 +0,0 @@
|
|||||||
diff -up librtas-1.3.5/rules.mk.libdir librtas-1.3.5/rules.mk
|
|
||||||
--- librtas-1.3.5/rules.mk.libdir 2010-01-28 20:04:30.000000000 +0100
|
|
||||||
+++ librtas-1.3.5/rules.mk 2011-08-09 15:47:16.842521606 +0200
|
|
||||||
@@ -145,7 +145,7 @@ define install_sbin
|
|
||||||
endef
|
|
||||||
|
|
||||||
define install_lib
|
|
||||||
- $(call install_files,$1,755,$2/$(LIB_DIR)$(call is_lib64,$1))
|
|
||||||
+ $(call install_files,$1,755,$2/$(LIB_DIR))
|
|
||||||
endef
|
|
||||||
|
|
||||||
define install_inc
|
|
||||||
@@ -188,7 +188,7 @@ define uninstall_sbin
|
|
||||||
endef
|
|
||||||
|
|
||||||
define uninstall_lib
|
|
||||||
- $(call uninstall_files,$1,$2/$(LIB_DIR)$(call is_lib64,$1))
|
|
||||||
+ $(call uninstall_files,$1,$2/$(LIB_DIR))
|
|
||||||
endef
|
|
||||||
|
|
||||||
define uninstall_inc
|
|
@ -1,46 +0,0 @@
|
|||||||
diff -upr librtas-2.0.0/librtasevent_src/Makefile librtas-2.0.0p/librtasevent_src/Makefile
|
|
||||||
--- librtas-2.0.0/librtasevent_src/Makefile 2016-04-06 08:33:56.000000000 +0530
|
|
||||||
+++ librtas-2.0.0p/librtasevent_src/Makefile 2016-04-07 00:07:58.309978958 +0530
|
|
||||||
@@ -47,15 +47,15 @@ install:
|
|
||||||
@$(call install_lib,$(LIBRE),$(DESTDIR))
|
|
||||||
@$(call install_lib,$(LIBRE_STATIC),$(DESTDIR))
|
|
||||||
@$(call install_inc,$(LIBRE_HDRS),$(DESTDIR))
|
|
||||||
- @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME)
|
|
||||||
- @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME).$(MAJOR_NO)
|
|
||||||
+ @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME)
|
|
||||||
+ @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME).$(MAJOR_NO)
|
|
||||||
|
|
||||||
uninstall:
|
|
||||||
@$(call uninstall_lib,$(LIBRE),$(DESTDIR))
|
|
||||||
@$(call uninstall_lib,$(LIBRE_STATIC),$(DESTDIR))
|
|
||||||
@$(call uninstall_inc,$(LIBRE_HDRS),$(DESTDIR))
|
|
||||||
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME)
|
|
||||||
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME).$(MAJOR_NO)
|
|
||||||
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME)
|
|
||||||
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME).$(MAJOR_NO)
|
|
||||||
|
|
||||||
clean:
|
|
||||||
@echo "Cleaning up $(WORK_DIR) files..."
|
|
||||||
diff -upr librtas-2.0.0/librtas_src/Makefile librtas-2.0.0p/librtas_src/Makefile
|
|
||||||
--- librtas-2.0.0/librtas_src/Makefile 2016-04-06 08:33:56.000000000 +0530
|
|
||||||
+++ librtas-2.0.0p/librtas_src/Makefile 2016-04-07 00:07:47.700025121 +0530
|
|
||||||
@@ -45,15 +45,15 @@ install:
|
|
||||||
@$(call install_lib,$(LIBRTAS),$(DESTDIR))
|
|
||||||
@$(call install_lib,$(LIBRTAS_STATIC),$(DESTDIR))
|
|
||||||
@$(call install_inc,$(HEADERS),$(DESTDIR))
|
|
||||||
- @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
|
|
||||||
- @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME).$(MAJOR_NO)
|
|
||||||
+ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME)
|
|
||||||
+ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME).$(MAJOR_NO)
|
|
||||||
|
|
||||||
uninstall:
|
|
||||||
@$(call uninstall_lib,$(LIBRTAS),$(DESTDIR))
|
|
||||||
@$(call uninstall_lib,$(LIBRTAS_STATIC),$(DESTDIR))
|
|
||||||
@$(call uninstall_inc,$(HEADERS),$(DESTDIR))
|
|
||||||
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
|
|
||||||
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME).$(MAJOR_NO)
|
|
||||||
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME)
|
|
||||||
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME)..$(MAJOR_NO)
|
|
||||||
|
|
||||||
clean:
|
|
||||||
@echo "Cleaning up $(WORK_DIR) files..."
|
|
27
librtas-2.0.1-libversion.patch
Normal file
27
librtas-2.0.1-libversion.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From 2c954feaa59657fd8a13cf6e7208c4bf8c46f0dc Mon Sep 17 00:00:00 2001
|
||||||
|
From: Sinny Kumari <sinny@redhat.com>
|
||||||
|
Date: Sun, 19 Mar 2017 00:21:22 +0530
|
||||||
|
Subject: [PATCH] Update library version to 2.0.1 to match with release version
|
||||||
|
|
||||||
|
---
|
||||||
|
Makefile.am | 4 +++-
|
||||||
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
|
index e02d007..5f819c3 100644
|
||||||
|
--- a/Makefile.am
|
||||||
|
+++ b/Makefile.am
|
||||||
|
@@ -19,7 +19,9 @@ AM_CFLAGS = -I$(top_srcdir)/librtas_src/ -I$(top_srcdir)/librtasevent_src/
|
||||||
|
|
||||||
|
library_includedir=$(includedir)
|
||||||
|
|
||||||
|
-LIBRTAS_LIBRARY_VERSION = 2:0:0
|
||||||
|
+# CURRENT:REVISION:AGE(C:R:A)
|
||||||
|
+# For calculating version number of library, formula used is (C - A).(A).(R)
|
||||||
|
+LIBRTAS_LIBRARY_VERSION = 2:1:0
|
||||||
|
|
||||||
|
lib_LTLIBRARIES += librtas.la
|
||||||
|
librtas_la_LDFLAGS = -version-info $(LIBRTAS_LIBRARY_VERSION)
|
||||||
|
--
|
||||||
|
2.9.3
|
||||||
|
|
38
librtas.spec
38
librtas.spec
@ -1,15 +1,18 @@
|
|||||||
Summary: Libraries to provide access to RTAS calls and RTAS events
|
Summary: Libraries to provide access to RTAS calls and RTAS events
|
||||||
Name: librtas
|
Name: librtas
|
||||||
Version: 2.0.0
|
Version: 2.0.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: https://github.com/nfont/librtas
|
URL: https://github.com/nfont/librtas
|
||||||
License: LGPL
|
License: LGPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
|
|
||||||
Source0: https://github.com/nfont/librtas/archive/v%{version}.tar.gz
|
Source0: https://github.com/nfont/librtas/archive/v%{version}.tar.gz
|
||||||
|
|
||||||
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: libtool
|
||||||
|
|
||||||
# Fedora specific patch
|
# Fedora specific patch
|
||||||
Patch0: %{name}-1.3.4-libdir.patch
|
Patch0: %{name}-2.0.1-libversion.patch
|
||||||
Patch1: %{name}-1.3.6-ln.patch
|
|
||||||
|
|
||||||
ExclusiveArch: ppc %{power64}
|
ExclusiveArch: ppc %{power64}
|
||||||
|
|
||||||
@ -33,23 +36,22 @@ The librtas-devel packages contains the header files necessary for
|
|||||||
developing programs using librtas.
|
developing programs using librtas.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -n %{name}-%{version}
|
||||||
%patch0 -p1 -b .libdir
|
%patch0 -p1 -b .ln
|
||||||
%patch1 -p1 -b .ln
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
./autogen.sh
|
||||||
# disable "-Werror=format-security" checking gcc option until we fix
|
# disable "-Werror=format-security" checking gcc option until we fix
|
||||||
# these errors in our code.
|
# these errors in our code.
|
||||||
|
%configure --disable-silent-rules --disable-static
|
||||||
CFLAGS="%{optflags} -fPIC -DPIC -I."
|
CFLAGS="%{optflags} -fPIC -DPIC -I."
|
||||||
CFLAGS=`echo $CFLAGS | sed 's/-Werror=format-security//'`
|
CFLAGS=`echo $CFLAGS | sed 's/-Werror=format-security//'`
|
||||||
make CFLAGS="$CFLAGS" %{?_smp_mflags}
|
%make_build CFLAGS="$CFLAGS"
|
||||||
|
|
||||||
%install
|
%install
|
||||||
mkdir -p %{buildroot}/%{_libdir}
|
%make_install
|
||||||
make install DESTDIR=%{buildroot} LIB_DIR=%{_libdir} INSTALL="install -p"
|
find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
||||||
rm -rf %{buildroot}%{_datadir}/doc
|
rm -f %{buildroot}/%{_docdir}/librtas/*
|
||||||
# Remove static libraries
|
|
||||||
rm -f %{buildroot}%{_libdir}/*.a
|
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
@ -59,20 +61,22 @@ rm -f %{buildroot}%{_libdir}/*.a
|
|||||||
%{!?_licensedir:%global license %%doc}
|
%{!?_licensedir:%global license %%doc}
|
||||||
%license COPYING.LESSER
|
%license COPYING.LESSER
|
||||||
%doc README Changelog
|
%doc README Changelog
|
||||||
%{_libdir}/librtas.so.%{version}
|
%{_libdir}/librtas.so.*
|
||||||
%{_libdir}/librtasevent.so.%{version}
|
%{_libdir}/librtasevent.so.*
|
||||||
%{_libdir}/librtas.so.2
|
|
||||||
%{_libdir}/librtasevent.so.2
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_libdir}/librtas.so
|
%{_libdir}/librtas.so
|
||||||
%{_libdir}/librtasevent.so
|
%{_libdir}/librtasevent.so
|
||||||
|
%{_libdir}/pkgconfig/librtas.pc
|
||||||
%{_includedir}/librtas.h
|
%{_includedir}/librtas.h
|
||||||
%{_includedir}/librtasevent.h
|
%{_includedir}/librtasevent.h
|
||||||
%{_includedir}/librtasevent_v4.h
|
%{_includedir}/librtasevent_v4.h
|
||||||
%{_includedir}/librtasevent_v6.h
|
%{_includedir}/librtasevent_v6.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 04 2017 Sinny Kumari <sinnykumari@fedoraproject.org> - 2.0.1-1
|
||||||
|
- Rebase to 2.0.1
|
||||||
|
|
||||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-3
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user