Update to upstream release 2.0.0

Signed-off-by: Sinny Kumari <sinny@redhat.com>
This commit is contained in:
Sinny Kumari 2016-04-07 00:22:34 +05:30
parent ee3a29be5a
commit 47a7a77110
5 changed files with 33 additions and 59 deletions

1
.gitignore vendored
View File

@ -7,3 +7,4 @@ librtas-1.3.4.tar.gz
/librtas-1.3.13.tar.gz
/librtas-1.3.14.tar.gz
/librtas-1.4.0.tar.gz
/librtas-2.0.0.tar.gz

View File

@ -1,45 +1,46 @@
diff -upr librtas-1.4.0/librtasevent_src/Makefile librtas-1.4.0p/librtasevent_src/Makefile
--- librtas-1.4.0/librtasevent_src/Makefile 2016-01-07 23:50:43.000000000 +0530
+++ librtas-1.4.0p/librtasevent_src/Makefile 2016-03-11 15:53:00.536781740 +0530
@@ -27,14 +27,14 @@ all: $(LIBRE_OBJS) $(HEADERS)
install:
diff -upr librtas-2.0.0/librtasevent_src/Makefile librtas-2.0.0p/librtasevent_src/Makefile
--- librtas-2.0.0/librtasevent_src/Makefile 2016-04-06 08:33:56.000000000 +0530
+++ librtas-2.0.0p/librtasevent_src/Makefile 2016-04-07 00:07:58.309978958 +0530
@@ -47,15 +47,15 @@ install:
@$(call install_lib,$(LIBRE),$(DESTDIR))
@$(call install_lib,$(LIBRE_STATIC),$(DESTDIR))
@$(call install_inc,$(LIBRE_HDRS),$(DESTDIR))
- @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME)
- @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME).1
- @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME).$(MAJOR_NO)
+ @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME)
+ @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME).1
+ @ln -sf $(LIBRE) $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME).$(MAJOR_NO)
uninstall:
@$(call uninstall_lib,$(LIBRE),$(DESTDIR))
@$(call uninstall_lib,$(LIBRE_STATIC),$(DESTDIR))
@$(call uninstall_inc,$(LIBRE_HDRS),$(DESTDIR))
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME)
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME).1
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRE))/$(LIBRE_SONAME).$(MAJOR_NO)
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME)
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME).1
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRE_SONAME).$(MAJOR_NO)
clean:
@echo "Cleaning up $(WORK_DIR) files..."
diff -upr librtas-1.4.0/librtas_src/Makefile librtas-1.4.0p/librtas_src/Makefile
--- librtas-1.4.0/librtas_src/Makefile 2016-01-07 23:50:43.000000000 +0530
+++ librtas-1.4.0p/librtas_src/Makefile 2016-03-11 15:51:42.482021031 +0530
@@ -32,14 +32,14 @@ librtas_static: $(LIBRTAS_OBJS) $(HEADER
install:
diff -upr librtas-2.0.0/librtas_src/Makefile librtas-2.0.0p/librtas_src/Makefile
--- librtas-2.0.0/librtas_src/Makefile 2016-04-06 08:33:56.000000000 +0530
+++ librtas-2.0.0p/librtas_src/Makefile 2016-04-07 00:07:47.700025121 +0530
@@ -45,15 +45,15 @@ install:
@$(call install_lib,$(LIBRTAS),$(DESTDIR))
@$(call install_lib,$(LIBRTAS_STATIC),$(DESTDIR))
@$(call install_inc,$(HEADERS),$(DESTDIR))
- @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
- @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME).1
- @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME).$(MAJOR_NO)
+ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME)
+ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME).1
+ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME).$(MAJOR_NO)
uninstall:
@$(call uninstall_lib,$(LIBRTAS),$(DESTDIR))
- @$(call uninstall_inc,$(HEADERS),$(DESTDIR))
@$(call uninstall_lib,$(LIBRTAS_STATIC),$(DESTDIR))
@$(call uninstall_inc,$(HEADERS),$(DESTDIR))
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME).1
+ @$(call uninstall_inc,$(LIBRTAS_HDR),$(DESTDIR))
- @rm -f $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME).$(MAJOR_NO)
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME)
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME).1
+ @rm -f $(DESTDIR)/$(LIB_DIR)/$(LIBRTAS_SONAME)..$(MAJOR_NO)
clean:
@echo "Cleaning up $(WORK_DIR) files..."

View File

@ -1,32 +0,0 @@
From 23b6261c0205d834ab9aba67cb52e3f320c5058c Mon Sep 17 00:00:00 2001
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
Date: Tue, 15 Mar 2016 15:35:05 +0530
Subject: [PATCH] librtas: Do not enable debug message by default
Commit eae18de3 removed dbg1 macro. But accidently enabled logging debug
message by default. This is confusing end users. Hence remove logging
debug message by default.
Fixes: eae18de3 (librtas: Update the dbg() macro)
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
CC: Nathan Fontenot <nfont@linux.vnet.ibm.com>
---
librtas_src/syscall.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/librtas_src/syscall.h b/librtas_src/syscall.h
index 42edf8f..f84ef37 100644
--- a/librtas_src/syscall.h
+++ b/librtas_src/syscall.h
@@ -64,7 +64,7 @@ extern int dbg_lvl;
#define dbg(_fmt, _args...) \
do { \
- if (dbg_lvl >= 0) \
+ if (dbg_lvl > 0) \
printf("librtas %s(): " _fmt, __func__, ##_args); \
} while (0)
--
2.5.0

View File

@ -1,7 +1,7 @@
Summary: Libraries to provide access to RTAS calls and RTAS events
Name: librtas
Version: 1.4.0
Release: 2%{?dist}
Version: 2.0.0
Release: 1%{?dist}
URL: http://librtas.ozlabs.org
License: LGPL
Group: System Environment/Libraries
@ -10,7 +10,6 @@ Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
# Fedora specific patch
Patch0: %{name}-1.3.4-libdir.patch
Patch1: %{name}-1.3.6-ln.patch
Patch2: %{name}-1.4.0-do-not-enable-debug-message.patch
ExclusiveArch: ppc ppc64 ppc64le
@ -37,7 +36,6 @@ developing programs using librtas.
%setup -q
%patch0 -p1 -b .libdir
%patch1 -p1 -b .ln
%patch2 -p1 -b .do-not-enable-debug-message
%build
# disable "-Werror=format-security" checking gcc option until we fix
@ -50,6 +48,8 @@ CFLAGS=`echo $CFLAGS | sed 's/-Werror=format-security//'`
mkdir -p %{buildroot}/%{_libdir}
%{__make} install DESTDIR=%{buildroot} LIB_DIR=%{_libdir} INSTALL="install -p"
%{__rm} -rf %{buildroot}%{_datadir}/doc
# Remove static libraries
%{__rm} -f %{buildroot}%{_libdir}/*.a
%post -p /sbin/ldconfig
@ -59,8 +59,8 @@ mkdir -p %{buildroot}/%{_libdir}
%doc COPYING.LESSER README Changelog
%{_libdir}/librtas.so.%{version}
%{_libdir}/librtasevent.so.%{version}
%{_libdir}/librtas.so.1
%{_libdir}/librtasevent.so.1
%{_libdir}/librtas.so.2
%{_libdir}/librtasevent.so.2
%files devel
%{_libdir}/librtas.so
@ -71,6 +71,10 @@ mkdir -p %{buildroot}/%{_libdir}
%{_includedir}/librtasevent_v6.h
%changelog
* Wed Apr 06 2016 Sinny Kumari <sinnykumari@fedoraproject.org> - 2.0.0-1
- Update to upstream release 2.0.0
- do-not-enable-debug-message patch is available in this release
* Mon Mar 21 2016 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 1.4.0-2
- Do not enable debug message by default

View File

@ -1 +1 @@
5d692a2387f0b7cfa29e410655fc696d librtas-1.4.0.tar.gz
0a39248ad768029f76b3150218581486 librtas-2.0.0.tar.gz