Upstream release 1.3.4
This commit is contained in:
parent
92ec6d97f1
commit
024af43b42
@ -1 +1 @@
|
||||
librtas-1.3.3.tar.gz
|
||||
librtas-1.3.4.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up librtas-1.3.2/librtas_src/syscall_rmo.c.mode librtas-1.3.2/librtas_src/syscall_rmo.c
|
||||
--- librtas-1.3.2/librtas_src/syscall_rmo.c.mode 2007-08-06 12:02:34.000000000 -0400
|
||||
+++ librtas-1.3.2/librtas_src/syscall_rmo.c 2007-09-05 17:03:10.000000000 -0400
|
||||
@@ -117,7 +117,7 @@ static int acquire_file_lock(off_t start
|
||||
|
||||
/* Lazily open lock file */
|
||||
if (wa_config.lockfile_fd < 0) {
|
||||
- wa_config.lockfile_fd = open(lockfile_path, O_CREAT | O_RDWR);
|
||||
+ wa_config.lockfile_fd = open(lockfile_path, O_CREAT | O_RDWR, 0600);
|
||||
if (wa_config.lockfile_fd < 0) {
|
||||
dbg1("could not open lockfile %s\n", lockfile_path);
|
||||
return RTAS_IO_ASSERT;
|
12
librtas-1.3.4-libdir.patch
Normal file
12
librtas-1.3.4-libdir.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up librtas-1.3.4/rules.mk.libdir librtas-1.3.4/rules.mk
|
||||
--- librtas-1.3.4/rules.mk.libdir 2009-09-21 16:41:57.000000000 +0200
|
||||
+++ librtas-1.3.4/rules.mk 2009-09-21 16:42:01.000000000 +0200
|
||||
@@ -135,7 +135,7 @@ define install_sbin
|
||||
endef
|
||||
|
||||
define install_lib
|
||||
- $(call install_files,$1,755,$2/$(LIB_DIR)$(findstring 64,$(shell file $(firstword $1))))
|
||||
+ $(call install_files,$1,755,$2/$(LIB_DIR))
|
||||
endef
|
||||
|
||||
define install_inc
|
18
librtas.spec
18
librtas.spec
@ -1,14 +1,14 @@
|
||||
Summary: Libraries to provide access to RTAS calls and RTAS events
|
||||
Name: librtas
|
||||
Version: 1.3.3
|
||||
Release: 5%{?dist}
|
||||
Version: 1.3.4
|
||||
Release: 1%{?dist}
|
||||
URL: http://librtas.ozlabs.org
|
||||
License: IBM
|
||||
Group: System Environment/Libraries
|
||||
|
||||
Source: http://librtas.ozlabs.org/releases/%{name}-%{version}.tar.gz
|
||||
|
||||
Patch0: %{name}-1.3.2-mode.patch
|
||||
Patch0: %{name}-1.3.4-libdir.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
ExclusiveArch: ppc ppc64
|
||||
@ -37,12 +37,13 @@ developing programs using librtas.
|
||||
|
||||
%prep
|
||||
%setup
|
||||
%patch0 -p1 -b .mode
|
||||
%patch0 -p1 -b .libdir
|
||||
|
||||
%build
|
||||
%{__make} CFLAGS="%{optflags} -fPIC -DPIC" %{?_smp_mflags}
|
||||
%{__make} CFLAGS="%{optflags} -fPIC -DPIC -I." %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
mkdir -p %{buildroot}/%{_libdir}
|
||||
%{__make} install DESTDIR=%{buildroot} LIB_DIR=%{_libdir}
|
||||
%{__rm} -rf %{buildroot}%{_datadir}/doc
|
||||
|
||||
@ -58,6 +59,7 @@ developing programs using librtas.
|
||||
%doc COPYRIGHT README Changelog
|
||||
%{_libdir}/librtas.so.%{version}
|
||||
%{_libdir}/librtasevent.so.%{version}
|
||||
%{_libdir}/libofdt.so.%{version}
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
@ -67,8 +69,14 @@ developing programs using librtas.
|
||||
%{_includedir}/librtasevent.h
|
||||
%{_includedir}/librtasevent_v4.h
|
||||
%{_includedir}/librtasevent_v6.h
|
||||
%{_includedir}/common.h
|
||||
%{_includedir}/libofdt.h
|
||||
%{_libdir}/libofdt.so
|
||||
|
||||
%changelog
|
||||
* Mon Sep 21 2009 Roman Rakus <rrakus@redhat.com> - 1.3.4-1
|
||||
- Upstream release 1.3.4
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user