346ba30eeb
All of the rust deps are now packaged in Fedora (with the exception of the 'criterion' crate, but that one is only required for benchmarking which we don't do during package builds) so we can stop using the bundled ones.
282 lines
6.6 KiB
Diff
282 lines
6.6 KiB
Diff
From 80334a27054aa3e5d813646b5068258208cca834 Mon Sep 17 00:00:00 2001
|
|
From: Kalev Lember <klember@redhat.com>
|
|
Date: Tue, 8 Nov 2022 17:02:19 +0100
|
|
Subject: [PATCH 2/3] Fedora: Drop dependencies required for benchmarking
|
|
|
|
Drop criterion that is only required for benchmarking, which we don't do
|
|
during package builds.
|
|
---
|
|
Cargo.lock | 159 -----------------------------------------------------
|
|
Cargo.toml | 1 -
|
|
2 files changed, 160 deletions(-)
|
|
|
|
diff --git a/Cargo.lock b/Cargo.lock
|
|
index 11a89191..300c8758 100644
|
|
--- a/Cargo.lock
|
|
+++ b/Cargo.lock
|
|
@@ -123,7 +123,6 @@ dependencies = [
|
|
"lazy_static",
|
|
"memchr",
|
|
"regex-automata",
|
|
- "serde",
|
|
]
|
|
|
|
[[package]]
|
|
@@ -252,42 +251,6 @@ dependencies = [
|
|
"cfg-if",
|
|
]
|
|
|
|
-[[package]]
|
|
-name = "criterion"
|
|
-version = "0.3.6"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "b01d6de93b2b6c65e17c634a26653a29d107b3c98c607c765bf38d041531cd8f"
|
|
-dependencies = [
|
|
- "atty",
|
|
- "cast",
|
|
- "clap",
|
|
- "criterion-plot",
|
|
- "csv",
|
|
- "itertools",
|
|
- "lazy_static",
|
|
- "num-traits",
|
|
- "oorandom",
|
|
- "plotters",
|
|
- "rayon",
|
|
- "regex",
|
|
- "serde",
|
|
- "serde_cbor",
|
|
- "serde_derive",
|
|
- "serde_json",
|
|
- "tinytemplate",
|
|
- "walkdir",
|
|
-]
|
|
-
|
|
-[[package]]
|
|
-name = "criterion-plot"
|
|
-version = "0.4.5"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "2673cc8207403546f45f5fd319a974b1e6983ad1a3ee7e6041650013be041876"
|
|
-dependencies = [
|
|
- "cast",
|
|
- "itertools",
|
|
-]
|
|
-
|
|
[[package]]
|
|
name = "crossbeam-channel"
|
|
version = "0.5.6"
|
|
@@ -360,28 +323,6 @@ dependencies = [
|
|
"syn 1.0.99",
|
|
]
|
|
|
|
-[[package]]
|
|
-name = "csv"
|
|
-version = "1.1.6"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "22813a6dc45b335f9bade10bf7271dc477e81113e89eb251a0bc2a8a81c536e1"
|
|
-dependencies = [
|
|
- "bstr",
|
|
- "csv-core",
|
|
- "itoa 0.4.8",
|
|
- "ryu",
|
|
- "serde",
|
|
-]
|
|
-
|
|
-[[package]]
|
|
-name = "csv-core"
|
|
-version = "0.1.10"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "2b2466559f260f48ad25fe6317b3c8dac77b5bdb5763ac7d9d6103530663bc90"
|
|
-dependencies = [
|
|
- "memchr",
|
|
-]
|
|
-
|
|
[[package]]
|
|
name = "data-url"
|
|
version = "0.1.1"
|
|
@@ -761,12 +702,6 @@ dependencies = [
|
|
"system-deps",
|
|
]
|
|
|
|
-[[package]]
|
|
-name = "half"
|
|
-version = "1.8.2"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "eabb4a44450da02c90444cf74558da904edde8fb4e9035a9a6a4e15445af0bd7"
|
|
-
|
|
[[package]]
|
|
name = "heck"
|
|
version = "0.4.0"
|
|
@@ -875,7 +810,6 @@ dependencies = [
|
|
"cast",
|
|
"chrono",
|
|
"clap",
|
|
- "criterion",
|
|
"cssparser",
|
|
"data-url",
|
|
"encoding",
|
|
@@ -1174,12 +1108,6 @@ version = "1.14.0"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
checksum = "2f7254b99e31cad77da24b08ebf628882739a608578bb1bcdfc1f9c21260d7c0"
|
|
|
|
-[[package]]
|
|
-name = "oorandom"
|
|
-version = "11.1.3"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "0ab1bc2a289d34bd04a330323ac98a1b4bc82c9d9fcb1e66b63caa84da26b575"
|
|
-
|
|
[[package]]
|
|
name = "pango"
|
|
version = "0.15.10"
|
|
@@ -1358,34 +1286,6 @@ version = "0.3.25"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
checksum = "1df8c4ec4b0627e53bdf214615ad287367e482558cf84b109250b37464dc03ae"
|
|
|
|
-[[package]]
|
|
-name = "plotters"
|
|
-version = "0.3.3"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "716b4eeb6c4a1d3ecc956f75b43ec2e8e8ba80026413e70a3f41fd3313d3492b"
|
|
-dependencies = [
|
|
- "num-traits",
|
|
- "plotters-backend",
|
|
- "plotters-svg",
|
|
- "wasm-bindgen",
|
|
- "web-sys",
|
|
-]
|
|
-
|
|
-[[package]]
|
|
-name = "plotters-backend"
|
|
-version = "0.3.4"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "193228616381fecdc1224c62e96946dfbc73ff4384fba576e052ff8c1bea8142"
|
|
-
|
|
-[[package]]
|
|
-name = "plotters-svg"
|
|
-version = "0.3.3"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "f9a81d2759aae1dae668f783c308bc5c8ebd191ff4184aaa1b37f65a6ae5a56f"
|
|
-dependencies = [
|
|
- "plotters-backend",
|
|
-]
|
|
-
|
|
[[package]]
|
|
name = "png"
|
|
version = "0.17.6"
|
|
@@ -1776,15 +1676,6 @@ dependencies = [
|
|
"bytemuck",
|
|
]
|
|
|
|
-[[package]]
|
|
-name = "same-file"
|
|
-version = "1.0.6"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "93fc1dc3aaa9bfed95e02e6eadabb4baf7e3078b0bd1b4d7b6b0b68378900502"
|
|
-dependencies = [
|
|
- "winapi-util",
|
|
-]
|
|
-
|
|
[[package]]
|
|
name = "scopeguard"
|
|
version = "1.1.0"
|
|
@@ -1839,16 +1730,6 @@ dependencies = [
|
|
"serde_derive",
|
|
]
|
|
|
|
-[[package]]
|
|
-name = "serde_cbor"
|
|
-version = "0.11.2"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "2bef2ebfde456fb76bbcf9f59315333decc4fda0b2b44b420243c11e0f5ec1f5"
|
|
-dependencies = [
|
|
- "half",
|
|
- "serde",
|
|
-]
|
|
-
|
|
[[package]]
|
|
name = "serde_derive"
|
|
version = "1.0.144"
|
|
@@ -2182,16 +2063,6 @@ dependencies = [
|
|
"syn 1.0.99",
|
|
]
|
|
|
|
-[[package]]
|
|
-name = "tinytemplate"
|
|
-version = "1.2.1"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "be4d6b5f19ff7664e8c98d03e2139cb510db9b0a60b55f8e8709b689d939b6bc"
|
|
-dependencies = [
|
|
- "serde",
|
|
- "serde_json",
|
|
-]
|
|
-
|
|
[[package]]
|
|
name = "tinyvec"
|
|
version = "1.6.0"
|
|
@@ -2300,17 +2171,6 @@ dependencies = [
|
|
"libc",
|
|
]
|
|
|
|
-[[package]]
|
|
-name = "walkdir"
|
|
-version = "2.3.2"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "808cf2735cd4b6866113f648b791c6adc5714537bc222d9347bb203386ffda56"
|
|
-dependencies = [
|
|
- "same-file",
|
|
- "winapi",
|
|
- "winapi-util",
|
|
-]
|
|
-
|
|
[[package]]
|
|
name = "wasi"
|
|
version = "0.9.0+wasi-snapshot-preview1"
|
|
@@ -2383,16 +2243,6 @@ version = "0.2.82"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
checksum = "6598dd0bd3c7d51095ff6531a5b23e02acdc81804e30d8f07afb77b7215a140a"
|
|
|
|
-[[package]]
|
|
-name = "web-sys"
|
|
-version = "0.3.59"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "ed055ab27f941423197eb86b2035720b1a3ce40504df082cac2ecc6ed73335a1"
|
|
-dependencies = [
|
|
- "js-sys",
|
|
- "wasm-bindgen",
|
|
-]
|
|
-
|
|
[[package]]
|
|
name = "wide"
|
|
version = "0.7.4"
|
|
@@ -2419,15 +2269,6 @@ version = "0.4.0"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
checksum = "ac3b87c63620426dd9b991e5ce0329eff545bccbbb34f3be09ff6fb6ab51b7b6"
|
|
|
|
-[[package]]
|
|
-name = "winapi-util"
|
|
-version = "0.1.5"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "70ec6ce85bb158151cae5e5c87f95a8e97d2c0c4b001223f33a334e3ce5de178"
|
|
-dependencies = [
|
|
- "winapi",
|
|
-]
|
|
-
|
|
[[package]]
|
|
name = "winapi-x86_64-pc-windows-gnu"
|
|
version = "0.4.0"
|
|
diff --git a/Cargo.toml b/Cargo.toml
|
|
index 4b7e4214..77a412c0 100644
|
|
--- a/Cargo.toml
|
|
+++ b/Cargo.toml
|
|
@@ -85,7 +85,6 @@ assert_cmd = "2.0.2"
|
|
cairo-rs = { version = "0.15", features = ["png"] }
|
|
cast = "0.3.0"
|
|
chrono = "0.4.0"
|
|
-criterion = "0.3"
|
|
glib = "0.15"
|
|
libc = "0.2"
|
|
lopdf = "0.26.0"
|
|
--
|
|
2.37.3
|
|
|