346ba30eeb
All of the rust deps are now packaged in Fedora (with the exception of the 'criterion' crate, but that one is only required for benchmarking which we don't do during package builds) so we can stop using the bundled ones.
55 lines
1.6 KiB
Diff
55 lines
1.6 KiB
Diff
From b0c51b70ba88778bceaef6a09645d50b7c47ad4b Mon Sep 17 00:00:00 2001
|
|
From: Kalev Lember <klember@redhat.com>
|
|
Date: Fri, 9 Sep 2022 11:53:06 +0200
|
|
Subject: [PATCH 1/3] Update the nalgebra crate
|
|
|
|
---
|
|
Cargo.lock | 8 ++++----
|
|
Cargo.toml | 2 +-
|
|
2 files changed, 5 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/Cargo.lock b/Cargo.lock
|
|
index 05992853..11a89191 100644
|
|
--- a/Cargo.lock
|
|
+++ b/Cargo.lock
|
|
@@ -1047,9 +1047,9 @@ dependencies = [
|
|
|
|
[[package]]
|
|
name = "nalgebra"
|
|
-version = "0.29.0"
|
|
+version = "0.30.1"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "d506eb7e08d6329505faa8a3a00a5dcc6de9f76e0c77e4b75763ae3c770831ff"
|
|
+checksum = "4fb2d0de08694bed883320212c18ee3008576bfe8c306f4c3c4a58b4876998be"
|
|
dependencies = [
|
|
"approx",
|
|
"matrixmultiply",
|
|
@@ -1898,9 +1898,9 @@ checksum = "ae1a47186c03a32177042e55dbc5fd5aee900b8e0069a8d70fba96a9375cd012"
|
|
|
|
[[package]]
|
|
name = "simba"
|
|
-version = "0.6.0"
|
|
+version = "0.7.2"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "f0b7840f121a46d63066ee7a99fc81dcabbc6105e437cae43528cea199b5a05f"
|
|
+checksum = "c48e45e5961033db030b56ad67aef22e9c908c493a6e8348c0a0f6b93433cd77"
|
|
dependencies = [
|
|
"approx",
|
|
"num-complex",
|
|
diff --git a/Cargo.toml b/Cargo.toml
|
|
index 98ff1c20..4b7e4214 100644
|
|
--- a/Cargo.toml
|
|
+++ b/Cargo.toml
|
|
@@ -64,7 +64,7 @@ language-tags = "0.3.1"
|
|
libc = "0.2"
|
|
locale_config = "*" # recommended explicitly by locale_config's README.md
|
|
markup5ever = "0.10"
|
|
-nalgebra = "0.29.0"
|
|
+nalgebra = "0.30.1"
|
|
num-traits = "0.2"
|
|
once_cell = "1.2.0"
|
|
pango = { version = "0.15", features = ["v1_46"] }
|
|
--
|
|
2.37.3
|
|
|