346ba30eeb
All of the rust deps are now packaged in Fedora (with the exception of the 'criterion' crate, but that one is only required for benchmarking which we don't do during package builds) so we can stop using the bundled ones.
77 lines
1.8 KiB
Diff
77 lines
1.8 KiB
Diff
From 056e7554857b248dda01afbbb8cb062ffe6f6d9e Mon Sep 17 00:00:00 2001
|
|
From: Kalev Lember <klember@redhat.com>
|
|
Date: Tue, 8 Nov 2022 17:25:01 +0100
|
|
Subject: [PATCH 3/3] Update the lopdf crate
|
|
|
|
---
|
|
Cargo.lock | 19 ++++++++++---------
|
|
Cargo.toml | 2 +-
|
|
2 files changed, 11 insertions(+), 10 deletions(-)
|
|
|
|
diff --git a/Cargo.lock b/Cargo.lock
|
|
index 300c8758..3da93d02 100644
|
|
--- a/Cargo.lock
|
|
+++ b/Cargo.lock
|
|
@@ -889,28 +889,23 @@ dependencies = [
|
|
|
|
[[package]]
|
|
name = "lopdf"
|
|
-version = "0.26.0"
|
|
+version = "0.27.0"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "b49a0272112719d0037ab63d4bb67f73ba659e1e90bc38f235f163a457ac16f3"
|
|
+checksum = "8146695b97752d9c66da0092c6364f8f3ca683f5ea34341db21e5550c3b8c4f4"
|
|
dependencies = [
|
|
"chrono",
|
|
"dtoa",
|
|
"encoding",
|
|
"flate2",
|
|
"itoa 0.4.8",
|
|
+ "lazy_static",
|
|
"linked-hash-map",
|
|
"log",
|
|
- "lzw",
|
|
"pom",
|
|
"time 0.2.27",
|
|
+ "weezl",
|
|
]
|
|
|
|
-[[package]]
|
|
-name = "lzw"
|
|
-version = "0.10.0"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "7d947cbb889ed21c2a84be6ffbaebf5b4e0f4340638cba0444907e38b56be084"
|
|
-
|
|
[[package]]
|
|
name = "mac"
|
|
version = "0.1.1"
|
|
@@ -2243,6 +2238,12 @@ version = "0.2.82"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
checksum = "6598dd0bd3c7d51095ff6531a5b23e02acdc81804e30d8f07afb77b7215a140a"
|
|
|
|
+[[package]]
|
|
+name = "weezl"
|
|
+version = "0.1.7"
|
|
+source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
+checksum = "9193164d4de03a926d909d3bc7c30543cecb35400c02114792c2cae20d5e2dbb"
|
|
+
|
|
[[package]]
|
|
name = "wide"
|
|
version = "0.7.4"
|
|
diff --git a/Cargo.toml b/Cargo.toml
|
|
index 77a412c0..d62250df 100644
|
|
--- a/Cargo.toml
|
|
+++ b/Cargo.toml
|
|
@@ -87,7 +87,7 @@ cast = "0.3.0"
|
|
chrono = "0.4.0"
|
|
glib = "0.15"
|
|
libc = "0.2"
|
|
-lopdf = "0.26.0"
|
|
+lopdf = "0.27.0"
|
|
matches = "0.1"
|
|
pango = "0.15"
|
|
pangocairo = "0.15"
|
|
--
|
|
2.37.3
|
|
|