Update to 2.56.0

This commit is contained in:
Kalev Lember 2023-03-29 12:38:02 +02:00
parent 3a2c309854
commit 4f57677aa6
6 changed files with 70 additions and 360 deletions

1
.gitignore vendored
View File

@ -93,3 +93,4 @@ librsvg-2.31.0.tar.bz2
/librsvg-2.54.5.tar.xz
/librsvg-2.55.1.tar.xz
/librsvg-2.55.90.tar.xz
/librsvg-2.56.0.tar.xz

View File

@ -1,4 +1,4 @@
From 54fec1d6f28aac6083643a7c130f9ba59297e9b2 Mon Sep 17 00:00:00 2001
From c9209bf8c1aa2caf09865afe24d240a3aa24af7f Mon Sep 17 00:00:00 2001
From: Kalev Lember <klember@redhat.com>
Date: Tue, 8 Nov 2022 17:02:19 +0100
Subject: [PATCH] Fedora: Drop dependencies required for benchmarking
@ -10,15 +10,15 @@ during package builds.
1 file changed, 1 deletion(-)
diff --git a/Cargo.toml b/Cargo.toml
index ed4bf8de..1f18ab3e 100644
index a53470d4..0335eb19 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -90,7 +90,6 @@ assert_cmd = "2.0.2"
cairo-rs = { version = "0.16", features = ["png"] }
@@ -92,7 +92,6 @@ assert_cmd = "2.0.2"
cairo-rs = { version = "0.17", features = ["png"] }
cast = "0.3.0"
chrono = "0.4.0"
-criterion = "0.3"
glib = "0.16"
chrono = { version = "0.4.23", default-features = false, features = ["clock", "std"] }
-criterion = "0.4"
glib = "0.17"
libc = "0.2"
lopdf = "0.29.0"
--

View File

@ -0,0 +1,54 @@
From 5db78316922eeb161cc9e68b91bd85460f068091 Mon Sep 17 00:00:00 2001
From: Kalev Lember <klember@redhat.com>
Date: Fri, 24 Mar 2023 15:48:12 +0100
Subject: [PATCH] Remove unused chrono wasmbind feature
This helps with building librsvg on Fedora where the rust-chrono package
is built with the wasmbind feature disabled.
Part-of: <https://gitlab.gnome.org/GNOME/librsvg/-/merge_requests/819>
---
Cargo.lock | 2 --
Cargo.toml | 4 ++--
2 files changed, 2 insertions(+), 4 deletions(-)
diff --git a/Cargo.lock b/Cargo.lock
index d962869f..f1d6821a 100644
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -207,10 +207,8 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "4e3c5919066adf22df73762e50cffcde3a758f2a848b113b586d1f86728b673b"
dependencies = [
"iana-time-zone",
- "js-sys",
"num-integer",
"num-traits",
- "wasm-bindgen",
"winapi",
]
diff --git a/Cargo.toml b/Cargo.toml
index d9e066d4..a53470d4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -55,7 +55,7 @@ anyhow = "1.0"
byteorder = "1.4"
cairo-rs = { version = "0.17", features=["v1_16", "png", "pdf", "ps", "svg"] }
cast = "0.3.0"
-chrono = { version = "0.4.23", default-features = false, features = ["clock", "std", "wasmbind"] } # rsvg-convert
+chrono = { version = "0.4.23", default-features = false, features = ["clock", "std"] } # rsvg-convert
clap = { version = "4.0.17", features = ["cargo", "derive"] } # rsvg-convert
clap_complete = "4.0.5" # rsvg-convert
cssparser = "0.29.0"
@@ -91,7 +91,7 @@ anyhow = "1.0"
assert_cmd = "2.0.2"
cairo-rs = { version = "0.17", features = ["png"] }
cast = "0.3.0"
-chrono = { version = "0.4.23", default-features = false, features = ["clock", "std", "wasmbind"] }
+chrono = { version = "0.4.23", default-features = false, features = ["clock", "std"] }
criterion = "0.4"
glib = "0.17"
libc = "0.2"
--
2.39.2

View File

@ -1,349 +0,0 @@
From c7a97807bb3bd96f452dde103163f171be36864a Mon Sep 17 00:00:00 2001
From: Kalev Lember <klember@redhat.com>
Date: Tue, 8 Nov 2022 17:02:19 +0100
Subject: [PATCH] Fedora: Drop dependencies required for benchmarking
Drop criterion that is only required for benchmarking, which we don't do
during package builds.
---
Cargo.lock | 198 +----------------------------------------------------
Cargo.toml | 1 -
2 files changed, 3 insertions(+), 196 deletions(-)
diff --git a/Cargo.lock b/Cargo.lock
index dbd032fe..3d2ca998 100644
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -47,7 +47,7 @@ version = "2.0.6"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "ba45b8163c49ab5f972e59a8a5a03b6d2972619d486e19ec9fe744f7c2753d3c"
dependencies = [
- "bstr 1.0.1",
+ "bstr",
"doc-comment",
"predicates",
"predicates-core",
@@ -55,17 +55,6 @@ dependencies = [
"wait-timeout",
]
-[[package]]
-name = "atty"
-version = "0.2.14"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "d9b39be18770d11421cdb1b9947a45dd3f37e93092cbf377614828a319d5fee8"
-dependencies = [
- "hermit-abi 0.1.19",
- "libc",
- "winapi",
-]
-
[[package]]
name = "autocfg"
version = "1.1.0"
@@ -105,18 +94,6 @@ version = "0.1.6"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "0d8c1fef690941d3e7788d328517591fecc684c084084702d6ff1641e993699a"
-[[package]]
-name = "bstr"
-version = "0.2.17"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "ba3569f383e8f1598449f1a423e72e99569137b47740b1da11ef19af3d5c3223"
-dependencies = [
- "lazy_static",
- "memchr",
- "regex-automata",
- "serde",
-]
-
[[package]]
name = "bstr"
version = "1.0.1"
@@ -214,17 +191,6 @@ dependencies = [
"winapi",
]
-[[package]]
-name = "clap"
-version = "2.34.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "a0610544180c38b88101fecf2dd634b174a62eef6946f84dfc6a7127512b381c"
-dependencies = [
- "bitflags",
- "textwrap",
- "unicode-width",
-]
-
[[package]]
name = "clap"
version = "4.0.27"
@@ -246,7 +212,7 @@ version = "4.0.6"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "b7b3c9eae0de7bf8e3f904a5e40612b21fb2e2e566456d177809a48b892d24da"
dependencies = [
- "clap 4.0.27",
+ "clap",
]
[[package]]
@@ -314,42 +280,6 @@ dependencies = [
"cfg-if",
]
-[[package]]
-name = "criterion"
-version = "0.3.6"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "b01d6de93b2b6c65e17c634a26653a29d107b3c98c607c765bf38d041531cd8f"
-dependencies = [
- "atty",
- "cast",
- "clap 2.34.0",
- "criterion-plot",
- "csv",
- "itertools",
- "lazy_static",
- "num-traits",
- "oorandom",
- "plotters",
- "rayon",
- "regex",
- "serde",
- "serde_cbor",
- "serde_derive",
- "serde_json",
- "tinytemplate",
- "walkdir",
-]
-
-[[package]]
-name = "criterion-plot"
-version = "0.4.5"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "2673cc8207403546f45f5fd319a974b1e6983ad1a3ee7e6041650013be041876"
-dependencies = [
- "cast",
- "itertools",
-]
-
[[package]]
name = "crossbeam-channel"
version = "0.5.6"
@@ -420,28 +350,6 @@ dependencies = [
"syn 1.0.103",
]
-[[package]]
-name = "csv"
-version = "1.1.6"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "22813a6dc45b335f9bade10bf7271dc477e81113e89eb251a0bc2a8a81c536e1"
-dependencies = [
- "bstr 0.2.17",
- "csv-core",
- "itoa 0.4.8",
- "ryu",
- "serde",
-]
-
-[[package]]
-name = "csv-core"
-version = "0.1.10"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "2b2466559f260f48ad25fe6317b3c8dac77b5bdb5763ac7d9d6103530663bc90"
-dependencies = [
- "memchr",
-]
-
[[package]]
name = "cxx"
version = "1.0.82"
@@ -911,12 +819,6 @@ dependencies = [
"system-deps",
]
-[[package]]
-name = "half"
-version = "1.8.2"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "eabb4a44450da02c90444cf74558da904edde8fb4e9035a9a6a4e15445af0bd7"
-
[[package]]
name = "heck"
version = "0.4.0"
@@ -1074,9 +976,8 @@ dependencies = [
"cairo-rs",
"cast",
"chrono",
- "clap 4.0.27",
+ "clap",
"clap_complete",
- "criterion",
"cssparser",
"data-url",
"encoding",
@@ -1383,12 +1284,6 @@ version = "1.16.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "86f0b0d4bf799edbc74508c1e8bf170ff5f41238e5f8225603ca7caaae2b7860"
-[[package]]
-name = "oorandom"
-version = "11.1.3"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "0ab1bc2a289d34bd04a330323ac98a1b4bc82c9d9fcb1e66b63caa84da26b575"
-
[[package]]
name = "os_str_bytes"
version = "6.4.1"
@@ -1574,34 +1469,6 @@ version = "0.3.26"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "6ac9a59f73473f1b8d852421e59e64809f025994837ef743615c6d0c5b305160"
-[[package]]
-name = "plotters"
-version = "0.3.4"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "2538b639e642295546c50fcd545198c9d64ee2a38620a628724a3b266d5fbf97"
-dependencies = [
- "num-traits",
- "plotters-backend",
- "plotters-svg",
- "wasm-bindgen",
- "web-sys",
-]
-
-[[package]]
-name = "plotters-backend"
-version = "0.3.4"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "193228616381fecdc1224c62e96946dfbc73ff4384fba576e052ff8c1bea8142"
-
-[[package]]
-name = "plotters-svg"
-version = "0.3.3"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "f9a81d2759aae1dae668f783c308bc5c8ebd191ff4184aaa1b37f65a6ae5a56f"
-dependencies = [
- "plotters-backend",
-]
-
[[package]]
name = "png"
version = "0.17.7"
@@ -2005,15 +1872,6 @@ dependencies = [
"bytemuck",
]
-[[package]]
-name = "same-file"
-version = "1.0.6"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "93fc1dc3aaa9bfed95e02e6eadabb4baf7e3078b0bd1b4d7b6b0b68378900502"
-dependencies = [
- "winapi-util",
-]
-
[[package]]
name = "scopeguard"
version = "1.1.0"
@@ -2074,16 +1932,6 @@ dependencies = [
"serde_derive",
]
-[[package]]
-name = "serde_cbor"
-version = "0.11.2"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "2bef2ebfde456fb76bbcf9f59315333decc4fda0b2b44b420243c11e0f5ec1f5"
-dependencies = [
- "half",
- "serde",
-]
-
[[package]]
name = "serde_derive"
version = "1.0.147"
@@ -2348,15 +2196,6 @@ dependencies = [
"syn 0.15.44",
]
-[[package]]
-name = "textwrap"
-version = "0.11.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "d326610f408c7a4eb6f51c37c330e496b08506c9457c9d34287ecc38809fb060"
-dependencies = [
- "unicode-width",
-]
-
[[package]]
name = "thiserror"
version = "1.0.37"
@@ -2426,16 +2265,6 @@ dependencies = [
"syn 1.0.103",
]
-[[package]]
-name = "tinytemplate"
-version = "1.2.1"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "be4d6b5f19ff7664e8c98d03e2139cb510db9b0a60b55f8e8709b689d939b6bc"
-dependencies = [
- "serde",
- "serde_json",
-]
-
[[package]]
name = "tinyvec"
version = "1.6.0"
@@ -2537,17 +2366,6 @@ dependencies = [
"libc",
]
-[[package]]
-name = "walkdir"
-version = "2.3.2"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "808cf2735cd4b6866113f648b791c6adc5714537bc222d9347bb203386ffda56"
-dependencies = [
- "same-file",
- "winapi",
- "winapi-util",
-]
-
[[package]]
name = "wasi"
version = "0.9.0+wasi-snapshot-preview1"
@@ -2620,16 +2438,6 @@ version = "0.2.83"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "1c38c045535d93ec4f0b4defec448e4291638ee608530863b1e2ba115d4fff7f"
-[[package]]
-name = "web-sys"
-version = "0.3.60"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "bcda906d8be16e728fd5adc5b729afad4e444e106ab28cd1c7256e54fa61510f"
-dependencies = [
- "js-sys",
- "wasm-bindgen",
-]
-
[[package]]
name = "weezl"
version = "0.1.7"
diff --git a/Cargo.toml b/Cargo.toml
index ed4bf8de..1f18ab3e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -90,7 +90,6 @@ assert_cmd = "2.0.2"
cairo-rs = { version = "0.16", features = ["png"] }
cast = "0.3.0"
chrono = "0.4.0"
-criterion = "0.3"
glib = "0.16"
libc = "0.2"
lopdf = "0.29.0"
--
2.38.1

View File

@ -14,15 +14,16 @@
Name: librsvg2
Summary: An SVG library based on cairo
Version: 2.55.90
Version: 2.56.0
Release: 1%{?dist}
License: LGPLv2+
URL: https://wiki.gnome.org/Projects/LibRsvg
Source0: https://download.gnome.org/sources/librsvg/2.55/librsvg-%{version}.tar.xz
Source0: https://download.gnome.org/sources/librsvg/2.56/librsvg-%{version}.tar.xz
%if ! 0%{?bundled_rust_deps}
# Patches to build with Fedora-packaged rust crates
Patch: 0001-Remove-unused-chrono-wasmbind-feature.patch
Patch: 0001-Fedora-Drop-dependencies-required-for-benchmarking.patch
%endif
@ -112,7 +113,7 @@ chrpath --delete %{buildroot}%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbufloader
rm -f %{buildroot}%{_pkgdocdir}/COMPILING.md
%files
%doc code-of-conduct.md CONTRIBUTING.md README.md
%doc code-of-conduct.md NEWS README.md
%license COPYING.LIB
%{_libdir}/librsvg-2.so.*
%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbufloader-svg.so
@ -137,6 +138,9 @@ rm -f %{buildroot}%{_pkgdocdir}/COMPILING.md
%{_mandir}/man1/rsvg-convert.1*
%changelog
* Wed Mar 29 2023 Kalev Lember <klember@redhat.com> - 2.56.0-1
- Update to 2.56.0
* Thu Mar 02 2023 Kalev Lember <klember@redhat.com> - 2.55.90-1
- Update to 2.55.90

View File

@ -1 +1 @@
SHA512 (librsvg-2.55.90.tar.xz) = 514607e2cf963ed95637469a2b44f8c93eaaca56e65a3747219c1a5a22441caca4f708a3bce172c5ab111fdfe39f1de5800fd31dfb1fce29857fbd9e96025036
SHA512 (librsvg-2.56.0.tar.xz) = ba73d13418bfe5aeec8a25ab23bc64509fc145d45811bed18951579b1fa5687de4c49bbb4380f33ccf92bf0dccb0d3567e157e66437f42fed221db6bf238a4f0