9926ac3d6a
and use hex value for dump dir mode in configure Signed-off-by: Matej Habrnal <mhabrnal@redhat.com>
37 lines
1.2 KiB
Diff
37 lines
1.2 KiB
Diff
From 9f32aba65d3d56e42f22f6b4709fd5cfd8b93f4c Mon Sep 17 00:00:00 2001
|
|
From: Jakub Filak <jfilak@redhat.com>
|
|
Date: Wed, 26 Aug 2015 08:30:14 +0200
|
|
Subject: [PATCH] configure: use hex value for dump dir mode
|
|
|
|
The hex value is hard to understand but is supported by all languages
|
|
(Python, C, ...).
|
|
|
|
The octal value is an invalid token in Python3.
|
|
|
|
The value is exported in libreport pkg-config file and projects like
|
|
ABRT use the value in their source files (sed 's/.../.../').
|
|
|
|
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
|
---
|
|
configure.ac | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 81a5ada..c7b9ef8 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -316,8 +316,8 @@ AC_PATH_PROG(AUGPARSE, augparse, no)
|
|
|
|
AC_ARG_WITH([defaultdumpdirmode],
|
|
AS_HELP_STRING([--with-defaultdumpdirmode=OCTAL-MODE],
|
|
- [Default dump dir mode (default: 0640)]),
|
|
- [], [with_defaultdumpdirmode="0640"])
|
|
+ [Default dump dir mode (default: 0x1A0 (0640))]),
|
|
+ [], [with_defaultdumpdirmode="0x1A0"])
|
|
AC_SUBST([DEFAULT_DUMP_DIR_MODE], [$with_defaultdumpdirmode])
|
|
|
|
DUMP_DIR_OWNED_BY_USER=1
|
|
--
|
|
2.5.0
|
|
|