Remove useless items from BZ, add reporter version, update translation
This commit is contained in:
parent
82e5d2c698
commit
eaf24d6cc8
@ -0,0 +1,87 @@
|
|||||||
|
From 9d294341f62be3d3e2716eb6111cfe61a21d9c99 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jakub Filak <jfilak@redhat.com>
|
||||||
|
Date: Fri, 26 Apr 2013 16:54:22 +0200
|
||||||
|
Subject: [LIBREPORT PATCH 1/6] reporter-bugzilla: support new format keyword
|
||||||
|
%reporter
|
||||||
|
|
||||||
|
Readd lost information essential for bug fixing.
|
||||||
|
|
||||||
|
Example of line added to a bug report:
|
||||||
|
reporter: libreport-2.1.3.36.g5816.dirty
|
||||||
|
|
||||||
|
Related to #155
|
||||||
|
|
||||||
|
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
||||||
|
Signed-off-by: Martin Milata <mmilata@redhat.com>
|
||||||
|
---
|
||||||
|
src/plugins/bugzilla_format.conf | 1 +
|
||||||
|
src/plugins/bugzilla_format_kernel.conf | 2 +-
|
||||||
|
src/plugins/bugzilla_format_libreport.conf | 1 +
|
||||||
|
src/plugins/bugzilla_formatdup.conf | 1 +
|
||||||
|
src/plugins/reporter-bugzilla.c | 4 ++++
|
||||||
|
5 files changed, 8 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/plugins/bugzilla_format.conf b/src/plugins/bugzilla_format.conf
|
||||||
|
index b06e68a..f668d17 100644
|
||||||
|
--- a/src/plugins/bugzilla_format.conf
|
||||||
|
+++ b/src/plugins/bugzilla_format.conf
|
||||||
|
@@ -48,6 +48,7 @@ Additional info:: \
|
||||||
|
-analyzer,-count,-duphash,-uuid,-abrt_version,\
|
||||||
|
-username,-hostname,-os_release,-os_info,\
|
||||||
|
-time,-pid,-pwd,\
|
||||||
|
+ %reporter,\
|
||||||
|
%oneline
|
||||||
|
|
||||||
|
Truncated backtrace:: %bare_%short_backtrace
|
||||||
|
diff --git a/src/plugins/bugzilla_format_kernel.conf b/src/plugins/bugzilla_format_kernel.conf
|
||||||
|
index c32e424..e46af89 100644
|
||||||
|
--- a/src/plugins/bugzilla_format_kernel.conf
|
||||||
|
+++ b/src/plugins/bugzilla_format_kernel.conf
|
||||||
|
@@ -40,6 +40,6 @@
|
||||||
|
|
||||||
|
Description of problem:: %bare_comment
|
||||||
|
|
||||||
|
-Additional info:: %bare_backtrace
|
||||||
|
+Additional info:: %reporter, %bare_backtrace
|
||||||
|
|
||||||
|
%attach:: dmesg
|
||||||
|
diff --git a/src/plugins/bugzilla_format_libreport.conf b/src/plugins/bugzilla_format_libreport.conf
|
||||||
|
index e5b3870..40428a5 100644
|
||||||
|
--- a/src/plugins/bugzilla_format_libreport.conf
|
||||||
|
+++ b/src/plugins/bugzilla_format_libreport.conf
|
||||||
|
@@ -50,6 +50,7 @@ Additional info:: \
|
||||||
|
-analyzer,-count,-duphash,-uuid,-abrt_version,\
|
||||||
|
-username,-hostname,-os_release,-os_info,\
|
||||||
|
-time,-pid,-pwd,\
|
||||||
|
+ %reporter,\
|
||||||
|
%oneline
|
||||||
|
|
||||||
|
Truncated backtrace:: %bare_%short_backtrace
|
||||||
|
diff --git a/src/plugins/bugzilla_formatdup.conf b/src/plugins/bugzilla_formatdup.conf
|
||||||
|
index 2ec183e..99f63c2 100644
|
||||||
|
--- a/src/plugins/bugzilla_formatdup.conf
|
||||||
|
+++ b/src/plugins/bugzilla_formatdup.conf
|
||||||
|
@@ -49,4 +49,5 @@
|
||||||
|
-username,-hostname,-os_release,-os_info,\
|
||||||
|
-time,-pid,-pwd,\
|
||||||
|
-var_log_messages,\
|
||||||
|
+ %reporter,\
|
||||||
|
%oneline
|
||||||
|
diff --git a/src/plugins/reporter-bugzilla.c b/src/plugins/reporter-bugzilla.c
|
||||||
|
index e9e0a70..d0e04b6 100644
|
||||||
|
--- a/src/plugins/reporter-bugzilla.c
|
||||||
|
+++ b/src/plugins/reporter-bugzilla.c
|
||||||
|
@@ -436,6 +436,10 @@ int append_item(struct strbuf *result, const char *item_name, problem_data_t *pd
|
||||||
|
if (strcmp(item_name, "%short_backtrace") == 0)
|
||||||
|
return append_short_backtrace(result, pd, CD_TEXT_ATT_SIZE_BZ, print_item_name);
|
||||||
|
|
||||||
|
+ /* Compat with previously-existed ad-hockery: %reporter */
|
||||||
|
+ if (strcmp(item_name, "%reporter") == 0)
|
||||||
|
+ return append_text(result, "reporter", PACKAGE"-"VERSION, print_item_name);
|
||||||
|
+
|
||||||
|
/* %oneline,%multiline,%text */
|
||||||
|
bool oneline = (strcmp(item_name+1, "oneline" ) == 0);
|
||||||
|
bool multiline = (strcmp(item_name+1, "multiline") == 0);
|
||||||
|
--
|
||||||
|
1.8.1.4
|
||||||
|
|
@ -0,0 +1,61 @@
|
|||||||
|
From 68a5b3036bb7d4b4b095a34d85a8873bcb5a442b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jakub Filak <jfilak@redhat.com>
|
||||||
|
Date: Fri, 26 Apr 2013 16:54:23 +0200
|
||||||
|
Subject: [LIBREPORT PATCH 2/6] reporter-bugzilla: remove recently added aux.
|
||||||
|
files from bz reports
|
||||||
|
|
||||||
|
last_occurrence - holds a time stamp of last problem occurrence
|
||||||
|
ureports_counter - holds a number of sent ureports
|
||||||
|
|
||||||
|
Closes #155
|
||||||
|
|
||||||
|
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
||||||
|
Signed-off-by: Martin Milata <mmilata@redhat.com>
|
||||||
|
---
|
||||||
|
src/plugins/bugzilla_format.conf | 2 +-
|
||||||
|
src/plugins/bugzilla_format_libreport.conf | 2 +-
|
||||||
|
src/plugins/bugzilla_formatdup.conf | 2 +-
|
||||||
|
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/plugins/bugzilla_format.conf b/src/plugins/bugzilla_format.conf
|
||||||
|
index f668d17..cad5876 100644
|
||||||
|
--- a/src/plugins/bugzilla_format.conf
|
||||||
|
+++ b/src/plugins/bugzilla_format.conf
|
||||||
|
@@ -47,7 +47,7 @@ Additional info:: \
|
||||||
|
-component,-architecture,\
|
||||||
|
-analyzer,-count,-duphash,-uuid,-abrt_version,\
|
||||||
|
-username,-hostname,-os_release,-os_info,\
|
||||||
|
- -time,-pid,-pwd,\
|
||||||
|
+ -time,-pid,-pwd,-last_occurrence,-ureports_counter,\
|
||||||
|
%reporter,\
|
||||||
|
%oneline
|
||||||
|
|
||||||
|
diff --git a/src/plugins/bugzilla_format_libreport.conf b/src/plugins/bugzilla_format_libreport.conf
|
||||||
|
index 40428a5..2ecdf6f 100644
|
||||||
|
--- a/src/plugins/bugzilla_format_libreport.conf
|
||||||
|
+++ b/src/plugins/bugzilla_format_libreport.conf
|
||||||
|
@@ -49,7 +49,7 @@ Additional info:: \
|
||||||
|
-component,-architecture,\
|
||||||
|
-analyzer,-count,-duphash,-uuid,-abrt_version,\
|
||||||
|
-username,-hostname,-os_release,-os_info,\
|
||||||
|
- -time,-pid,-pwd,\
|
||||||
|
+ -time,-pid,-pwd,-last_occurrence,-ureports_counter,\
|
||||||
|
%reporter,\
|
||||||
|
%oneline
|
||||||
|
|
||||||
|
diff --git a/src/plugins/bugzilla_formatdup.conf b/src/plugins/bugzilla_formatdup.conf
|
||||||
|
index 99f63c2..f5e89f7 100644
|
||||||
|
--- a/src/plugins/bugzilla_formatdup.conf
|
||||||
|
+++ b/src/plugins/bugzilla_formatdup.conf
|
||||||
|
@@ -47,7 +47,7 @@
|
||||||
|
-component,-architecture,\
|
||||||
|
-analyzer,-count,-duphash,-uuid,-abrt_version,\
|
||||||
|
-username,-hostname,-os_release,-os_info,\
|
||||||
|
- -time,-pid,-pwd,\
|
||||||
|
+ -time,-pid,-pwd,-last_occurrence,-ureports_counter,\
|
||||||
|
-var_log_messages,\
|
||||||
|
%reporter,\
|
||||||
|
%oneline
|
||||||
|
--
|
||||||
|
1.8.1.4
|
||||||
|
|
@ -0,0 +1,73 @@
|
|||||||
|
From ba41acbee0b8d65ccfac89265a2b6e84c6e0bf7a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michal Toman <mtoman@redhat.com>
|
||||||
|
Date: Fri, 26 Apr 2013 09:20:34 +0200
|
||||||
|
Subject: [LIBREPORT PATCH 3/6] do not build or install any piece of BZ when
|
||||||
|
--without-bugzilla
|
||||||
|
|
||||||
|
Signed-off-by: Michal Toman <mtoman@redhat.com>
|
||||||
|
Signed-off-by: Jiri Moskovcak <jmoskovc@redhat.com>
|
||||||
|
---
|
||||||
|
configure.ac | 23 +++++++++++++++++++++++
|
||||||
|
src/plugins/Makefile.am | 5 ++---
|
||||||
|
2 files changed, 25 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 67310d1..179add8 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -104,8 +104,31 @@ XMLRPC_CLIENT_CFLAGS=`xmlrpc-c-config client --cflags 2> /dev/null`
|
||||||
|
XMLRPC_CLIENT_LIBS=`xmlrpc-c-config client --libs 2> /dev/null`
|
||||||
|
AC_SUBST(XMLRPC_CLIENT_CFLAGS)
|
||||||
|
AC_SUBST(XMLRPC_CLIENT_LIBS)
|
||||||
|
+
|
||||||
|
+# enable bugzilla translations
|
||||||
|
+for FILE in `grep "#.*ugzilla.*" po/POTFILES.in`
|
||||||
|
+do
|
||||||
|
+ sed -ie "s,$FILE,${FILE:1}," po/POTFILES.in
|
||||||
|
+ sed -ie "\,^${FILE:1}$,d" po/POTFILES.skip
|
||||||
|
+done
|
||||||
|
else
|
||||||
|
AM_CONDITIONAL(BUILD_BUGZILLA, false)
|
||||||
|
+
|
||||||
|
+# disablie bugzilla translations
|
||||||
|
+for FILE in `grep "ugzilla" po/POTFILES.in`
|
||||||
|
+do
|
||||||
|
+ if test "${FILE:0:1}" = "#"
|
||||||
|
+ then
|
||||||
|
+ continue
|
||||||
|
+ fi
|
||||||
|
+
|
||||||
|
+ sed -ie "s,$FILE,#$FILE," po/POTFILES.in
|
||||||
|
+ grep "$FILE" po/POTFILES.skip > /dev/null 2>&1
|
||||||
|
+ if test $?
|
||||||
|
+ then
|
||||||
|
+ echo "$FILE" >> po/POTFILES.skip
|
||||||
|
+ fi
|
||||||
|
+done
|
||||||
|
fi dnl end NO_BUGZILLA
|
||||||
|
|
||||||
|
AC_PATH_PROG([PYTHON_CONFIG], [python-config], [no])
|
||||||
|
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
|
||||||
|
index 79fe9d2..16ff97c 100644
|
||||||
|
--- a/src/plugins/Makefile.am
|
||||||
|
+++ b/src/plugins/Makefile.am
|
||||||
|
@@ -62,14 +62,13 @@ eventsconfdir = $(EVENTS_CONF_DIR)
|
||||||
|
dist_eventsconf_DATA = \
|
||||||
|
mailx_event.conf \
|
||||||
|
print_event.conf \
|
||||||
|
- bugzilla_event.conf \
|
||||||
|
rhtsupport_event.conf \
|
||||||
|
uploader_event.conf \
|
||||||
|
- emergencyanalysis_event.conf \
|
||||||
|
- bugzilla_anaconda_event.conf
|
||||||
|
+ emergencyanalysis_event.conf
|
||||||
|
|
||||||
|
reporters_extra_dist =
|
||||||
|
if BUILD_BUGZILLA
|
||||||
|
+dist_eventsconf_DATA += bugzilla_event.conf bugzilla_anaconda_event.conf
|
||||||
|
reporters_extra_dist += report_Bugzilla.xml.in report_Bugzilla.conf
|
||||||
|
endif
|
||||||
|
|
||||||
|
--
|
||||||
|
1.8.1.4
|
||||||
|
|
157
0004-do-not-build-or-install-BZ-dependencies-when-without.patch
Normal file
157
0004-do-not-build-or-install-BZ-dependencies-when-without.patch
Normal file
@ -0,0 +1,157 @@
|
|||||||
|
From 96f766fbf741ebef67d9ef3aa9256f9e94bd24be Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michal Toman <mtoman@redhat.com>
|
||||||
|
Date: Fri, 26 Apr 2013 09:20:35 +0200
|
||||||
|
Subject: [LIBREPORT PATCH 4/6] do not build or install BZ dependencies when
|
||||||
|
--without-bugzilla
|
||||||
|
|
||||||
|
Signed-off-by: Michal Toman <mtoman@redhat.com>
|
||||||
|
Signed-off-by: Jiri Moskovcak <jmoskovc@redhat.com>
|
||||||
|
---
|
||||||
|
configure.ac | 8 ++++----
|
||||||
|
doc/Makefile.am | 2 +-
|
||||||
|
src/plugins/Makefile.am | 9 ++++++---
|
||||||
|
src/workflows/Makefile.am | 22 +++++++++++++++++-----
|
||||||
|
4 files changed, 28 insertions(+), 13 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 179add8..cef8b64 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -105,8 +105,8 @@ XMLRPC_CLIENT_LIBS=`xmlrpc-c-config client --libs 2> /dev/null`
|
||||||
|
AC_SUBST(XMLRPC_CLIENT_CFLAGS)
|
||||||
|
AC_SUBST(XMLRPC_CLIENT_LIBS)
|
||||||
|
|
||||||
|
-# enable bugzilla translations
|
||||||
|
-for FILE in `grep "#.*ugzilla.*" po/POTFILES.in`
|
||||||
|
+# enable bugzilla & deps translations
|
||||||
|
+for FILE in `grep -e "#.*ugzilla.*" -e "#.*naconda.*" po/POTFILES.in`
|
||||||
|
do
|
||||||
|
sed -ie "s,$FILE,${FILE:1}," po/POTFILES.in
|
||||||
|
sed -ie "\,^${FILE:1}$,d" po/POTFILES.skip
|
||||||
|
@@ -114,8 +114,8 @@ done
|
||||||
|
else
|
||||||
|
AM_CONDITIONAL(BUILD_BUGZILLA, false)
|
||||||
|
|
||||||
|
-# disablie bugzilla translations
|
||||||
|
-for FILE in `grep "ugzilla" po/POTFILES.in`
|
||||||
|
+# disablie bugzilla & deps translations
|
||||||
|
+for FILE in `grep -e "ugzilla" -e "naconda" po/POTFILES.in`
|
||||||
|
do
|
||||||
|
if test "${FILE:0:1}" = "#"
|
||||||
|
then
|
||||||
|
diff --git a/doc/Makefile.am b/doc/Makefile.am
|
||||||
|
index fc5241d..b52a043 100644
|
||||||
|
--- a/doc/Makefile.am
|
||||||
|
+++ b/doc/Makefile.am
|
||||||
|
@@ -12,6 +12,7 @@ MAN1_TXT += report-cli.txt
|
||||||
|
|
||||||
|
if BUILD_BUGZILLA
|
||||||
|
MAN1_TXT += reporter-bugzilla.txt
|
||||||
|
+MAN1_TXT += report.txt
|
||||||
|
endif
|
||||||
|
|
||||||
|
MAN1_TXT += reporter-kerneloops.txt
|
||||||
|
@@ -19,7 +20,6 @@ MAN1_TXT += reporter-mailx.txt
|
||||||
|
MAN1_TXT += reporter-print.txt
|
||||||
|
MAN1_TXT += reporter-rhtsupport.txt
|
||||||
|
MAN1_TXT += reporter-upload.txt
|
||||||
|
-MAN1_TXT += report.txt
|
||||||
|
|
||||||
|
MAN5_TXT =
|
||||||
|
MAN5_TXT += report_event.conf.txt
|
||||||
|
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
|
||||||
|
index 16ff97c..129b436 100644
|
||||||
|
--- a/src/plugins/Makefile.am
|
||||||
|
+++ b/src/plugins/Makefile.am
|
||||||
|
@@ -2,7 +2,9 @@ pluginslibdir = $(PLUGINS_LIB_DIR)
|
||||||
|
|
||||||
|
reporters_bin =
|
||||||
|
if BUILD_BUGZILLA
|
||||||
|
-reporters_bin += reporter-bugzilla
|
||||||
|
+reporters_bin += \
|
||||||
|
+ reporter-bugzilla \
|
||||||
|
+ report
|
||||||
|
endif
|
||||||
|
|
||||||
|
if BUILD_UREPORT
|
||||||
|
@@ -14,8 +16,7 @@ bin_PROGRAMS = $(reporters_bin) \
|
||||||
|
reporter-kerneloops \
|
||||||
|
reporter-upload \
|
||||||
|
reporter-mailx \
|
||||||
|
- reporter-print \
|
||||||
|
- report
|
||||||
|
+ reporter-print
|
||||||
|
|
||||||
|
pluginsconfdir = $(PLUGINS_CONF_DIR)
|
||||||
|
|
||||||
|
@@ -218,6 +219,7 @@ reporter_print_CPPFLAGS = \
|
||||||
|
reporter_print_LDADD = \
|
||||||
|
../lib/libreport.la
|
||||||
|
|
||||||
|
+if BUILD_BUGZILLA
|
||||||
|
report_SOURCES = \
|
||||||
|
report.c
|
||||||
|
report_CPPFLAGS = \
|
||||||
|
@@ -235,6 +237,7 @@ report_CPPFLAGS = \
|
||||||
|
-D_GNU_SOURCE
|
||||||
|
report_LDADD = \
|
||||||
|
../lib/libreport.la
|
||||||
|
+endif
|
||||||
|
|
||||||
|
if BUILD_UREPORT
|
||||||
|
reporter_ureport_SOURCES = \
|
||||||
|
diff --git a/src/workflows/Makefile.am b/src/workflows/Makefile.am
|
||||||
|
index 17e3f1a..45ba7e0 100644
|
||||||
|
--- a/src/workflows/Makefile.am
|
||||||
|
+++ b/src/workflows/Makefile.am
|
||||||
|
@@ -3,30 +3,42 @@ workflowsdir = $(WORKFLOWS_DIR)
|
||||||
|
dist_workflows_DATA = \
|
||||||
|
workflow_Fedora.xml \
|
||||||
|
workflow_Upload.xml \
|
||||||
|
- workflow_AnacondaFedora.xml \
|
||||||
|
- workflow_AnacondaUpload.xml \
|
||||||
|
workflow_RHELCCpp.xml \
|
||||||
|
workflow_RHELKerneloops.xml \
|
||||||
|
workflow_RHELPython.xml \
|
||||||
|
workflow_RHELvmcore.xml \
|
||||||
|
workflow_RHELxorg.xml
|
||||||
|
|
||||||
|
+if BUILD_BUGZILLA
|
||||||
|
+dist_workflows_DATA += \
|
||||||
|
+ workflow_AnacondaFedora.xml \
|
||||||
|
+ workflow_AnacondaUpload.xml
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
workflowsconfdir = $(WORKFLOWS_CONF_DIR)
|
||||||
|
|
||||||
|
dist_workflowsconf_DATA =\
|
||||||
|
report_fedora.conf \
|
||||||
|
- anaconda_event.conf \
|
||||||
|
report_rhel.conf
|
||||||
|
|
||||||
|
+if BUILD_BUGZILLA
|
||||||
|
+dist_workflowsconf_DATA += \
|
||||||
|
+ anaconda_event.conf
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
@INTLTOOL_XML_RULE@
|
||||||
|
|
||||||
|
EXTRA_DIST = \
|
||||||
|
workflow_Fedora.xml.in \
|
||||||
|
workflow_Upload.xml.in \
|
||||||
|
- workflow_AnacondaFedora.xml.in \
|
||||||
|
- workflow_AnacondaUpload.xml.in \
|
||||||
|
workflow_RHELCCpp.xml.in \
|
||||||
|
workflow_RHELKerneloops.xml.in \
|
||||||
|
workflow_RHELPython.xml.in \
|
||||||
|
workflow_RHELvmcore.xml.in \
|
||||||
|
workflow_RHELxorg.xml.in
|
||||||
|
+
|
||||||
|
+if BUILD_BUGZILLA
|
||||||
|
+EXTRA_DIST += \
|
||||||
|
+ workflow_AnacondaFedora.xml.in \
|
||||||
|
+ workflow_AnacondaUpload.xml.in
|
||||||
|
+endif
|
||||||
|
--
|
||||||
|
1.8.1.4
|
||||||
|
|
89306
0006-updated-translation.patch
Normal file
89306
0006-updated-translation.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -5,13 +5,20 @@
|
|||||||
Summary: Generic library for reporting various problems
|
Summary: Generic library for reporting various problems
|
||||||
Name: libreport
|
Name: libreport
|
||||||
Version: 2.1.4
|
Version: 2.1.4
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: https://fedorahosted.org/abrt/
|
URL: https://fedorahosted.org/abrt/
|
||||||
Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
|
Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
|
||||||
Source1: autogen.sh
|
Source1: autogen.sh
|
||||||
|
|
||||||
|
# Remove with 2.1.5
|
||||||
|
Patch1: 0001-reporter-bugzilla-support-new-format-keyword-reporte.patch
|
||||||
|
Patch2: 0002-reporter-bugzilla-remove-recently-added-aux.-files-f.patch
|
||||||
|
Patch3: 0003-do-not-build-or-install-any-piece-of-BZ-when-without.patch
|
||||||
|
Patch4: 0004-do-not-build-or-install-BZ-dependencies-when-without.patch
|
||||||
|
Patch6: 0006-updated-translation.patch
|
||||||
|
|
||||||
BuildRequires: dbus-devel
|
BuildRequires: dbus-devel
|
||||||
BuildRequires: gtk3-devel
|
BuildRequires: gtk3-devel
|
||||||
BuildRequires: curl-devel
|
BuildRequires: curl-devel
|
||||||
@ -269,6 +276,11 @@ infrastructure or uploading the gathered data over ftp/scp...
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
%patch6 -p1
|
||||||
# koji in f19 has new autotools, so we need to regenerate everything
|
# koji in f19 has new autotools, so we need to regenerate everything
|
||||||
cp %SOURCE1 %_builddir/%{name}-%{version}
|
cp %SOURCE1 %_builddir/%{name}-%{version}
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
@ -481,6 +493,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 03 2013 Jakub Filak <jfilak@redhat.com> 2.1.4-2
|
||||||
|
- update translation
|
||||||
|
- reporter-bugzilla: provide version of libreport
|
||||||
|
|
||||||
* Mon Apr 29 2013 Jakub Filak <jfilak@redhat.com> 2.1.4-1
|
* Mon Apr 29 2013 Jakub Filak <jfilak@redhat.com> 2.1.4-1
|
||||||
- support /etc/os-release
|
- support /etc/os-release
|
||||||
- added flag to not retry locking the incomplete problem dir
|
- added flag to not retry locking the incomplete problem dir
|
||||||
|
Loading…
Reference in New Issue
Block a user