- Add support for AlmaLinux Bug Tracker

- Remove libreport-rhel-bugzilla and libreport-rhel-anaconda-bugzilla
This commit is contained in:
eabdullin 2024-08-02 14:47:14 +03:00
parent b699c7bc88
commit d35bcfb167
2 changed files with 725 additions and 101 deletions

View File

@ -0,0 +1,669 @@
From 2774f9ed702c7b7f27aa2bee192cfe5457a81157 Mon Sep 17 00:00:00 2001
From: eabdullin <ed.abdullin.1@gmail.com>
Date: Mon, 5 Aug 2024 16:06:57 +0300
Subject: [PATCH] Add AlmaLinux plugin
---
doc/Makefile.am | 5 +-
doc/report_AlmaLinuxBugTracker.conf.txt | 45 +++++++++++++
doc/report_almalinux.conf.txt | 41 ++++++++++++
po/POTFILES.in | 10 +++
src/plugins/Makefile.am | 12 ++--
src/plugins/almalinux_report_event.conf | 38 +++++++++++
src/plugins/mantisbt.c | 4 +-
src/plugins/report_AlmaLinuxBugTracker.conf | 4 ++
src/plugins/report_AlmaLinuxBugTracker.xml.in | 66 +++++++++++++++++++
src/plugins/reporter-mantisbt.c | 4 +-
src/plugins/reporter-ureport.c | 2 +-
src/plugins/ureport.conf | 2 +-
src/workflows/Makefile.am | 25 ++++++-
src/workflows/report_almalinux.conf | 31 +++++++++
src/workflows/workflow_AlmaLinuxCCpp.xml.in | 12 ++++
src/workflows/workflow_AlmaLinuxJava.xml.in | 11 ++++
.../workflow_AlmaLinuxJavaScript.xml.in | 11 ++++
.../workflow_AlmaLinuxKerneloops.xml.in | 11 ++++
.../workflow_AlmaLinuxLibreport.xml.in | 9 +++
src/workflows/workflow_AlmaLinuxPython.xml.in | 11 ++++
.../workflow_AlmaLinuxPython3.xml.in | 11 ++++
src/workflows/workflow_AlmaLinuxVmcore.xml.in | 12 ++++
src/workflows/workflow_AlmaLinuxXorg.xml.in | 9 +++
23 files changed, 372 insertions(+), 14 deletions(-)
create mode 100644 doc/report_AlmaLinuxBugTracker.conf.txt
create mode 100644 doc/report_almalinux.conf.txt
create mode 100644 src/plugins/almalinux_report_event.conf
create mode 100644 src/plugins/report_AlmaLinuxBugTracker.conf
create mode 100644 src/plugins/report_AlmaLinuxBugTracker.xml.in
create mode 100644 src/workflows/report_almalinux.conf
create mode 100644 src/workflows/workflow_AlmaLinuxCCpp.xml.in
create mode 100644 src/workflows/workflow_AlmaLinuxJava.xml.in
create mode 100644 src/workflows/workflow_AlmaLinuxJavaScript.xml.in
create mode 100644 src/workflows/workflow_AlmaLinuxKerneloops.xml.in
create mode 100644 src/workflows/workflow_AlmaLinuxLibreport.xml.in
create mode 100644 src/workflows/workflow_AlmaLinuxPython.xml.in
create mode 100644 src/workflows/workflow_AlmaLinuxPython3.xml.in
create mode 100644 src/workflows/workflow_AlmaLinuxVmcore.xml.in
create mode 100644 src/workflows/workflow_AlmaLinuxXorg.xml.in
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 675d93a..e10b791 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -52,6 +52,7 @@ MAN5_TXT = \
mailx_event.conf.txt \
print_event.conf.txt \
report_event.conf.txt \
+ report_almalinux.conf.txt \
report_fedora.conf.txt \
report_centos.conf.txt \
report_Logger.conf.txt \
@@ -61,6 +62,7 @@ MAN5_TXT = \
report_uploader.conf.txt \
report_Uploader.conf.txt \
report_CentOSBugTracker.conf.txt \
+ report_AlmaLinuxBugTracker.conf.txt \
uploader_event.conf.txt \
ureport.conf.txt \
upload.conf.txt
@@ -73,7 +75,8 @@ EXTRA_DIST += $(MAN1_BUGZILLA) $(MAN5_BUGZILLA)
endif
MAN5_PREFORMATTED =
-MAN5_PREFORMATTED += centos_report_event.conf.5
+MAN5_PREFORMATTED += centos_report_event.conf.5 \
+ almalinux_report_event.conf.5
# Manual pages are generated from .txt via Docbook
man1_MANS = ${MAN1_TXT:%.txt=%.1}
diff --git a/doc/report_AlmaLinuxBugTracker.conf.txt b/doc/report_AlmaLinuxBugTracker.conf.txt
new file mode 100644
index 0000000..0c84f94
--- /dev/null
+++ b/doc/report_AlmaLinuxBugTracker.conf.txt
@@ -0,0 +1,45 @@
+report_AlmaLinuxBugTracker.conf(5)
+==================================
+
+NAME
+----
+report_AlmaLinuxBugTracker.conf - libreport's configuration file for 'report_AlmaLinuxBugTracker' events.
+
+DESCRIPTION
+-----------
+This configuration file contains values for options defined in
+/usr/share/libreport/events/report_AlmaLinuxBugTracker.xml
+
+Configuration file lines should have 'PARAM = VALUE' format. The parameters are:
+
+'Mantisbt_Login'::
+ Login to MantisBT account.
+
+'Mantisbt_Password'::
+ Password to MantisBT account.
+
+'Mantisbt_MantisbtURL'::
+ MantisBT HTTP(S) address. (default: https://bugs.almalinux.org)
+
+'Mantisbt_SSLVerify'::
+ Use yes/true/on/1 to verify server's SSL certificate. (default: yes)
+
+'Mantisbt_Project'::
+ Project issue field value. Useful if you needed different project than specified in /etc/os-release
+
+'Mantisbt_ProjectVersion'::
+ Version issue field value. Useful if you needed different project version than specified in /etc/os-release
+
+'http_proxy'::
+ the proxy server to use for HTTP
+
+'HTTPS_PROXY'::
+ the proxy server to use for HTTPS
+
+SEE ALSO
+--------
+report_event.conf(5), reporter-mantisbt(1)
+
+AUTHOR
+------
+* AlmaLinux team
diff --git a/doc/report_almalinux.conf.txt b/doc/report_almalinux.conf.txt
new file mode 100644
index 0000000..613545a
--- /dev/null
+++ b/doc/report_almalinux.conf.txt
@@ -0,0 +1,41 @@
+report_almalinux.conf(5)
+========================
+
+NAME
+----
+report_almalinux.conf - configuration file for libreport.
+
+DESCRIPTION
+-----------
+This configuration file specifies which of the reporting work flow definitions
+are applicable for all problems types on AlmaLinux.
+
+All applicable work flows are presented to users in User Interface as
+possibilities for processing of any problems. A particular work flow becomes
+applicable if its conditions are satisfied.
+
+This configuration file consists from one condition per line.
+
+Each condition line must start with EVENT=workflow_NAME where "workflow_" is
+constant prefix and "workflow_NAME" is base name of path to reporting work flow
+configuration file.
+
+The rest of condition line has form VAR=VAL, VAR!=VAL or VAL~=REGEX, where VAR
+is a name of problem directory element to be checked (for example,
+"executable", "package", hostname" etc). The condition may consists
+from as many element checks as it is necessary.
+
+EXAMPLES
+--------
+Condition line::
+ EVENT=workflow_AlmaLinuxCCpp analyzer=CCpp
+
+The condition line above expects existence of /usr/share/libreport/workflows/workflow_AlmaLinuxCCpp.xml
+
+SEE ALSO
+--------
+report-gtk(1)
+
+AUTHOR
+------
+* AlmaLinux team
diff --git a/po/POTFILES.in b/po/POTFILES.in
index dc11673..c66f123 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -41,6 +41,7 @@ src/plugins/reporter-print.c
src/plugins/reporter-systemd-journal.c
src/plugins/reporter-upload.c
src/plugins/reporter-mantisbt.c
+src/plugins/report_AlmaLinuxBugTracker.xml.in
src/plugins/report_CentOSBugTracker.xml.in
src/plugins/report_Kerneloops.xml.in
src/plugins/report_Logger.xml.in
@@ -60,6 +61,15 @@ src/client-python/reportclient/internal/reported_to.py
src/client-python/reportclient/internal/report_result.py
src/client-python/reportclient/internal/utils.py
src/report-newt/report-newt.c
+src/workflows/workflow_AlmaLinuxCCpp.xml.in
+src/workflows/workflow_AlmaLinuxJava.xml.in
+src/workflows/workflow_AlmaLinuxJavaScript.xml.in
+src/workflows/workflow_AlmaLinuxKerneloops.xml.in
+src/workflows/workflow_AlmaLinuxLibreport.xml.in
+src/workflows/workflow_AlmaLinuxPython.xml.in
+src/workflows/workflow_AlmaLinuxPython3.xml.in
+src/workflows/workflow_AlmaLinuxVmcore.xml.in
+src/workflows/workflow_AlmaLinuxXorg.xml.in
src/workflows/workflow_AnacondaFedora.xml.in
src/workflows/workflow_AnacondaRHELBugzilla.xml.in
src/workflows/workflow_AnacondaUpload.xml.in
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 6145c9d..5706f6e 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -68,9 +68,11 @@ reporters_events_conf += report_Bugzilla.conf
endif
if BUILD_MANTISBT
-reporters_events += report_CentOSBugTracker.xml
+reporters_events += report_CentOSBugTracker.xml \
+ report_AlmaLinuxBugTracker.xml
-reporters_events_conf += report_CentOSBugTracker.conf
+reporters_events_conf += report_CentOSBugTracker.conf \
+ report_AlmaLinuxBugTracker.conf
endif
if BUILD_UREPORT
@@ -95,7 +97,8 @@ dist_eventsdef_DATA = \
mailx_event.conf \
print_event.conf \
uploader_event.conf \
- centos_report_event.conf
+ centos_report_event.conf \
+ almalinux_report_event.conf
reporters_extra_dist =
if BUILD_BUGZILLA
@@ -109,7 +112,8 @@ reporters_extra_dist += report_uReport.xml.in
endif
if BUILD_MANTISBT
-reporters_extra_dist += report_CentOSBugTracker.xml.in
+reporters_extra_dist += report_CentOSBugTracker.xml.in \
+ report_AlmaLinuxBugTracker.xml.in
endif
EXTRA_DIST = $(reporters_extra_dist) \
diff --git a/src/plugins/almalinux_report_event.conf b/src/plugins/almalinux_report_event.conf
new file mode 100644
index 0000000..635a50e
--- /dev/null
+++ b/src/plugins/almalinux_report_event.conf
@@ -0,0 +1,38 @@
+EVENT=report_AlmaLinuxBugTracker type=xorg
+ reporter-mantisbt
+
+EVENT=report_AlmaLinuxBugTracker type=Kerneloops
+ reporter-mantisbt
+
+EVENT=report_AlmaLinuxBugTracker type=vmcore
+ reporter-mantisbt
+
+EVENT=report_AlmaLinuxBugTracker type=Python component!=anaconda
+ test -f component || abrt-action-save-package-data
+ reporter-mantisbt \
+ -F /etc/libreport/plugins/mantisbt_format.conf \
+ -A /etc/libreport/plugins/mantisbt_formatdup.conf
+
+EVENT=report_AlmaLinuxBugTracker type=Python3 component!=anaconda
+ test -f component || abrt-action-save-package-data
+ reporter-mantisbt \
+ -F /etc/libreport/plugins/mantisbt_format.conf \
+ -A /etc/libreport/plugins/mantisbt_formatdup.conf
+
+EVENT=report_AlmaLinuxBugTracker type=CCpp duphash!=
+ test -f component || abrt-action-save-package-data
+ component="`cat component`"
+ format="mantisbt_format.conf"
+ test -f "/etc/libreport/plugins/mantisbt_format_$component.conf" \
+ && format="mantisbt_format_$component.conf"
+ formatdup="mantisbt_formatdup.conf"
+ test -f "/etc/libreport/plugins/mantisbt_formatdup_$component.conf" \
+ && formatdup="mantisbt_formatdup_$component.conf"
+ reporter-mantisbt \
+ -F "/etc/libreport/plugins/$format" \
+ -A "/etc/libreport/plugins/$formatdup"
+
+EVENT=report_AlmaLinuxBugTracker analyzer=libreport
+ reporter-mantisbt \
+ -F /etc/libreport/plugins/mantisbt_format_analyzer_libreport.conf \
+ -A /etc/libreport/plugins/mantisbt_formatdup_analyzer_libreport.conf
diff --git a/src/plugins/mantisbt.c b/src/plugins/mantisbt.c
index eef2c76..cd98c8d 100644
--- a/src/plugins/mantisbt.c
+++ b/src/plugins/mantisbt.c
@@ -335,7 +335,7 @@ soap_add_new_issue_parameters(soap_request_t *req,
error_msg_and_die(_("SOAP: Failed to create a new property in custom fields."));
}
- soap_node_add_child_node(issue_node, "os_build", SOAP_STRING, version);
+ soap_node_add_child_node(issue_node, "version", SOAP_STRING, version);
soap_node_add_child_node(issue_node, "category", SOAP_STRING, category);
soap_node_add_child_node(issue_node, "summary", SOAP_STRING, summary);
soap_node_add_child_node(issue_node, "description", SOAP_STRING, description);
@@ -862,7 +862,7 @@ mantisbt_search_duplicate_issues(mantisbt_settings_t *settings, const char *cate
// version
if (version != NULL)
- soap_filter_add_new_array_parameter(filter_node, "os_build", SOAP_STRINGARRAY, version);
+ soap_filter_add_new_array_parameter(filter_node, "version", SOAP_STRINGARRAY, version);
soap_request_add_method_parameter(req, "page_number", SOAP_INTEGER, "1");
soap_request_add_method_parameter(req, "per_page", SOAP_INTEGER, /* -1 means get all issues */ "-1");
diff --git a/src/plugins/report_AlmaLinuxBugTracker.conf b/src/plugins/report_AlmaLinuxBugTracker.conf
new file mode 100644
index 0000000..bcbf370
--- /dev/null
+++ b/src/plugins/report_AlmaLinuxBugTracker.conf
@@ -0,0 +1,4 @@
+Mantisbt_MantisbtURL = https://bugs.almalinux.org
+Mantisbt_Login =
+Mantisbt_Password =
+Mantisbt_SSLVerify = yes
diff --git a/src/plugins/report_AlmaLinuxBugTracker.xml.in b/src/plugins/report_AlmaLinuxBugTracker.xml.in
new file mode 100644
index 0000000..2e7a246
--- /dev/null
+++ b/src/plugins/report_AlmaLinuxBugTracker.xml.in
@@ -0,0 +1,66 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<event>
+ <_name>AlmaLinux Bug Tracker</_name>
+ <_description>Report to AlmaLinux Bug Tracker</_description>
+
+ <requires-items>component,duphash,os_release</requires-items>
+ <exclude-items-by-default>coredump,count,event_log,reported_to,vmcore</exclude-items-by-default>
+ <exclude-items-always></exclude-items-always>
+ <exclude-binary-items>no</exclude-binary-items>
+ <include-items-by-default></include-items-by-default>
+ <minimal-rating>3</minimal-rating>
+ <gui-review-elements>yes</gui-review-elements>
+ <support-restricted-access optionname="Mantisbt_CreatePrivate">yes</support-restricted-access>
+
+ <options>
+ <option type="text" name="Mantisbt_Login">
+ <_label>User name</_label>
+ <allow-empty>no</allow-empty>
+ <_description>AlmaLinux Bug Tracker account user name</_description>
+ <_note-html>You can create bugs.almalinux.org account &lt;a href="https://bugs.almalinux.org/signup_page.php"&gt;here&lt;/a&gt;</_note-html>
+ </option>
+ <option type="password" name="Mantisbt_Password">
+ <_label>Password</_label>
+ <allow-empty>no</allow-empty>
+ <_description>AlmaLinux Bug Tracker account password</_description>
+ </option>
+ <option type="bool" name="Mantisbt_CreatePrivate">
+ <_label>Restrict access</_label>
+ <_note-html>The issue will be accessible only to users with access to 'Private Issues'</_note-html>
+ <default-value>no</default-value>
+ </option>
+ <advanced-options>
+ <option type="text" name="Mantisbt_MantisbtURL">
+ <_label>AlmaLinux Bug Tracker URL</_label>
+ <allow-empty>no</allow-empty>
+ <_note-html>Address of AlmaLinux Bug Tracker server</_note-html>
+ <default-value>https://bugs.almalinux.org</default-value>
+ </option>
+ <option type="bool" name="Mantisbt_SSLVerify">
+ <_label>Verify SSL</_label>
+ <_note-html>Check SSL key validity</_note-html>
+ <default-value>yes</default-value>
+ </option>
+ <option type="text" name="Mantisbt_Project">
+ <_label>AlmaLinux Bug Tracker project</_label>
+ <allow-empty>yes</allow-empty>
+ <_note-html>Specify this only if you needed different project than specified in /etc/os-release</_note-html>
+ </option>
+ <option type="text" name="Mantisbt_ProjectVersion">
+ <_label>AlmaLinux Bug Tracker project version</_label>
+ <allow-empty>yes</allow-empty>
+ <_note-html>Specify this only if you needed different project version than specified in /etc/os-release</_note-html>
+ </option>
+ <option type="text" name="http_proxy">
+ <_label>HTTP Proxy</_label>
+ <allow-empty>yes</allow-empty>
+ <_note-html>Sets the proxy server to use for HTTP</_note-html>
+ </option>
+ <option type="text" name="HTTPS_PROXY">
+ <_label>HTTPS Proxy</_label>
+ <allow-empty>yes</allow-empty>
+ <_note-html>Sets the proxy server to use for HTTPS</_note-html>
+ </option>
+ </advanced-options>
+ </options>
+</event>
diff --git a/src/plugins/reporter-mantisbt.c b/src/plugins/reporter-mantisbt.c
index e68aa3e..53fb949 100644
--- a/src/plugins/reporter-mantisbt.c
+++ b/src/plugins/reporter-mantisbt.c
@@ -25,11 +25,11 @@
static void
parse_osinfo_for_mantisbt(GHashTable *osinfo, char** project, char** version)
{
- const char *name = g_hash_table_lookup(osinfo, "CENTOS_MANTISBT_PROJECT");
+ const char *name = g_hash_table_lookup(osinfo, "ALMALINUX_MANTISBT_PROJECT");
if (!name)
name = g_hash_table_lookup(osinfo, OSINFO_NAME);
- const char *version_id = g_hash_table_lookup(osinfo, "CENTOS_MANTISBT_PROJECT_VERSION");
+ const char *version_id = g_hash_table_lookup(osinfo, "ALMALINUX_MANTISBT_PROJECT_VERSION");
if (!version_id)
version_id = g_hash_table_lookup(osinfo, OSINFO_VERSION_ID);
diff --git a/src/plugins/reporter-ureport.c b/src/plugins/reporter-ureport.c
index d5f587c..0a9a28f 100644
--- a/src/plugins/reporter-ureport.c
+++ b/src/plugins/reporter-ureport.c
@@ -22,7 +22,7 @@
#include "ureport.h"
#include "libreport_curl.h"
-#define DEFAULT_WEB_SERVICE_URL "https://retrace.fedoraproject.org/faf"
+#define DEFAULT_WEB_SERVICE_URL "https://retrace.almalinux.org/faf"
int main(int argc, char **argv)
{
diff --git a/src/plugins/ureport.conf b/src/plugins/ureport.conf
index 240a8b6..6125690 100644
--- a/src/plugins/ureport.conf
+++ b/src/plugins/ureport.conf
@@ -1,5 +1,5 @@
# Base URL to uReport server
-# URL = https://retrace.fedoraproject.org/faf
+# URL = https://retrace.almalinux.org/faf
# no means that ssl certificates will not be checked
# SSLVerify = no
diff --git a/src/workflows/Makefile.am b/src/workflows/Makefile.am
index 4fa145f..b0460e6 100644
--- a/src/workflows/Makefile.am
+++ b/src/workflows/Makefile.am
@@ -28,7 +28,16 @@ dist_workflows_DATA += \
workflow_CentOSXorg.xml \
workflow_CentOSLibreport.xml \
workflow_CentOSJava.xml \
- workflow_CentOSJavaScript.xml
+ workflow_CentOSJavaScript.xml \
+ workflow_AlmaLinuxCCpp.xml \
+ workflow_AlmaLinuxKerneloops.xml \
+ workflow_AlmaLinuxPython.xml \
+ workflow_AlmaLinuxPython3.xml \
+ workflow_AlmaLinuxVmcore.xml \
+ workflow_AlmaLinuxXorg.xml \
+ workflow_AlmaLinuxLibreport.xml \
+ workflow_AlmaLinuxJava.xml \
+ workflow_AlmaLinuxJavaScript.xml
endif
if BUILD_BUGZILLA
@@ -54,7 +63,8 @@ dist_workflowsdef_DATA =\
report_mailx.conf \
report_logger.conf \
report_uploader.conf \
- report_centos.conf
+ report_centos.conf \
+ report_almalinux.conf
if BUILD_BUGZILLA
dist_workflowsdef_DATA += \
@@ -108,5 +118,14 @@ EXTRA_DIST += \
workflow_CentOSXorg.xml.in \
workflow_CentOSLibreport.xml.in \
workflow_CentOSJava.xml.in \
- workflow_CentOSJavaScript.xml.in
+ workflow_CentOSJavaScript.xml.in \
+ workflow_AlmaLinuxCCpp.xml.in \
+ workflow_AlmaLinuxKerneloops.xml.in \
+ workflow_AlmaLinuxPython.xml.in \
+ workflow_AlmaLinuxPython3.xml.in \
+ workflow_AlmaLinuxVmcore.xml.in \
+ workflow_AlmaLinuxXorg.xml.in \
+ workflow_AlmaLinuxLibreport.xml.in \
+ workflow_AlmaLinuxJava.xml.in \
+ workflow_AlmaLinuxJavaScript.xml.in
endif
diff --git a/src/workflows/report_almalinux.conf b/src/workflows/report_almalinux.conf
new file mode 100644
index 0000000..7700894
--- /dev/null
+++ b/src/workflows/report_almalinux.conf
@@ -0,0 +1,31 @@
+EVENT=workflow_AlmaLinuxLibreport analyzer=libreport
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_AlmaLinuxCCpp type=CCpp
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_AlmaLinuxPython type=Python component!=anaconda
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_AlmaLinuxPython3 type=Python3 component!=anaconda
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_AlmaLinuxKerneloops type=Kerneloops
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_AlmaLinuxVmcore type=vmcore
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_AlmaLinuxXorg type=xorg
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
+
+EVENT=workflow_AlmaLinuxJava type=Java
+# this is just a meta event which consists of other events
+# the list is defined in the xml file
diff --git a/src/workflows/workflow_AlmaLinuxCCpp.xml.in b/src/workflows/workflow_AlmaLinuxCCpp.xml.in
new file mode 100644
index 0000000..1253f68
--- /dev/null
+++ b/src/workflows/workflow_AlmaLinuxCCpp.xml.in
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to AlmaLinux Bug Tracker</_name>
+ <_description>Process the C/C++ crash using the AlmaLinux infrastructure</_description>
+
+ <events>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>analyze_CCpp</event>
+ <event>report_AlmaLinuxBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_AlmaLinuxJava.xml.in b/src/workflows/workflow_AlmaLinuxJava.xml.in
new file mode 100644
index 0000000..55bb38f
--- /dev/null
+++ b/src/workflows/workflow_AlmaLinuxJava.xml.in
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to AlmaLinux Bug Tracker</_name>
+ <_description>Process the Java exception using the AlmaLinux infrastructure</_description>
+
+ <events>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>report_AlmaLinuxBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_AlmaLinuxJavaScript.xml.in b/src/workflows/workflow_AlmaLinuxJavaScript.xml.in
new file mode 100644
index 0000000..9751853
--- /dev/null
+++ b/src/workflows/workflow_AlmaLinuxJavaScript.xml.in
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to AlmaLinux Bug Tracker</_name>
+ <_description>Process the JavaScript exception using the AlmaLinux infrastructure</_description>
+
+ <events>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>report_AlmaLinuxBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_AlmaLinuxKerneloops.xml.in b/src/workflows/workflow_AlmaLinuxKerneloops.xml.in
new file mode 100644
index 0000000..1f72928
--- /dev/null
+++ b/src/workflows/workflow_AlmaLinuxKerneloops.xml.in
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to AlmaLinux Bug Tracker</_name>
+ <_description>Process the kerneloops using the AlmaLinux infrastructure</_description>
+
+ <events>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>report_AlmaLinuxBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_AlmaLinuxLibreport.xml.in b/src/workflows/workflow_AlmaLinuxLibreport.xml.in
new file mode 100644
index 0000000..ff35001
--- /dev/null
+++ b/src/workflows/workflow_AlmaLinuxLibreport.xml.in
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to AlmaLinux Bug Tracker</_name>
+ <_description>Process the problem using the AlmaLinux infrastructure</_description>
+
+ <events>
+ <event>report_AlmaLinuxBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_AlmaLinuxPython.xml.in b/src/workflows/workflow_AlmaLinuxPython.xml.in
new file mode 100644
index 0000000..f14d315
--- /dev/null
+++ b/src/workflows/workflow_AlmaLinuxPython.xml.in
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to AlmaLinux Bug Tracker</_name>
+ <_description>Process the python exception using the AlmaLinux infrastructure</_description>
+
+ <events>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>report_AlmaLinuxBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_AlmaLinuxPython3.xml.in b/src/workflows/workflow_AlmaLinuxPython3.xml.in
new file mode 100644
index 0000000..47bca9c
--- /dev/null
+++ b/src/workflows/workflow_AlmaLinuxPython3.xml.in
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to AlmaLinux Bug Tracker</_name>
+ <_description>Process the python 3 exception using the AlmaLinux infrastructure</_description>
+
+ <events>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>report_AlmaLinuxBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_AlmaLinuxVmcore.xml.in b/src/workflows/workflow_AlmaLinuxVmcore.xml.in
new file mode 100644
index 0000000..85e8626
--- /dev/null
+++ b/src/workflows/workflow_AlmaLinuxVmcore.xml.in
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to AlmaLinux Bug Tracker</_name>
+ <_description>Process the kernel crash using the AlmaLinux infrastructure</_description>
+
+ <events>
+ <event>analyze_VMcore</event>
+ <event>report_uReport</event>
+ <event>collect_*</event>
+ <event>report_AlmaLinuxBugTracker</event>
+ </events>
+</workflow>
diff --git a/src/workflows/workflow_AlmaLinuxXorg.xml.in b/src/workflows/workflow_AlmaLinuxXorg.xml.in
new file mode 100644
index 0000000..b9debc1
--- /dev/null
+++ b/src/workflows/workflow_AlmaLinuxXorg.xml.in
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<workflow>
+ <_name>Report to AlmaLinux Bug Tracker</_name>
+ <_description>Process the X Server problem using the AlmaLinux infrastructure</_description>
+
+ <events>
+ <event>report_AlmaLinuxBugTracker</event>
+ </events>
+</workflow>
--
2.39.3 (Apple Git-146)

View File

@ -15,7 +15,7 @@
Summary: Generic library for reporting various problems
Name: libreport
Version: 2.17.14
Release: 2%{?dist}
Release: 2%{?dist}.alma.1
License: GPL-2.0-or-later
URL: https://abrt.readthedocs.org/
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
@ -64,6 +64,9 @@ Obsoletes: %{name}-compat < 2.13.2
Obsoletes: %{name}-plugin-rhtsupport < 2.13.2
Obsoletes: %{name}-rhel < 2.13.2
Patch2000: 0001-Add-AlmaLinux-plugin.patch
%description
Libraries providing API for reporting different problems in applications
to different bug targets like Bugzilla, ftp, trac, etc...
@ -211,14 +214,14 @@ Requires: libreport-web = %{version}-%{release}
%description plugin-mantisbt
Plugin to report bugs into the mantisbt.
%package centos
Summary: %{name}'s CentOS Bug Tracker workflow
%package almalinux
Summary: %{name}'s AlmaLinux Bug Tracker workflow
Requires: %{name} = %{version}-%{release}
Requires: libreport-web = %{version}-%{release}
Requires: libreport-plugin-mantisbt = %{version}-%{release}
%description centos
Workflows to report issues into the CentOS Bug Tracker.
%description almalinux
Workflows to report issues into the AlmaLinux Bug Tracker.
%package plugin-ureport
Summary: %{name}'s micro report plugin
@ -237,40 +240,6 @@ Requires: libreport-web = %{version}-%{release}
%description plugin-reportuploader
Plugin to report bugs into anonymous FTP site associated with ticketing system.
%if 0%{?fedora} || 0%{?eln}
%package fedora
Summary: Default configuration for reporting bugs via Fedora infrastructure
Requires: %{name} = %{version}-%{release}
%description fedora
Default configuration for reporting bugs via Fedora infrastructure
used to easily configure the reporting process for Fedora systems. Just
install this package and you're done.
%endif
%if 0%{?rhel} && ! 0%{?eln}
%package rhel-bugzilla
Summary: Default configuration for reporting bugs to Red Hat Bugzilla
Requires: %{name} = %{version}-%{release}
Requires: libreport-plugin-bugzilla = %{version}-%{release}
Requires: libreport-plugin-ureport = %{version}-%{release}
%description rhel-bugzilla
Default configuration for reporting bugs to Red Hat Bugzilla used to easily
configure the reporting process for Red Hat systems. Just install this package
and you're done.
%package rhel-anaconda-bugzilla
Summary: Default configuration for reporting anaconda bugs to Red Hat Bugzilla
Requires: %{name} = %{version}-%{release}
Requires: libreport-plugin-bugzilla = %{version}-%{release}
%description rhel-anaconda-bugzilla
Default configuration for reporting Anaconda problems to Red Hat Bugzilla used
to easily configure the reporting process for Red Hat systems. Just install this
package and you're done.
%endif
%if %{with bugzilla}
%package anaconda
Summary: Default configuration for reporting anaconda bugs
@ -286,7 +255,10 @@ data over ftp/scp...
%endif
%prep
%autosetup
%autosetup -p1
sed -e 's/AlmaLinux/AlmaLinux/g' -i po/*.po
sed -e 's/almalinux/almalinux/g' -i po/*.po
%build
./autogen.sh
@ -345,7 +317,6 @@ rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
%endif
# Remove unwanted RHEL specific workflow configuration files
%if ! 0%{?rhel} || 0%{?eln}
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_uReport.xml
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
rm -f %{buildroot}/%{_datadir}/libreport/workflows/workflow_RHELBugzillaCCpp.xml
@ -368,7 +339,28 @@ rm -f %{buildroot}/%{_sysconfdir}/libreport/workflows.d/report_uReport.conf
rm -f %{buildroot}/%{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
rm -f %{buildroot}%{_mandir}/man5/report_uReport.conf.5
rm -f %{buildroot}%{_mandir}/man5/report_rhel_bugzilla.conf.5
%endif
rm -f %{buildroot}%{_mandir}/man1/reporter-rhtsupport.1
rm -f %{buildroot}%{_mandir}/man5/rhtsupport.conf.5
rm -f %{buildroot}%{_mandir}/man5/rhtsupport_event.conf.5
rm -f %{buildroot}/%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
# Remove unwanted AlmaLinux specific workflow configuration files
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_AlmaLinuxCCpp.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_AlmaLinuxKerneloops.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_AlmaLinuxPython.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_AlmaLinuxPython3.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_AlmaLinuxVmcore.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_AlmaLinuxXorg.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_AlmaLinuxLibreport.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_AlmaLinuxJava.xml
rm -f %{buildroot}/%{_datadir}/%{name}/workflows/workflow_AlmaLinuxJavaScript.xml
rm -f %{buildroot}/%{_sysconfdir}/libreport/workflows.d/report_almalinux.conf
rm -f %{buildroot}/%{_mandir}/man5/report_almalinux.conf.5
rm -f %{buildroot}/%{_datadir}/%{name}/events/report_AlmaLinuxBugTracker.xml
rm -f %{buildroot}/%{_sysconfdir}/libreport/events/report_AlmaLinuxBugTracker.conf
rm -f %{buildroot}/%{_mandir}/man5/report_AlmaLinuxBugTracker.conf.5
rm -f %{buildroot}/%{_sysconfdir}/libreport/events.d/almalinux_report_event.conf
rm -f %{buildroot}/%{_mandir}/man5/almalinux_report_event.conf.5
%if 0%{?fedora} >= 38
mv %{buildroot}/%{_bindir}/reporter-bugzilla-python %{buildroot}/%{_bindir}/reporter-bugzilla
@ -534,11 +526,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_mandir}/man1/reporter-ureport.1.gz
%{_mandir}/man5/ureport.conf.5.gz
%{_datadir}/%{name}/events/report_uReport.xml
%if 0%{?rhel} && ! 0%{?eln}
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
%{_datadir}/%{name}/workflows/workflow_uReport.xml
%{_mandir}/man5/report_uReport.conf.5.*
%endif
%if %{with bugzilla}
%files plugin-bugzilla
@ -585,24 +572,24 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_mandir}/man5/mantisbt_format_analyzer_libreport.conf.5.*
%{_mandir}/man5/mantisbt_formatdup_analyzer_libreport.conf.5.*
%files centos
%{_datadir}/%{name}/workflows/workflow_CentOSCCpp.xml
%{_datadir}/%{name}/workflows/workflow_CentOSKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_CentOSPython.xml
%{_datadir}/%{name}/workflows/workflow_CentOSPython3.xml
%{_datadir}/%{name}/workflows/workflow_CentOSVmcore.xml
%{_datadir}/%{name}/workflows/workflow_CentOSXorg.xml
%{_datadir}/%{name}/workflows/workflow_CentOSLibreport.xml
%{_datadir}/%{name}/workflows/workflow_CentOSJava.xml
%{_datadir}/%{name}/workflows/workflow_CentOSJavaScript.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
%{_mandir}/man5/report_centos.conf.5.*
%{_datadir}/%{name}/events/report_CentOSBugTracker.xml
%config(noreplace) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
%{_mandir}/man5/report_CentOSBugTracker.conf.5.*
# report_CentOSBugTracker events are shipped by libreport package
%config(noreplace) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
%{_mandir}/man5/centos_report_event.conf.5.gz
%files almalinux
%{_datadir}/%{name}/workflows/workflow_AlmaLinuxCCpp.xml
%{_datadir}/%{name}/workflows/workflow_AlmaLinuxKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_AlmaLinuxPython.xml
%{_datadir}/%{name}/workflows/workflow_AlmaLinuxPython3.xml
%{_datadir}/%{name}/workflows/workflow_AlmaLinuxVmcore.xml
%{_datadir}/%{name}/workflows/workflow_AlmaLinuxXorg.xml
%{_datadir}/%{name}/workflows/workflow_AlmaLinuxLibreport.xml
%{_datadir}/%{name}/workflows/workflow_AlmaLinuxJava.xml
%{_datadir}/%{name}/workflows/workflow_AlmaLinuxJavaScript.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_almalinux.conf
%{_mandir}/man5/report_almalinux.conf.5.*
%{_datadir}/%{name}/events/report_AlmaLinuxBugTracker.xml
%config(noreplace) %{_sysconfdir}/libreport/events/report_AlmaLinuxBugTracker.conf
%{_mandir}/man5/report_AlmaLinuxBugTracker.conf.5.*
# report_AlmaLinuxBugTracker events are shipped by libreport package
%config(noreplace) %{_sysconfdir}/libreport/events.d/almalinux_report_event.conf
%{_mandir}/man5/almalinux_report_event.conf.5.gz
%files plugin-reportuploader
%{_mandir}/man*/reporter-upload.*
@ -620,43 +607,8 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%config(noreplace) %{_sysconfdir}/libreport/events/report_Uploader.conf
%{_mandir}/man5/report_Uploader.conf.5.*
%if 0%{?fedora} || 0%{?eln}
%files fedora
%{_datadir}/%{name}/workflows/workflow_FedoraCCpp.xml
%{_datadir}/%{name}/workflows/workflow_FedoraKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_FedoraPython.xml
%{_datadir}/%{name}/workflows/workflow_FedoraPython3.xml
%{_datadir}/%{name}/workflows/workflow_FedoraVmcore.xml
%{_datadir}/%{name}/workflows/workflow_FedoraXorg.xml
%{_datadir}/%{name}/workflows/workflow_FedoraLibreport.xml
%{_datadir}/%{name}/workflows/workflow_FedoraJava.xml
%{_datadir}/%{name}/workflows/workflow_FedoraJavaScript.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
%{_mandir}/man5/report_fedora.conf.5.*
%endif
%if %{with bugzilla}
%if 0%{?rhel} && ! 0%{?eln}
%files rhel-bugzilla
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaCCpp.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaKerneloops.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaPython.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaVmcore.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaXorg.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaLibreport.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaJava.xml
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaJavaScript.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
%{_mandir}/man5/report_rhel_bugzilla.conf.5.*
%files rhel-anaconda-bugzilla
%{_datadir}/%{name}/workflows/workflow_AnacondaRHELBugzilla.xml
%endif
%files anaconda
%if 0%{?fedora} || 0%{?eln}
%{_datadir}/%{name}/workflows/workflow_AnacondaFedora.xml
%endif
%{_datadir}/%{name}/workflows/workflow_AnacondaUpload.xml
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
%config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
@ -666,9 +618,12 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{_mandir}/man5/bugzilla_anaconda_event.conf.5.*
%{_mandir}/man5/bugzilla_format_anaconda.conf.5.*
%{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5.*
%endif
%changelog
* Fri Aug 02 2024 Eduard Abdullin <eabdullin@almalinux.org> - 2.17.14-2.alma.1
- Add support for AlmaLinux Bug Tracker
- Remove libreport-rhel-bugzilla and libreport-rhel-anaconda-bugzilla
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 2.17.14-2
- Bump release for June 2024 mass rebuild