New upstream release 2.0.20
This commit is contained in:
parent
a8219b4565
commit
bcd306be0c
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@
|
||||
/libreport-2.0.17.tar.gz
|
||||
/libreport-2.0.18.tar.gz
|
||||
/libreport-2.0.19.tar.gz
|
||||
/libreport-2.0.20.tar.gz
|
||||
|
@ -1,27 +0,0 @@
|
||||
From b3fe4ce72fa196cbfe4f5faabfd7e4baa43cb064 Mon Sep 17 00:00:00 2001
|
||||
From: Denys Vlasenko <vda.linux@googlemail.com>
|
||||
Date: Fri, 30 Nov 2012 14:42:45 +0100
|
||||
Subject: [LIBREPORT PATCH] reporter-bz: add AVC's description added to BZ
|
||||
comment
|
||||
|
||||
Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
|
||||
---
|
||||
src/plugins/bugzilla_format_libreport.conf | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/plugins/bugzilla_format_libreport.conf b/src/plugins/bugzilla_format_libreport.conf
|
||||
index 9fc1f0d..68fe7c5 100644
|
||||
--- a/src/plugins/bugzilla_format_libreport.conf
|
||||
+++ b/src/plugins/bugzilla_format_libreport.conf
|
||||
@@ -31,7 +31,7 @@
|
||||
# which excludes given element from all wildcards
|
||||
#
|
||||
%summary: %reason%
|
||||
-Description of problem: %bare_comment
|
||||
+Description of problem: %bare_comment, %bare_description
|
||||
Additional info: -pkg_arch,-pkg_epoch,-pkg_name,-pkg_release,-pkg_version,-component,-analyzer,-count,-duphash,-uuid,-username,-hostname,-abrt_version,-architecture,-os_release,-time,-pid,-pwd,%oneline
|
||||
Truncated backtrace: %bare_%short_backtrace
|
||||
%attach: -reported_to,-comment,-reason,-event_log,%multiline,-coredump,%binary
|
||||
--
|
||||
1.7.11.7
|
||||
|
@ -1,73 +0,0 @@
|
||||
From 86b383640cba5834e7185901d00edc35dbb8ff35 Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Filak <jfilak@redhat.com>
|
||||
Date: Mon, 26 Nov 2012 15:59:29 +0100
|
||||
Subject: [LIBREPORT PATCH] fix bugzilla summary formatting
|
||||
|
||||
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
||||
---
|
||||
src/plugins/bugzilla_event.conf | 4 +++-
|
||||
src/plugins/reporter-bugzilla.c | 15 +++++----------
|
||||
2 files changed, 8 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/src/plugins/bugzilla_event.conf b/src/plugins/bugzilla_event.conf
|
||||
index 109c581..d3355a3 100644
|
||||
--- a/src/plugins/bugzilla_event.conf
|
||||
+++ b/src/plugins/bugzilla_event.conf
|
||||
@@ -1 +1,3 @@
|
||||
-EVENT=report_Bugzilla analyzer=libreport reporter-bugzilla -b
|
||||
+EVENT=report_Bugzilla analyzer=libreport
|
||||
+ reporter-bugzilla -b \
|
||||
+ -F /etc/libreport/plugins/bugzilla_format_libreport.conf
|
||||
diff --git a/src/plugins/reporter-bugzilla.c b/src/plugins/reporter-bugzilla.c
|
||||
index 78b8b11..2623122 100644
|
||||
--- a/src/plugins/reporter-bugzilla.c
|
||||
+++ b/src/plugins/reporter-bugzilla.c
|
||||
@@ -224,9 +224,7 @@ char *format_percented_string(const char *str, problem_data_t *pd)
|
||||
char *nextpercent = strchr(++str, '%');
|
||||
if (!nextpercent)
|
||||
{
|
||||
- error_msg("Unterminated %%element%%: '%s'", str - 1);
|
||||
- strbuf_free(result);
|
||||
- return NULL;
|
||||
+ error_msg_and_die("Unterminated %%element%%: '%s'", str - 1);
|
||||
}
|
||||
|
||||
*nextpercent = '\0';
|
||||
@@ -244,16 +242,12 @@ char *format_percented_string(const char *str, problem_data_t *pd)
|
||||
|
||||
if (opt_depth > 1)
|
||||
{
|
||||
- error_msg("Unbalanced [[ ]] bracket");
|
||||
- strbuf_free(result);
|
||||
- return NULL;
|
||||
+ error_msg_and_die("Unbalanced [[ ]] bracket");
|
||||
}
|
||||
|
||||
if (!okay[0])
|
||||
{
|
||||
error_msg("Undefined variable outside of [[ ]] bracket");
|
||||
- strbuf_free(result);
|
||||
- return NULL;
|
||||
}
|
||||
|
||||
return strbuf_free_nobuf(result);
|
||||
@@ -274,13 +268,14 @@ char *create_summary_string(problem_data_t *pd, GList *comment_fmt_spec)
|
||||
|
||||
GList *item = sec->items;
|
||||
if (!item)
|
||||
- return NULL;
|
||||
+ /* not supposed to happen, there will be at least "" */
|
||||
+ error_msg_and_die("BUG in %%summary parser");
|
||||
|
||||
const char *str = item->data;
|
||||
return format_percented_string(str, pd);
|
||||
}
|
||||
|
||||
- return format_percented_string("%comment%", pd);
|
||||
+ return format_percented_string("%reason%", pd);
|
||||
}
|
||||
|
||||
|
||||
--
|
||||
1.7.11.7
|
||||
|
101
libreport.spec
101
libreport.spec
@ -4,14 +4,12 @@
|
||||
|
||||
Summary: Generic library for reporting various problems
|
||||
Name: libreport
|
||||
Version: 2.0.19
|
||||
Release: 3%{?dist}
|
||||
Version: 2.0.20
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: https://fedorahosted.org/abrt/
|
||||
Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
|
||||
Patch0: libreport-2.0.19-bugzilla_summary_formatting.patch
|
||||
Patch1: libreport-2.0.19-add_description_to_bz_comment.patch
|
||||
|
||||
BuildRequires: dbus-devel
|
||||
BuildRequires: gtk3-devel
|
||||
@ -121,6 +119,7 @@ bugs
|
||||
Summary: GTK front-end for libreport
|
||||
Group: User Interface/Desktops
|
||||
Requires: libreport = %{version}-%{release}
|
||||
Requires: recordmydesktop
|
||||
Provides: report-gtk = 0:0.23-1
|
||||
Obsoletes: report-gtk < 0:0.23-1
|
||||
|
||||
@ -203,8 +202,9 @@ Plugin to report bugs into RH support system.
|
||||
%package compat
|
||||
Summary: %{name}'s compat layer for obsoleted 'report' package
|
||||
Group: System Environment/Libraries
|
||||
Requires: %{name}-plugin-bugzilla
|
||||
Requires: %{name}-plugin-rhtsupport
|
||||
Requires: libreport = %{version}-%{release}
|
||||
Requires: %{name}-plugin-bugzilla = %{version}-%{release}
|
||||
Requires: %{name}-plugin-rhtsupport = %{version}-%{release}
|
||||
|
||||
%description compat
|
||||
Provides 'report' command-line tool.
|
||||
@ -226,10 +226,27 @@ Obsoletes: report-config-scp < 0:0.23-1
|
||||
%description plugin-reportuploader
|
||||
Plugin to report bugs into anonymous FTP site associated with ticketing system.
|
||||
|
||||
%package fedora
|
||||
Summary: Default configuration for reporting bugs via Fedora infrastructure
|
||||
Group: Applications/File
|
||||
|
||||
%description fedora
|
||||
Default configuration for reporting bugs via Fedora infrastructure
|
||||
used to easy configure the reporting process for Fedora sytems. Just
|
||||
install this package and you're done.
|
||||
|
||||
%package anaconda
|
||||
Summary: Default configuration for reporting anaconda bugs
|
||||
Group: Applications/File
|
||||
Requires: libreport-plugin-reportuploader
|
||||
Requires: libreport-plugin-bugzilla
|
||||
|
||||
%description anaconda
|
||||
Default configuration for reporting Anaconda problems using Fedora
|
||||
infrastructure or uploading the gathered data over ftp/scp...
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
autoconf
|
||||
@ -302,6 +319,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_includedir}/libreport/problem_data.h
|
||||
%{_includedir}/libreport/report.h
|
||||
%{_includedir}/libreport/run_event.h
|
||||
%{_includedir}/libreport/file_obj.h
|
||||
%{_includedir}/libreport/config_item_info.h
|
||||
%{_includedir}/libreport/workflow.h
|
||||
# Private api headers:
|
||||
%{_includedir}/libreport/internal_abrt_dbus.h
|
||||
%{_includedir}/libreport/internal_libreport.h
|
||||
@ -336,6 +356,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%files gtk
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/report-gtk
|
||||
%{_libexecdir}/abrt-screencast
|
||||
%{_libdir}/libreport-gtk.so.*
|
||||
|
||||
%files gtk-devel
|
||||
@ -404,8 +425,72 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_bindir}/reporter-upload
|
||||
%{_sysconfdir}/libreport/events/report_Uploader.xml
|
||||
%config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
|
||||
%{_sysconfdir}/libreport/workflows/workflow_Upload.xml
|
||||
|
||||
%files fedora
|
||||
%defattr(-,root,root,-)
|
||||
%{_sysconfdir}/libreport/workflows/workflow_Fedora.xml
|
||||
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
|
||||
|
||||
%files anaconda
|
||||
%defattr(-,root,root,-)
|
||||
%{_sysconfdir}/libreport/workflows/workflow_AnacondaFedora.xml
|
||||
%{_sysconfdir}/libreport/workflows/workflow_AnacondaUpload.xml
|
||||
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 19 2012 Jiri Moskovcak <jmoskovc@redhat.com> 2.0.20-1
|
||||
- New version 2.0.20
|
||||
- updated po files
|
||||
- add abrt-screencast to POTFILES.in
|
||||
- added screen casting support to the wizard
|
||||
- fix memory leaks in workflow code
|
||||
- report_problem_in_dir(): make LIBREPORT_DEL_DIR work
|
||||
- add Yes/No dialog saving answer
|
||||
- refactor: move ask_yes_no_save_result from wizard to libreport-gtk
|
||||
- added anaconda workflows rhbz#885690
|
||||
- report-python: export dd_delete_item too
|
||||
- report-python: export DD_OPEN_READONLY too
|
||||
- strtrimch: optimize it a bit
|
||||
- show only workflows applicable to actual problem directory
|
||||
- report-gtk: destroy global text cache only once
|
||||
- change rules for FILENAME_NOT_REPORTABLE to always include trailing period.
|
||||
- ask for BZ login/BZ pwd if Login attempt failed
|
||||
- ask for BZ login/BZ password if not provided by conf
|
||||
- remove new line from ask/ask_password responses
|
||||
- add ask_yes_no_yesforever() to Python client API
|
||||
- make client API independent on translation
|
||||
- run_event: use client functions for the communication callbacks
|
||||
- clean the workflow buttons when refreshing the event page
|
||||
- Fix a bug - inverted check for failed rename() call
|
||||
- wrap the not_reportable label .trac#908
|
||||
- don't show events without configuration in preferences .trac#881
|
||||
- - implemented saving/loading configuratio for workflows - related to trac#822
|
||||
- reporter-bz: add AVC's description added to BZ comment
|
||||
- add microseconds to dump dir name (problem ID)
|
||||
- teach reporter-bugzilla to read BZ ID from reported_to element
|
||||
- teach reporter-bugzilla to add reporter to CC
|
||||
- introduce a function deleting dd's element
|
||||
- introduce a function getting no. of Bytes of dd's element
|
||||
- make event config name immutable
|
||||
- fixed segv in the last commit
|
||||
- made struct workflow private related to trac#822
|
||||
- don't show the spinner if the problem is not reportable trac#852
|
||||
- made the config_item_info structure private
|
||||
- added workflows trac#822
|
||||
- added x,--expert cmdline option to enable expert mode
|
||||
- switch comment and event selector page
|
||||
- use get_ and set_ functions to access event_config_t
|
||||
- reporter-bz: don't return NULL on %non_existing_item% - use "" instead
|
||||
- refactoring the xml and conf loader code related to trac#822
|
||||
- reporter-bugzilla: add a --debug option
|
||||
- reporter-bz: fix a summary line formatting bug
|
||||
- let logging_callback and post_run_callback members be None
|
||||
- expose make_run_event_state_forwarding() in Python API
|
||||
- reporter-bz: change syntax of bugzilla_format_*.conf to require "text::", not "text:"
|
||||
- reporter-bz: add support for line continuation and simple text in bugzilla_format*.conf
|
||||
|
||||
* Mon Dec 03 2012 Jakub Filak <jfilak@redhat.com> 2.0.19-3
|
||||
- add a description of AVC to bugzilla comment 0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user