This commit is contained in:
Ernestas Kulik 2020-03-20 19:15:11 +01:00
parent 55c465af05
commit 8c80901c1e
2 changed files with 40 additions and 302 deletions

View File

@ -0,0 +1,32 @@
From 1f14c9fa96937e589354589665eb8c64d6d16d80 Mon Sep 17 00:00:00 2001
From: Ernestas Kulik <ekulik@redhat.com>
Date: Fri, 20 Mar 2020 18:04:19 +0100
Subject: [PATCH] gui-wizard-gtk: Wrap event log messages
Currently, large logs received by abrt-retrace-client may cause
X/Wayland protocol errors due to an overly large buffer being allocated
for GtkTextView. Enabling word wrapping and eliminating horizontal
scrolling seems to prevent that from happening.
Cf. https://gitlab.gnome.org/GNOME/gtk/issues/1143
https://bugzilla.redhat.com/show_bug.cgi?id=1815544
---
src/gui-wizard-gtk/wizard.glade | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/gui-wizard-gtk/wizard.glade b/src/gui-wizard-gtk/wizard.glade
index e86fc90b..f7782ba2 100644
--- a/src/gui-wizard-gtk/wizard.glade
+++ b/src/gui-wizard-gtk/wizard.glade
@@ -705,6 +705,7 @@
<property name="expand">True</property>
<property name="visible">True</property>
<property name="editable">False</property>
+ <property name="wrap-mode">word</property>
</object>
</child>
</object>
--
2.25.1

View File

@ -15,10 +15,12 @@
Summary: Generic library for reporting various problems
Name: libreport
Version: 2.12.0
Release: 2%{?dist}
Release: 3%{?dist}
License: GPLv2+
URL: https://abrt.readthedocs.org/
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
Patch0001: 0001-gui-wizard-gtk-Wrap-event-log-messages.patch
BuildRequires: %{dbus_devel}
BuildRequires: gtk3-devel
BuildRequires: curl-devel
@ -37,6 +39,7 @@ BuildRequires: libproxy-devel
BuildRequires: satyr-devel >= 0.24
BuildRequires: glib2-devel >= %{glib_ver}
BuildRequires: nettle-devel
BuildRequires: git-core
%if 0%{?fedora} >= 24 || 0%{?rhel} > 7
# A test case uses zh_CN locale to verify XML event translations
@ -310,7 +313,7 @@ data over ftp/scp...
%endif
%prep
%setup -q
%autosetup -S git
%build
autoconf
@ -745,6 +748,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%endif
%changelog
* Fri Mar 20 2020 Ernestas Kulik <ekulik@redhat.com> - 2.12.0-3
- Add patch for https://bugzilla.redhat.com/show_bug.cgi?id=1815544
* Fri Feb 07 2020 Ernestas Kulik <ekulik@redhat.com> - 2.12.0-2
- Bump release for side tag rebuild
@ -852,303 +858,3 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
- Update to 2.10.0
- Bump GLib dependency
- Add patch to work around issue with test
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.7-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Mon Jan 07 2019 Martin Kutlak <mkutlak@redhat.com> 2.9.7-2
- rhbz: Replace nomail flag with minor_update
* Fri Dec 07 2018 Matej Marusak <mmarusak@redhat.com> 2.9.7-1
- reportclient: Search for required packages recursively
- event_config: Modify unusable backtrace message
- reportclient: Find and download required debuginfo packages
- lib: Explicitly do not use DST
- autogen: List make in sysdeps command
- lib: Seek beginning of mountinfo file
- report-client: Find debuginfos in own method
- lib: Add a null guard
- gui-wizard-gtk: Require GTK+ 3.10
- gui-wizard-gtk: Dont set GtkButton:xalign
- gui-wizard-gtk: Replace use of GtkTable
- gui-wizard-gtk: Show warnings inline on progress page
- gui-wizard-gtk: Remove unused size group
- gui-wizard-gtk: Replace Gtk{H,V}Box with GtkBox
- gui-wizard-gtk: Remove unneeded windows
- gtk-helpers: config_dialog: Hide tree view header
- augeas: Use generic augeas modules
* Mon Oct 8 2018 Martin Kutlak <mkutlak@redhat.com> 2.9.6-1
- Fix majority of bugs found by Coverity Scan.
- Remove option to screencast problems
- tests: Adjust format of truncated backtrace for python and core
- gui: Replace deprecated g_type_class_add_private
- potfiles: fix issue in POTFILES.in
- lib: fix a SEGV in list_possible_events()
- ureport: use python3 to get consumerCertDir
- r-mailx: Add comment explaining expected values in config
- reporter-mailx: Remove double quotes from config
- spec: Make libreport-filesystem subpackage noarch
- spec: drop dependency on python-rhsm
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.5-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Mon Jun 18 2018 Matej Habrnal <mhabrnal@redhat.com> 2.9.5-3
- Make this build without /usr/bin/python
- Resolves #1592073
* Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 2.9.5-2
- Rebuilt for Python 3.7
* Tue Apr 24 2018 Matej Habrnal <mhabrnal@redhat.com> 2.9.5-1
- spec: actualize according to downstream
- spec: Conditionalize the Python2 and Python3
- report-python: fix tests if configure --without-python2
- autogen: correctly parse buildrequires from spec file
* Tue Mar 27 2018 Martin Kutlak <mkutlak@redhat.com> 2.9.4-1
- Translation updates
- Revert "use /usr/sbin/"
- ureport: remove json-c is_error() usage
- ldconfig and gtk-update-icon-cache is not needed in rawhide
- reporter-rhtsupport: Remove dependency on redhat-access-insights
- do not expand macro in changelog
- move defattr which match the defaults
- use /usr/sbin/
- macro python_sitearch is always defined on rhel7+
- remove rhel6 specific items and accomodate to rhel7+
- This package uses names with ambiguous `python-` prefix in requirements.
- reporter-{bugzilla,mantisbt,rhtsupport}: fix free
- reporter-mailx: rely on configured email
- spec: fix unowned directories
- augeas: include local config path
- doc: update to contain newly added user's local config
- reporter-mantisbt: read configuration from user's home
- reporter-rhtsupport: read configuration from user's home
- reporter-bugzilla: read configuration from user's home
- reporter-bugzilla: ask concrete bz when requiring login
- makefile: fix make release
* Thu Nov 02 2017 Julius Milan <jmilan@redhat.com> 2.9.3-1
- Translation updates
- commit to delete
- workflows: fix description in workflow_RHELJavaScript.xml.in
- workflows: add workflow for adding data to existing case
- client-python,report-python: Allow python to be optional at build time
- ignored words: add SYSTEMD_NSS_BYPASS_BUS
- reporter-ureport: add 'ProcessUnpackaged' option
- spec: add workflow for adding data to existing case
- rep-sys-journal: fix in finding executable basename
- remove old obsolete
- Group is not used any more
- remove old changelogs
- requires pythonX-dnf instead of dnf
- doc: fix obsolete doxygen tags & complains
- lib: Introduce pid_for_children element from ns
- client-python: Do not try to unlink None
- spec: rename Python binary packages
* Thu Mar 16 2017 Matej Habrnal <mhabrnal@redhat.com> 2.9.1-1
- build: create tarball in release-* target
- problem_data: fix double const
- wizard: fix error found by -Werror=format-security
- run_event: fix cmp between pointer and zero character
- build: do not upload tarball to fedorahosted.org
- spec: do not use fedorahosted.org as source
- build: fix generating list of dependences in autogen.sh
- build: generate new release entries with date
- report-newt: free allocated variables, don't close dd twice
- build: fix scratch-build target
- changelog: reflect the PR
- lib: several bug fixes in parsing of mountinfo
- lib: correctly recognize chroot in container
- lib: declare CONTAINER_ROOTS element name
- lib: add more log wrappers for perror
- reporter-bugzilla: use /etc/os-release for default url
- configure.ac: Remove nss dependency
- spec: include testsuite headers in the devel package
- tests: include testsuite.h in the dist archive
- maint: check pulled .po files for errors
- build: fix bug in changelog generating in release target
- changelog: fix typos
* Fri Dec 02 2016 Jakub Filak <jakub@thefilaks.net> 2.9.0-1
- Translation updates
- build: make the release-* targets smarter
- add CHANGELOG.md
- reporter-s-journal: enable SYSLOG_IDENTIFIER from env
- report-python: add method run_event_on_problem_dir
- lib: use lz4 instead of lz4cat
- reportclient: honor ABRT_VERBOSE
- tree-wide: introduce 'stop_on_not_reportable' option
- client: add support for $releasever to debuginfo
- lib: correct test for own root
- workflows: run analyze_BodhiUpdates event on Fedora
- man: fix formating
- reporter-systemd-journal: introduce reporter-systemd-journal
- problem_data: add function which returns all problem data keys
- include: add exception_type element constant
- spec: changes related to reporter-systemd-journal
- problem_report: add normalization of crashed thread
- problem_report: make generate report configurable
- problem_report: use core_backtrace if there is no backtrace
- lib: refuse to parse negative number as unsigned int
- spec: simplify and remove old conditional
- build: add gettext-devel to sysdeps
- dd: add check for validity of new file FD
- build: configure tree for debugging by default
- spec: use %%buildroot macro
- spec: remove defattr which match the defaults
- spec: do not clean buildroot
- spec: remove Groups
- spec: code cleanup
- lib: fix a bug in dealing with errno
- lib: add convenient wrappers for uint in map_string_t
- problem_report: ensure C-string null terminator
- lib: fix invalid cgroup namespace ID
- lib: make die function configurable
- lib: allow using FD of /proc/[pid] instead of pid_t
- dd: add functions for opening dd item
- lib: add xfdopen
- problem data: search for sensitive words in more files
- dd: add dd_copy_file_at
- ignored words: add "systemd-logind" and "hawkey"
- build: reset the default version with each release
- doc: make README more verbose
- tree-wide: produce less messages in NOTICE log lvl
- ureport: less confusing logging
- spec: install JavaScript workflows
- workflow: add JavaScript workflows
- bugzilla: stop including package details
* Fri Sep 09 2016 Jakub Filak <jfilak@redhat.com> 2.8.0-1
- lib: fix a memory leak in create_dump_dir fn
- rhtsupport: fix a double free of config at exit
- autogen: fix typo in usage help string
- debuginfo: dnf API logging workarounds list
- lib: don't warn when user word file doesn't exist
- testuite: add test for forbidden_words
- lib: be able to define base conf dir at runtime
- wizard: use dnf instead of yum in add a screencast note
- problem_report: document resevered elements
* Mon Jul 18 2016 Matej Habrnal <mhabrnal@redhat.com> 2.7.2-1
- Translation updates
- wizard: do not create reproducible if complex_detail == no
- include: save_user_settings function declaration isnt a prototype
- Bugzilla: fix typo in comment don -> don't
- client-python: fix a typo in error check
- dd: do not log missing uid file when creating new dump dir
- build: update searched pkg names for systemd
* Wed May 18 2016 Matej Habrnal <mhabrnal@redhat.com> 2.7.1-1
- spec: compression updates
- lib: add lz4 decompression
- lib: avoid the need to link against lzma
- all: format security
- lib: add cgroup namespace
- dd: introduce functions getting occurrence stamps
- dd: introduce dd_get_env_variable
- lib: add get env variable from a file
- RHTSupport: include count in Support cases
- lib: problem report API check fseek return code
- ignored words: remove 'kwallet_jwakely' which I added wrongly
* Fri Apr 08 2016 Matej Habrnal <mhabrnal@redhat.com> 2.7.0-1
- ignored words: update ignored words
- mailx: introduce debug parameter -D
- mailx: mail formatting: add comment right after %%oneline
- mailx: use problem report api to define an emais' content
- lib: remove unused function make_description_bz
- augeas: trim spaces before key value
- Revert "xml parser: be more verbose in case xml file cannot be opened"
- xml parser: be more verbose in case xml file cannot be opened
- spec: add workflows.d to filesystem package
- makefile: define LANG in release target
- mailx: stop creating dead.letter on mailx failures
- workflows: add comments to ambiguous functions
- workflows: NULL for the default configuration dir
- workflows: publish the function loading configuration
- build: fix build on Fedora24
- augeas: exclude mantisbt format configurations
- reporter-mantisbt: add missing '=' to conf file
- curl: fix typo Ingoring -> Ignoring
- rhtsupport: attach all dump dir's element to a new case
- rhtsupport: add pkg_vendor, reproducer and reproducible to description
- report client: add silent mode to clean_up()
- doc: add documentation for requires-details attribute
- rhtsupport: Discourage users from reporting in non Red Hat stuff
- rhtsupport: Discourage users from opening one-shot crashes
- report-gtk: Require Reproducer for RHTSupport
- Add workflow for RHEL anonymous report
- spec: add workflow for RHEL anonymous report files
- wizard: fix the broken widget expansion
- dd: add documentation of dd_create_skeleton
- workflow: add extern C to the header file
- Fix minor typos
- Translation updates
- translations: update zanata configuration
- wizard: fix the broken "Show log" widget
- wizard: remove the code correcting Bugzilla groups
* Tue Feb 02 2016 Matej Habrnal <mhabrnal@redhat.com> 2.6.4-1
- doc: add option -o and -O into reporter-ureport man page
- rhtsupport: use problme report API to create description
- bugzilla: make the event configurable
- report-gtk: offer users to create private ticket
- bugzilla|centos: declare 'restricted access' support
- event config: add support for 'restricted access'
- lib: move CREATE_PRIVATE_TICKET to the global configuration
- dd: dd_delete_item does not die
- dd: add function getting stat of item
- dd: correct handling of TYPE when creating dump directory
- dd: add function computing dump dir file system size
- dd: add function counting number of dd items
- dd: add function copying file descriptor to element
- dd: allow 1 and 2 letter long element names
- problem_data: factor out function reading single problem element
- formatdup: more universal comment
- dd: make function uid_in_group() public
- Refactoring conditional directives that break parts of statements.
- bugzilla: actualize man pages
- bugzilla: don't report private problem as comment
- uploader: move username and password to the advanced options
- uploader: allow empty username and password
- spec: add uploader config files and related man page
- uploader: add possibility to set SSH keyfiles
- curl: add possibility to configure SSH keys
- desktop-utils: deal with Destkop files without command line
- ureport: enable attaching of arbitrary values
- update .gitignore
- uploader: save remote name in reported_to
- curl: return URLs without userinfo
- lib: add function for removing userinfo from URIs
- plugins: port reporters to add_reported_to_entry
- reported_to: add a function formatting reported_to lines
- lib: introduce parser of ISO date strings
- uploader: use shared dd_create_archive function
- dd: add a function for compressing dumpdirs
- problem_report: add examples to the documentation
- client: document environment variables
* Thu Oct 15 2015 Matej Habrnal <mhabrnal@redhat.com> 2.6.3-1
- wizard: correct comments in save_text_if_changed()
- events: improve example
- reporter-bugzilla: add parameter -p
- wizard: fix save users changes after reviewing dump dir files
- dd: make function load_text_file non-static
- bugzilla: don't attach build_ids
- run_event: rewrite event rule parser
- dd: add convenience wrappers fro loading numbers
- ureport: improve curl's error messages
- ureport: use Red Hat Certificate Authority to make rhsm cert trusted
- curl: add posibility to use own Certificate Authority cert
- spec: add redhat-access-insights to Requires of l-p-rhtsupport
- bugzilla: put VARIANT_ID= to Whiteboard
- autogen: use dnf instead of yum to install dependencies
- configure: use hex value for dump dir mode
- curl: add a helper for HTTP GET
- dd: don't warn about missing 'type' if the locking fails
- dd: stop warning about corrupted mandatory files
- Use a dgettext function returning strings instead of bytes