New upstream release 2.1.6
This commit is contained in:
parent
a023dcd71f
commit
86211cc713
1
.gitignore
vendored
1
.gitignore
vendored
@ -21,3 +21,4 @@
|
|||||||
/libreport-2.1.3.tar.gz
|
/libreport-2.1.3.tar.gz
|
||||||
/libreport-2.1.4.tar.gz
|
/libreport-2.1.4.tar.gz
|
||||||
/libreport-2.1.5.tar.gz
|
/libreport-2.1.5.tar.gz
|
||||||
|
/libreport-2.1.6.tar.gz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From 0b4ef1e6f83e7f4a2e0262d0c2dc6280cfbd72a0 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jakub Filak <jfilak@redhat.com>
|
|
||||||
Date: Tue, 2 Jul 2013 09:55:52 +0200
|
|
||||||
Subject: [LIBREPORT PATCH 5/6] rhbz: test rhbz_new_bug() return value for
|
|
||||||
errors
|
|
||||||
|
|
||||||
Related to rhbz#980228
|
|
||||||
|
|
||||||
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
|
||||||
Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
|
|
||||||
---
|
|
||||||
src/plugins/reporter-bugzilla.c | 5 +++++
|
|
||||||
1 file changed, 5 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/plugins/reporter-bugzilla.c b/src/plugins/reporter-bugzilla.c
|
|
||||||
index d0e04b6..626b41f 100644
|
|
||||||
--- a/src/plugins/reporter-bugzilla.c
|
|
||||||
+++ b/src/plugins/reporter-bugzilla.c
|
|
||||||
@@ -1240,6 +1240,11 @@ int main(int argc, char **argv)
|
|
||||||
free(bzcomment);
|
|
||||||
free(summary);
|
|
||||||
|
|
||||||
+ if (new_id == -1)
|
|
||||||
+ {
|
|
||||||
+ error_msg_and_die(_("Failed to create a new bug."));
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
log(_("Adding attachments to bug %i"), new_id);
|
|
||||||
char new_id_str[sizeof(int)*3 + 2];
|
|
||||||
sprintf(new_id_str, "%i", new_id);
|
|
||||||
--
|
|
||||||
1.8.2.1
|
|
||||||
|
|
@ -1,31 +0,0 @@
|
|||||||
From ed04964627f465d8bd18297286abf3a3d3e922ce Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jakub Filak <jfilak@redhat.com>
|
|
||||||
Date: Tue, 2 Jul 2013 09:55:53 +0200
|
|
||||||
Subject: [LIBREPORT PATCH 6/6] rhbz: test xmlrpc env for errors in
|
|
||||||
abrt_xmlrpc_call_params()
|
|
||||||
|
|
||||||
Closes rhbz#980228
|
|
||||||
|
|
||||||
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
|
||||||
Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
|
|
||||||
---
|
|
||||||
src/lib/abrt_xmlrpc.c | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/lib/abrt_xmlrpc.c b/src/lib/abrt_xmlrpc.c
|
|
||||||
index b531d25..75f1f2b 100644
|
|
||||||
--- a/src/lib/abrt_xmlrpc.c
|
|
||||||
+++ b/src/lib/abrt_xmlrpc.c
|
|
||||||
@@ -206,6 +206,9 @@ xmlrpc_value *abrt_xmlrpc_call_params(xmlrpc_env *env, struct abrt_xmlrpc *ax, c
|
|
||||||
xmlrpc_client_call2(env, ax->ax_client, ax->ax_server_info, method,
|
|
||||||
array, &result);
|
|
||||||
|
|
||||||
+ if (env->fault_occurred)
|
|
||||||
+ abrt_xmlrpc_die(env);
|
|
||||||
+
|
|
||||||
xmlrpc_DECREF(array);
|
|
||||||
return result;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
1.8.2.1
|
|
||||||
|
|
207
libreport.spec
207
libreport.spec
@ -4,18 +4,14 @@
|
|||||||
|
|
||||||
Summary: Generic library for reporting various problems
|
Summary: Generic library for reporting various problems
|
||||||
Name: libreport
|
Name: libreport
|
||||||
Version: 2.1.5
|
Version: 2.1.6
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: https://fedorahosted.org/abrt/
|
URL: https://fedorahosted.org/abrt/
|
||||||
Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
|
Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
|
||||||
Source1: autogen.sh
|
Source1: autogen.sh
|
||||||
|
|
||||||
# Remove these patches with libreport-2.1.6
|
|
||||||
Patch5: 0005-rhbz-test-rhbz_new_bug-return-value-for-errors.patch
|
|
||||||
Patch6: 0006-rhbz-test-xmlrpc-env-for-errors-in-abrt_xmlrpc_call_.patch
|
|
||||||
|
|
||||||
BuildRequires: dbus-devel
|
BuildRequires: dbus-devel
|
||||||
BuildRequires: gtk3-devel
|
BuildRequires: gtk3-devel
|
||||||
BuildRequires: curl-devel
|
BuildRequires: curl-devel
|
||||||
@ -33,7 +29,7 @@ BuildRequires: asciidoc
|
|||||||
BuildRequires: xmlto
|
BuildRequires: xmlto
|
||||||
BuildRequires: newt-devel
|
BuildRequires: newt-devel
|
||||||
BuildRequires: libproxy-devel
|
BuildRequires: libproxy-devel
|
||||||
BuildRequires: btparser-devel
|
BuildRequires: satyr-devel >= 0.5
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
Requires: libreport-filesystem = %{version}-%{release}
|
Requires: libreport-filesystem = %{version}-%{release}
|
||||||
# required for update from old report library, otherwise we obsolete report-gtk
|
# required for update from old report library, otherwise we obsolete report-gtk
|
||||||
@ -41,7 +37,8 @@ Requires: libreport-filesystem = %{version}-%{release}
|
|||||||
# end-up with: can't import report.GtkIO
|
# end-up with: can't import report.GtkIO
|
||||||
# FIXME: can be removed when F15 will EOLed, needs to stay in rhel6!
|
# FIXME: can be removed when F15 will EOLed, needs to stay in rhel6!
|
||||||
Requires: libreport-python = %{version}-%{release}
|
Requires: libreport-python = %{version}-%{release}
|
||||||
Conflicts: abrt < 2.1.0
|
Requires: satyr >= 0.5
|
||||||
|
|
||||||
|
|
||||||
# for rhel6
|
# for rhel6
|
||||||
%if 0%{?rhel} == 6
|
%if 0%{?rhel} == 6
|
||||||
@ -73,7 +70,7 @@ Development libraries and headers for libreport
|
|||||||
|
|
||||||
%package web
|
%package web
|
||||||
Summary: Library providing network API for libreport
|
Summary: Library providing network API for libreport
|
||||||
Group: Libraries
|
Group: System Environment/Libraries
|
||||||
Requires: libreport = %{version}-%{release}
|
Requires: libreport = %{version}-%{release}
|
||||||
|
|
||||||
%description web
|
%description web
|
||||||
@ -127,6 +124,7 @@ Summary: GTK front-end for libreport
|
|||||||
Group: User Interface/Desktops
|
Group: User Interface/Desktops
|
||||||
Requires: libreport = %{version}-%{release}
|
Requires: libreport = %{version}-%{release}
|
||||||
Requires: libreport-plugin-reportuploader = %{version}-%{release}
|
Requires: libreport-plugin-reportuploader = %{version}-%{release}
|
||||||
|
Requires: fros >= 1.0
|
||||||
%if 0%{?rhel} >= 6
|
%if 0%{?rhel} >= 6
|
||||||
%else
|
%else
|
||||||
Requires: pygobject3
|
Requires: pygobject3
|
||||||
@ -160,11 +158,6 @@ server, usually to kerneloops.org.
|
|||||||
Summary: %{name}'s logger reporter plugin
|
Summary: %{name}'s logger reporter plugin
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Obsoletes: abrt-plugin-logger < 2.0.4
|
|
||||||
Provides: report-plugin-localsave = 0:0.23-1
|
|
||||||
Obsoletes: report-plugin-localsave < 0:0.23-1
|
|
||||||
Provides: report-config-localsave = 0:0.23-1
|
|
||||||
Obsoletes: report-config-localsave < 0:0.23-1
|
|
||||||
|
|
||||||
%description plugin-logger
|
%description plugin-logger
|
||||||
The simple reporter plugin which writes a report to a specified file.
|
The simple reporter plugin which writes a report to a specified file.
|
||||||
@ -174,7 +167,6 @@ Summary: %{name}'s mailx reporter plugin
|
|||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: mailx
|
Requires: mailx
|
||||||
Obsoletes: abrt-plugin-mailx < 2.0.4
|
|
||||||
|
|
||||||
%description plugin-mailx
|
%description plugin-mailx
|
||||||
The simple reporter plugin which sends a report via mailx to a specified
|
The simple reporter plugin which sends a report via mailx to a specified
|
||||||
@ -185,11 +177,6 @@ Summary: %{name}'s bugzilla plugin
|
|||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: libreport-web = %{version}-%{release}
|
Requires: libreport-web = %{version}-%{release}
|
||||||
Obsoletes: abrt-plugin-bugzilla < 2.0.4
|
|
||||||
Provides: report-plugin-bugzilla = 0:0.23-1
|
|
||||||
Obsoletes: report-plugin-bugzilla < 0:0.23-1
|
|
||||||
Provides: report-config-bugzilla-redhat-com = 0:0.23-1
|
|
||||||
Obsoletes: report-config-bugzilla-redhat-com < 0:0.23-1
|
|
||||||
|
|
||||||
%package plugin-ureport
|
%package plugin-ureport
|
||||||
Summary: %{name}'s micro report plugin
|
Summary: %{name}'s micro report plugin
|
||||||
@ -209,7 +196,6 @@ Summary: %{name}'s RHTSupport plugin
|
|||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: libreport-web = %{version}-%{release}
|
Requires: libreport-web = %{version}-%{release}
|
||||||
Obsoletes: abrt-plugin-rhtsupport < 2.0.4
|
|
||||||
|
|
||||||
%description plugin-rhtsupport
|
%description plugin-rhtsupport
|
||||||
Plugin to report bugs into RH support system.
|
Plugin to report bugs into RH support system.
|
||||||
@ -229,51 +215,47 @@ Summary: %{name}'s reportuploader plugin
|
|||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: libreport-web = %{version}-%{release}
|
Requires: libreport-web = %{version}-%{release}
|
||||||
Obsoletes: abrt-plugin-reportuploader < 2.0.4
|
|
||||||
Provides: report-plugin-ftp = 0:0.23-1
|
|
||||||
Obsoletes: report-plugin-ftp < 0:0.23-1
|
|
||||||
Provides: report-config-ftp = 0:0.23-1
|
|
||||||
Obsoletes: report-config-ftp < 0:0.23-1
|
|
||||||
Provides: report-plugin-scp = 0:0.23-1
|
|
||||||
Obsoletes: report-plugin-scp < 0:0.23-1
|
|
||||||
Provides: report-config-scp = 0:0.23-1
|
|
||||||
Obsoletes: report-config-scp < 0:0.23-1
|
|
||||||
|
|
||||||
%description plugin-reportuploader
|
%description plugin-reportuploader
|
||||||
Plugin to report bugs into anonymous FTP site associated with ticketing system.
|
Plugin to report bugs into anonymous FTP site associated with ticketing system.
|
||||||
|
|
||||||
|
%if 0%{?fedora}
|
||||||
%package fedora
|
%package fedora
|
||||||
Summary: Default configuration for reporting bugs via Fedora infrastructure
|
Summary: Default configuration for reporting bugs via Fedora infrastructure
|
||||||
Group: Applications/File
|
Group: Applications/File
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
%description fedora
|
%description fedora
|
||||||
Default configuration for reporting bugs via Fedora infrastructure
|
Default configuration for reporting bugs via Fedora infrastructure
|
||||||
used to easy configure the reporting process for Fedora sytems. Just
|
used to easy configure the reporting process for Fedora sytems. Just
|
||||||
install this package and you're done.
|
install this package and you're done.
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%if 0%{?rhel}
|
||||||
%package rhel
|
%package rhel
|
||||||
Summary: Default configuration for reporting bugs via Red Hat infrastructure
|
Summary: Default configuration for reporting bugs via Red Hat infrastructure
|
||||||
Group: Applications/File
|
Group: Applications/File
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
%description rhel
|
%description rhel
|
||||||
Default configuration for reporting bugs via Red Hat infrastructure
|
Default configuration for reporting bugs via Red Hat infrastructure
|
||||||
used to easy configure the reporting process for Red Hat sytems. Just
|
used to easy configure the reporting process for Red Hat sytems. Just
|
||||||
install this package and you're done.
|
install this package and you're done.
|
||||||
|
%endif
|
||||||
|
|
||||||
%package anaconda
|
%package anaconda
|
||||||
Summary: Default configuration for reporting anaconda bugs
|
Summary: Default configuration for reporting anaconda bugs
|
||||||
Group: Applications/File
|
Group: Applications/File
|
||||||
Requires: libreport-plugin-reportuploader
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: libreport-plugin-bugzilla
|
Requires: libreport-plugin-reportuploader = %{version}-%{release}
|
||||||
|
Requires: libreport-plugin-bugzilla = %{version}-%{release}
|
||||||
|
|
||||||
%description anaconda
|
%description anaconda
|
||||||
Default configuration for reporting Anaconda problems using Fedora
|
Default configuration for reporting Anaconda problems or uploading the gathered
|
||||||
infrastructure or uploading the gathered data over ftp/scp...
|
data over ftp/scp...
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch5 -p1
|
|
||||||
%patch6 -p1
|
|
||||||
|
|
||||||
# koji in f19 has new autotools, so we need to regenerate everything
|
# koji in f19 has new autotools, so we need to regenerate everything
|
||||||
cp %SOURCE1 %_builddir/%{name}-%{version}
|
cp %SOURCE1 %_builddir/%{name}-%{version}
|
||||||
@ -295,10 +277,36 @@ find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
|
|||||||
mkdir -p $RPM_BUILD_ROOT/%{_initrddir}
|
mkdir -p $RPM_BUILD_ROOT/%{_initrddir}
|
||||||
mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/events.d/
|
mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/events.d/
|
||||||
mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/events/
|
mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/events/
|
||||||
|
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}/events/
|
||||||
|
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}/workflows/
|
||||||
|
|
||||||
# After everything is installed, remove info dir
|
# After everything is installed, remove info dir
|
||||||
rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
|
rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
|
||||||
|
|
||||||
|
# Remove unwanted Fedora specific workflow configuration files
|
||||||
|
%if 0%{!?fedora:1}
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_FedoraCCpp.xml
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_FedoraKerneloops.xml
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_FedoraPython.xml
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_FedoraVmcore.xml
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_FedoraXorg.xml
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/libreport/workflows.d/report_fedora.conf
|
||||||
|
rm -f $RPM_BUILD_ROOT%{_mandir}/man5/report_fedora.conf.5
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
|
||||||
|
%endif
|
||||||
|
|
||||||
|
# Remove unwanted RHEL specific workflow configuration files
|
||||||
|
%if 0%{!?rhel:1}
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELCCpp.xml
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELKerneloops.xml
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELPython.xml
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELvmcore.xml
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_RHELxorg.xml
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/libreport/workflows.d/report_rhel.conf
|
||||||
|
rm -f $RPM_BUILD_ROOT%{_mandir}/man5/report_rhel.conf.5
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_datadir}/libreport/workflows/workflow_AnacondaRHEL.xml
|
||||||
|
%endif
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
@ -324,6 +332,13 @@ fi
|
|||||||
%posttrans gtk
|
%posttrans gtk
|
||||||
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||||
|
|
||||||
|
|
||||||
|
%post web -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
|
%postun web -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc README COPYING
|
%doc README COPYING
|
||||||
@ -332,6 +347,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%{_libdir}/libreport.so.*
|
%{_libdir}/libreport.so.*
|
||||||
%{_libdir}/libabrt_dbus.so.*
|
%{_libdir}/libabrt_dbus.so.*
|
||||||
%{_mandir}/man5/report_event.conf.5*
|
%{_mandir}/man5/report_event.conf.5*
|
||||||
|
%{_mandir}/man5/forbidden_words.conf.5*
|
||||||
|
|
||||||
%files filesystem
|
%files filesystem
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -339,11 +355,13 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%dir %{_sysconfdir}/%{name}/events.d/
|
%dir %{_sysconfdir}/%{name}/events.d/
|
||||||
%dir %{_sysconfdir}/%{name}/events/
|
%dir %{_sysconfdir}/%{name}/events/
|
||||||
%dir %{_sysconfdir}/%{name}/plugins/
|
%dir %{_sysconfdir}/%{name}/plugins/
|
||||||
|
%dir %{_datadir}/%{name}/events/
|
||||||
|
%dir %{_datadir}/%{name}/workflows/
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
# Public api headers:
|
# Public api headers:
|
||||||
%doc apidoc/html/*
|
%doc apidoc/html/*.{html,png,css,js}
|
||||||
%{_includedir}/libreport/libreport_types.h
|
%{_includedir}/libreport/libreport_types.h
|
||||||
%{_includedir}/libreport/client.h
|
%{_includedir}/libreport/client.h
|
||||||
%{_includedir}/libreport/dump_dir.h
|
%{_includedir}/libreport/dump_dir.h
|
||||||
@ -365,10 +383,11 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
|
|
||||||
%files web
|
%files web
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/libreport-web.so*
|
%{_libdir}/libreport-web.so.*
|
||||||
|
|
||||||
%files web-devel
|
%files web-devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
|
%{_libdir}/libreport-web.so
|
||||||
%{_includedir}/libreport/libreport_curl.h
|
%{_includedir}/libreport/libreport_curl.h
|
||||||
%{_libdir}/pkgconfig/libreport-web.pc
|
%{_libdir}/pkgconfig/libreport-web.pc
|
||||||
|
|
||||||
@ -385,6 +404,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%files newt
|
%files newt
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_bindir}/report-newt
|
%{_bindir}/report-newt
|
||||||
|
%{_mandir}/man1/report-newt.1.gz
|
||||||
|
|
||||||
%files gtk
|
%files gtk
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -392,7 +412,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%{_libexecdir}/abrt-screencast
|
%{_libexecdir}/abrt-screencast
|
||||||
%{_libdir}/libreport-gtk.so.*
|
%{_libdir}/libreport-gtk.so.*
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
|
%config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
|
||||||
%{_sysconfdir}/libreport/events/report_EmergencyAnalysis.xml
|
%{_mandir}/man5/emergencyanalysis_event.conf.5.*
|
||||||
|
%{_datadir}/%{name}/events/report_EmergencyAnalysis.xml
|
||||||
|
%{_mandir}/man1/report-gtk.1.gz
|
||||||
|
|
||||||
|
|
||||||
%files gtk-devel
|
%files gtk-devel
|
||||||
@ -403,31 +425,35 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
|
|
||||||
%files plugin-kerneloops
|
%files plugin-kerneloops
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_sysconfdir}/libreport/events/report_Kerneloops.xml
|
%{_datadir}/%{name}/events/report_Kerneloops.xml
|
||||||
%{_mandir}/man*/reporter-kerneloops.*
|
%{_mandir}/man*/reporter-kerneloops.*
|
||||||
%{_bindir}/reporter-kerneloops
|
%{_bindir}/reporter-kerneloops
|
||||||
|
|
||||||
%files plugin-logger
|
%files plugin-logger
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_sysconfdir}/libreport/events/report_Logger.conf
|
%config(noreplace) %{_sysconfdir}/libreport/events/report_Logger.conf
|
||||||
%{_sysconfdir}/libreport/events/report_Logger.xml
|
%{_mandir}/man5/report_Logger.conf.5.*
|
||||||
|
%{_datadir}/%{name}/events/report_Logger.xml
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/events.d/print_event.conf
|
%config(noreplace) %{_sysconfdir}/libreport/events.d/print_event.conf
|
||||||
|
%{_mandir}/man5/print_event.conf.5.*
|
||||||
%{_bindir}/reporter-print
|
%{_bindir}/reporter-print
|
||||||
%{_mandir}/man*/reporter-print.*
|
%{_mandir}/man*/reporter-print.*
|
||||||
|
|
||||||
%files plugin-mailx
|
%files plugin-mailx
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
|
%config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
|
||||||
%{_sysconfdir}/libreport/events/report_Mailx.xml
|
%{_datadir}/%{name}/events/report_Mailx.xml
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
|
%config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
|
||||||
|
%{_mandir}/man5/mailx.conf.5.*
|
||||||
|
%{_mandir}/man5/mailx_event.conf.5.*
|
||||||
%{_mandir}/man*/reporter-mailx.*
|
%{_mandir}/man*/reporter-mailx.*
|
||||||
%{_bindir}/reporter-mailx
|
%{_bindir}/reporter-mailx
|
||||||
|
|
||||||
%files plugin-ureport
|
%files plugin-ureport
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_bindir}/reporter-ureport
|
%{_bindir}/reporter-ureport
|
||||||
#%{_mandir}/man1/reporter-ureport.1.gz
|
%{_mandir}/man1/reporter-ureport.1.gz
|
||||||
%{_sysconfdir}/libreport/events/report_uReport.xml
|
%{_datadir}/%{name}/events/report_uReport.xml
|
||||||
|
|
||||||
%files plugin-bugzilla
|
%files plugin-bugzilla
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -436,19 +462,28 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
|
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_libreport.conf
|
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_libreport.conf
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_kernel.conf
|
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_kernel.conf
|
||||||
%{_sysconfdir}/libreport/events/report_Bugzilla.xml
|
%{_datadir}/%{name}/events/report_Bugzilla.xml
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
|
%config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
|
%config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
|
||||||
# FIXME: remove with the old gui
|
# FIXME: remove with the old gui
|
||||||
%{_mandir}/man1/reporter-bugzilla.1.gz
|
%{_mandir}/man1/reporter-bugzilla.1.gz
|
||||||
|
%{_mandir}/man5/report_Bugzilla.conf.5.*
|
||||||
|
%{_mandir}/man5/bugzilla_event.conf.5.*
|
||||||
|
%{_mandir}/man5/bugzilla.conf.5.*
|
||||||
|
%{_mandir}/man5/bugzilla_format.conf.5.*
|
||||||
|
%{_mandir}/man5/bugzilla_formatdup.conf.5.*
|
||||||
|
%{_mandir}/man5/bugzilla_format_libreport.conf.5.*
|
||||||
|
%{_mandir}/man5/bugzilla_format_kernel.conf.5.*
|
||||||
%{_bindir}/reporter-bugzilla
|
%{_bindir}/reporter-bugzilla
|
||||||
|
|
||||||
%files plugin-rhtsupport
|
%files plugin-rhtsupport
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
|
%config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
|
||||||
%{_sysconfdir}/libreport/events/report_RHTSupport.xml
|
%{_datadir}/%{name}/events/report_RHTSupport.xml
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
|
%config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
|
||||||
%{_mandir}/man1/reporter-rhtsupport.1.gz
|
%{_mandir}/man1/reporter-rhtsupport.1.gz
|
||||||
|
%{_mandir}/man5/rhtsupport.conf.5.*
|
||||||
|
%{_mandir}/man5/rhtsupport_event.conf.5.*
|
||||||
%{_bindir}/reporter-rhtsupport
|
%{_bindir}/reporter-rhtsupport
|
||||||
|
|
||||||
%files compat
|
%files compat
|
||||||
@ -459,36 +494,86 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%files plugin-reportuploader
|
%files plugin-reportuploader
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_mandir}/man*/reporter-upload.*
|
%{_mandir}/man*/reporter-upload.*
|
||||||
|
%{_mandir}/man5/uploader_event.conf.5.*
|
||||||
%{_bindir}/reporter-upload
|
%{_bindir}/reporter-upload
|
||||||
%{_sysconfdir}/libreport/events/report_Uploader.xml
|
%{_datadir}/%{name}/events/report_Uploader.xml
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
|
%config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
|
||||||
%{_sysconfdir}/libreport/workflows/workflow_Upload.xml
|
%{_datadir}/%{name}/workflows/workflow_Upload.xml
|
||||||
|
|
||||||
|
%if 0%{?fedora}
|
||||||
%files fedora
|
%files fedora
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_sysconfdir}/libreport/workflows/workflow_Fedora.xml
|
%{_datadir}/%{name}/workflows/workflow_FedoraCCpp.xml
|
||||||
|
%{_datadir}/%{name}/workflows/workflow_FedoraKerneloops.xml
|
||||||
|
%{_datadir}/%{name}/workflows/workflow_FedoraPython.xml
|
||||||
|
%{_datadir}/%{name}/workflows/workflow_FedoraVmcore.xml
|
||||||
|
%{_datadir}/%{name}/workflows/workflow_FedoraXorg.xml
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
|
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
|
||||||
|
%{_mandir}/man5/report_fedora.conf.5.*
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%if 0%{?rhel}
|
||||||
%files rhel
|
%files rhel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_sysconfdir}/libreport/workflows/workflow_RHELCCpp.xml
|
%{_datadir}/%{name}/workflows/workflow_RHELCCpp.xml
|
||||||
%{_sysconfdir}/libreport/workflows/workflow_RHELKerneloops.xml
|
%{_datadir}/%{name}/workflows/workflow_RHELKerneloops.xml
|
||||||
%{_sysconfdir}/libreport/workflows/workflow_RHELPython.xml
|
%{_datadir}/%{name}/workflows/workflow_RHELPython.xml
|
||||||
%{_sysconfdir}/libreport/workflows/workflow_RHELvmcore.xml
|
%{_datadir}/%{name}/workflows/workflow_RHELvmcore.xml
|
||||||
%{_sysconfdir}/libreport/workflows/workflow_RHELxorg.xml
|
%{_datadir}/%{name}/workflows/workflow_RHELxorg.xml
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
|
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
|
||||||
|
%{_mandir}/man5/report_rhel.conf.5.*
|
||||||
|
%endif
|
||||||
|
|
||||||
%files anaconda
|
%files anaconda
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_sysconfdir}/libreport/workflows/workflow_AnacondaFedora.xml
|
%if 0%{?fedora}
|
||||||
%{_sysconfdir}/libreport/workflows/workflow_AnacondaUpload.xml
|
%{_datadir}/%{name}/workflows/workflow_AnacondaFedora.xml
|
||||||
|
%endif
|
||||||
|
%if 0%{?rhel}
|
||||||
|
%{_datadir}/%{name}/workflows/workflow_AnacondaRHEL.xml
|
||||||
|
%endif
|
||||||
|
%{_datadir}/%{name}/workflows/workflow_AnacondaUpload.xml
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
|
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
|
%config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_anaconda.conf
|
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_anaconda.conf
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup_anaconda.conf
|
%config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup_anaconda.conf
|
||||||
|
%{_mandir}/man5/anaconda_event.conf.5.*
|
||||||
|
%{_mandir}/man5/bugzilla_anaconda_event.conf.5.*
|
||||||
|
%{_mandir}/man5/bugzilla_format_anaconda.conf.5.*
|
||||||
|
%{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5.*
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 26 2013 Jakub Filak <jfilak@redhat.com> 2.1.6-1
|
||||||
|
- add related packages version in emergency event
|
||||||
|
- replace functions deprecated in Gtk-3.10 with their substitutes
|
||||||
|
- fixed the bugzilla private group names rhbz#985881
|
||||||
|
- workflows: add Anaconda work flow for RHEL
|
||||||
|
- add missing manual pages for configuration files, binaries and scripts
|
||||||
|
- added options to create private bz tickets rhbz#803772
|
||||||
|
- skip the workflow selection if there is only 1 available closes #167
|
||||||
|
- added missing workflows for Fedora rhbz#866027
|
||||||
|
- spec: double up percent signs in chagelog entries
|
||||||
|
- spec: make anaconda package description more generic
|
||||||
|
- spec: install RHEL anaconda work flow
|
||||||
|
- spec: added new workflow files rhbz#866027
|
||||||
|
- spec: build only workflow subpkg relevant for host's OS
|
||||||
|
- spec: install all manual pages
|
||||||
|
- spec: install only documentation files
|
||||||
|
- spec: drop unnecessary Obsoletes and Provides
|
||||||
|
- spec: add manual pages to packages
|
||||||
|
- spec: specify all config files
|
||||||
|
- spec: replace btparser with satyr
|
||||||
|
- move non-conf XML files from /etc/libreport/ to /usr/share/libreport/
|
||||||
|
- Update satyr support, drop btparser compatibility
|
||||||
|
- fixed typo in config file related #866027
|
||||||
|
- resize the config window upon collapsing Advanced section
|
||||||
|
- rhbz: test xmlrpc env for errors in abrt_xmlrpc_call_params()
|
||||||
|
- rhbz: test rhbz_new_bug() return value for errors
|
||||||
|
- wizard: show accurate messages
|
||||||
|
- spec: add dependency on fros rhbz#958979
|
||||||
|
- use fros instead of hard dependency on recordmydesktop rhbz#958979
|
||||||
|
|
||||||
* Tue Jul 02 2013 Jakub Filak <jfilak@redhat.com> 2.1.5-2
|
* Tue Jul 02 2013 Jakub Filak <jfilak@redhat.com> 2.1.5-2
|
||||||
- reporter-bugzilla: test return values for errors
|
- reporter-bugzilla: test return values for errors
|
||||||
- Resolves: #980228
|
- Resolves: #980228
|
||||||
@ -570,7 +655,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
|
|
||||||
* Tue Mar 19 2013 Jakub Filak <jfilak@redhat.com> 2.1.2-1
|
* Tue Mar 19 2013 Jakub Filak <jfilak@redhat.com> 2.1.2-1
|
||||||
- always treat os-release as textual related to rhbz#922433
|
- always treat os-release as textual related to rhbz#922433
|
||||||
- is_text_file(): bump allowable non-ASCII chars from 2% to 10%. Closes rhbz#922433
|
- is_text_file(): bump allowable non-ASCII chars from 2%% to 10%%. Closes rhbz#922433
|
||||||
- report-gtk: don't clear warnings after reporting is finished
|
- report-gtk: don't clear warnings after reporting is finished
|
||||||
- report-gtk: show tabs only in verbose expert mode
|
- report-gtk: show tabs only in verbose expert mode
|
||||||
- report-gtk: prettify the workflow buttons rhbz#917694
|
- report-gtk: prettify the workflow buttons rhbz#917694
|
||||||
@ -596,7 +681,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
- fix logic of 'Dont ask me again' dialogues (stop returning true for all options)
|
- fix logic of 'Dont ask me again' dialogues (stop returning true for all options)
|
||||||
- make [p]error_msg[_and_die] more fork-in-multithreaded-app safe
|
- make [p]error_msg[_and_die] more fork-in-multithreaded-app safe
|
||||||
- Make forking code paths more robust.
|
- Make forking code paths more robust.
|
||||||
- curl_debug: fix use of "%.*s" (need to pass an int, not size_t)
|
- curl_debug: fix use of "%%.*s" (need to pass an int, not size_t)
|
||||||
- curl_debug: prettify debug output
|
- curl_debug: prettify debug output
|
||||||
- Resolves: #871126, #885055, #890778, #901467, #916389, #917684, #917694, #919536, #922433, #923117
|
- Resolves: #871126, #885055, #890778, #901467, #916389, #917684, #917694, #919536, #922433, #923117
|
||||||
|
|
||||||
@ -655,7 +740,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
- don't require recordmydesktop on RHEL rhbz#891512
|
- don't require recordmydesktop on RHEL rhbz#891512
|
||||||
- fixed the relro flags rhbz#812283
|
- fixed the relro flags rhbz#812283
|
||||||
- bugzilla_format_kernel.conf: Attach dmesg element. Closes rhbz#826058
|
- bugzilla_format_kernel.conf: Attach dmesg element. Closes rhbz#826058
|
||||||
- bugzilla_format_kernel.conf: fix %summary
|
- bugzilla_format_kernel.conf: fix %%summary
|
||||||
- Make get_dirsize_find_largest_dir less talkative.
|
- Make get_dirsize_find_largest_dir less talkative.
|
||||||
- Minor fixes: robustify start_command(), fix style, fix English in msgs
|
- Minor fixes: robustify start_command(), fix style, fix English in msgs
|
||||||
- Fix typo, remove c-format from a not c-formatted message
|
- Fix typo, remove c-format from a not c-formatted message
|
||||||
@ -706,7 +791,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
- added x,--expert cmdline option to enable expert mode
|
- added x,--expert cmdline option to enable expert mode
|
||||||
- switch comment and event selector page
|
- switch comment and event selector page
|
||||||
- use get_ and set_ functions to access event_config_t
|
- use get_ and set_ functions to access event_config_t
|
||||||
- reporter-bz: don't return NULL on %non_existing_item% - use "" instead
|
- reporter-bz: don't return NULL on %%non_existing_item%% - use "" instead
|
||||||
- refactoring the xml and conf loader code related to trac#822
|
- refactoring the xml and conf loader code related to trac#822
|
||||||
- reporter-bugzilla: add a --debug option
|
- reporter-bugzilla: add a --debug option
|
||||||
- reporter-bz: fix a summary line formatting bug
|
- reporter-bz: fix a summary line formatting bug
|
||||||
|
Loading…
Reference in New Issue
Block a user