New upstream release 2.10.1
* Remove gen-version from spec - This is upstream script to generate version. This is not needed in dist-git. [2.10.1] - 2019-07-03 Changed - Clearer warnings about missing report elements. - Export workflow when saving server response. - uReport workflow moved to plugin-ureport subpackage. - Refined composition of error messages during problem reporting. Fixed - Fixed dump dir lock up in case of delete failure. Signed-off-by: Martin Kutlak <mkutlak@redhat.com>
This commit is contained in:
parent
216f0e95b1
commit
7b7c13b297
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
|||||||
/libreport-2.9.6.tar.gz
|
/libreport-2.9.6.tar.gz
|
||||||
/libreport-2.9.7.tar.gz
|
/libreport-2.9.7.tar.gz
|
||||||
/libreport-2.10.0.tar.gz
|
/libreport-2.10.0.tar.gz
|
||||||
|
/libreport-2.10.1.tar.gz
|
||||||
|
@ -1,44 +0,0 @@
|
|||||||
From f2d98e0ee81037f18e50c06e409def19e791c2f2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ernestas Kulik <ekulik@redhat.com>
|
|
||||||
Date: Wed, 17 Apr 2019 13:24:19 +0200
|
|
||||||
Subject: [PATCH] lib: ureport: Export workflow when saving server response
|
|
||||||
|
|
||||||
Oversight from 779b16202c3fe990f6ecda17085c436899340e12.
|
|
||||||
|
|
||||||
Signed-off-by: Ernestas Kulik <ekulik@redhat.com>
|
|
||||||
---
|
|
||||||
src/lib/ureport.c | 18 +++++++++++++++++-
|
|
||||||
1 file changed, 17 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/lib/ureport.c b/src/lib/ureport.c
|
|
||||||
index cc18aefd..a5953244 100644
|
|
||||||
--- a/src/lib/ureport.c
|
|
||||||
+++ b/src/lib/ureport.c
|
|
||||||
@@ -680,7 +680,23 @@ ureport_server_response_save_in_dump_dir(struct ureport_server_response *resp,
|
|
||||||
if (resp->urr_reported_to_list)
|
|
||||||
{
|
|
||||||
for (GList *e = resp->urr_reported_to_list; e; e = g_list_next(e))
|
|
||||||
- add_reported_to(dd, e->data);
|
|
||||||
+ {
|
|
||||||
+ char *workflow;
|
|
||||||
+
|
|
||||||
+ workflow = getenv("LIBREPORT_WORKFLOW");
|
|
||||||
+ if (NULL == workflow)
|
|
||||||
+ {
|
|
||||||
+ add_reported_to(dd, e->data);
|
|
||||||
+ }
|
|
||||||
+ else
|
|
||||||
+ {
|
|
||||||
+ g_autofree char *line = NULL;
|
|
||||||
+
|
|
||||||
+ line = g_strdup_printf("%s WORKFLOW=%s", (const char *)e->data, workflow);
|
|
||||||
+
|
|
||||||
+ add_reported_to(dd, line);
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
if (resp->urr_solution)
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
@ -28,14 +28,12 @@
|
|||||||
|
|
||||||
Summary: Generic library for reporting various problems
|
Summary: Generic library for reporting various problems
|
||||||
Name: libreport
|
Name: libreport
|
||||||
Version: 2.10.0
|
Version: 2.10.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://abrt.readthedocs.org/
|
URL: https://abrt.readthedocs.org/
|
||||||
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
|
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
Patch0: 0001-lib-ureport-Export-workflow-when-saving-server-respo.patch
|
|
||||||
|
|
||||||
BuildRequires: %{dbus_devel}
|
BuildRequires: %{dbus_devel}
|
||||||
BuildRequires: gtk3-devel
|
BuildRequires: gtk3-devel
|
||||||
BuildRequires: curl-devel
|
BuildRequires: curl-devel
|
||||||
@ -312,6 +310,7 @@ install this package and you're done.
|
|||||||
%package rhel
|
%package rhel
|
||||||
Summary: Default configuration for reporting bugs via Red Hat infrastructure
|
Summary: Default configuration for reporting bugs via Red Hat infrastructure
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: %{name}-plugin-ureport
|
||||||
|
|
||||||
%description rhel
|
%description rhel
|
||||||
Default configuration for reporting bugs via Red Hat infrastructure
|
Default configuration for reporting bugs via Red Hat infrastructure
|
||||||
@ -365,7 +364,6 @@ data over ftp/scp...
|
|||||||
%autosetup -S git
|
%autosetup -S git
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./gen-version
|
|
||||||
autoreconf -if
|
autoreconf -if
|
||||||
intltoolize --automake -c -f
|
intltoolize --automake -c -f
|
||||||
|
|
||||||
@ -642,6 +640,11 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%{_mandir}/man5/ureport.conf.5.gz
|
%{_mandir}/man5/ureport.conf.5.gz
|
||||||
%{_datadir}/%{name}/events/report_uReport.xml
|
%{_datadir}/%{name}/events/report_uReport.xml
|
||||||
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
|
%{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
|
||||||
|
%if 0%{?rhel}
|
||||||
|
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
|
||||||
|
%{_datadir}/%{name}/workflows/workflow_uReport.xml
|
||||||
|
%{_mandir}/man5/report_uReport.conf.5.*
|
||||||
|
%endif
|
||||||
|
|
||||||
%if %{with bugzilla}
|
%if %{with bugzilla}
|
||||||
%files plugin-bugzilla
|
%files plugin-bugzilla
|
||||||
@ -772,12 +775,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%{_datadir}/%{name}/workflows/workflow_RHELAddDatavmcore.xml
|
%{_datadir}/%{name}/workflows/workflow_RHELAddDatavmcore.xml
|
||||||
%{_datadir}/%{name}/workflows/workflow_RHELAddDataxorg.xml
|
%{_datadir}/%{name}/workflows/workflow_RHELAddDataxorg.xml
|
||||||
%{_datadir}/%{name}/workflows/workflow_RHELAddDataJavaScript.xml
|
%{_datadir}/%{name}/workflows/workflow_RHELAddDataJavaScript.xml
|
||||||
%{_datadir}/%{name}/workflows/workflow_uReport.xml
|
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
|
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_add_data.conf
|
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_add_data.conf
|
||||||
%config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uReport.conf
|
|
||||||
%{_mandir}/man5/report_rhel.conf.5.*
|
%{_mandir}/man5/report_rhel.conf.5.*
|
||||||
%{_mandir}/man5/report_uReport.conf.5.*
|
|
||||||
|
|
||||||
%files rhel-bugzilla
|
%files rhel-bugzilla
|
||||||
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaCCpp.xml
|
%{_datadir}/%{name}/workflows/workflow_RHELBugzillaCCpp.xml
|
||||||
@ -815,6 +815,28 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 03 2019 Martin Kutlak <mkutlak@redhat.com> 2.10.1-1
|
||||||
|
- doc: Makefile.am: Use correct path for --conf-file
|
||||||
|
- lib: copy_file_recursive: Use GLib abstractions
|
||||||
|
- gui-wizard-gtk: Fix fix
|
||||||
|
- cli: run-command: Replace use of vfork() with fork()
|
||||||
|
- plugins: rhbz: Don’t call strlen() on attachment data
|
||||||
|
- Check for empty fmt_file name when printing error msgs
|
||||||
|
- cli: Unpack command-line argument parsing logic
|
||||||
|
- lib: event_config: Remove pointless assignment
|
||||||
|
- gui-wizard-gtk: Fix never-read assignment
|
||||||
|
- lib: xatonum: Check string parameters
|
||||||
|
- Rework and refine composition of error messages
|
||||||
|
- Add clearer warnings about missing report elements specified in format files
|
||||||
|
- Move uReport workflow to plugin-ureport subpackage
|
||||||
|
- lib: ureport: Export workflow when saving server response
|
||||||
|
- lib: dump_dir: Clean up on failure in dd_delete()
|
||||||
|
- Use #ifdef to check whether macros are defined
|
||||||
|
- autogen.sh: Use autoreconf
|
||||||
|
- autogen.sh: Allow skipping running configure
|
||||||
|
- tests: forbidden_words: Don’t hardcode sysconfdir
|
||||||
|
- Makefile.am: Use correct locale when getting date
|
||||||
|
|
||||||
* Tue Apr 23 2019 Ernestas Kulik <ekulik@redhat.com> - 2.10.0-3
|
* Tue Apr 23 2019 Ernestas Kulik <ekulik@redhat.com> - 2.10.0-3
|
||||||
- Add patch to fix workflow fields not being added to reported_to when μReport response comes with a Bugzilla URL
|
- Add patch to fix workflow fields not being added to reported_to when μReport response comes with a Bugzilla URL
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libreport-2.10.0.tar.gz) = 978ea442d82b75abf80b2075f540cb05c5577387a9221f2070c9695c4546d36169738d223f5e903d0b774b7e1566a6111c55a6bb51a0822ad1676095f067c45b
|
SHA512 (libreport-2.10.1.tar.gz) = 9c110b7a5f0e3803d12b7ea05eaf47b3a37592612f0107ed7e6604168d283a09bf3d08b805b415ec90772498062b742814cbf86a8b9ea0f4cc5ff774a77d9671
|
||||||
|
Loading…
Reference in New Issue
Block a user