libreport package is retired on branch c10s for CS-2490

This commit is contained in:
Johnny Hughes 2024-08-22 15:44:31 +00:00
parent b699c7bc88
commit 699baa49da
13 changed files with 1 additions and 1302 deletions

View File

@ -1 +0,0 @@
1

32
.gitignore vendored
View File

@ -1,32 +0,0 @@
/libreport-2.9.3.tar.gz
/libreport-2.9.4.tar.gz
/libreport-2.9.5.tar.gz
/libreport-2.9.6.tar.gz
/libreport-2.9.7.tar.gz
/libreport-2.10.0.tar.gz
/libreport-2.10.1.tar.gz
/libreport-2.11.0.tar.gz
/libreport-2.11.1.tar.gz
/libreport-2.11.2.tar.gz
/libreport-2.11.3.tar.gz
/libreport-2.12.0.tar.gz
/libreport-2.13.0.tar.gz
/libreport-2.13.1.tar.gz
/libreport-2.14.0.tar.gz
/libreport-2.15.1.tar.gz
/libreport-2.15.2.tar.gz
/libreport-2.16.0.tar.gz
/libreport-2.17.0.tar.gz
/libreport-2.17.1.tar.gz
/libreport-2.17.2.tar.gz
/libreport-2.17.3.tar.gz
/libreport-2.17.4.tar.gz
/libreport-2.17.5.tar.gz
/libreport-2.17.6.tar.gz
/libreport-2.17.7.tar.gz
/libreport-2.17.8.tar.gz
/libreport-2.17.9.tar.gz
/libreport-2.17.10.tar.gz
/libreport-2.17.11.tar.gz
/libreport-2.17.13.tar.gz
/libreport-2.17.14.tar.gz

View File

@ -1,21 +0,0 @@
specfile_path: libreport.spec
synced_files:
- .packit.yml
- libreport.spec
upstream_package_name: libreport
upstream_project_url: https://github.com/abrt/libreport
downstream_package_name: libreport
# No extra dependencies are necessary to build the SRPM.
srpm_build_deps: []
jobs:
- job: propose_downstream
trigger: release
metadata:
dist_git_branch: fedora-all
- job: copr_build
trigger: pull_request
metadata:
targets:
- fedora-all

View File

@ -1,42 +0,0 @@
From 9be0010e109d307921a049d10078813423227582 Mon Sep 17 00:00:00 2001
From: Nicolas Iooss <nicolas.iooss_git@polytechnique.org>
Date: Fri, 15 Dec 2023 18:03:33 +0100
Subject: [PATCH] Fix compatibility with libxml2 2.12
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Since libxml2 2.12, xmlNodePtr is no longer included by libxml/encoding.h.
This leads to build errors such as:
CC reporter_mantisbt-reporter-mantisbt.o
In file included from reporter-mantisbt.c:22:
mantisbt.h:48:5: error: unknown type name xmlNodePtr
48 | xmlNodePtr sr_root;
| ^~~~~~~~~~
mantisbt.h:49:5: error: unknown type name xmlNodePtr
49 | xmlNodePtr sr_body;
| ^~~~~~~~~~
mantisbt.h:50:5: error: unknown type name xmlNodePtr
50 | xmlNodePtr sr_method;
| ^~~~~~~~~~
Fix this by including libxml/tree.h.
Signed-off-by: Nicolas Iooss <nicolas.iooss_git@polytechnique.org>
---
src/plugins/mantisbt.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/plugins/mantisbt.h b/src/plugins/mantisbt.h
index 1feaf8f88..6979e7244 100644
--- a/src/plugins/mantisbt.h
+++ b/src/plugins/mantisbt.h
@@ -25,6 +25,7 @@ extern "C" {
#endif
#include <libxml/encoding.h>
+#include <libxml/tree.h>
#include "problem_report.h"
#define SOAP_STRING "ns2:string"

View File

@ -1,3 +0,0 @@
This repository is maintained by packit.
https://packit.dev/
The file was generated using packit 0.91.0.post1.dev2+g269d9a5d.

1
dead.package Normal file
View File

@ -0,0 +1 @@
libreport package is retired on branch c10s for CS-2490

View File

@ -1,15 +0,0 @@
--- !Policy
product_versions:
- fedora-*
decision_context: bodhi_update_push_testing
subject_type: koji_build
rules:
- !PassingTestCaseRule {test_case_name: fedora-ci.koji-build.tier0.functional}
--- !Policy
product_versions:
- fedora-*
decision_context: bodhi_update_push_stable
subject_type: koji_build
rules:
- !PassingTestCaseRule {test_case_name: fedora-ci.koji-build.tier0.functional}

View File

@ -1,46 +0,0 @@
problem_item_get_size expects unsigned long * argument in problem_data.at test
Otherwise, the test fails to build on i686 with GCC 14.
Submitted upstream: <https://github.com/abrt/libreport/pull/802>
diff --git a/tests/problem_data.at b/tests/problem_data.at
index 4d8bf0075c0a8b91..db67a76732d48663 100644
--- a/tests/problem_data.at
+++ b/tests/problem_data.at
@@ -89,7 +89,7 @@ int main(int argc, char **argv)
struct problem_item *itm = problem_data_add_ext(data, "1", "foo", CD_FLAG_TXT | CD_FLAG_ISNOTEDITABLE, PROBLEM_ITEM_UNINITIALIZED_SIZE);
const size_t old_size = strlen(itm->content);
{
- size_t current_size = PROBLEM_ITEM_UNINITIALIZED_SIZE;
+ unsigned long current_size = PROBLEM_ITEM_UNINITIALIZED_SIZE;
assert(problem_item_get_size(itm, &current_size) == 0);
assert(current_size != PROBLEM_ITEM_UNINITIALIZED_SIZE);
assert(current_size == old_size);
@@ -97,7 +97,7 @@ int main(int argc, char **argv)
{
g_free(itm->content);
itm->content = NULL;
- size_t current_size = PROBLEM_ITEM_UNINITIALIZED_SIZE;
+ unsigned long current_size = PROBLEM_ITEM_UNINITIALIZED_SIZE;
assert(problem_item_get_size(itm, &current_size) == 0);
assert(current_size != PROBLEM_ITEM_UNINITIALIZED_SIZE);
assert(current_size == old_size);
@@ -120,7 +120,7 @@ int main(int argc, char **argv)
struct problem_item *itm = problem_data_add_ext(data, "2", flnm, CD_FLAG_BIN, PROBLEM_ITEM_UNINITIALIZED_SIZE);
{
- size_t current_size = PROBLEM_ITEM_UNINITIALIZED_SIZE;
+ unsigned long current_size = PROBLEM_ITEM_UNINITIALIZED_SIZE;
assert(problem_item_get_size(itm, &current_size) == 0);
assert(current_size != PROBLEM_ITEM_UNINITIALIZED_SIZE);
assert(current_size == old_size);
@@ -129,7 +129,7 @@ int main(int argc, char **argv)
close(flds);
unlink(flnm);
assert(stat(flnm, &buf) != 0);
- size_t current_size = PROBLEM_ITEM_UNINITIALIZED_SIZE;
+ unsigned long current_size = PROBLEM_ITEM_UNINITIALIZED_SIZE;
assert(problem_item_get_size(itm, &current_size) == 0);
assert(current_size != PROBLEM_ITEM_UNINITIALIZED_SIZE);
assert(current_size == old_size);

View File

@ -1,28 +0,0 @@
Remove incorrect casts from tests/string_list.at
The list_order argument already has the correct pointer type const
char * const * (after array-to-pointer decay).
Submitted upstream: <https://github.com/abrt/libreport/pull/802>
diff --git a/tests/string_list.at b/tests/string_list.at
index 6af162a2f8da3919..2118298da4de0ec3 100644
--- a/tests/string_list.at
+++ b/tests/string_list.at
@@ -22,13 +22,13 @@ int main(void)
NULL
};
- int index = libreport_index_of_string_in_list(FILENAME_REASON, (char**) list_order);
+ int index = libreport_index_of_string_in_list(FILENAME_REASON, list_order);
assert(index == 0);
- index = libreport_index_of_string_in_list(FILENAME_COUNT, (char**) list_order);
+ index = libreport_index_of_string_in_list(FILENAME_COUNT, list_order);
assert(index == 5);
- index = libreport_index_of_string_in_list("other", (char**) list_order);
+ index = libreport_index_of_string_in_list("other", list_order);
assert(index < 0);
return 0;

File diff suppressed because it is too large Load Diff

View File

@ -1 +0,0 @@
SHA512 (libreport-2.17.14.tar.gz) = 90203748e6665d715c2b723d727b94c70ac864f1a3d1e742eab9a0c33e1767d84bc9408183349c7e6d0d019385aae48cc2ff3b3439a115c5cec61493de826a74

View File

@ -1,11 +0,0 @@
#!/usr/bin/bash
gcc -x c -o smoke_test -lreport -Wno-implicit-function-declaration - <<EOF
#include <stdio.h>
int main(void) {
libreport_init();
printf("libreport initialized OK\n");
return 0;
}
EOF
./smoke_test

View File

@ -1,15 +0,0 @@
summary: Basic smoke test for libreport
prepare:
how: install
# Do not attempt to install conflicting subpackages.
exclude:
- abrt-atomic
- abrt-java-connector-container
- python3-abrt-container-addon
# Prerequisite for smoke testing liblibreport.
package:
- gcc
execute:
script: |
tests/library-smoke.sh
report-cli --version