link with gobject libs, user RHTSupport
This commit is contained in:
parent
86211cc713
commit
4c4d45c36b
210
libreport-2.1.6-rhel_workflows_and_gobject_libs.patch
Normal file
210
libreport-2.1.6-rhel_workflows_and_gobject_libs.patch
Normal file
@ -0,0 +1,210 @@
|
||||
diff -ruN libreport-2.1.6/src/lib/Makefile.am libreport-2.1.6.3.g787f/src/lib/Makefile.am
|
||||
--- libreport-2.1.6/src/lib/Makefile.am 2013-07-25 14:47:08.000000000 +0200
|
||||
+++ libreport-2.1.6.3.g787f/src/lib/Makefile.am 2013-07-26 18:28:36.000000000 +0200
|
||||
@@ -68,11 +68,13 @@
|
||||
-DDEFAULT_DUMP_DIR_MODE=$(DEFAULT_DUMP_DIR_MODE) \
|
||||
-DDUMP_DIR_OWNED_BY_USER=$(DUMP_DIR_OWNED_BY_USER) \
|
||||
$(GLIB_CFLAGS) \
|
||||
+ $(GOBJECT_CFLAGS) \
|
||||
-D_GNU_SOURCE
|
||||
libreport_la_LDFLAGS = \
|
||||
-version-info 0:1:0
|
||||
libreport_la_LIBADD = \
|
||||
- $(GLIB_LIBS)
|
||||
+ $(GLIB_LIBS) \
|
||||
+ $(GOBJECT_LIBS)
|
||||
|
||||
libreportconfdir = $(CONF_DIR)
|
||||
dist_libreportconf_DATA = \
|
||||
@@ -118,7 +120,6 @@
|
||||
-DPLUGINS_CONF_DIR=\"$(PLUGINS_CONF_DIR)\" \
|
||||
-DEVENTS_DIR=\"$(EVENTS_DIR)\" \
|
||||
$(GLIB_CFLAGS) \
|
||||
- $(GOBJECT_CFLAGS) \
|
||||
$(CURL_CFLAGS) \
|
||||
$(PROXY_CFLAGS) \
|
||||
$(LIBXML_CFLAGS) \
|
||||
@@ -130,7 +131,6 @@
|
||||
-version-info 0:1:0
|
||||
libreport_web_la_LIBADD = \
|
||||
$(GLIB_LIBS) \
|
||||
- $(GOBJECT_LIBS) \
|
||||
$(CURL_LIBS) \
|
||||
$(PROXY_LIBS) \
|
||||
$(LIBXML_LIBS) \
|
||||
diff -ruN libreport-2.1.6/src/lib/Makefile.in libreport-2.1.6.3.g787f/src/lib/Makefile.in
|
||||
--- libreport-2.1.6/src/lib/Makefile.in 2013-07-26 07:54:50.000000000 +0200
|
||||
+++ libreport-2.1.6.3.g787f/src/lib/Makefile.in 2013-07-29 09:00:13.000000000 +0200
|
||||
@@ -147,7 +147,7 @@
|
||||
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
|
||||
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
|
||||
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
|
||||
- $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) libreport.la
|
||||
+ $(am__DEPENDENCIES_1) libreport.la
|
||||
am__libreport_web_la_SOURCES_DIST = abrt_xmlrpc.h abrt_xmlrpc.c \
|
||||
ureport.h json.c curl.c proxies.h proxies.c
|
||||
@BUILD_BUGZILLA_TRUE@am__objects_1 = libreport_web_la-abrt_xmlrpc.lo
|
||||
@@ -160,7 +160,8 @@
|
||||
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
|
||||
$(AM_CFLAGS) $(CFLAGS) $(libreport_web_la_LDFLAGS) $(LDFLAGS) \
|
||||
-o $@
|
||||
-libreport_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
|
||||
+libreport_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
|
||||
+ $(am__DEPENDENCIES_1)
|
||||
am_libreport_la_OBJECTS = libreport_la-xfuncs.lo \
|
||||
libreport_la-is_in_string_list.lo \
|
||||
libreport_la-is_in_comma_separated_list.lo \
|
||||
@@ -534,13 +535,15 @@
|
||||
-DDEFAULT_DUMP_DIR_MODE=$(DEFAULT_DUMP_DIR_MODE) \
|
||||
-DDUMP_DIR_OWNED_BY_USER=$(DUMP_DIR_OWNED_BY_USER) \
|
||||
$(GLIB_CFLAGS) \
|
||||
+ $(GOBJECT_CFLAGS) \
|
||||
-D_GNU_SOURCE
|
||||
|
||||
libreport_la_LDFLAGS = \
|
||||
-version-info 0:1:0
|
||||
|
||||
libreport_la_LIBADD = \
|
||||
- $(GLIB_LIBS)
|
||||
+ $(GLIB_LIBS) \
|
||||
+ $(GOBJECT_LIBS)
|
||||
|
||||
libreportconfdir = $(CONF_DIR)
|
||||
dist_libreportconf_DATA = \
|
||||
@@ -581,7 +584,6 @@
|
||||
-DPLUGINS_CONF_DIR=\"$(PLUGINS_CONF_DIR)\" \
|
||||
-DEVENTS_DIR=\"$(EVENTS_DIR)\" \
|
||||
$(GLIB_CFLAGS) \
|
||||
- $(GOBJECT_CFLAGS) \
|
||||
$(CURL_CFLAGS) \
|
||||
$(PROXY_CFLAGS) \
|
||||
$(LIBXML_CFLAGS) \
|
||||
@@ -595,7 +597,6 @@
|
||||
|
||||
libreport_web_la_LIBADD = \
|
||||
$(GLIB_LIBS) \
|
||||
- $(GOBJECT_LIBS) \
|
||||
$(CURL_LIBS) \
|
||||
$(PROXY_LIBS) \
|
||||
$(LIBXML_LIBS) \
|
||||
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELCCpp.xml libreport-2.1.6.3.g787f/src/workflows/workflow_RHELCCpp.xml
|
||||
--- libreport-2.1.6/src/workflows/workflow_RHELCCpp.xml 2013-07-10 13:46:52.000000000 +0200
|
||||
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELCCpp.xml 2013-07-26 15:21:52.000000000 +0200
|
||||
@@ -23,7 +23,6 @@
|
||||
|
||||
<events>
|
||||
<event>collect_*</event>
|
||||
- <event>analyze_CCpp</event>
|
||||
- <event>report_Bugzilla</event>
|
||||
+ <event>report_RHTSupport</event>
|
||||
</events>
|
||||
</workflow>
|
||||
\ No newline at end of file
|
||||
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELCCpp.xml.in libreport-2.1.6.3.g787f/src/workflows/workflow_RHELCCpp.xml.in
|
||||
--- libreport-2.1.6/src/workflows/workflow_RHELCCpp.xml.in 2013-07-10 13:20:16.000000000 +0200
|
||||
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELCCpp.xml.in 2013-07-26 15:20:14.000000000 +0200
|
||||
@@ -5,7 +5,6 @@
|
||||
|
||||
<events>
|
||||
<event>collect_*</event>
|
||||
- <event>analyze_CCpp</event>
|
||||
- <event>report_Bugzilla</event>
|
||||
+ <event>report_RHTSupport</event>
|
||||
</events>
|
||||
</workflow>
|
||||
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELKerneloops.xml libreport-2.1.6.3.g787f/src/workflows/workflow_RHELKerneloops.xml
|
||||
--- libreport-2.1.6/src/workflows/workflow_RHELKerneloops.xml 2013-07-10 13:46:52.000000000 +0200
|
||||
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELKerneloops.xml 2013-07-26 15:21:52.000000000 +0200
|
||||
@@ -23,6 +23,6 @@
|
||||
|
||||
<events>
|
||||
<event>collect_*</event>
|
||||
- <event>report_Bugzilla</event>
|
||||
+ <event>report_RHTSupport</event>
|
||||
</events>
|
||||
</workflow>
|
||||
\ No newline at end of file
|
||||
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELKerneloops.xml.in libreport-2.1.6.3.g787f/src/workflows/workflow_RHELKerneloops.xml.in
|
||||
--- libreport-2.1.6/src/workflows/workflow_RHELKerneloops.xml.in 2013-07-10 13:20:16.000000000 +0200
|
||||
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELKerneloops.xml.in 2013-07-26 15:20:14.000000000 +0200
|
||||
@@ -5,6 +5,6 @@
|
||||
|
||||
<events>
|
||||
<event>collect_*</event>
|
||||
- <event>report_Bugzilla</event>
|
||||
+ <event>report_RHTSupport</event>
|
||||
</events>
|
||||
</workflow>
|
||||
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELPython.xml libreport-2.1.6.3.g787f/src/workflows/workflow_RHELPython.xml
|
||||
--- libreport-2.1.6/src/workflows/workflow_RHELPython.xml 2013-07-10 13:46:52.000000000 +0200
|
||||
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELPython.xml 2013-07-26 15:21:52.000000000 +0200
|
||||
@@ -23,6 +23,6 @@
|
||||
|
||||
<events>
|
||||
<event>collect_*</event>
|
||||
- <event>report_Bugzilla</event>
|
||||
+ <event>report_RHTSupport</event>
|
||||
</events>
|
||||
</workflow>
|
||||
\ No newline at end of file
|
||||
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELPython.xml.in libreport-2.1.6.3.g787f/src/workflows/workflow_RHELPython.xml.in
|
||||
--- libreport-2.1.6/src/workflows/workflow_RHELPython.xml.in 2013-07-10 13:20:16.000000000 +0200
|
||||
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELPython.xml.in 2013-07-26 15:20:14.000000000 +0200
|
||||
@@ -5,6 +5,6 @@
|
||||
|
||||
<events>
|
||||
<event>collect_*</event>
|
||||
- <event>report_Bugzilla</event>
|
||||
+ <event>report_RHTSupport</event>
|
||||
</events>
|
||||
</workflow>
|
||||
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELvmcore.xml libreport-2.1.6.3.g787f/src/workflows/workflow_RHELvmcore.xml
|
||||
--- libreport-2.1.6/src/workflows/workflow_RHELvmcore.xml 2013-07-10 13:46:52.000000000 +0200
|
||||
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELvmcore.xml 2013-07-26 15:21:52.000000000 +0200
|
||||
@@ -22,8 +22,7 @@
|
||||
<description xml:lang="zh_TW">使用 Red Hat 基礎架構處理內核崩潰問題</description>
|
||||
|
||||
<events>
|
||||
- <event>analyze_VMcore</event>
|
||||
<event>collect_*</event>
|
||||
- <event>report_Bugzilla</event>
|
||||
+ <event>report_RHTSupport</event>
|
||||
</events>
|
||||
</workflow>
|
||||
\ No newline at end of file
|
||||
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELvmcore.xml.in libreport-2.1.6.3.g787f/src/workflows/workflow_RHELvmcore.xml.in
|
||||
--- libreport-2.1.6/src/workflows/workflow_RHELvmcore.xml.in 2013-07-10 13:20:16.000000000 +0200
|
||||
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELvmcore.xml.in 2013-07-26 15:20:14.000000000 +0200
|
||||
@@ -4,8 +4,7 @@
|
||||
<_description>Process the kernel crash using the Red Hat infrastructure</_description>
|
||||
|
||||
<events>
|
||||
- <event>analyze_VMcore</event>
|
||||
<event>collect_*</event>
|
||||
- <event>report_Bugzilla</event>
|
||||
+ <event>report_RHTSupport</event>
|
||||
</events>
|
||||
</workflow>
|
||||
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELxorg.xml libreport-2.1.6.3.g787f/src/workflows/workflow_RHELxorg.xml
|
||||
--- libreport-2.1.6/src/workflows/workflow_RHELxorg.xml 2013-07-10 13:46:52.000000000 +0200
|
||||
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELxorg.xml 2013-07-26 15:21:52.000000000 +0200
|
||||
@@ -22,6 +22,6 @@
|
||||
<description xml:lang="zh_TW">使用 Red Hat 基礎架構處理 X Server 問題</description>
|
||||
|
||||
<events>
|
||||
- <event>report_Bugzilla</event>
|
||||
+ <event>report_RHTSupport</event>
|
||||
</events>
|
||||
</workflow>
|
||||
\ No newline at end of file
|
||||
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELxorg.xml.in libreport-2.1.6.3.g787f/src/workflows/workflow_RHELxorg.xml.in
|
||||
--- libreport-2.1.6/src/workflows/workflow_RHELxorg.xml.in 2013-07-10 13:20:16.000000000 +0200
|
||||
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELxorg.xml.in 2013-07-26 15:20:14.000000000 +0200
|
||||
@@ -4,6 +4,6 @@
|
||||
<_description>Process the X Server problem using the Red Hat infrastructure</_description>
|
||||
|
||||
<events>
|
||||
- <event>report_Bugzilla</event>
|
||||
+ <event>report_RHTSupport</event>
|
||||
</events>
|
||||
</workflow>
|
@ -5,13 +5,16 @@
|
||||
Summary: Generic library for reporting various problems
|
||||
Name: libreport
|
||||
Version: 2.1.6
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: https://fedorahosted.org/abrt/
|
||||
Source: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
|
||||
Source1: autogen.sh
|
||||
|
||||
# Remove with libreport > 2.1.6
|
||||
Patch0: libreport-2.1.6-rhel_workflows_and_gobject_libs.patch
|
||||
|
||||
BuildRequires: dbus-devel
|
||||
BuildRequires: gtk3-devel
|
||||
BuildRequires: curl-devel
|
||||
@ -92,7 +95,8 @@ Requires: libreport = %{version}-%{release}
|
||||
Provides: report = 0:0.23-1
|
||||
Obsoletes: report < 0:0.23-1
|
||||
# in report the rhtsupport is in the main package, so we need to install it too
|
||||
%if 0%{?rhel} >= 6
|
||||
# report is only in RHEL6, we do not need to carry the dependency to newer RHELs
|
||||
%if 0%{?rhel} == 6
|
||||
Requires: libreport-plugin-rhtsupport
|
||||
%endif
|
||||
|
||||
@ -248,7 +252,11 @@ Summary: Default configuration for reporting anaconda bugs
|
||||
Group: Applications/File
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: libreport-plugin-reportuploader = %{version}-%{release}
|
||||
%if 0%{?rhel}
|
||||
Requires: libreport-plugin-rhtsupport = %{version}-%{release}
|
||||
%else
|
||||
Requires: libreport-plugin-bugzilla = %{version}-%{release}
|
||||
%endif
|
||||
|
||||
%description anaconda
|
||||
Default configuration for reporting Anaconda problems or uploading the gathered
|
||||
@ -256,6 +264,7 @@ data over ftp/scp...
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
# koji in f19 has new autotools, so we need to regenerate everything
|
||||
cp %SOURCE1 %_builddir/%{name}-%{version}
|
||||
@ -544,6 +553,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jul 29 2013 Jakub Filak <jfilak@redhat.com> 2.1.6-2
|
||||
- link with gobject libraries
|
||||
- use RHTSupport in RHEL workflows
|
||||
|
||||
* Fri Jul 26 2013 Jakub Filak <jfilak@redhat.com> 2.1.6-1
|
||||
- add related packages version in emergency event
|
||||
- replace functions deprecated in Gtk-3.10 with their substitutes
|
||||
|
Loading…
Reference in New Issue
Block a user