Rebuilt for libjson-c.so.3
Use %%global instead of %%define
This commit is contained in:
parent
b8624863e8
commit
4104372ff4
25
libreport-2.9.3_fix_json-c_013.patch
Normal file
25
libreport-2.9.3_fix_json-c_013.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From ad6b52edd4c36b413d3bac6cb03f35369dae1d28 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
|
||||||
|
Date: Sun, 10 Dec 2017 20:20:21 +0100
|
||||||
|
Subject: [PATCH 2/2] Fix build against libjson-c.so.3
|
||||||
|
|
||||||
|
---
|
||||||
|
src/lib/ureport.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/lib/ureport.c b/src/lib/ureport.c
|
||||||
|
index 9e8bbd6..81f0791 100644
|
||||||
|
--- a/src/lib/ureport.c
|
||||||
|
+++ b/src/lib/ureport.c
|
||||||
|
@@ -609,7 +609,7 @@ ureport_server_response_from_reply(post_state_t *post_state,
|
||||||
|
|
||||||
|
json_object *const json = json_tokener_parse(post_state->body);
|
||||||
|
|
||||||
|
- if (is_error(json))
|
||||||
|
+ if (json == NULL)
|
||||||
|
{
|
||||||
|
error_msg(_("Unable to parse response from ureport server at '%s'"), config->ur_url);
|
||||||
|
log_notice("%s", post_state->body);
|
||||||
|
--
|
||||||
|
2.15.1
|
||||||
|
|
@ -1,18 +1,19 @@
|
|||||||
# platform-dependent
|
%global satyr_ver 0.24
|
||||||
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
%global glib_ver 2.43
|
||||||
|
|
||||||
%define satyr_ver 0.24
|
|
||||||
%define glib_ver 2.43
|
|
||||||
|
|
||||||
Summary: Generic library for reporting various problems
|
Summary: Generic library for reporting various problems
|
||||||
Name: libreport
|
Name: libreport
|
||||||
Version: 2.9.3
|
Version: 2.9.3
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://abrt.readthedocs.org/
|
URL: https://abrt.readthedocs.org/
|
||||||
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
|
Source: https://github.com/abrt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
Source1: autogen.sh
|
Source1: autogen.sh
|
||||||
|
|
||||||
|
# Needed for libjson-c.so.3*.
|
||||||
|
# See: https://github.com/json-c/json-c/issues/304
|
||||||
|
Patch0: libreport-2.9.3_fix_json-c_013.patch
|
||||||
|
|
||||||
# git format-patch %%{Version} -N -M --topo-order
|
# git format-patch %%{Version} -N -M --topo-order
|
||||||
# i=0; for p in `ls 0*.patch`; do printf "Patch%04d: %s\n" $i $p; ((i++)); done
|
# i=0; for p in `ls 0*.patch`; do printf "Patch%04d: %s\n" $i $p; ((i++)); done
|
||||||
|
|
||||||
@ -328,9 +329,9 @@ data over ftp/scp...
|
|||||||
# Default '__scm_apply_git' is 'git apply && git commit' but this workflow
|
# Default '__scm_apply_git' is 'git apply && git commit' but this workflow
|
||||||
# doesn't allow us to create a new file within a patch, so we have to use
|
# doesn't allow us to create a new file within a patch, so we have to use
|
||||||
# 'git am' (see /usr/lib/rpm/macros for more details)
|
# 'git am' (see /usr/lib/rpm/macros for more details)
|
||||||
%define __scm_apply_git(qp:m:) %{__git} am --exclude src/report-python/libreport-meh-test.py
|
%global __scm_apply_git(qp:m:) %{__git} am --exclude src/report-python/libreport-meh-test.py
|
||||||
#%%define __scm_apply_git(qp:m:) %%{__git} am --exclude libreport.spec.in --exclude .gitignore
|
#%%global __scm_apply_git(qp:m:) %%{__git} am --exclude libreport.spec.in --exclude .gitignore
|
||||||
%autosetup -S git
|
%autosetup -S git -p 1
|
||||||
|
|
||||||
# koji in f19 has new autotools, so we need to regenerate everything
|
# koji in f19 has new autotools, so we need to regenerate everything
|
||||||
cp %SOURCE1 %_builddir/%{name}-%{version}
|
cp %SOURCE1 %_builddir/%{name}-%{version}
|
||||||
@ -759,6 +760,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Dec 10 2017 Björn Esser <besser82@fedoraproject.org> - 2.9.3-2
|
||||||
|
- Rebuilt for libjson-c.so.3
|
||||||
|
- Use %%global instead of %%define
|
||||||
|
|
||||||
* Thu Nov 02 2017 Julius Milan <jmilan@redhat.com> 2.9.3-1
|
* Thu Nov 02 2017 Julius Milan <jmilan@redhat.com> 2.9.3-1
|
||||||
- Translation updates
|
- Translation updates
|
||||||
- commit to delete
|
- commit to delete
|
||||||
|
Loading…
Reference in New Issue
Block a user