New upstream release 2.1.8

This commit is contained in:
Jakub Filak 2013-10-04 14:51:43 +02:00
parent 509005ecca
commit 21e8e344c0
4 changed files with 13 additions and 214 deletions

1
.gitignore vendored
View File

@ -23,3 +23,4 @@
/libreport-2.1.5.tar.gz
/libreport-2.1.6.tar.gz
/libreport-2.1.7.tar.gz
/libreport-2.1.8.tar.gz

View File

@ -1,210 +0,0 @@
diff -ruN libreport-2.1.6/src/lib/Makefile.am libreport-2.1.6.3.g787f/src/lib/Makefile.am
--- libreport-2.1.6/src/lib/Makefile.am 2013-07-25 14:47:08.000000000 +0200
+++ libreport-2.1.6.3.g787f/src/lib/Makefile.am 2013-07-26 18:28:36.000000000 +0200
@@ -68,11 +68,13 @@
-DDEFAULT_DUMP_DIR_MODE=$(DEFAULT_DUMP_DIR_MODE) \
-DDUMP_DIR_OWNED_BY_USER=$(DUMP_DIR_OWNED_BY_USER) \
$(GLIB_CFLAGS) \
+ $(GOBJECT_CFLAGS) \
-D_GNU_SOURCE
libreport_la_LDFLAGS = \
-version-info 0:1:0
libreport_la_LIBADD = \
- $(GLIB_LIBS)
+ $(GLIB_LIBS) \
+ $(GOBJECT_LIBS)
libreportconfdir = $(CONF_DIR)
dist_libreportconf_DATA = \
@@ -118,7 +120,6 @@
-DPLUGINS_CONF_DIR=\"$(PLUGINS_CONF_DIR)\" \
-DEVENTS_DIR=\"$(EVENTS_DIR)\" \
$(GLIB_CFLAGS) \
- $(GOBJECT_CFLAGS) \
$(CURL_CFLAGS) \
$(PROXY_CFLAGS) \
$(LIBXML_CFLAGS) \
@@ -130,7 +131,6 @@
-version-info 0:1:0
libreport_web_la_LIBADD = \
$(GLIB_LIBS) \
- $(GOBJECT_LIBS) \
$(CURL_LIBS) \
$(PROXY_LIBS) \
$(LIBXML_LIBS) \
diff -ruN libreport-2.1.6/src/lib/Makefile.in libreport-2.1.6.3.g787f/src/lib/Makefile.in
--- libreport-2.1.6/src/lib/Makefile.in 2013-07-26 07:54:50.000000000 +0200
+++ libreport-2.1.6.3.g787f/src/lib/Makefile.in 2013-07-29 09:00:13.000000000 +0200
@@ -147,7 +147,7 @@
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
- $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) libreport.la
+ $(am__DEPENDENCIES_1) libreport.la
am__libreport_web_la_SOURCES_DIST = abrt_xmlrpc.h abrt_xmlrpc.c \
ureport.h json.c curl.c proxies.h proxies.c
@BUILD_BUGZILLA_TRUE@am__objects_1 = libreport_web_la-abrt_xmlrpc.lo
@@ -160,7 +160,8 @@
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
$(AM_CFLAGS) $(CFLAGS) $(libreport_web_la_LDFLAGS) $(LDFLAGS) \
-o $@
-libreport_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
+libreport_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1)
am_libreport_la_OBJECTS = libreport_la-xfuncs.lo \
libreport_la-is_in_string_list.lo \
libreport_la-is_in_comma_separated_list.lo \
@@ -534,13 +535,15 @@
-DDEFAULT_DUMP_DIR_MODE=$(DEFAULT_DUMP_DIR_MODE) \
-DDUMP_DIR_OWNED_BY_USER=$(DUMP_DIR_OWNED_BY_USER) \
$(GLIB_CFLAGS) \
+ $(GOBJECT_CFLAGS) \
-D_GNU_SOURCE
libreport_la_LDFLAGS = \
-version-info 0:1:0
libreport_la_LIBADD = \
- $(GLIB_LIBS)
+ $(GLIB_LIBS) \
+ $(GOBJECT_LIBS)
libreportconfdir = $(CONF_DIR)
dist_libreportconf_DATA = \
@@ -581,7 +584,6 @@
-DPLUGINS_CONF_DIR=\"$(PLUGINS_CONF_DIR)\" \
-DEVENTS_DIR=\"$(EVENTS_DIR)\" \
$(GLIB_CFLAGS) \
- $(GOBJECT_CFLAGS) \
$(CURL_CFLAGS) \
$(PROXY_CFLAGS) \
$(LIBXML_CFLAGS) \
@@ -595,7 +597,6 @@
libreport_web_la_LIBADD = \
$(GLIB_LIBS) \
- $(GOBJECT_LIBS) \
$(CURL_LIBS) \
$(PROXY_LIBS) \
$(LIBXML_LIBS) \
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELCCpp.xml libreport-2.1.6.3.g787f/src/workflows/workflow_RHELCCpp.xml
--- libreport-2.1.6/src/workflows/workflow_RHELCCpp.xml 2013-07-10 13:46:52.000000000 +0200
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELCCpp.xml 2013-07-26 15:21:52.000000000 +0200
@@ -23,7 +23,6 @@
<events>
<event>collect_*</event>
- <event>analyze_CCpp</event>
- <event>report_Bugzilla</event>
+ <event>report_RHTSupport</event>
</events>
</workflow>
\ No newline at end of file
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELCCpp.xml.in libreport-2.1.6.3.g787f/src/workflows/workflow_RHELCCpp.xml.in
--- libreport-2.1.6/src/workflows/workflow_RHELCCpp.xml.in 2013-07-10 13:20:16.000000000 +0200
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELCCpp.xml.in 2013-07-26 15:20:14.000000000 +0200
@@ -5,7 +5,6 @@
<events>
<event>collect_*</event>
- <event>analyze_CCpp</event>
- <event>report_Bugzilla</event>
+ <event>report_RHTSupport</event>
</events>
</workflow>
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELKerneloops.xml libreport-2.1.6.3.g787f/src/workflows/workflow_RHELKerneloops.xml
--- libreport-2.1.6/src/workflows/workflow_RHELKerneloops.xml 2013-07-10 13:46:52.000000000 +0200
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELKerneloops.xml 2013-07-26 15:21:52.000000000 +0200
@@ -23,6 +23,6 @@
<events>
<event>collect_*</event>
- <event>report_Bugzilla</event>
+ <event>report_RHTSupport</event>
</events>
</workflow>
\ No newline at end of file
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELKerneloops.xml.in libreport-2.1.6.3.g787f/src/workflows/workflow_RHELKerneloops.xml.in
--- libreport-2.1.6/src/workflows/workflow_RHELKerneloops.xml.in 2013-07-10 13:20:16.000000000 +0200
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELKerneloops.xml.in 2013-07-26 15:20:14.000000000 +0200
@@ -5,6 +5,6 @@
<events>
<event>collect_*</event>
- <event>report_Bugzilla</event>
+ <event>report_RHTSupport</event>
</events>
</workflow>
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELPython.xml libreport-2.1.6.3.g787f/src/workflows/workflow_RHELPython.xml
--- libreport-2.1.6/src/workflows/workflow_RHELPython.xml 2013-07-10 13:46:52.000000000 +0200
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELPython.xml 2013-07-26 15:21:52.000000000 +0200
@@ -23,6 +23,6 @@
<events>
<event>collect_*</event>
- <event>report_Bugzilla</event>
+ <event>report_RHTSupport</event>
</events>
</workflow>
\ No newline at end of file
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELPython.xml.in libreport-2.1.6.3.g787f/src/workflows/workflow_RHELPython.xml.in
--- libreport-2.1.6/src/workflows/workflow_RHELPython.xml.in 2013-07-10 13:20:16.000000000 +0200
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELPython.xml.in 2013-07-26 15:20:14.000000000 +0200
@@ -5,6 +5,6 @@
<events>
<event>collect_*</event>
- <event>report_Bugzilla</event>
+ <event>report_RHTSupport</event>
</events>
</workflow>
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELvmcore.xml libreport-2.1.6.3.g787f/src/workflows/workflow_RHELvmcore.xml
--- libreport-2.1.6/src/workflows/workflow_RHELvmcore.xml 2013-07-10 13:46:52.000000000 +0200
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELvmcore.xml 2013-07-26 15:21:52.000000000 +0200
@@ -22,8 +22,7 @@
<description xml:lang="zh_TW">使用 Red Hat 基礎架構處理內核崩潰問題</description>
<events>
- <event>analyze_VMcore</event>
<event>collect_*</event>
- <event>report_Bugzilla</event>
+ <event>report_RHTSupport</event>
</events>
</workflow>
\ No newline at end of file
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELvmcore.xml.in libreport-2.1.6.3.g787f/src/workflows/workflow_RHELvmcore.xml.in
--- libreport-2.1.6/src/workflows/workflow_RHELvmcore.xml.in 2013-07-10 13:20:16.000000000 +0200
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELvmcore.xml.in 2013-07-26 15:20:14.000000000 +0200
@@ -4,8 +4,7 @@
<_description>Process the kernel crash using the Red Hat infrastructure</_description>
<events>
- <event>analyze_VMcore</event>
<event>collect_*</event>
- <event>report_Bugzilla</event>
+ <event>report_RHTSupport</event>
</events>
</workflow>
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELxorg.xml libreport-2.1.6.3.g787f/src/workflows/workflow_RHELxorg.xml
--- libreport-2.1.6/src/workflows/workflow_RHELxorg.xml 2013-07-10 13:46:52.000000000 +0200
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELxorg.xml 2013-07-26 15:21:52.000000000 +0200
@@ -22,6 +22,6 @@
<description xml:lang="zh_TW">使用 Red Hat 基礎架構處理 X Server 問題</description>
<events>
- <event>report_Bugzilla</event>
+ <event>report_RHTSupport</event>
</events>
</workflow>
\ No newline at end of file
diff -ruN libreport-2.1.6/src/workflows/workflow_RHELxorg.xml.in libreport-2.1.6.3.g787f/src/workflows/workflow_RHELxorg.xml.in
--- libreport-2.1.6/src/workflows/workflow_RHELxorg.xml.in 2013-07-10 13:20:16.000000000 +0200
+++ libreport-2.1.6.3.g787f/src/workflows/workflow_RHELxorg.xml.in 2013-07-26 15:20:14.000000000 +0200
@@ -4,6 +4,6 @@
<_description>Process the X Server problem using the Red Hat infrastructure</_description>
<events>
- <event>report_Bugzilla</event>
+ <event>report_RHTSupport</event>
</events>
</workflow>

View File

@ -4,7 +4,7 @@
Summary: Generic library for reporting various problems
Name: libreport
Version: 2.1.7
Version: 2.1.8
Release: 1%{?dist}
License: GPLv2+
Group: System Environment/Libraries
@ -29,7 +29,7 @@ BuildRequires: asciidoc
BuildRequires: xmlto
BuildRequires: newt-devel
BuildRequires: libproxy-devel
BuildRequires: satyr-devel >= 0.9
BuildRequires: satyr-devel >= 0.10
BuildRequires: doxygen
Requires: libreport-filesystem = %{version}-%{release}
# required for update from old report library, otherwise we obsolete report-gtk
@ -37,7 +37,7 @@ Requires: libreport-filesystem = %{version}-%{release}
# end-up with: can't import report.GtkIO
# FIXME: can be removed when F15 will EOLed, needs to stay in rhel6!
Requires: libreport-python = %{version}-%{release}
Requires: satyr >= 0.9
Requires: satyr >= 0.10
# for rhel6
@ -349,6 +349,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%doc README COPYING
%config(noreplace) %{_sysconfdir}/%{name}/report_event.conf
%config(noreplace) %{_sysconfdir}/%{name}/forbidden_words.conf
%config(noreplace) %{_sysconfdir}/%{name}/ignored_words.conf
%{_libdir}/libreport.so.*
%{_libdir}/libabrt_dbus.so.*
%{_mandir}/man5/report_event.conf.5*
@ -548,6 +549,13 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%changelog
* Fri Oct 04 2013 Jakub Filak <jfilak@redhat.com> 2.1.8-1
- disable rhel/fedora workflows for anaconda
- added whitelist for sensitive data - rhbz#1009730 rhbz#896246
- ureport: always add BTHASH link to a report
- reprot-gtk: underline tab titles with sensitive information
- introduce FILENAME_EXPLOITABLE; related to abrt/abrt#703
* Wed Sep 11 2013 Jakub Filak <jfilak@redhat.com> 2.1.7-1
- Fix problem_item_format() to work properly after 2038 on x32. #691
- Use proper json-c requirement in libreport-web.pc.

View File

@ -1 +1 @@
0d0e0ca3556afa3dcfe83e91af8ab722 libreport-2.1.7.tar.gz
b926d31e1cfdaf2870d094aea660c782 libreport-2.1.8.tar.gz